Está en la página 1de 12

Ayuda y aprendizaje de Excel Fórmulas y funciones

Función
CONTAR.S
I
 Información general sobre fórmulas en Excel
Artículo
 BUSCARV
Artículo
 Función SUMA
Artículo
 Función CONTAR.SI
Artículo
 Función SI
Artículo
 SI.CONJUNTO
Artículo
 SUMAR.SI
Artículo
 SUMAR.SI.CONJUNTO
Artículo
 Numerar filas automáticamente
Artículo
 Calcular la diferencia entre dos fechas
Artículo
 Definir y usar nombres en fórmulas
Artículo
 Combinar texto de dos o más celdas en una celda
Artículo

CONTAR.SI
(función
CONTAR.SI)
Use CONTAR.SI, una de las funciones estadísticas, para contar
el número de celdas que cumplen un criterio; por ejemplo,
para contar el número de veces que una ciudad determinada
aparece en una lista de clientes.

En su forma más sencilla, CONTAR.SI indica lo siguiente:

 =CONTAR.SI(¿Dónde quiere realizar la búsqueda y qué


quiere buscar?)

Por ejemplo:

 =CONTAR.SI(A2:A5,"Londres")
 =CONTAR.SI(A2:A5;A4)

Sintaxis

CONTAR.SI(rango;criterios)

Nombre del
Descripción
argumento

El grupo de celdas que desea


Rango (obligatorio) contar. Rango puede contener
números, matrices, un rango con
nombre o referencias que
Nombre del
Descripción
argumento

contengan números. Los valores


en blanco y de texto se ignoran.
Obtenga información sobre cómo
seleccionar rangos en una hoja.

Número, expresión, referencia de


celda o cadena de texto que
determina las celdas que se van a
contar.
Por ejemplo, puede usar un
número como 32, una
Criterios (obligatorio)
comparación como ">32", una
celda como B4 o una palabra
como "manzanas".
CONTAR.SI usa solo un criterio.
Use CONTAR.SI.CONJUNTO si
desea usar varios criterios.

Ejemplos
Para usar estos ejemplos de Excel, copie los datos de la tabla
de abajo y péguelos en la celda A1 de una nueva hoja de
cálculo.
Datos Datos
manzanas 32
naranjas 54
melocotones 75
manzanas 86
Fórmula Descripción
Cuenta el número de
celdas con manzanas
=CONTAR.SI(A2:A5;"manzanas")
entre las celdas A2 y
A5. El resultado es 2.
Cuenta el número de
celdas con
melocotones, el valor
=CONTAR.SI(A2:A5;A4)
de A4, entre las celdas
A2 y A5. El resultado
es 1.
Cuenta el número de
manzanas, el valor de
A2, y de naranjas, el
valor de A3, entre las
celdas A2 y A5. El
=CONTAR.SI(A2:A5,A2)+CONTAR.SI(
resultado es 3. Esta
A2:A5,A3)
fórmula usa
CONTAR.SI dos veces
para especificar varios
criterios, un criterio
por expresión.
Datos Datos
También puede
utilizar la función
CONTAR.SI.CONJUNT
O.
Cuenta el número de
celdas con un valor
=CONTAR.SI(B2:B5;">55") superior a 55 entre las
celdas B2 y B5. El
resultado es 2.
Cuenta el número de
celdas con un valor
distinto de 75 entre las
celdas B2 y B5. El
símbolo de la "y" (&)
combina el operador
=CONTAR.SI(B2:B5;"<>"&B4)
de comparación "<>"
(no es igual a) y el
valor de B4 para leer
=CONTAR.SI(B2:B5,"<
>75"). El resultado es
3.
Cuenta el número de
celdas con un valor
=CONTAR.SI(B2:B5;">=32")- superior o igual a 32 e
CONTAR.SI(B2:B5;">85") inferior o igual a 85
entre las celdas B2 y
A5. El resultado es 3.
Datos Datos
Cuenta el número de
celdas que contienen
texto entre las celdas
A2 y A5. El carácter
=CONTAR.SI(A2:A5,"*")
comodín * se usa para
reemplazar cualquier
carácter. El resultado
es 4.
Cuenta el número de
celdas que tienen
exactamente 7
caracteres y que
terminan con las letras
"es" entre las celdas
A2 y A5. El signo de
=CONTAR.SI(A2:A5,"?????es")
interrogación (?) se
usa como carácter
comodín para
coincidir con
caracteres
individuales. El
resultado es 2.

Problemas comunes
Problema Qué ha fallado
La función CONTAR.SI devuelve resultados
incorrectos cuando se usa para comparar
Se devolvió un cadenas de más de 255 caracteres.
valor incorrecto Para comparar cadenas de más de 255
para cadenas caracteres, use la función CONCATENAR o
largas. el operador concatenar &. Por ejemplo,
=CONTAR.SI(A2:A5,"cadena larga"&"otra
cadena larga").
No se devolvió
ningún valor Asegúrese de encerrar el argumento de
cuando se criterios entre comillas.
esperaba uno.
Una formula
Este error se produce cuando la fórmula
CONTAR.SI
que contiene la función hace referencia a
recibe un error
celdas o a un rango de un libro cerrado y
#¡VALOR! al
se calculan las celdas. Para que esta
hacer referencia
característica funcione, el otro libro debe
a otra hoja de
estar abierto.
cálculo.

Prácticas recomendadas
Realice este
¿Por qué?
procedimiento
Tenga en cuenta Los criterios no distinguen entre
que CONTAR.SI mayúsculas y minúsculas. En otras
Realice este
¿Por qué?
procedimiento
pasa por alto palabras, la cadena "manzanas" y la
mayúsculas y cadena "MANZANAS" darán como
minúsculas en las resultado la misma cantidad de celdas.
cadenas de texto.
Los caracteres comodín, como el signo de
interrogación (?) y asterisco (*), pueden
usarse en criterios. El signo de
interrogación reemplaza cualquier
carácter individual. El asterisco reemplaza
cualquier secuencia de caracteres. Si lo
Use caracteres que desea buscar es un signo de
comodín. interrogación o un asterisco, escriba una
tilde (~) antes del carácter.

Por ejemplo,
=CONTAR.SI(A2:A5,"manzana?") contará
todas las instancias de "manzana" con
una última letra que podrá variar.
Al contar valores de texto, asegúrese de
Asegúrese de que
que los datos no contienen espacios al
los datos no
principio ni al final, de que no haya un
contienen
uso incoherente de las comillas rectas (' o
caracteres
") ni tipográficas (‘ o “) y de que no haya
incorrectos.
caracteres no imprimibles. En estos casos,
Realice este
¿Por qué?
procedimiento
CONTAR.SI puede devolver un valor
inesperado o incorrecto.

Intente usar la función LIMPIAR o la


función ESPACIOS.
CONTAR.si admite rangos con nombre en
una fórmula (como = contar.Si (fruta, ">=
Para mayor 32")-contar.Si (fruta, ">85"). El rango con
comodidad, use nombre puede estar en la hoja de cálculo
rangos con actual, en otra hoja de cálculo del mismo
nombre. libro o en una hoja de cálculo de otro
libro. Para hacer referencia a otro libro,
ese libro también debe estar abierto.

Nota: La función CONTAR.SI no contará celdas según el color


de la fuente o el fondo de la celda. Pero Excel es compatible
con funciones definidas por el usuario (UDF) con las
operaciones de Microsoft Visual Basic para Aplicaciones (VBA)
en celdas basadas en el color de la fuente o el fondo. Este es
un ejemplo de cómo puede contar el número de celdas con
un color de celda específico con VBA.

¿Necesitas más ayuda?


Siempre puede preguntar a un experto en Excel Tech
Community, obtener soporte técnico en la Comunidad de
respuestas o sugerir una característica nueva o mejora en el
UserVoice de Excel.

Vea también
Para contar las celdas que no están en blanco, use la función
CONTARA.

Para contar las celdas mediante varios criterios, use la función


CONTAR.SI.CONJUNTO

Ver un vídeo sobre cómo usar la función


CONTAR.SI.CONJUNTO

La función SUMAR.SI solo suma los valores que coinciden con


un criterio único

La función SUMAR.SI.CONJUNTO solo suma los valores que


coinciden con varios criterios

Función IFS (Microsoft 365, Excel 2016 y posterior)

Use la función ESPACIOS para quitar espacios iniciales y


finales de celdas

Use la función LIMPIAR para quitar caracteres no imprimibles


de celdas

Información general sobre fórmulas en Excel

Cómo evitar la ruptura de las fórmulas


Detectar errores en fórmulas

Funciones estadísticas

Funciones de Excel (por orden alfabético)

Funciones de Excel (por categoría)

Use SUMAR.SI, CONTAR.SI y otras funciones relacionadas


para analizar los datos rápidamente (versión preliminar
gratuita)

Nota: Esta página se ha traducido mediante un sistema


automático y es posible que contenga imprecisiones o errores
gramaticales. Nuestro objetivo es que este contenido le
resulte útil. ¿Podría decirnos si la información le resultó útil?
Aquí puede consultar el artículo en inglés.

También podría gustarte