Está en la página 1de 10

Evaluación Final (A) 2019 – 20 – B

Semipresencial – Programa a Distancia

Asignatura

Informática

Consigna de trabajo
1. Desarrolle las siguientes preguntas, según indicaciones, en el caso de la pregunta 3 y 4 utilizar el
programa Pseint y copiar el pseudocódigo y el diagrama de flujo en este documento, en la pregunta 5
utilizar el programa Dev C++ y copiar el pseudocódigo en este documento, guardar los cambios del
documento y enviarlo a través de la plataforma.

Pregunta 1. Nivel Básico.

Desarrolle las siguientes conversiones, se debe mostrar el procedimiento:

a) De binario a decimal: 11001


b) De decimal a binario: 258

Solución de la pregunta a) Solución de la pregunta b)

16 + 8 + 0 + 0 + 1 258 2
0 129 2
1 64 2
0 32 2
0 16 2
0 8 2
Rpta:25 0 4 2
0 2 2
0 1

Rpta: 100000010

Pregunta 2. Nivel Intermedio.

Desarrolle las siguientes operaciones con números binarios, se debe mostrar el procedimiento:
Informática

a) b)

1 1 1 0 0 1 1 + 1 0 1 0 1 0 1 -

1 0 0 1 1 0 1 0 1 1 1 0

Solución de la pregunta a) Solución de la pregunta b)

1 1 1 0 0 1 1 +
0-0= 1 0 1 0 1 0 1 -
0
1-0=
1 0 0 1 1 0 1
1-1=
0 1 0 1 1 1 0
10 0 1 1 0 0 1 0-1=
no
cabe o 1 0 0 1 1 1
1+0= 1 se
1+1= 2…… PONGO 0 Y LLEVO 1 pide prestado al próximo.
0+1+1=2..PONGO 0 Y LLEVO 1
0+0+1=1 Rpta: 100111
1+0=1
1+1= 2…… PONGO 0 Y LLEVO 1
1+1=2…SE PONDRIA 10

Rpta:10011001

Pregunta 3. Nivel Intermedio.

Escribe el algoritmo en Pseudocódigo y en Diagrama de flujo del siguiente ejercicio utilizando Pseint:

Una tienda efectúa un descuento a los clientes dependiendo del monto de compra. El descuento se lleva a
cabo según la siguiente tabla:

Monto de compra (soles) Porcentaje de descuento


Menor de 500 Sin descuento
Mayor o igual de 500 y menor de 800 12%
Mayor o igual de 800 y menor de 1200 18%
Mayor o igual de 1200 22%

Evaluación Final 2019 – 20 - B Página 2


Informática

Diseñe el algoritmo que muestre el porcentaje de descuento, su equivalente en soles y el monto final a
pagar.

Seudocódigo

Proceso Pregunta3
definir desc Como Entero;
definir precio,descuento,pagar Como Real;
Escribir "Ingrese el monto de compra:";
Leer precio;
Si precio < 500 Entonces

desc <- 0;
Escribir "El descuento es de ",desc,"%";
Sino
Si precio < 800 Entonces
desc <- 12;
Escribir "El descuento es de ",desc,"%";
Sino
Si precio < 1200 Entonces
desc <- 18
Escribir "El descuento es de ",desc,"%";
Sino
desc <- 22
Escribir "El descuento es de ",desc,"%";
FinSi
FinSi

FinSi

descuento <- precio*desc/100;


pagar <- precio - descuento;
Escribir "Y su equivalente en soles es: s/",descuento;
Escribir "Y el monto final a pagar es: s/",pagar;
FinProceso

Evaluación Final 2019 – 20 - B Página 3


Informática

Evaluación Final 2019 – 20 - B Página 4


Informática

Diagrama de Flujo

Evaluación Final 2019 – 20 - B Página 5


Informática

Pregunta 4. Nivel Intermedio.

Escribe el algoritmo en Pseudocódigo y en Diagrama de flujo del siguiente ejercicio utilizando Pseint:

Un encuestador ingresa las edades de 20 personas (validar edad entre 18 y 99 años), desea mostrar el
siguiente reporte:

 Cantidad de personas cuya edad está entre 50 y 70 años


 La edad promedio

Seudocódigo

Proceso Pregunta4
Definir edad,c,a Como Entero;
Definir sum Como Real;

Escribir 'Ingrese las 20 edades';


c <- 0;
sum <- 0;
Para a<-1 Hasta 20 Hacer
Escribir "Persona ",a;
Escribir "Edad[18-99]:";
Leer edad;
Si edad >= 18 Y edad <= 99 Entonces
Si edad >= 50 Y edad <=70 Entonces
c <-c+1;
FinSi
sum <- sum + edad;
Sino
Escribir "Volver a ingresar la edad";
a <-a-1;
FinSi
FinPara

Escribir "La cantidad de personas cuya edad está entre 50 y 70 años es: ",c;
Escribir "La edad promedio es: ", sum/20;
FinProceso

Evaluación Final 2019 – 20 - B Página 6


Informática

Evaluación Final 2019 – 20 - B Página 7


Informática

Diagrama de Flujo

Evaluación Final 2019 – 20 - B Página 8


Informática

Pregunta 5. Nivel Alto.

Diseñe un programa (en lenguaje de programación Dev C++) del siguiente ejercicio:

El docente de un colegio tiene a su cargo 35 estudiantes de nivel primaria (validar edades entre 6 y 12
años), desea ingresar la edad y la nota final de cada estudiante (notas entre 0 y 20), su objetivo es mostrar
el siguiente reporte:

 Cantidad de estudiantes aprobados cuya edad esta entre 10 y 12 años


 Estudiantes que superaron la nota de 10
 Porcentaje de estudiantes desaprobados

Seudocódigo

#include<iostream>
using namespace std;

int main()
{
int edad,i;
float peso,nota;
float a=0,b=0,c=0;

for(i=1; i<=35; i++)


{
cout<<"\nEstudiante "<<i<<": \n";
cout<<"Edad [6-12]: ";
cin>>edad;
if(edad < 6 || edad > 12)
{
cout<<"Edad incorrecta ... \n";
i = i-1;
}
else
{
cout<<"Nota [0-20]: ";
cin>>nota;
if(nota < 0 || nota > 20)
{
cout<<"Nota incorrecta ... \n";
i = i-1;
}

else
{
//Suponemos que aprueban con 11
if(nota>=11 && edad>=10 && edad<=12){
a = a + 1;}

if(nota>10){
b = b + 1;}

if(nota<11){
c = c + 1;}

Evaluación Final 2019 – 20 - B Página 9


Informática

}
}
cout<<"\nCantidad de Estudiantes aprobados cuya edad esta en 10 y 12: "<<a;
cout<<"\nEstudiantes que superan la nota 10: "<<b;
cout<<"\nPorcentaje de estudiantes desaprobados: "<< c*100/35 <<"%";

cout<<endl<<endl;
return 0;

Evaluación Final 2019 – 20 - B Página 10