Está en la página 1de 14

1Taller 1

Juan Nicolás Cárdenas Caicedo


084800822020
Daniel Felipe Murcia Báez
084851482019
.
Marzo 2019

Universidad del Tolima


Gestión bases de datos

Lógica de sistemas

Tabla de Contenidos
ii
Algoritmos Informales y Diagramas de Flujos................................................................................1
Valores de Variables........................................................................................................................3
Jerarquía de Operadores..................................................................................................................4
Tablas de Verdad.............................................................................................................................5
Estructuras Básicas de la Programación Estructurada.....................................................................7
Secuencias....................................................................................................................................7
Decisiones o condiciones.............................................................................................................7
Ciclos...........................................................................................................................................7
Algoritmos Informales y Diagramas de Flujos

(capitulo 4, el CIPAS 1 hace los 5 primeros ejercicios y así sucesivamente)

Algoritmo informal

1
Algoritmo amarrar_zapato
Dimension A[2],B[2],C[2];
Definir A,B,C Como cadena;
Escribir "Para comenzar, debes tener medias puestas, responde si o no,
tiene media puestas? ";
Leer A[];
Si A[] = "si" entonces
Escribir "Tiene puestos los zapatos?, responde si o no";
Leer B[];
Si B[] = "si" Entonces
Escribir "Sabe como amarrarse los zapatos ?, responda si o
no";
Leer C[];
Si C[] = "si" Entonces
Escribir "Por favor amarreselos.";
SiNo
Si C[] = "no" Entonces
Escribir "Busque en internet un tutorial o
pida ayuda a otra persona, luego repita el procedimiento";
SiNo
Escribir "Por favor de una respuesta correcta
y en minusculas, repita el procedimiento";
FinSi
FinSi
SiNo
Si B[] = "no" Entonces
Escribir "Por favor pongase los zapatos y repita el
procedimiento";
SiNo
Escribir "Por favor de una respuesta correcta y en
minusculas, repita el procedimiento";
FinSi
FinSi
SiNo
Si A[] = "no" Entonces
Escribir "Por favor pongase unas medias y repita el
procedimiento";
SiNo
Escribir "Por favor de una respuesta correcta y en
minusculas, repita el procedimiento";

FinSi
FinSi
FinAlgoritmo
2
Proceso elevar_cometa
Dimension a[2], b[2], c[2], d[2];
Definir a, b, c, d como cadena;
Escribir "Responda si o no a las siguientes preguntas para que usted
pueda elevar una cometa.";
Escribir "Tiene una cometa ?";
Leer a[];
Si a[] = "si" entonces
Escribir "Tiene nylon o cabuya ?";
Leer b[];
Si b[] = "si" Entonces
Escribir "Esta en un lugar despejado donde pueda elevar la
cometa ?";
Leer c[];
Si c[] = "si" Entonces
Escribir "Sabe elevar cometa ?";
Leer d[];
Si d[] = "si" entonces
Escribir "Puede elevar su cometa.";
SiNo
si d[] = "no" entonces
Escribir "Puede buscar un tutorial e
intentar de nuevo.";
SiNo
Escribir "De una respuesta correcta y en
minuscula, repita el procedimiento.";
FinSi
FinSi
SiNo
si c[] = "no" entonces
Escribir "Por favor dirigirse a un lugar
despejado e intentelo de nuevo.";
SiNo
Escribir "De una respuesta correcta y en
minuscula, repita el procedimiento.";
FinSi
FinSi
SiNo
si b[] = "no" Entonces
Escribir "Consiga nylon o cabuya e intentelo de
nuevo.";
SiNo
Escribir "De una respuesta correcta y en minuscula,
repita el procedimiento";
FinSi
FinSi
SiNo
si a[] = "no" Entonces
Escribir "Consiga una cometa e intentelo de nuevo.";
SiNo
Escribir "De una respuesta correcta y en minuscula, repita
el procedimiento.";
FinSi
FinSi

FinProceso
3
Proceso Hacer_algoritmo
Dimension a[2], b[2], c[2];
Definir a, b, c como cadenas;
Escribir "Sabe lo basico de algoritmos ? responda si o no.";
Leer a[];
Si a[] = "si" entonces
Escribir "Sabe que algoritmo desarrollar ? responda si o
no.";
Leer b[];
Si b[] = "si" Entonces
Escribir "Empiece con dar inicio y cumplir cada uno
de los pasos.";
Escribir "Ha completado todos los pasos para lograr
el objetivo de su algoritmo? responda si o no";
Leer c[];
Si c[] = "si" Entonces
Escribir "Habiendo completado todos los
pasos, agrege el fin a su algoritmo y finalice.";
SiNo
Si c[] = "no" Entonces
Escribir "Complete todos los pasos y
vuelva a repetir el proceso.";
SiNo
Escribir "De una respuesta correcta y en
minuscula, repita el procedimiento.";
FinSi
FinSi
SiNo
Si b[] = "no" Entonces
Escribir "Decida el algoritmo a desarrollar y
luego repita el procedimiento.";
SiNo
Escribir "De una respuesta correcta y en
minuscula, repita el procedimiento.";
FinSi
FinSi
SiNo
Si a[] = "no" Entonces
Escribir "Busque un tutorial en internet sobre lo
basico de algoritmos.";
SiNo
Escribir "De una respuesta correcta y en minuscula,
repita el procedimiento.";
FinSi
FinSi
FinProceso
4
Proceso quitar_zapatos
Dimension A[2],B[2],C[2];
Definir A,B,C Como cadena;
Escribir "Tiene los zapatos desamarrados?";
Leer A[];
Si A[] = "si" entonces
Escribir "Aflojese los cordones y retirese los zapatos";

SiNo
Si A[] = "no" Entonces
Escribir "Por favor desamarrese los zapatos y
repita el procedimiento";
SiNo
Escribir "Por favor de una respuesta correcta y en
minusculas, repita el procedimiento";

FinSi
FinSi
FinProceso
5
Proceso como_silbar
Dimension A[2], B[2], C[2];
Definir A, B, C como cadena;
Escribir "Tiene la boca vacia? responde si o no.";
Leer A[];
Si A[] = "si" Entonces
Escribir "Posicione los labios de manera adecuada.";
Escribir "Si lo haz logrado, responde si, de lo contrario,
responde no.";
Leer B[];
Si B[] = "si" Entonces
Escribir "Ahora debes soplar.";
Escribir "Lo haz conseguido ?";
Leer C[];
Si C[] = "si" Entonces
Escribir "Felicidades ! haz conseguido silbar.";
SiNo
Si C[] = "no" Entonces
Escribir "vuelve a intentarlo, la practica
hace al maestro.";
FinSi
FinSi
SiNo
Si B[] = "no" Entonces
Escribir "Por favor repite el procedimiento";
SiNo
Escribir "De una respuesta correcta y en minuscula,
repita el procedimiento.";
FinSi
FinSi
SiNo
Si A[] = "no" Entonces
Escribir "Debe tener la boca vacia.";
SiNo
Escribir "De una respuesta correcta y en minuscula, repita
el procedimiento";
FinSi
FinSi
FinProceso
Valores de Variables

Se tienen las siguientes variables:

a = 97
b = 98
c = 99
d = 100

Adicionalmente, es necesario que defina una constante:

z =122

Posteriormente se desarrollan diferentes operaciones matemáticas con ellas:

a=a+b–c+d*z
b=a+b–c+d
c=a+b–c+d*z
d=a+b–c+d
a=a+b–c+d
b = a + b – c + d* z
c=a+b–c+d
d = a + b – c + d* z

¿Qué valores quedan almacenados en las variables a, b c y d?

a = 97+98-99+100*122= 12296 a = 12296


b = 97+98-99+100= 196 b = 196
c = 97+98-99+100*122= 12296 c = 12296
d = 97+98-99+100= 196 d = 196

a = 97+98-99+100= 196 a = 196


b = 97+98-99+100*122= 12296 b = 12296
c = 97+98-99+100= 196 c = 196
d = 97+98-99+100*122= 12296 d = 12296
Jerarquía de Operadores

Capitulo 3, el CIPAS 1 hace el ejercicio 20, el CIPAS 2 el ejercicio 19 y así


sucesivamente.

En el siguiente ejercicio escribir el orden en que el computador realizaría las operaciones.

Tener en cuenta el término “linealizar” (escribir una expresión algebraica en una sola
línea) utilizado en el texto guía.

RTA/ x= (a + (b/c)) / ((a/b) + c )

RTA/ x= ((a+b) + (a/b)) / c


RTA/ x= ( a / (a+b)) / ( a (a-b))

RTA/ x= ( a + (b/(a+b+(b/c))) / (a + (b/(c+a)))

RTA/ x= (a+b+c) / ( a+ (b/c))

RTA/ x= ((a+b)+ (c/(d*a))) / (( a+b) * (c/d))


RTA/ x= (a + (b/c) + d) / a

RTA/ x= ( (a/b) + (b/c) ) / ( (a/b) – (b/c) )

RTA/ x= ( a + ( a + (a+b) / (c+d) ) / ( a + (a/b) ) )

RTA/ x=( a + b + (c/d) + ( a / (b-c) ) / ( a / (b+c) ) )


Tablas de Verdad

Construir las tablas de verdad para:

La cantidad de posibles combinaciones resulta de: 2n, donde n es la cantidad de


proposiciones.

AND
OR
~ NOT

~(p q)

p q p q ~(p q)
V V V F
V F F V
F V F V
F F F V

p (p q)

p q p qp (p q)
V V V V
V F F V
F V F F
F F F F
~(p q) (~r)

p q r p q ~(p q) ~r ~(p q) (~r)


V V V V F F F
V V F V F V F
V F V F V F F
V F F F V V V
F V V F V F F
F V F F V V V
F F V F V F F
F F F F V V V

~(p q) (r)

p q r p q ~(p q) ~(p q) (r)


V V V V F V
V V F V F F
V F V V F V
V F F V F F
F V V V F V
F V F V F F
F F V F V V
F F F F V V
Estructuras Básicas de la Programación Estructurada

Indique un ejemplo de la cotidianidad donde se evidencie:

Secuencias

Levantarse, tender la cama, desayunar e ir a la escuela…

Decisiones o condiciones

Hacer el trabajo (buena nota) No hacer el trabajo (mala nota)

Ciclos

Desayunar, almorzar, cenar…