Está en la página 1de 5

1. El rey Ignacio V tiene N caballos en su caballeriza y desea herrarlos.

Por herrar cada caballo


el herrero real cobra así: 1 centavo por el primer clavo que le coloque al caballo y por cada
clavo adicional cobra el doble del precio del clavo anterior. Al mandar herrar los caballos el
rey sabe el nombre del caballo y el número de clavos que necesita ese caballo para ser
herrado. Construya un programa que calcule:
– ¿Cuánto pagará el rey por herrar todos los caballos de su caballeriza?
– ¿Cómo se llama el caballo que más le costó herrar al rey? (El que más clavos necesita).
– ¿Cuántos caballos no necesitaron ser herrados?
– ¿Cuál es el porcentaje de caballos que requiere menos de 6 clavos? (el costo de
herrarlos es menor de 100 centavos)

Inicio
Lea “Ingrese la cantidad de caballos a herrar”,nc
i=1
mayorcostoc=0
Totalpagar=0
Mq(i<=nc) para(i=1,i<nc,i=i+1)
Lea “ingrese el nombre del caballo”,ncaballo
Lea “ingrese si el caballo debe ser herrado, responda si o no ”,p
Si(p==”si”)
Lea “Ingrese la cantidad de clavos ”,cc
Si(cc<=6)
Contcm6= Contcm6+1
finsi
Valorcaballoherrado=1+(cc-1)*2
Si(mayorcostoc==0)
Mayorcostoc= Valorcaballoherrado
Caballomascostoso=ncaballo
Sino
Si (Mayorcostoc< Valorcaballoherrado)
Mayorcostoc= Valorcaballoherrado
Caballomascostoso=ncaballo
Finsi
finsi
Total_pagar=Total_pagar + valorcaballoherrrado
contch=contch+1
Sino
contcnh=contcnh+1
finsi
i=i+1
fMq
porcentaje= (Contcm6*100)/ contch
Escriba “El total a pagar por todos caballos herrados es”, Total_pagar
Escriba “El nombre del caballo que más costo herrar es”, Caballomascostoso
Escriba “La cantidad de caballos no herrados es”, contcnh
Escriba “El porcentaje de caballos con menos de 6 clavos es”, porcentaje
Fin
2. En la Facultad de Ingeniería de la Universidad se desea llevar el control de los promedios
de los alumnos en un semestre. De cada estudiante se conoce lo siguiente: nombre,
matrícula, número de materias cursadas, calificación de cada una de las materias y
créditos de cada materia. Cuando se ingresa un número de matrícula igual a 0, significa
que no hay más estudiantes. Se necesita generar un reporte de la siguiente manera:

Carlos Rodríguez 8054242-123 4.3

Diana Arias 12312345-13 4.2

Adicionalmente se desea conocer el nombre y la matrícula del alumno con mejor promedio y el
porcentaje de alumnos cuyo promedio es superior a 4.

INICIO

Repetir

Escribir "nombre del estudiante"


Leer nestudiante

Escribir "numero de matricula"


Leer nmatricula

Escribir "numeros de materias cursadas"


Leer nmaterias

Escribir "numeros de notas"


Leer nnotas

Para i<-0 Hasta nnotas Con Paso paso Hacer


Escribir "ingrese nota" , i
Leer nota
Escribir "ingrese numero de creditos" , i
Leer credito

notas<-nota+credito

sumanotas=sumanotas+notas
sumacreditos=sumacreditos+credito

Fin Para
totalpromedio=sumanotas/sumacreditos
valorpromedio<-totalpromedio

Escribir "", nestudiante , "", nmatricula , "" , totalpromedio

Si valorpromedio>totalpromedio Entonces
promediomayor<-totalpromedio
SiNo
valorpromedio<-totalpromedio
Fin Si

Hasta Que nmatricula=0

FIN

3. En una empresa se tienen 400 empleados y de cada uno de ellos se conoce:


nombre, número de empleado, hrs. trabajadas en cada día de la semana
(lunes a viernes), sueldo por hora. Las horas normales de trabajo son 40
horas por semana, a partir de ese número se pueden cobrar horas extra. Se
pide elaborar un programa que permita calcular el sueldo semanal que le
corresponde a cada empleado de acuerdo a lo siguiente:

– si el empleado trabajó más de 40 pero hasta 45 horas a la semana se le pagarán


al doble las horas extra.
– si trabajó más de 45 las que se exceden se la pagarán al triple, más las horas
dobles, más las normales.
Se pide imprimir además del nombre, número de empleado y sueldo, los sueldos acumulados
de todos los empleados, y el nombre y número de empleado del que gana más.

INICIO
cantempleados<-400
x<-1
sst<-0
nemv<-""
cemv<-0

Mientras x<= cantempleados Hacer


Escribir "ingrese la cantidad de horas trabajadas"
Leer horas

Escribir "ingrese nombre del empleado"


Leer nempleado

Escribir "ingrese nel codigo del empleado"


Leer cempleado

sph<-100000

Si horas=40 Entonces
ss<-horas*sph
SiNo
Si horas>40 y horas <=45 Entonces
he<-horas-40
ss<-(40*horas)+(he*sph*2)
SiNo
Si horas >45 Entonces
he<-horas-45
ss<-(40*horas)+(5*sph*2)+(he*sph*3)

Fin Si
Fin Si
Fin Si

Si x=1 Entonces
mayo<-ss
npmv<-ne
cemv<-ce
SiNo
Si ss>mayo Entonces
mayo<-ss
npmv<-ne
cemv<-ce

Fin Si
Fin Si
sst<- sst+ss

Escribir "el nombre del empleado es", ne


Escribir "el codigo del empleado es", ce
Escribir "el sueldo del empleado es", ss
x<-x+1

Fin Mientras

Escribir "el sueldo del empleado es", sst


Escribir "el nombre del empleado con mayor sueldo es", nemv
Escribir "el codigo del empleado con mayor sueldo es", cemv
Escribir "el sueldo del empleado con mayor salario es", mayo

FIN