Está en la página 1de 2

FACULTAD DE INGENIERÍAS

PROGRAMACIÓN DE COMPUTADORES
SEGUNDO PARCIAL

I. Seleccione la respuesta correcta y justifique la respuesta:

1. (0.5 punto) En este problema planteado: A una fiesta asistieron personas de diferentes
edades y sexos; pero no se permitió el ingreso de menores de 18 años. Se desea diseñar un
algoritmo, que, dadas las edades y sexos de las personas, calcule y muestre: Cuantas
personas asistieron a la fiesta, cuantos hombres y cuantas mujeres, promedio de edades por
sexo, el número de mujeres y el número de hombres que no pudieron ingresar.

Para solucionar el problema anteriormente planteado es cierto que:


a. No se puede utilizar ciclo Mientras que y se necesitan cuatro contadores y un
acumulador
b. No se puede utilizar ciclo Haga Mientras que y se necesitan tres contadores y dos
acumuladores
c. Se puede utilizar el ciclo Mientras que y se necesitan cuatro contadores y un
acumulador
d. Solo se puede utilizar el ciclo Mientras que y se necesitan cuatro contadores y un
acumulador

2. (0.75 puntos) Seleccione la respuesta correcta y muestre paso a paso la prueba de escritorio,
es decir, el valor que toma cada una de las variables del algoritmo, la justificación de su respuesta a
través de la prueba de escritorio. Dado el siguiente algoritmo, cuales son los valores finales para las
variables total, y totalb
Proceso MISTERIO
Definir i, total, totalb como entero;
i←5;
totalb←0;
total←1;
Mientras (i>1) Hacer
totalb totalb+i;
totaltotal*i;
i i -1;
Escribir total;
Escribir totalb;
FinMientras
Fin
a. 120 y 14
b. 25 y 14
c. 14 y 120
d. 25 y 120
e. 120 y 25
3. (0.75 puntos punto) Seleccione la respuesta correcta y muestre paso a paso y muestre paso
a paso la prueba de escritorio, es decir, el valor que toma cada una de las variables del algoritmo,
la justificación de su respuesta a través de la prueba de escritorio. Dado el siguiente algoritmo,
cuales son los valores finales para las variables totalb, y total
Proceso MISTERIO
Definir i, total, totalb como entero;
i←5;
totalb←0;
total←1;
Mientras (i>1) Hacer
totalb totalb+1;
totaltotal+i;
i i -1;
Escribir totalb;
Escribir total;
FinMientras
Fin
a. 15 y 5
b. 4 y 15
c. 5 y 15
d. 14 y 4