Está en la página 1de 3

FACULTAD DE INGENIERÍA

Sección
Curso: Principios de Algoritmos 10584
:
In
Docente: Mg. Karen Melissa Quispe Vergaray Código:
dic aci
on Alumno: Jeep Anderson Vargas Yucra Código: U20102715 es
 Toda indisciplina será sancionada de acuerdo al reglamento.
 Apague y guarde su teléfono celular o cualquier otro dispositivo electrónico.
 Descargue el archivo PC1.doc del módulo Semana 5 en Canvas.
 No está permitido el uso de apuntes, materiales de clase, videotutoriales Youtube, buscar
en Google.
 Recuerde guardar su archivo cada cierto tiempo.
 5 minutos antes de la hora límite deberá subir su archivo a la Tarea - PC1 resuelta

Elabore el algoritmo correspondiente en pseudocódigo a cada una de las preguntas:

1. Pregunta 01. (6 pts.): Se requiere:


a. Mostrar el área del triángulo equilátero
b. Mostrar la parte entera del resultado en a)
c. Mostrar el redondeo de la operación en a)

Proceso TRIANGULO
Definir a Como Real
Escribir " ingresar lado a"
Leer a
area=(a^2*rc(3))/4
Escribir " el area del triangulo es:",área
Escribir “Parte entera de la operación es:”,trunc(área)
Escribir “El redondeo de la operación es:”,redon(área)
FinProceso

1
2. Pregunta 02 (6 pts.):. Se desea calcular los valores de a, b y c con los datos mostrados en la
siguiente tabla:

COCHES NÚMERO DE VENTAS


1 Audi 71,056.00
2 BMW 59,201.00
3 Citroën 148,578.00
4 Daewoo 21,671.00
5 Fiat 69,319.00
6 Ford 98,012.00
7 Hyundai 37,885.00
8 Mercedes Benz 40,299.00
9 Nissan 36,911.00
10 Opel 99,156.00
11 Peugeot 124,988.00
12 Renault 168,000.00
13 Seat 112,200.00
14 Skoda 16,000.00
15 Toyota 36,005.00
16 Vollkswagen 86,745.00

Calcular:
a. El promedio de los coches cuyas ventas son mayores a 100,000.00 unidades.
b. Agregar el 2% al total de unidades vendidas, de la marca de coches. Donde el número de
ventas es el más bajo
c. Quitar el 18% al total de unidades vendidas, de la marca de coches. Donde el número de
ventas es el mayor.

ALGORITMO
Proceso valores_de_a_b_c
Definir prom,sueldo1 como real;
Citroen<-148578.00
peugeot<-124988.00
renault<-168000.00
seat<-112200.00
skoda<-16000.00
prom<-(citroen+peugeot+renault+seat)/4;
v_baja<-skoda*0.02+skoda
v_alta<-renault-renault*0.18
Escribir " Promedio de ventas>100 000:",prom
Escribir "2% de la venta mas baja:",skoda”es”,v_baja;
Escribir " 18% de la venta mas alta ",renault”es”,v_alta;
FinProceso

3. Pregunta 03 (08 pts.): Considerando que se inscribieron al curso de Principios (virtual) 45


Brasileros, 22 Peruanos y el número de alumnos de su sección 10584. Se desea conocer:
2
a. Calcular el porcentaje de Total de alumnos.
b. Incrementar el número de Peruanos en 15 y calcular el promedio total de alumnos en el
curso de Principios.
c. Restar 10 al número de brasileros y mostrar el total de alumnos.

ALGORITMO:
Proceso ALUMNOS
Definir h,m,Ph,Pm,Total,sección como real
brasileros<-45;
peruanos<-22;
Escribir "Cuantos alumnos son seccion 10584:"
Leer seccion;
Total<-brasileros+peruanos+seccion;
Pb<-(brasileros*100)/total
Pp<-(peruanos*100)/total
Ps<-(seccion*100)/total
Escribir "El porcentaje de brasileros es:",Pb
Escribir "El porcentaje de peruanos es:",Pp
Escribir "El porcentaje de la seccion es:",Ps
peruanos<-peruanos+15;
brasileros<-brasileros-10;
pro<- (brasileros+peruanos+seccion)/3;
Escribir "Promedio de:",pro
Escribir "total de alumnos”, brasileros+peruanos+seccion;
FinProceso

También podría gustarte