Está en la página 1de 7

1. ¿Esta es la estructura básica del código en Karel?

iniciar-programa inicia-ejecucion apagate; termina-ejecucion

finalizar-programa

Verdadero

Falso

2. ¿Cuáles son las instrucciones básicas de Karel?

avanza-gira ... izquierda ... coge‐zumbador ... deja‐zumbador ... apagate

avanza-gira ... izquierda ... coge‐zumbador ... deja‐zumbador

frente libre ... izquierda‐libre ... derecha‐libre ... junto a zumbador

si frente‐libre entonces inicio ... fin

3. Sin tomar en cuenta las instrucciones básicas. ¿El siguiente código nos sirve para?

define nueva instrucción gira-derecha como inicio gira?izquierda; gira?izquierda; gira?izquierda;

fin;

girar a la derecha

dar media buelta

definir nueva instruccion

definir nuevo programa

4. Instrucción para que KAREL avance hasta que tope con una pared:

repeir 5 veces avanza;

avanza mientras puedas;

frente libre ... izquierda‐libre

mientras frente-libre hacer avanza;

5. ¿En que lenguaje programamos KAREL?

HTML

C++

Pascal
XML

6. Son funciones BOOLEANAS

frente-libre ... junto-a-zumbador ... no-orientado-al-este ... derecha-bloqueada

no-orientado-al-este ... avanza ... fin

frente-libre ... deja-zumbador ... apagate

junto-a-zumbador ... si termino entonces expresion1 sino expresion2

7. Son unos objetos que pueden ser simulados como canicas. Éstos le ayudan a Karel a realizar sus
tareas ya que pueden ser utilizados para muchas cosas como contar, marcar lugares especiales o
caminos importantes, etc.

calles y avenidas

comandos

funciones boleanas

zumbadores

8. ¿En que pestaña de KAREL programamos las instrucciones?

Escribe la respuesta

9. Pestaña que es el lugar en el cual Karel realiza sus tareas y puede ser diseñado como tú quieras,
mientras la tarea de Karel puede ser realizada ahí

ejecutar

mundo

programa

ayuda

10. Al momento de haber terminado de escribir el código, y para poder ver como funciona,
debemos de ir a la pestaña de ejecutar, antes de eso hay que realizar una acción ¿cual es?

guardar

evaluar

nuevo

compilar
11. El siguiente código no funcionara ¿porque?

iniciar-programa; inicia-ejecucion; avanza: avanza: coge-zumbador: gira-izquierda: gira-izquierda:


avanza: avanza: deja-zumbador:

apagate;

termina-ejecucion;

finalizar-programa;

No tiene el código base

Algunas funciones no existen

Las palabras estan mal escritas

Al final de cada función tiene ":"

12. ¿Karel esta representado por?

una mujer

un hombre

no sabemos

una flecha

13. Funciones que nos permiten hacer que Karel realice una serie de toma de decisiones

básicas

complejas

booleanas

combinadas

Resultados Examen de KAREL


 Pregunta 1

¿Esta es la estructura básica del código en Karel?


iniciar-programa inicia-ejecucion apagate; termina-ejecucion
finalizar-programa

Tu Respuesta: [ Ninguna ]
Respuesta Correcta: Verdadero

 Pregunta 2

¿Cuáles son las instrucciones básicas de Karel?


Tu Respuesta: [ Ninguna ]
Respuesta Correcta: avanza-gira ... izquierda ... coge‐zumbador ... deja‐zumbador ...
apagate

 Pregunta 3

Sin tomar en cuenta las instrucciones básicas. ¿El siguiente código nos sirve para?

define nueva instrucción gira-derecha como inicio gira?izquierda; gira?izqu


ierda; gira?izquierda;
fin;

Tu Respuesta: [ Ninguna ]
Respuesta Correcta: definir nueva instruccion

 Pregunta 4

Instrucción para que KAREL avance hasta que tope con una pared:
Tu Respuesta: [ Ninguna ]
Respuesta Correcta: mientras frente-libre hacer avanza;

 Pregunta 5

¿En que lenguaje programamos KAREL?


Tu Respuesta: [ Ninguna ]
Respuesta Correcta: Pascal

 Pregunta 6

Son funciones BOOLEANAS


Tu Respuesta: [ Ninguna ]
Respuesta Correcta: frente-libre ... junto-a-zumbador ... no-orientado-al-este ... derecha-
bloqueada

 Pregunta 7

Son unos objetos que pueden ser simulados como canicas. Éstos le ayudan a Karel a
realizar sus tareas ya que pueden ser utilizados para muchas cosas como contar, marcar
lugares especiales o caminos importantes, etc.
Tu Respuesta: [ Ninguna ]
Respuesta Correcta: zumbadores

 Pregunta 8
¿En que pestaña de KAREL programamos las instrucciones?
Tu Respuesta: [ Ninguna ]
Respuesta Correcta: PROGRAMA

 Pregunta 9

Pestaña que es el lugar en el cual Karel realiza sus tareas y puede ser diseñado como tú
quieras, mientras la tarea de Karel puede ser realizada ahí
Tu Respuesta: [ Ninguna ]
Respuesta Correcta: mundo

 Pregunta 10

Al momento de haber terminado de escribir el código, y para poder ver como funciona,
debemos de ir a la pestaña de ejecutar, antes de eso hay que realizar una acción ¿cual
es?
Tu Respuesta: [ Ninguna ]
Respuesta Correcta: compilar

 Pregunta 11

El siguiente código no funcionara ¿porque?

iniciar-programa; inicia-ejecucion; avanza: avanza: coge-zumbador: gira-izq


uierda: gira-izquierda: avanza: avanza: deja-zumbador:
apagate;
termina-ejecucion;
finalizar-programa;
Tu Respuesta: [ Ninguna ]
Respuesta Correcta: Al final de cada función tiene ":"

 Pregunta 12

¿Karel esta representado por?


Tu Respuesta: [ Ninguna ]
Respuesta Correcta: una flecha

 Pregunta 13

Funciones que nos permiten hacer que Karel realice una serie de toma de decisiones
Tu Respuesta: [ Ninguna ]
Respuesta Correcta: booleanas