Está en la página 1de 33

Integración de múltiples protocolos con túneles 6to4

Ing Luis Arturo Bule

Diagrama del ejercicio

La explicación es la siguiente: se desea que los routers del recuadro verde configurados
con OSPFv3 puedan comunicarse con el router R7, la técnica e mpleada para realizar
dicha conexión es la redistribución de rutas de OSPFv3 a EIGRPv6, usando MPBGP
en los AS correspondientes salen por un túnel 6to4 en IPv6, cabe destacar que R5 y R6
tienen configurados en cada una de las interfaces con direccionamiento IPv4, OSPFv2,
ya que este funciona como “Medio” para transportar IPv6, es decir agrega una
cabecera IPv4 al paquete IPv6 y finalmente este paquete encapsulado llega a R7.
Configuración en los Routers

R1
Building configuration...

Current configuration : 1350 bytes


!
upgrade fpd auto
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R2
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
no ip icmp rate -limit unreachable
ip cef
!
!
!
!
no ip domain lookup
ipv6 unicast-routing
ipv6 cef
!
multilink bundle -name authenticated
!
!
!
!
!
!
!
!
!
!
!
!
!
!
archive
log config
hidekeys
!
!
!
!
ip tcp synwait-time 5
!
!
!
!
interface Loopback0
no ip address
ipv6 address 2000:FADD:A::/64 eui-64
ipv6 ospf 1 area 0
!
interface FastEthernet0/0
no ip address
shutdown
duplex half
!
interface GigabitEthernet1/0
no ip address
negotiation auto
ipv6 address 2000:A::1/64
ipv6 ospf 1 area 0
!
interface GigabitEthernet2/0
no ip address
shutdown
negotiation auto
!
interface GigabitEthernet3/0
no ip address
negotiation auto
ipv6 address 2000:D::1/64
ipv6 ospf 1 area 0
!
ip forward-protocol nd
no ip http server
no ip http secure -server
!
!
!
logging alarm informational
no cdp log mismatch duplex
ipv6 router ospf 1
router-id 2.2.2.2
log-adjacency-changes
!
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
gatekeeper
shutdown
!
!
line con 0
exec-timeout 0 0
privilege level 15
logging synchronous
stopbits 1
line aux 0
exec-timeout 0 0
privilege level 15
logging synchronous
stopbits 1
line vty 0 4
login
!
!
End

R3
Building configuration...

Current configuration : 1350 bytes


!
upgrade fpd auto
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R3
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
no ip icmp rate -limit unreachable
ip cef
!
!
!
!
no ip domain lookup
ipv6 unicast-routing
ipv6 cef
!
multilink bundle -name authenticated
!
!
!
!
!
!
!
!
!
!
!
!
!
!
archive
log config
hidekeys
!
!
!
!
ip tcp synwait-time 5
!
!
!
!
interface Loopback0
no ip address
ipv6 address 2000:FADD:A::/64 eui-64
ipv6 ospf 1 area 0
!
interface FastEthernet0/0
no ip address
shutdown
duplex half
!
interface GigabitEthernet1/0
no ip address
shutdown
negotiation auto
!
interface GigabitEthernet2/0
no ip address
negotiation auto
ipv6 address 2000:B::2/64
ipv6 ospf 1 area 0
!
interface GigabitEthernet3/0
no ip address
negotiation auto
ipv6 address 2000:D::2/64
ipv6 ospf 1 area 0
!
ip forward-protocol nd
no ip http server
no ip http secure -server
!
!
!
logging alarm informational
no cdp log mismatch duplex
ipv6 router ospf 1
router-id 3.3.3.3
log-adjacency-changes
!
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
gatekeeper
shutdown
!
!
line con 0
exec-timeout 0 0
privilege level 15
logging synchronous
stopbits 1
line aux 0
exec-timeout 0 0
privilege level 15
logging synchronous
stopbits 1
line vty 0 4
login
!
!
End

R1
Building configuration...

Current configuration : 1681 bytes


!
upgrade fpd auto
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
no ip icmp rate -limit unreachable
ip cef
!
!
!
!
no ip domain lookup
ipv6 unicast-routing
ipv6 cef
!
multilink bundle -name authenticated
!
!
!
!
!
!
!
!
!
!
!
!
!
!
archive
log config
hidekeys
!
!
!
!
ip tcp synwait-time 5
!
!
!
!
interface Loopback0
no ip address
ipv6 address 2000:FADD:A::/64 eui-64
ipv6 ospf 1 area 0
!
interface FastEthernet0/0
no ip address
shutdown
duplex half
!
interface GigabitEthernet1/0
no ip address
negotiation auto
ipv6 address 2000:A::2/64
ipv6 ospf 1 area 0
!
interface GigabitEthernet2/0
no ip address
negotiation auto
ipv6 address 2000:B::2/64
!
interface GigabitEthernet3/0
no ip address
negotiation auto
ipv6 address 2000:C:C::1/64
ipv6 eigrp 99
!
ip forward-protocol nd
no ip http server
no ip http secure -server
!
!
!
logging alarm informational
no cdp log mismatch duplex
ipv6 router eigrp 99
router-id 11.11.11.11
no shutdown
redistribute connected metric 100000000 10 255 1 1500
redistribute ospf 1 metric 100000000 10 255 1 1500
!
ipv6 router ospf 1
router-id 1.1.1.1
log-adjacency-changes
default-information originate always
redistribute connected metric 10 metric-type 1
redistribute eigrp 99 metric 10 metric-type 1 include -connected
!
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
gatekeeper
shutdown
!
!
line con 0
exec-timeout 0 0
privilege level 15
logging synchronous
stopbits 1
line aux 0
exec-timeout 0 0
privilege level 15
logging synchronous
stopbits 1
line vty 0 4
login
!
!
End

R4

Building configuration...

Current configuration : 1694 bytes


!
upgrade fpd auto
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R4
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
no ip icmp rate -limit unreachable
ip cef
!
!
!
!
no ip domain lookup
ipv6 unicast-routing
ipv6 cef
!
multilink bundle -name authenticated
!
!
!
!
!
!
!
!
!
!
!
!
!
!
archive
log config
hidekeys
!
!
!
!
ip tcp synwait-time 5
!
!
!
!
interface Loopback0
no ip address
ipv6 address 2000:FADD:A::/64 eui-64
!
interface FastEthernet0/0
no ip address
shutdown
duplex half
!
interface GigabitEthernet1/0
no ip address
shutdown
negotiation auto
!
interface GigabitEthernet2/0
no ip address
negotiation auto
ipv6 address 2000:10:A::1/64
!
interface GigabitEthernet3/0
no ip address
negotiation auto
ipv6 address 2000:C:C::2/64
ipv6 eigrp 99
!
router bgp 1000
no synchronization
bgp router-id 20.0.0.0
bgp log-neighbor-changes
neighbor 2000:10:A::2 remote -as 2000
no auto-summary
!
address-family ipv6
neighbor 2000:10:A::2 activate
network 2000:A::/64
network 2000:B::/64
network 2000:C:C::/64
network 2000:D::/64
network 2000:FADD:A::/64
exit-address-family
!
ip forward-protocol nd
no ip http server
no ip http secure -server
!
!
!
logging alarm informational
no cdp log mismatch duplex
ipv6 route ::/0 2000:10:A::2
ipv6 router eigrp 99
router-id 33.33.33.33
no shutdown
redistribute static
!
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
gatekeeper
shutdown
!
!
line con 0
exec-timeout 0 0
privilege level 15
logging synchronous
stopbits 1
line aux 0
exec-timeout 0 0
privilege level 15
logging synchronous
stopbits 1
line vty 0 4
login
!
!
End
R5
Building configuration...

Current configuration : 1890 bytes


!
upgrade fpd auto
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R5
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
no ip icmp rate -limit unreachable
ip cef
!
!
!
!
no ip domain lookup
ipv6 unicast-routing
ipv6 general-prefix telconex 6to4 GigabitEthernet1/0
ipv6 cef
!
multilink bundle -name authenticated
!
!
!
!
!
!
!
!
!
!
!
!
!
!
archive
log config
hidekeys
!
!
!
!
ip tcp synwait-time 5
!
!
!
!
interface Loopback0
ip address 5.5.5.5 255.255.255.255
!
interface Tunnel0
no ip address
no ip redirects
ipv6 address 2002:ACAA:1::1/64
tunnel source GigabitEthernet1/0
tunnel mode ipv6ip 6to4
!
interface FastEthernet0/0
no ip address
shutdown
duplex half
!
interface GigabitEthernet1/0
ip address 172.170.0.1 255.255.255.128
negotiation auto
!
interface GigabitEthernet2/0
no ip address
negotiation auto
ipv6 address 2000:10:A::2/64
!
interface GigabitEthernet3/0
no ip address
shutdown
negotiation auto
!
router ospf 1
router-id 70.10.0.0
log-adjacency-changes
network 0.0.0.0 255.255.255.255 area 0
!
router bgp 2000
no synchronization
bgp router-id 40.0.0.0
bgp log-neighbor-changes
neighbor 2000:10:A::1 remote -as 1000
no auto-summary
!
address-family ipv6
neighbor 2000:10:A::1 activate
network 2000:AD20:2::/64
network 2002::/16
redistribute static metric 10
no synchronization
exit-address-family
!
ip forward-protocol nd
no ip http server
no ip http secure -server
!
!
!
logging alarm informational
no cdp log mismatch duplex
ipv6 route 2002::/16 Tunnel0
ipv6 route ::/0 2002:ACAA:101::2
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
gatekeeper
shutdown
!
!
line con 0
exec-timeout 0 0
privilege level 15
logging synchronous
stopbits 1
line aux 0
exec-timeout 0 0
privilege level 15
logging synchronous
stopbits 1
line vty 0 4
login
!
!
End
R6
Building configuration...

Current configuration : 1247 bytes


!
upgrade fpd auto
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R6
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
no ip icmp rate -limit unreachable
ip cef
!
!
!
!
no ip domain lookup
ipv6 unicast-routing
ipv6 cef
!
multilink bundle -name authenticated
!
!
!
!
!
!
!
!
!
!
!
!
!
!
archive
log config
hidekeys
!
!
!
!
ip tcp synwait-time 5
!
!
!
!
interface FastEthernet0/0
no ip address
shutdown
duplex half
!
interface GigabitEthernet1/0
ip address 172.170.0.2 255.255.255.128
negotiation auto
!
interface GigabitEthernet2/0
no ip address
shutdown
negotiation auto
!
interface GigabitEthernet3/0
ip address 172.170.1.2 255.255.255.128
negotiation auto
!
router ospf 1
router-id 50.0.0.1
log-adjacency-changes
network 0.0.0.0 255.255.255.255 area 0
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!
!
logging alarm informational
no cdp log mismatch duplex
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
gatekeeper
shutdown
!
!
line con 0
exec-timeout 0 0
privilege level 15
logging synchronous
stopbits 1
line aux 0
exec-timeout 0 0
privilege level 15
logging synchronous
stopbits 1
line vty 0 4
login
!
!
End
R7
Building configuration...

Current configuration : 1490 bytes


!
upgrade fpd auto
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R7
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
no ip icmp rate -limit unreachable
ip cef
!
!
!
!
no ip domain lookup
ipv6 unicast-routing
ipv6 general-prefix telconex 6to4 GigabitEthernet3/0
ipv6 cef
!
multilink bundle -name authenticated
!
!
!
!
!
!
!
!
!
!
!
!
!
!
archive
log config
hidekeys
!
!
!
!
ip tcp synwait-time 5
!
!
!
!
interface Tunnel0
no ip address
no ip redirects
ipv6 address 2002:ACAA:101::2/64
tunnel source GigabitEthernet3/0
tunnel mode ipv6ip 6to4
!
interface FastEthernet0/0
no ip address
shutdown
duplex half
!
interface GigabitEthernet1/0
no ip address
shutdown
negotiation auto
!
interface GigabitEthernet2/0
no ip address
shutdown
negotiation auto
!
interface GigabitEthernet3/0
ip address 172.170.1.1 255.255.255.128
negotiation auto
!
router ospf 1
router-id 60.0.0.3
log-adjacency-changes
network 0.0.0.0 255.255.255.255 area 0
!
ip forward-protocol nd
no ip http server
no ip http secure -server
!
!
!
logging alarm informational
no cdp log mismatch duplex
ipv6 route 2002::/16 Tunnel0
ipv6 route ::/0 2002:ACAA:1::1
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
gatekeeper
shutdown
!
!
line con 0
exec-timeout 0 0
privilege level 15
logging synchronous
stopbits 1
line aux 0
exec-timeout 0 0
privilege level 15
logging synchronous
stopbits 1
line vty 0 4
login
!
!
End

Prueba de conectividad:

Al realizar un ping desde R2, R3 e incluso R1 debería de establecer una correcta conectividad
hacia el router (R7), también pueden realizar un traceroute y ver los saltos IPv6 con el protocolo
ICMPv6, en este punto no pudieses observar ICMPv4 ni ver las IP correspondiente, ya que solo
se usó para agregar una cabecera extra con el fin de transportar el túnel 6to4.

También podría gustarte