Está en la página 1de 13

Título de la tarea: Sentencias de Selección en PHP

Nombre Alumno: Michael Tomás Fonseca Acuña

Nombre Asignatura: Programación de computadores I

Instituto IACC

02/12/2019
Elabore un algoritmo en pseudocódigo que permita calcular la edad de una persona,

utilizando PHP como lenguaje formal. Puede apoyar su construcción presentando el

diagrama de flujo respectivo si lo considera necesario. Se deben usar cada una de las

siguientes estructuras de control de selección (un algoritmo por cada estructura):

a. IF…ELSE

Algoritmo EdadPersona

//Primero definimos las variables

Definir dia_hoy como entero;

Definir mes_hoy como entero;

Definir año_hoy como entero;

Definir dia como entero;

Definir mes como entero;

Definir año como entero;

Definir edad_base como entero;

Definir edad como entero;

//Pedimos ingresar los datos al usuario

Escribir "Ingrese el dia actual y presione Enter";

Leer dia_hoy;

Escribir "Ingrese el mes actual y presione Enter";

Leer mes_hoy;

Escribir "Ingrese el año actual y presione Enter";

Leer año_hoy;
Escribir "Ingrese el día de nacimiento y presione Enter";

Leer dia;

Escribir "Ingrese el mes de nacimiento y presione Enter";

Leer mes;

Escribir "Ingrese el año de nacimiento y presione Enter";

Leer año;

edad_base <- año_hoy – año;

//Se ingresan las condiciones

Si (mes_hoy < mes) Entonces

edad_base <- edad_base - 1;

FinSi

Si mes_hoy = mes Entonces

Si (dia_hoy < dia) Entonces

edad_base <- edad_base - 1;

FinSi

FinSi

edad <- edad_base;

Escribir "La edad de la persona es: ",edad_base," años";

FinAlgoritmo
b. IF…ELSEIF…ELS

Algoritmo EdadPersona

//Primero definimos las variables

Definir año_hoy como entero;

Definir mes_hoy como entero;

Definir dia_hoy como entero;

Definir año_nacimiento como entero;

Definir mes_nacimiento como entero;

Definir dia como entero;

Definir edad como entero;

Definir edad_meses Como Entero;

//Pedimos ingresar los datos al usuario

Escribir 'Ingrese año actual y presione enter: ';

Leer año_hoy;

Escribir 'Ingrese mes actual y presione enter: ';

Leer mes_hoy;

Escribir 'Ingrese dia actual y presione enter: ';

Leer dia_actual;

Escribir 'Ingrese año de nacimiento y presione enter: ';

Leer año_nacimiento;

Escribir 'Ingrese mes de nacimiento y presione enter: ';

Leer mes_nacimiento;

Escribir 'Ingrese dia de nacimiento y presione enter: ';

Leer dia;
//Se ingresan las condiciones

edad<-año_hoy-año_nacimiento;

edad_meses←mes_hoy-mes_nacimiento;

//Se ingresa la sentencia IF…ELSEIF…ELS

Si edad_meses<0 Entonces

edad<-edad-1;

edad_meses<-edad_meses+12;

Escribir 'La edad de la persona es ', edad, ' años y ', edad_meses, ' meses.';

Sino

Si edad_meses=0 entonces

Escribir 'La edad de la persona es: ';

Si (dia_hoy < dia) Entonces

edad <- edad - 1;

Escribir edad, ' años y 11 meses.';

Sino

Escribir edad, ' años.';

FinSi

Sino

Escribir 'La edad de la persona es ', edad, ' años y ', edad_meses, ' meses.';

FinSi

FinSi

FinAlgoritmo
Seleccione, según prefiera, una de las estructuras de control antes utilizadas e implemente

un script en PHP que realice el cálculo solicitado. El script debe ser completamente
funcional y efectivo. Para probar que su programa está correcto, puede utilizar el ambiente

de programación dispuesto para estos efectos en la página del curso a través del link PHP

Online.

<?php

//fecha actual

$dia=date(2);

$mes=date(12);

$ano=date(2019);

//fecha de nacimiento

$dia_nacimiento=4;

$mes_nacimiento=1;

$ano_nacimiento=1991;

//Utilizaremos la sentencia IF ELSE, si cumple con la condición sigue el proceso de ejecución

if (($mes_nacimiento == $mes) && ($dia_nacimiento > $dia)) {

$ano_nacimiento=($ano-1); }

if ($mes_nacimiento > $mes) {

$ano=($ano-1);}

//ya no habría mas condiciones, ahora se procede a restar los años y se imprime la edad

$edad=($ano-$ano_nacimiento);

print $edad;
Bibliografía

[Haga triple clic en cualquier parte de este párrafo para escribir la primera referencia bibliográfica.]

Instrucciones para la sección de las citas bibliográficas:


Escriba la bibliografía aquí en orden alfabético (empezando por el apellido del primer autor o, de
no haber autor, por la primera palabra del título). Esta página ya está formateada con sangrías
francesas. Incluya sólo las citas bibliográficas a las que haya hecho referencia en su trabajo y
asegúrese de incluir todas las citas bibliográficas a las que se haya referido en el mismo.

Ejemplo de un periódico:

Lee, H. W. (2005). Los factores que influyen en los expatriados. Journal of American Academy of

Business, 6(2), 273-279. Consultado el 29 de enero de 2009, del banco de datos

ProQuest.

Ejemplo de un texto:

McShane, S. L., & Von Glinow, M. (2004). Organizational behavior: Emerging realities for the

workplace. New York: The McGraw-Hill Companies.

NOTA: Liste las citas bibliográficas en orden alfabético del apellido del autor, NO por el tipo de la
publicación. Los ejemplos previos le ayudarán a darle formato a cada tipo de publicación
en forma adecuada.

Por ejemplo:

 Banco de datos EBSCOhost


 Banco de datos ProQuest
 EIU Viewswire
 InvestText Plus

 Borre este recuadro de instrucciones antes de enviar su trabajo de investigación final.