Está en la página 1de 3

 Calcular el pago por ciclo de un alumno de una Universidad, si se ingresan,

créditos inscritos, categoría, matricula (1: normal, 2: extemporánea). El pago


por crédito depende de la categoría de acuerdo a la siguiente tabla:

CATEGORÍA PAGO CREDITO


A 125.00
B 150.00
C 180.00
Por matricula extemporánea se paga un recargo de 40.00 soles.
Algoritmo ejercicio16
Definir matricula, creditos, pago,categoria como entero
Escribir "Digite su categoria"
Leer categoria
Escribir "Digite su tipo de matricula"
Leer matricula
Escribir "Digite la cantidad de creditos a tomar"
Leer creditos
Si matricula=1 entonces
Segun categoria Hacer
1:
pago<-creditos*125
2:
pago<-creditos*150
3:
pago<-creditos*180
Fin Segun
sino
Si matricula=2 entonces
Segun categoria Hacer
1:
pago<-creditos*125+40
2:
pago<-creditos*150+40
3:
pago<-creditos*180+40
Fin Segun
fin si
FinSi
escribir "el monto a pagar es de:",pago
FinAlgoritmo
 En un
hospital se ha hecho un estudio sobre los pacientes registrados durante los últimos
10 años, con el objeto de hacer una aproximación de los costos de internamiento por
paciente. Se obtuvo un costo promedio diario según el tipo de enfermedad que
aqueja al paciente, además se pudo determinar que en promedio todos los pacientes
con edad entre 14 y 22 años implican un costo adicional del 10%. La siguiente tabla
expresa los costos diarios según el tipo de enfermedad.
TIPO DE ENFERMEDAD COSTO /PACIENTE
0 25
1 16
2 20
3 32
Calcular e imprimir el costo que representa un paciente
Algoritmo ejercicio17
definir tipoe,edad Como Entero
definir costo Como Real
escribir"ingresetipo de enfermedad"
leer tipoe
escribir "ingrese edad del paciente"
leer edad
Segun tipoe Hacer
0:
costo<-25
1:
costo<-16
2:
costo<-20
3:
costo<-32
De Otro Modo:
escribir "error"
Fin Segun
si edad>=14 y edad<=22 entonces
costo<-costo+0.1*costo
FinSi
escribir "el costo del paciente es ",costo
FinAlgoritmo

También podría gustarte