Está en la página 1de 16

Trabajo de investigación Redes de computadores y sistemas

distribuidos 1

Redes de computadores y sistemas distribuidos 1


Curso

Universidad de Pamplona
Facultad de ingenierías y arquitectura
Ingeniería de sistemas.
1. Que es una VLAN
No es muy habitual encontrar esta función en los equipos suministrados por los operadores,
muchas de las alternativas existentes en el mercado permiten configurar las VLANs.
Del inglés Virtual LAN (Red de área local y virtual), es un método que permite crear redes
que lógicamente son independientes, aunque estas se encuentren dentro de una misma
red física. De esta forma, un usuario podría disponer de varias VLANs dentro de un mismo
router o switch. Podría decirse que cada una de estas redes agrupa los equipos de un
determinado segmento de red. Crear estas particiones tiene unas ventajas bastante claras
a la hora de administrar una red.
Una red de área local, o LAN, proporciona a los nodos conectados a ella acceso directo
(Capa 2) el uno al otro. Por lo general, está compuesto por uno o más conmutadores
Ethernet. Las computadoras en diferentes LAN se comunican entre sí utilizando Capa 3
(IP), a través de un enrutador.
Una LAN virtual (VLAN) abstrae la idea de la LAN; una VLAN puede comprender un
subconjunto de los puertos en un único conmutador o subconjuntos de puertos en
conmutadores múltiples. De manera predeterminada, los sistemas en una VLAN no ven el
tráfico asociado con los sistemas en otras VLAN en la misma red.

Qué uso tienen y ventajas


A día de hoy se configuran a través de software y poseen grandes beneficios a la hora de
garantizar la seguridad y administrar los equipos de forma eficaz, tal y como a hemos
puntualizado. En lo que concierne a la seguridad, hay que tener en cuenta que los
dispositivos pertenecientes a una VLAN no tienen acceso a los que se encuentren en otras
y viceversa. Resulta útil cuando queremos segmentar los equipos y limitar el acceso entre
ellos por temas de seguridad.
De lo dicho con anterioridad se deduce que la gestión también será mucho más sencilla, ya
que tendríamos a los dispositivos divididos en «clases» aunque pertenezcan a una misma
red.
Los puertos en los switches se pueden asignar a una o más VLANs, permitiendo que los
sistemas se dividan en grupos lógicos, por ejemplo, según el departamento al que están
asociados, y las reglas que se establecerán sobre cómo los sistemas en los grupos
separados pueden comunicarse juntos. Estos pueden ir desde lo simple y práctico (las
computadoras en una VLAN pueden ver la impresora en esa VLAN, pero las computadoras
fuera de esa VLAN no pueden), hasta las complejas y legales (por ejemplo, las
computadoras en los departamentos comerciales no pueden interactuar con computadoras
de los departamentos de banca minorista).
Además, las VLAN se pueden tunelizar a través de los límites de la Capa 3 (es decir, a
través de un enlace de enrutador) para permitir que los sistemas geográficamente dispersos
se comuniquen como si estuvieran físicamente en la misma LAN.

Tipos de VLANs
Dependiendo de la fuente consultada incluso del fabricante se pueden distinguir
hasta seis tipos de redes virtuales. Sin embargo, solo nos vamos a centrar en tres:
a nivel de puerto, MAC y aplicación.

 Puerto. También conocida como Port Switching en los menús de


configuración de los routers y switches, se trata de la más extendida y
utilizada. Cada puerto se asigna a una VLAN y los usuarios que estén
conectados a ese puerto pertenecen a la VLAN asignada. Los usuarios
dentro de una misma VLAN poseen de visibilidad los unos sobre los otros,
aunque no a las redes virtuales vecinas. El único inconveniente es que no
permite dinamismo a la hora de ubicar los usuarios y en el caso de que el
usuario cambie de emplazamiento físicamente se debería reconfigurar la red
virtual.
 MAC: El razonamiento es similar a la anterior, salvo que en vez de ser una
asignación a nivel de puerto lo es a nivel de dirección MAC del dispositivo.
La ventaja es que permite movilidad sin necesidad de que se tengan que
aplicar cambios en la configuración del switch o del router. El problema
parece bastante claro: añadir todos los usuarios puede resultar tedioso.
 Aplicaciones: Se asignarían redes virtuales en función de la aplicación
utilizada, y en este caso intervienen varios factores, como por ejemplo la hora
en la que nos encontramos, la dirección MAC o la subred, permitiendo
distinguir entre aplicaciones SSH, FTP, Samba o incluso SMTP.

Aplicaciones en equipos domésticos


¿Cuantos lectores poseen conexiones FTTH? En este servicio tenemos un claro
ejemplo de utilización de VLANs pero a gran escala. Los operadores ubican los
diferentes servicios en redes lógicas separadas. Por ejemplo, en el caso de
Movistar, el servicio de televisión, VoIP e Internet se encuentran en redes
separadas, algo que los usuarios que hagan uso de routers diferentes a los
ofrecidos por la operadora conocerán.

Hablando de qué uso se puede dar, resulta bastante claro. Por ejemplo, separar
aquellos equipos que acceden a Internet de los que no lo hacen. Esto evita que los
intrusos no lleguen a estos y que por ejemplo malware pueda distribuirse gracias a
unidades de red que estarían disponibles.

2. Historia
A principios de la década de 1980, Ethernet era una tecnología consolidada que
ofrecía una velocidad de 10 Mbps, mucho mayor que gran parte de las alternativas
de la época. Las redes Ethernet tenían una topología en bus, donde el medio físico
de transmisión (cable coaxial) era compartido.

Ethernet era, por lo tanto, una red de difusión y como tal cuando dos estaciones
transmiten simultáneamente se producen colisiones y se desperdicia ancho de
banda en transmisiones fallidas. El diseño de Ethernet no ofrecía escalabilidad, es
decir, al aumentar el tamaño de la red disminuyen sus prestaciones o el costo se
hace inasumible. CSMA/CD, el protocolo que controla el acceso al medio
compartido en Ethernet, impone de por sí limitaciones en cuanto al ancho de banda
máximo y a la máxima distancia entre dos estaciones. Conectar múltiples redes
Ethernet era por aquel entonces complicado, y aunque se podía utilizar un router
para la interconexión, estos eran caros y requería un mayor tiempo de procesado
por paquete grande, aumentando el retardo.

Para solucionar estos problemas, primero W. Kempf inventó el bridge (puente),


dispositivo software para interconectar dos LANs.

En 1990 Kalpana desarrolló el switch Ethernet, puente multipuerto implementado en


hardware, dispositivo de conmutación de tramas de nivel 2. Usar switches para
interconectar redes Ethernet permite separar dominios de colisión, aumentando la
eficiencia y la escalabilidad de la red. Una red tolerante a fallos y con un nivel alto
de disponibilidad requiere que se usen topologías redundantes: enlaces múltiples
entre switches y equipos redundantes. De esta manera, ante un fallo en un único
punto es posible recuperar de forma automática y rápida el servicio. Este diseño
redundante requiere la habilitación del protocolo spanning tree (STP) para
asegurarse de que solo haya activo un camino lógico para ir de un nodo a otro y
evitar así el fenómeno conocido como tormentas broadcast. El principal
inconveniente de esta topología lógica de la red es que los switches centrales se
convierten en cuellos de botella, pues la mayor parte del tráfico circula a través de
ellos.
Sincoskie consiguió aliviar la sobrecarga de los switches inventando LAN virtuales
al añadir una etiqueta a las tramas Ethernet con la que se diferencia el tráfico. Al
definir varias LAN virtuales cada una de ellas tendrá su propio spanning tree y se
podrá asignar los distintos puertos de un switch a cada una de las VLAN.

Para unir VLAN que están definidas en varios switches se puede crear un enlace
especial llamado trunk, por el que fluye tráfico de varias VLAN. Los switches sabrán
a qué VLAN pertenece cada trama observando la etiqueta VLAN (definida en la
norma IEEE 802.1Q). Aunque hoy en día el uso de LAN virtuales es generalizado
en las redes Ethernet modernas, usarlas para el propósito original puede ser un
tanto extraño, ya que lo habitual es utilizarlas para separar dominios de difusión
(hosts que pueden ser alcanzados por una trama broadcast).

IEEE 802.1aq-2012 - Shortest Path Bridging ofrece mucha más escalabilidad a


hasta 16 millones comparado con el límite de 4096 de las VLAN.

3. Clasificación
Aunque las más habituales son las VLAN basadas en puertos (nivel 1), las redes de
área local virtuales se pueden clasificar en cuatro tipos según el nivel de la jerarquía
OSI en el que operen:

 VLAN de nivel 1 (por puerto). También conocida como “port switching”. Se


especifica qué puertos del switch pertenecen a la VLAN, los miembros de
dicha VLAN son los que se conecten a esos puertos. No permite la movilidad
de los usuarios, habría que reconfigurar las VLAN si el usuario se mueve
físicamente. Es la más común y la que se explica en profundidad en este
artículo.
 VLAN de nivel 2 por direcciones MAC. Se asignan hosts a una VLAN en
función de su dirección MAC. Tiene la ventaja de que no hay que reconfigurar
el dispositivo de conmutación si el usuario cambia su localización, es decir,
se conecta a otro puerto de ese u otro dispositivo. El principal inconveniente
es que hay que asignar los miembros uno a uno y si hay muchos usuarios
puede ser agotador.
 VLAN de nivel 2 por tipo de protocolo. La VLAN queda determinada por el
contenido del campo tipo de protocolo de la trama MAC. Por ejemplo, se
asociaría VLAN 1 al protocolo IPv4, VLAN 2 al protocolo IPv6, VLAN 3 a
AppleTalk, VLAN 4 a IPX...
 VLAN de nivel 3 por direcciones de subred (subred virtual). La cabecera de
nivel 3 se utiliza para mapear la VLAN a la que pertenece. En este tipo de
VLAN son los paquetes, y no las estaciones, quienes pertenecen a la VLAN.
Estaciones con múltiples protocolos de red (nivel 3) estarán en múltiples
VLAN.
 VLAN de niveles superiores. Se crea una VLAN para cada aplicación: FTP,
flujos multimedia, correo electrónico... La pertenencia a una VLAN puede
basarse en una combinación de factores como puertos, direcciones MAC,
subred, hora del día, forma de acceso, condiciones de seguridad del equipo.

4. VLAN estática, VLAN Dinámica.


Las VLAN estáticas también se denominan VLAN basadas en el puerto. Las asignaciones
en una VLAN estática se crean mediante la asignación de los puertos de un switch o
conmutador a dicha VLAN. Cuando un dispositivo entra en la red, automáticamente asume
su pertenencia a la VLAN a la que ha sido asignado el puerto. Si el usuario cambia de puerto
de entrada y necesita acceder a la misma VLAN, el administrador de la red debe cambiar
manualmente la asignación a la VLAN del nuevo puerto de conexión en el switch.

En las VLAN dinámicas, la asignación se realiza mediante paquetes de software tales


como el CiscoWorks 2000. Con el VMPS (acrónimo en inglés de VLAN Management Policy
Server o Servidor de Gestión de Directivas de la VLAN), el administrador de la red puede
asignar los puertos que pertenecen a una VLAN de manera automática basándose en
información tal como la dirección MAC del dispositivo que se conecta al puerto o el nombre
de usuario utilizado para acceder al dispositivo. En este procedimiento, el dispositivo que
accede a la red, hace una consulta a la base de datos de miembros de la VLAN. Se puede
consultar el software FreeNAC para ver un ejemplo de implementación de un servidor
VMPS.

VLAN estática vs VLAN dinámica


La red de área local virtual (VLAN) es un conjunto de puertos seleccionados por el
conmutador como pertenecientes al mismo dominio de difusión. Normalmente, todos los
puertos que transportan tráfico a una dirección de subred particular pertenecerían a la
misma VLAN. Las VLAN estáticas son VLAN que se configuran manualmente al
proporcionar un nombre, ID de VLAN (VID) y asignaciones de puertos. Las VLAN dinámicas
se crean almacenando las direcciones de hardware de los dispositivos host en una base de
datos para que el conmutador pueda asignar la VLAN dinámicamente en cualquier
momento cuando un host esté conectado a un conmutador. Las VLAN le permiten agrupar
usuarios según la función lógica en lugar de su ubicación física.

¿Cuál es la diferencia entre VLAN estática y VLAN dinámica?


La principal diferencia entre las VLAN estáticas y las VLAN dinámicas es que las VLAN
estáticas se configuran manualmente al asignar puertos a una VLAN, mientras que las
VLAN dinámicas usan una base de datos que almacena una asignación de VLAN a MAC
para determinar la VLAN a la que está conectado un host en particular. Esto proporciona
más flexibilidad en las VLAN dinámicas, lo que permite que los hosts se muevan dentro de
la red en lugar de las redes estáticas. Pero la configuración del servidor VMPS que contiene
la asignación de VLAN a MAC requiere mucho trabajo inicial. Debido a esta sobrecarga, los
administradores de red tienden a preferir las VLAN estáticas.

5. Protocolos relacionados a las VLAN


Durante todo el proceso de configuración y funcionamiento de una VLAN es necesaria la
participación de una serie de protocolos entre los que destacan el IEEE 802.1Q, STP y VTP
(cuyo equivalente IEEE es GVRP). El protocolo IEEE 802.1Q se encarga del etiquetado de
las tramas que es asociada inmediatamente con la información de la VLAN. El cometido
principal de Spanning Tree Protocol (STP) es evitar la aparición de bucles lógicos para que
haya un solo camino entre dos nodos. VTP (VLAN Trunking Protocol) es un protocolo
propietario de Cisco que permite una gestión centralizada de todas las VLAN.

El protocolo de etiquetado IEEE 802.1Q es el más común para el etiquetado de las VLAN.
Antes de su introducción existían varios protocolos propietarios, como el ISL (Inter-Switch
Link) de Cisco, una variante del IEEE 802.1Q, y el VLT (Virtual LAN Trunk) de 3Com. El
IEEE 802.1Q se caracteriza por utilizar un formato de trama similar a 802.3 (Ethernet) donde
solo cambia el valor del campo Ethertype, que en las tramas 802.1Q vale 0x8100, y se
añaden dos bytes para codificar la prioridad, el CFI y el VLAN ID. Este protocolo es un
estándar internacional y por lo dicho anteriormente es compatible con bridges y switches
sin capacidad de VLAN.

Las VLAN y Protocolos de Árbol de Expansión. Para evitar la saturación de los switches
debido a las tormentas broadcast, una red con topología redundante tiene que tener
habilitado el protocolo STP. Los switches intercambian mensajes STP BPDU (Bridge
Protocol Data Units) entre sí para lograr que la topología de la red sea un árbol (no tenga
enlaces redundantes) y solo haya activo un camino para ir de un nodo a otro. El protocolo
STP/RSTP es agnóstico a las VLAN, MSTP (IEEE 802.1Q) permite crear árboles de
expansión diferentes y asignarlos a grupos de las VLAN mediante configuración. Esto
permite utilizar enlaces en un árbol que están bloqueados en otro árbol.

En los dispositivos Cisco, VTP (VLAN trunking protocol) se encarga de mantener la


coherencia de la configuración VLAN por toda la red. VTP utiliza tramas de nivel 2 para
gestionar la creación, borrado y renombrado de las VLAN en una red sincronizando todos
los dispositivos entre sí y evitar tener que configurarlos uno a uno. Para eso hay que
establecer primero un dominio de administración VTP. Un dominio VTP para una red es un
conjunto contiguo de switches unidos con enlaces trunk que tienen el mismo nombre de
dominio VTP.

Los switches pueden estar en uno de los siguientes modos: servidor, cliente o transparente.
«Servidor» es el modo por defecto, anuncia su configuración al resto de equipos y se
sincroniza con otros servidores VTP. Un switch en modo cliente no puede modificar la
configuración VLAN, simplemente sincroniza la configuración sobre la base de la
información que le envían los servidores. Por último, un switch está en modo transparente
cuando solo se puede configurar localmente pues ignora el contenido de los mensajes VTP.

VTP también permite «podar» (función VTP pruning), lo que significa dirigir tráfico VLAN
específico solo a los conmutadores que tienen puertos en la VLAN destino. Con lo que se
ahorra ancho de banda en los posiblemente saturados enlaces trunk.

Uno de los peores problemas que puede presentarse para un Switch es cuando escucha la
misma dirección MAC (Medium Access Control) por dos interfaces físicas diferentes, este
es un bucle que en principio, no sabría como resolver.2 Este problema si bien parece poco
probable que pueda ocurrir, en realidad en redes grandes al tener cientos o miles de cables
(muchos de ellos para redundancia), este hecho es tan sencillo como conectar el mismo
cable en diferentes patch pannels que cierran un lazo sobre el mismo dispositivo, y en la
realidad ocurre con cierta frecuencia, mayor, en la medida que más grande sea la red LAN.
También es un hecho concreto cuando el cableado se diseña para poseer caminos
redundantes, justamente para incrementar la disponibilidad de la red.

Cuando físicamente se cierra un bucle, la topología pura de red “Jerárquica” deja de serlo
y se convierte en una red “Malla”. Para tratar este problema el protocolo Spanning Tree
crea una red “Jerárquica lógica (árbol Lógico)” sobre esta red “Malla Física”. Este protocolo
crea “Puentes” (bridges) de unión sobre estos enlaces y define a través de diferentes
algoritmos que se pueden configurar, cuál es el que tiene mayor prioridad, este puente de
máxima prioridad lo denomina “Root Bridge” (o Puente Raíz) y será el que manda
jerárquicamente las interfaces por las cuales se separarán los diferentes dominios de
colisión. Todo el control de STP se realiza mediante tramas llamadas BPDU (Bridge
Protocol Data Unit) que son las que regulan los diferentes dominios de colisión . El
parámetro que define esta jerarquía es el BID (Bridge Identifier) que está compuesto por el
Bridge Priority + dirección MAC. El Bridge Priority es un valor configurable que por defecto
está asignado en 32768.

En general este protocolo se configura de forma automática, y se basa en el orden de


encendido de los diferentes Switchs de la red, siendo el primero que se pone en
funcionamiento el que se auto designa “Root Bridge”, pero por supuesto se puede realizar
de forma manual.

6. Diseño de las VLAN


Los primeros diseñadores de redes solían configurar las VLAN con el objetivo de reducir el
tamaño del dominio de colisión en un segmento Ethernet y mejorar su rendimiento. Cuando
los switches lograron esto, porque cada puerto es un dominio de colisión, su prioridad fue
reducir el tamaño del dominio de difusión. Ya que, si aumenta el número de terminales,
aumenta el tráfico difusión y el consumo de CPU por procesado de tráfico broadcast no
deseado. Una de las maneras más eficientes de lograr reducir el domino de difusión es con
la división de una red grande en varias VLAN.

Red institucional

Actualmente, las redes institucionales y corporativas modernas suelen estar configuradas


de forma jerárquica dividiéndose en varios grupos de trabajo. Razones de seguridad y
confidencialidad aconsejan también limitar el ámbito del tráfico de difusión para que un
usuario no autorizado no pueda acceder a recursos o a información que no le corresponde.
Por ejemplo, la red institucional de un campus universitario suele separar los usuarios en
tres grupos: alumnos, profesores y administración. Cada uno de estos grupos constituye un
dominio de difusión, una VLAN, y se suele corresponder asimismo con una subred IP
diferente. De esta manera la comunicación entre miembros del mismo grupo se puede
hacer en nivel 2, y los grupos están aislados entre sí, sólo se pueden comunicar a través
de un router.

La definición de múltiples VLAN y el uso de enlaces trunk, frente a las redes LAN
interconectadas con un router, es una solución escalable. Si se deciden crear nuevos
grupos se pueden acomodar fácilmente las nuevas VLAN haciendo una redistribución de
los puertos de los switches. Además, la pertenencia de un miembro de la comunidad
universitaria a una VLAN es independiente de su ubicación física. E incluso se puede lograr
que un equipo pertenezca a varias VLAN (mediante el uso de una tarjeta de red que soporte
trunk).

Imagine que la universidad tiene una red con un rango de direcciones IP del tipo
172.16.XXX.0/24, cada VLAN, definida en la capa de enlace de datos (nivel 2 de OSI), se
corresponderá con una subred IP distinta:

VLAN 10, Administración, Subred IP 172.16.10.0/24.

VLAN 20, Profesores, Subred IP 172.16.20.0/24.

VLAN 30, Alumnos, Subred IP 172.16.30.0/24.

En cada edificio de la universidad hay un switch denominado de acceso, porque a él se


conectan directamente los sistemas finales. Los switches de acceso están conectados con
enlaces trunk (enlace que transporta tráfico de las tres VLAN) a un switch troncal, de
grandes prestaciones, típicamente Gigabit Ethernet o 10-Gigabit Ethernet. Este switch está
unido a un router también con un enlace trunk, el router es el encargado de llevar el tráfico
de una VLAN a otra.

7. Ventajas de las redes virtuales


Una de las ventajas principales de utilizar una VLAN es que reduce la latencia y la carga de
tráfico de la red y los dispositivos, lo que ahorra recursos y mejora la eficacia del sistema.

Asimismo, este tipo de red privada segmenta a los usuarios, cosa que facilita la seguridad,
la escalabilidad y la administración:

 Mayor seguridad. Los dispositivos vinculados a una red privada virtual no tienen
acceso a los dispositivos que se encuentren en otras redes y viceversa, lo que
refuerza la confidencialidad. Además, los administradores pueden aplicar
medidas extra entre comunicaciones internas.
 Posibilidad de expansión más fácil. Se simplifica la ampliación y reubicación de
una red o un dispositivo de la red.
 Gestión centralizada. Los administradores pueden configurarlo todo en un
entorno centralizado, aunque los dispositivos se encuentren en diferentes puntos
geográficos. Por otro lado, los equipos se pueden gestionar por separado, en
función de la «clase» que se les haya asignado.

Por último, cabe recordar que las VLAN también permiten analizar fácilmente las pautas de
tráfico.

Desventajas de una VLAN


Las redes privadas virtuales también tienen algunas desventajas y limitaciones:

 Administración compleja. Tener varias VLAN supone el mismo trabajo que


gestionar diversas LAN, por lo que se debe configurar cada switch.
 Aislamiento del tráfico. En redes grandes puede ser necesario contar con varios
routers para que las VLAN se puedan comunicar.
 Agujero de seguridad. Sin un virus llega a infectar un ordenador, se puede
reproducir «fácilmente» por toda la red lógica.
 Latencia limitada. Las VLAN son más eficaces que una WAN en cuanto a la
latencia, pero menos que una LAN.

¿Cuándo utilizar una VLAN?


Los beneficios principales de implementar una red privada virtual son, por un lado, mejorar
el rendimiento de la red y, por otro, aplicar medidas de seguridad más potentes.

Un ejemplo típico referido a la seguridad es el de la información personal de la plantilla: el


departamento de Recursos Humanos no quiere que los datos que manejan sean visibles
en la misma red que la del equipo de marketing o atención al cliente. Con una LAN virtual
podemos separar los equipos en tantas redes como consideremos oportunas.
8. Configuración de VLANs con Cisco
Ambiente

La asignación de VLANs quedará:

 VLAN4: 192.168.4.0/24.
o Switch0: puertos 1 al 9.
o Switch1: puertos 1 al 9.
 VLAN5: 192.168.5.0/24.
o Switch0: puertos 9, 10, 12.
o Switch1: puertos 10 al 14.
 TRUNK
o Switch0: fastEthernet 0/11, gigabitEthernet 1/1.
o Switch1: gigabitEthernet 1/1.
o Router0: fastEthernet 0/0.

Creación de las VLAN


sw0(config)# interface vlan 4
sw0(config-if)# description Vlan4
sw0(config-if)# no shutdown

sw0(config)# interface vlan 5


sw0(config-if)# description Vlan5
sw0(config-if)# no shutdown

sw1(config)# interface vlan 4


sw1(config-if)# description Vlan4
sw1(config-if)# no shutdown

sw1(config)# interface vlan 5


sw1(config-if)# description Vlan5
sw1(config-if)# no shutdown
Asignar puertos a las VLAN
sw0(config)#interface range fastEthernet 0/1 - fastEthernet 0/8
sw0(config-if-range)#switchport mode access
sw0(config-if-range)#switchport access vlan 4
sw0(config-if-range)#exit

sw0(config)#interface range fastEthernet 0/9, fastEthernet 0/10,


fastEthernet0/12
sw0(config-if-range)#switchport mode access
sw0(config-if-range)#switchport access vlan 5
sw0(config-if-range)#exit

sw1(config)#interface range fastEthernet 0/1 - fastEthernet 0/9


sw1(config-if-range)#switchport mode access
sw1(config-if-range)#switchport access vlan 4
sw1(config-if-range)#exit

sw1(config)#interface range fastEthernet 0/10 - fastEthernet 0/14


sw1(config-if-range)#switchport mode access
sw1(config-if-range)#switchport access vlan 5
sw1(config-if-range)#exit

Configurar los puertos de Trunk


sw0(config)#interface fastEthernet 0/11
sw0(config-if)#switchport mode trunk
sw0(config-if)#switchport trunk encapsulation dot1q
sw0(config-if)#switchport trunk allowed vlan 4,5
sw0(config-if)#exit

sw0(config)#interface gigabitEthernet 1/1


sw0(config-if)#switchport mode trunk
sw0(config-if)#switchport trunk encapsulation dot1q
sw0(config-if)#switchport trunk allowed vlan 4,5
sw0(config-if)#exit

sw1(config)#interface gigabitEthernet 1/1


sw1(config-if)#switchport mode trunk
sw0(config-if)#switchport trunk encapsulation dot1q
sw1(config-if)#switchport trunk allowed vlan 4,5
sw1(config-if)#exit

Ruteo entre VLANs


central(config)#interface fastEthernet 0/0
central(config-if)#no shutdown
central(config-if)#exit

central(config)# interface fastEthernet 0/0.4


central(config-if)# encapsulation dot1Q 4
central(config-if)# ip address 192.168.4.1 255.255.255.0
exit
central(config)# interface fastEthernet 0/0.5
central(config-if)# encapsulation dot1Q 5
central(config-if)# ip address 192.168.5.1 255.255.255.0
exit

Verificación de la configuración de las VLAN


sw1#show vlan brief

VLAN Name Status Ports


---- -------------------------------- --------- -------------------------
------
1 default active Fa0/15, Fa0/16, Fa0/17,
Fa0/18
Fa0/19, Fa0/20, Fa0/21,
Fa0/22
Fa0/23, Fa0/24, Gig1/2
4 VLAN0004 active Fa0/1, Fa0/2, Fa0/3,
Fa0/4
Fa0/5, Fa0/6, Fa0/7,
Fa0/8
Fa0/9
5 VLAN0005 active Fa0/10, Fa0/11, Fa0/12,
Fa0/13
Fa0/14
1002 fddi-default active
1003 token-ring-default active
1004 fddinet-default active
1005 trnet-default active

sw1#show vlan id 4

VLAN Name Status Ports


---- -------------------------------- --------- -------------------------
------
4 VLAN0004 active Fa0/1, Fa0/2, Fa0/3,
Fa0/4
Fa0/5, Fa0/6, Fa0/7,
Fa0/8
Fa0/9

VLAN Type SAID MTU Parent RingNo BridgeNo Stp BrdgMode Trans1
Trans2
---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ -
-----
4 enet 100004 1500 - - - - - 0 0

sw1#show interfaces vlan 4


Vlan4 is up, line protocol is up
Hardware is CPU Interface, address is 0007.ecaa.64a6 (bia 0007.ecaa.64a6)
MTU 1500 bytes, BW 100000 Kbit, DLY 1000000 usec, reliability 255/255,
txload 1/255, rxload 1/255
Encapsulation ARPA, loopback not set
ARP type: ARPA, ARP Timeout 04:00:00
Last input 21:40:21, output never, output hang never
Last clearing of "show interface" counters never
Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
Queueing strategy: fifo
Output queue: 0/40 (size/max)
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
1682 packets input, 530955 bytes, 0 no buffer
Received 0 broadcasts (0 IP multicast)
0 runts, 0 giants, 0 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
563859 packets output, 0 bytes, 0 underruns
0 output errors, 23 interface resets
0 output buffer failures, 0 output buffers swapped out

sw1#show interfaces trunk


Port Mode Encapsulation Status Native vlan
Gig1/1 on 802.1q trunking 1

Port Vlans allowed on trunk


Gig1/1 4-5

Port Vlans allowed and active in management domain


Gig1/1 4,5

Port Vlans in spanning tree forwarding state and not pruned


Gig1/1 4,5
Conclusión

Las redes virtuales también son prácticas para aislar fallos de dominio y, por tanto, reducir
el tiempo medio que se tarda en resolver el problema. Imaginemos, por ejemplo, que
nuestros usuarios no pueden acceder al servidor; con una VLAN podemos restringir el fallo
a un grupo de usuarios, en lugar de tener que suponer que afecta a toda la red.

Sin duda alguna, el rendimiento de una red representa un factor predominante en la


productividad de una organización. Por ellos se han realizado importantes avances en la
tecnología y se ha previsto un conjunto de métodos que contribuyen al excelente
rendimiento de una red. Uno de estos aportes son las VLAN.

Las VLANs son un medio muy poderoso a la hora de gestionar redes de área local de
mediano y gran tamaño. Ampliamente utilizadas hoy en día, el conocimiento y comprensión
de las mismas es fundamental para cualquier administrador de redes.
Bibliografía

https://www.redeszone.net/2016/11/29/vlans-que-son-tipos-y-para-
que-sirven/

https://www.cisco.com/c/es_mx/support/docs/wireless-
mobility/wireless-vlan/68100-wlan-controllers-vlans.html

https://www.ibm.com/support/knowledgecenter/es/ssw_aix_72/network
/adapters_vlan.html

https://es.wikipedia.org/wiki/VLAN

https://www.mikroways.net/2010/01/18/introduccion-a-las-vlan/

También podría gustarte