Está en la página 1de 18

INGENIERÍA INDUSTRIAL

ALGORITMOS Y LENGUAJES DE PROGRAMACIÓN


- INC-1005-2019B

Actividad 3 T2 "Actividad práctica"

Profesor: Rafael Portillo Rosales


Alumno: Mario Silva Esparza
Fecha: 22/09/2019
DESCRIPCIÓN:
Resuelve los siguientes problemas, debes llevar a cabo el análisis y posteriormente
escribe el pseudocódigo que permita resolver el problema planteado, genera el diagrama
de flujo y preséntalos en un documento en word con la nomeclatura indicada al inicio del
curso:

Problema No. 9
El maestro de estadística desea que lo apoyes para calcular el promedio de un alumno
a partir de las calificaciones de 5 unidades, debes mostrar el promedio, así como uno de
los dos siguientes mensajes: "APROBADO”, "REPROBADO, DEBES HACER
SEGUNDA OPORTUNIDAD”.
Problema No. 10

En la escuela naval necesitan reclutar aspirantes para formar parte de la misma, los requisitos
son los siguientes:

El aspirante debe ser mayor de edad, debe tener promedio mínimo de 9.5, debe ser hombre y
debe tener cartilla militar. En caso de no ser seleccionado debe especificar la(s) razones por las
cuales no fue seleccionado.

Edad

Promedio

Sexo

Cartilla
Proceso Problema_10
definir expe como real
definir edad,edad1 como entero
definir prom como real
definir sex como texto
definir cart,resultado como texto
definir ca,ed,pro,se como texto
definir conde,conda,conda1,condx como texto
Escribir "Edad del aspirante"
Leer edad
Escribir "Promedio de calificacion de 0 a 10"
Leer prom
Escribir "introduzca H (Hombre) M (Mujer)"
Leer sex
Escribir "introduzca S(Con cartilla),N(sin Cartilla)"
Leer cart

Si edad>=18 Entonces
ed="Aceptada"
Si prom>=9.5 Entonces
pro="Aceptada"
Si sex="H" Entonces
se="Aceptada"
Si cart="S" Entonces
ca="Aceptada"
resultado="Aceptado"
Sino
ca="Te hace falta cartilla"
resultado="No Aceptado"
Fin Si
Sino
se="No eres Hombre"
resultado="No Aceptado"
Fin Si
Sino
Pro="No cumples con el promedio de 9.5 mínimo"
Resultado="No Aceptado"
Fin Si
Sino
ed="Eres menor de edad"
resultado="No Aceptado"
Fin Si

Escribir resultado
Escribir "Por edad " ed " " edad
Escribir "Por Promedio " pro " " prom
Escribir "Por sexo " se " " sex
Escribir "Por Cartilla " ca " " cart
Fin Proceso

Problema No. 11

En la empresa NISSAN se necesita personal en el área de producción, el gerente ha indicado


que se recluten a las personas a partir de los siguientes requisitos:

Experiencia laboral mínima de 2 años, debe ser mayor de edad y como máximo 40 años y sólo
se reclutará a personal de sexo masculino. En caso de no ser seleccionado mencione las razones
por las cuales no fue seleccionado.
Realizar la lectura, análisis y comprensión de los temas de CICLOS en los diagramas de
flujo ó PSEUDOCÓDIGO así como el uso de CONTADORES y ACUMULADORES resuelve los
siguientes problemas.

Realiza el análisis, pseudocódigo y posteriormente genera el diagrama de flujo


correspondiente en el lenguaje PSEint.
Problema No. 13

Realiza el problema No. 10 para capturar los datos de 50 aspirantes a la escuela. Mostrar cuantos
aspirantes fueron seleccionados y cuantos rechazados.

Proceso Problema_13
definir expe como real
definir edad,edad1 como entero
definir prom como real
definir sex como texto
definir cart,resultado como texto
definir ca,ed,pro,se como texto
definir conde,conda,conda1,condx como texto
definir cicl, acep,repr como entero
cicl=1
Repetir

Escribir "Edad del aspirante " cicl


Leer edad
Escribir "Promedio de calificacion de 0 a 10 " cicl
Leer prom
Escribir "introduzca H (Hombre) M (Mujer)" cicl
Leer sex
Escribir "introduzca S(Con cartilla),N(sin Cartilla) " cicl
Leer cart

Si edad>=18 Entonces
ed="Aceptada"
Si prom>=9.5 Entonces
pro="Aceptada"
Si sex="H" Entonces
se="Aceptada"
Si cart="S" Entonces
ca="Aceptada"
resultado="Aceptado"
acep=acep+1
Sino
ca="Te hace falta cartilla"
resultado="No Aceptado"
repr=repr+1

Fin Si
Sino
se="No eres Hombre"
resultado="No Aceptado"
repr=repr+1
Fin Si
Sino
pro="No cumples con el promedio de 9.5 minimo"
resultado="No Aceptado"
repr=repr+1
Fin Si
Sino
ed="Eres menor de edad"
resultado="No Aceptado"
repr=repr+1
Fin Si

Escribir resultado
Escribir "Por edad " ed " " edad
Escribir "Por Promedio " pro " " prom
Escribir "Por sexo " se " " sex
Escribir "Por Cartilla " ca " " cart
cicl=cicl+1

Hasta Que cicl=51


Escribir "Total Aceptados:" acep
Escribir "Total de no Aceptados" repr
FinProceso

Problema No. 14

Realiza el problema No. 11 para capturar los datos de 10 aspirantes para trabajar en Nissan.
Mostrar cuantos aspirantes fueron seleccionados y cuantos rechazados.
Realiza el análisis, pseudocódigo y diagrama de flujo correspondiente en un documento en Word
y sube el archivo con la nomenclatura indicada al inicio del curso.
Proceso Problema_11

definir expe como real

definir edad,edad1 como entero

definir prom como real

definir sex como texto

definir cart,resultado como texto

definir ex,ed,pro,se como texto

definir conde,conda,conda1,condx como texto

definir cicl, acep,repr como entero


cicl=1

Repetir

Escribir "Introduzca experiencia laboral " cicl

Leer expe

Escribir "Introdzca su edad " cicl

Leer edad

Escribir "introduzca H (Hombre) M (Mujer) " cicl

Leer sex

Si expe>=2 Entonces

ex="Aceptada"

Si edad>=18 Entonces

ed="Aceptada"

Si edad<=40 Entonces

ed="Aceptada"

resultado="Aceptado"

Si sex="H" Entonces

se="Aceptada"

resultado="Aceptado"

acep=acep+1

Sino

se="No eres hombre"

repr=repr+1

Fin Si

Sino

ed="Sobre pasas la edad"

repr=repr+1

Fin Si

Sino
ed="No eres mayor de edad"

repr=repr+1

Fin Si

Sino

ex="No tiene la experiencia minima requerida de 2 años"

repr=repr+1

Fin Si

Escribir Resultado

Escribir "Por experiencia " ex " " expe

Escribir "Por edad " ed " " edad

Escribir "Por sexo " se " " sex

cicl=cicl+1

Hasta Que cicl=3

Escribir "Total Aceptados:" acep

Escribir "Total de no Aceptados" repr

FinProceso

Problema No. 15

El dueño de la tienda departamental se ha percatado de que las ventas han disminuido


considerablemente por lo que ha decidido implementar la siguiente estrategia:

·Aplicar el 25% de descuento en caso de que las compras sean menores a $2,500.00

·Aplicar el 40% de descuento en caso de que las compras sean entre $2,500.00 y $5,000.00

·Aplicar el 50% de descuento en caso de que las compras sean mayores a $5,000.00 y
menores a $7,500.00

·Aplicar el 70% de descuento en caso de que las compras sean $7,500.00 o mayores a esa
cantidad.

Desea mostrar al cliente la siguiente información: Cantidad de la compra, cantidad de descuento


aplicado y cantidad real a pagar por el cliente.
El dueño de la tienda desea que se implemente el problema para atender a 10 clientes, además
desea conocer el total de dinero correspondiente a las compras realizadas al terminar de atender
a esos 10 clientes, cantidad de descuento realizado y cantidad real de dinero recaudado por la
tienda (compras menos descuentos).
Proceso Problema_15
definir total, pago,sum,tot, desc Como Real
Definir descuento como entero
definir cicl como entero
Definir cont25, cont40, cont50, cont70 como entero
definir control como entero
cicl=0
Repetir
control=cicl+1
Escribir "Introduzca compra total " control
Leer pago
Si pago<2500 Entonces
total=pago*.75
descuento=25
contador25=contador25+1
Sino
Si pago>=2500 y pago<=5000 Entonces
total=pago*.60
descuento=40
contador40=contador40+1
Sino
Si pago>5000 y pago<7500 Entonces
total=pago*0.50
descuento=50
contador50=contador50+1
Sino
total=pago*0.30
descuento=70
contador70=contador70+1
Fin Si
Fin Si
Fin Si
Escribir "Su compra fue de " pago
Escribir "Su descuento fue " descuento "%"
Escribir "Su total con descuento es de " total
Escribir cicl
tot=tot+pago
sum=sum+total
cicl=cicl+1
Hasta Que cicl=3
desc=tot-sum
Escribir "La venta total de 10 clientes fue " tot
Escribir "Descuento de " desc
Escribir "Lo pagado es de " sum
Escribir "del 25% se aplico una cantidad de " contador25
Escribir "del 40% se aplico una cantidad de " contador40
Escribir "del 50% se aplico una cantidad de " contador50
Escribir "del 70% se aplico una cantidad de " contador70
FinProceso

Problema No. 16

Se desea obtener la suma de los números del 1 al 100.

Problema No. 17

Se desea obtener la suma de los números pares del 1 al 100.


Problema No. 18

A partir de la información del problema No. 8 (selección de alumnos para formar parte del equipo
de Basquetbol del ITA), implementa el diagrama de flujo para que permita seleccionar a 10
alumnos que cumplan con los requisitos para formar el equipo de basquetbol, al terminar la
selección debes mostrar cuantos alumnos fueron rechazados.

Proceso Problema_18
Definir peso,estatura Como Real
definir edad Como Real
Definir condp,conde,conda,resultado como texto
definir est,pes,eda como entero
Definir ContAc, ContRe como entero
Resultado="No Aceptado"
Repetir
cont=cont+1
Escribir "Escriba la estatura del alumno #" cont
Leer estatura
Escribir "Escriba el peso del alumno #" cont
Leer peso
Escribir "Escriba la edad del alumno #" cont
Leer edad
Si estatura>=170 Entonces
conde="Aceptada"
Si peso<=90 Entonces
condp="Aceptada"
Si edad>=18 Entonces
conda="Aceptada"
resultado="Aceptado"
ContAc=ContAc+1
Sino
conda="Eres menor de edad"
ContRe=ContRe+1
Fin Si
Sino
condp="El peso pasa el máximo permitido"
ContRe=ContRe+1
Fin Si
Sino
conde="La estatura está por debajo del mínimo"
ContRe=ContRe+1
Fin Si

Escribir Resultado
Escribir "Por estatura " conde " " estatura
Escribir "Por peso " condp " " peso
Escribir "Por edad " conda " " edad
Hasta Que cont=10
Escribir "Total de Rechazados " ContRe
FinProceso

Referencias Bibliografías
https://www.uv.mx/personal/mansuarez/files/2014/02/Tema-1.Introduccion-a-los-
algoritmos.pdf