Está en la página 1de 11

Actividades de transferencia de conocimiento

Para evaluar competencia de producto, se debe dar una solución empresarial de


acuerdo a las siguientes premisas:
El punto de partida del ejercicio es una situación para brindar una “solución
empresarial” tal y como se expone en el siguiente fragmento:
Una vez planteado el siguiente enunciado, el aprendiz deberá plantear la
solución en un documento. La solución deberá tener el análisis de variables,
el algoritmo y el DFD.
Ejercicio de solución empresarial:
Una central distribuye cal hacia diferentes almacenes sucursales. Disponen de un
muelle de carga a donde van llegando sacas de cal de entre 3000 y 9000 kg, con
pesos variables en función de las circunstancias de la producción. La empresa
dispone de una flota de camiones con capacidades de carga de entre 18000 y
28000 kg. Se pretende establecer un protocolo que consiste en cargar 20
camiones diarios. Cada camión se quiere cargar como máximo a su límite de
capacidad teniendo este que partir, si con la siguiente saca en la línea de
producción fuera a exceder su capacidad. La empresa quiere desarrollar un
programa que le pida al operario encargado de carga la capacidad del camión y el
peso de las sacas, indicándole si debe cargar la saca o despachar el camión para
comenzar a cargar otro. Analícelo de manera lógica y posteriormente desarrolle un
documento describiendo detalladamente los pasos que siguió en el proceso de
análisis y diseño de la solución. A continuación, envíe un archivo en PDF o Word
con la actividad resuelta a través de la plataforma en el enlace dispuesto.
“actividad 4 – evidencia 2”

Paso que se siguieron para la realización de la actividad.


1. Se leyó el enunciado y se sacaron los datos importantes como son:
a. Los datos de entrada que requería el algoritmo.
b. La capacidad del camión y el peso de las sacas.
c. Rango de valores de cada uno.
2. Se identificaron cuales eran los datos que se pedirían en el ciclo y cuáles no.
3. Se procede al desarrollo del algoritmo pidiendo como primer dato de entrada y fuera del
ciclo la capacidad del camión, se piden el peso de las sacas dentro del ciclo y se le va
restando a la capacidad del camión para que así el ciclo pare cuando alcance la
capacidad.
4. Se proceden a realizar pruebas.
5. Se identifica que las sumas de las sacas esta superando la capacidad del camión.
6. Se realiza condicional que evalué la capacidad del camión sobre 3000 ya que es la saca
mínima que entra al sistema dado en el requerimiento.
7. Se realizan validaciones para la capacidad mínima y máxima del camión ya que el
enunciado dice que lo9s camiones son de 18000 y 28000.
8. Se realiza validación para el peso de las sacas ya que el enunciado dice que como
mínimo de 3000 y como máximo de 9000.
9. Para los datos de salida se indica que el camión alcanzo su límite, se indica que pase otro
camión, se indica cuantas sacas se cargaron, en dado caso la ultima saca supere la
capacidad que le queda al camión también lo indica.
Proceso algoritmo_final

definir capacidad_camion como entero;

definir saca como real;

definir acumulador_saca como real;

definir contador como entero;

Definir restante como real;

Definir contador_camiones como entero;

definir contador_perdido como entero;

contador_perdido <- 0;

capacidad_camion <- 0;

acumulador_saca<-0;

saca<-0;

contador <- 0;

restante <- 0;

contador_Camiones <- 1;

//entrada

mientras contador_Camiones <=20 hacer

Escribir "Por favor ingrese la capacidad del camion numero ",contador_Camiones;

Leer capacidad_camion;

Escribir "*******************************************";

Escribir "*******************************************";

Escribir " ";

Escribir "Camion numero ",contador_Camiones;

Escribir " ";

Escribir "*******************************************";

Escribir "*******************************************";
Escribir " ";

si capacidad_camion < 18000 o capacidad_camion > 28000 Entonces

Escribir "El camion no cumple con la capacidad necesaria";

Escribir "Pase el siguiente camion de carga";

contador_perdido <- contador_perdido +1;

Sino

Mientras capacidad_camion > 0 Hacer

si capacidad_camion > 3000 Entonces

Escribir "Por favor digitar el peso de la siguiente saca: ";

Leer saca;

si saca < 3000 y saca > 9000 entonces

Escribir "La saca no esta entre el peso estipulado";

Sino

si saca > capacidad_camion entonces

EScribir "Esta saca supera el maximo de


carga del camion";

Escribir "Se debe cargar con una saca de


",capacidad_camion," kilos";

Sino

capacidad_camion <- capacidad_camion -


saca;

acumulador_saca <- acumulador_saca +


saca;

contador <- contador + 1;

FinSi

FinSi

Sino

restante <- capacidad_camion;

capacidad_camion <-0;

Escribir "La capacidad restante del camion es: ", restante;


FinSi

FinMientras

Escribir "*******************************************";

Escribir "*******************************************";

Escribir " ";

Escribir "El camion ya alcanzo su limite";

Escribir "El peso de las sacas cargadas es: ",acumulador_saca;

EScribir "Se cargaron ", contador," sacas";

Escribir "ingrese el Proximo camion para ser cargado";

Escribir " ";

Escribir "*******************************************";

Escribir "*******************************************";

Escribir " ";

FinSi

contador_Camiones <- contador_Camiones + 1;

contador<-0;

acumulador_saca<-0;

FinMientras

Escribir "Se cargaron ",(contador_Camiones -1) - contador_perdido, " camiones";

Escribir "la Cantidad de Camiones que no cumplieron con la capacidad fueron ",
contador_perdido, " camiones";

FinProceso