Está en la página 1de 22

República Bolivariana de Venezuela

Ministerio del poder popular para la educación universitaria

Universidad Experimental de la Gran Caracas

Asignatura: Taller de introducción a la Informática

Sección: 101 turno matutino, trayecto inicial.

Profesor: Alumnos:

Miguel Gavidia. José Celis C.I 27099645

Kevin Figueroa C.I 27703298


Algoritmos condicionales
1-Dados 4 números indicar cuantos y cuales son mayores a 10.

Diagrama de bloque

E- a4, b11, c15, d8

P- Comparar estos 4 números

S- 2 números mayores a 10: b11 y c15.

1- Inicio

2-Declarar(a, b, c, d, conta) Tipo entero

3-Inicializar(a0,b0, c0, d0, conta0)

4-Leer (a)

5-Si a>10 entonces

Comienzo del si

Escribir(a, “es mayor a 10”)

Contaconta+1

Fin-si

6- Leer(b)

7-Si b>10 entonces

Comienzo del si

Escribir(b, “ si es mayor a 10”)

Contaconta+1

Fin-si

8- Leer(c )

9-Si c>10 entonces

Comienzo del si

Escribir(c,“ es mayor a 10”)

Contaconta+1
Fin-si

10-Leer(d)

11-Si d>10 entonces

Comienzo del si

Escribir (d,“ si es mayor a 10”)

Contaconta+1

Fin-si

12- escribir(“total de números mayores a 10 es: ”, conta)

13-Fin.

2. Dados dos números determinar si son pares o impares.

Diagrama de bloque

E- a1, b2

P- determinar si los números dados son par o impar

S-Mensaje que indica si son números pares o no.

1- Inicio

2-D(a, b, resto) tipo entero

3-I(a0, b0, resto0)

4-Leer (a)

5-resto (a módulo 2)

6) si resto = 0 entonces

Comienzo del si

Escribir (“el numero dado es par”)

Fin-si

7-Si no

Comienzo del sino

Escribir ( “el número dado es impar” )


Fin-sino

8-Leer (b)

9-resto (b módulo 2)

si resto = 0 entonces

Comienzo del si

Escribir (“el numero dado es par”)

Fin-si

10- Sino

Comienzo del sino

Escribir ( “el número dado es impar” )

Fin-sino

11-Fin

3. Dados 2 números determinar si uno de ellos es igual al doble del otro.

Diagrama de bloque

E- a2, b4

P-Determinar si un número es igual al doble del otro.

S-b4 es igual al doble de a2.

1-Inicio

2-D(a, b, resto) tipo entero

3-I(a0, b0, resto0)

4-Leer (a)

5-Leer (b)

6-resto((a*2)= -b= )

Si resto= 0 entonces

Comienzo del si

Escribir(“b es igual al doble de a”)

Fin-si
Sino

Escribir(“b no es igual al doble de a”)

Fin-sino

7-resto((b*2)= -a= )

Si resto= 0 entonces

Comienzo del si

Escribir(“a es igual al doble de b”)

Fin-si

Sino

Escribir(“a no es igual al doble de b”)

Fin-sino

8-Fin.

4. Dados tres números enteros positivos determinar el mayor.

Diagrama de bloque

E- 7 a, 1b, 4c

P-Determinar el número mayor.

S-Mensaje que refleje el número mayor.

1- Inicio

2-D(a, b, c)Tipo entero

3-I(a0, b0, c0)

4-Leer (a)

5-Leer (b)

6-Leer( c)

7-Si a>b y a>c Entonces


Escribir "el mayor es:", a
Sino
Si b>a y b>C Entonces
Escribir "el mayor es:", b
Sino
Si c>a y c>b entonces
Escribir "el mayor es:", c
Sino
Escribir "son iguales";
FinSi
FinSi
FinSi

11-Fin.

5. Dados tres números enteros positivos determinar el mayor y el menor.

Diagrama de bloque

E- a4, b7, c8

P-Determinar cuál es el número mayor y menor.

S- Mensaje indicando cual es el número mayor y menor.

1- Inicio

2-D(a, b, c)Tipo entero

3-I(a0, b0, c0)

4-Leer (a)
5-Leer (b)
6-Leer (c)
Si a>b y a>c Entonces
Escribir "el mayor es:", a
Sino
Si b>a y b>C Entonces
Escribir "el mayor es:", b
Sino
Si c>a y c>b entonces
Escribir "el mayor es:", c
Sino
Escribir "son iguales";
FinSi
FinSi
FinSi
Si a<b y a<c entonces
Escribir "el menor es:", a
Sino
Si b<a y b<c entonces
Escribir "el menor es:", b
Sino
Si c<a y c<b entonces
Escribir "el menor es:", c
Sino
Escribir "Son iguales";
FinSi
FinSi
FinSi

7-Fin.

6. Dados dos números enteros mayores a 7 determinar si son impares.

Diagrama de bloque

E- a8, b10

P-Determinar si los números dados son impares

S-Mensaje que refleje si los números dados son impares.

1-Inicio

2-D(a, b, resto)

3-I(a0, b0, resto0)

4-Leer (a)

5-Si a>7

resto (a módulo 2)

Y resto no es= 0 Entonces

Comienzo del si

Escribir(“el numero dado es impar”)

Fin del si

Si no

Escribir (“ El numero dado no es impar”)

6-Leer (b)

7-Si b>7

resto (b modulo 2)

Y resto no es= 0 Entonces

Comienzo del si
Escribir(“el numero dado es impar”)

Fin del si

Si no

Escribir (“ El numero dado no es impar”)

Fin del sino

8-Fin

7. Dados 4 números sumar solo aquellos menores a 20

Diagrama de bloque

E- a7, b5, c1, d9

P- Sumar aquellos números menores a 20

S- Mensaje informando la suma de dichos números.

1-Inicio

2-D(a, b, c, d)Tipo entero

3-I(a0, b0, c0, d0)

4-Leer(a)

5- Leer(b)

6- Leer(c)

7- Leer(d)

8-Si a<20 entonces

Comienzo del si

Sumar(sumar+a)

Fin del si

9- Si b<20 entonces

Comienzo del si

Sumar(sumar+b)

Fin del si

10- Si c<20 entonces


Comienzo del si

Sumar(sumar+c)

Fin del si

11- Si d<20 entonces

Comienzo del si

Sumar(sumar+d)

Fin del si

12-escribir “resultado de la suma es:”, sumar

13-Fin.

8. Dados 4 números obtener la media solo de aquellos menores a 20

Diagrama de bloque

E-a5, b7, c15, d3

P- Calcular promedio

S-Mensaje que indique el promedio de los números dados.

1-Inicio

2-D(a, b, c, d, cuenta, acumula, pr)Tipo entero

3-I(a0, b0, c0, d0, cuenta0, acumula0, Pr0)

4-Leer (a)

5-Si a<20 Entonces

Comienzo del si

cuenta(cuenta+a)

Acumulaacumula+1

Fin del si

6-Si b<20 Entonces

Comienzo del si

cuenta(cuenta+b)

Acumulaacumula+1
Fin del si

7-Si c<20 Entonces

Comienzo del si

cuenta(cuenta+c)

Acumulaacumula+1

Fin del si

8-Si d<20 Entonces

Comienzo del si

cuenta(cuenta+d)

Acumulaacumula+1

Fin del si

9-Pr(cuenta/acumula)

10-Escribir (“pr”)

11-Fin

9. Dados 4 números sumar solo aquellos menores a 20 y número par

Diagrama de bloque

E- a6, b18, c4, d5

P-Suma de valores que sean menores a 20 y número par.

S-Mensaje indicando el resultado de la suma

1-Inicio

2-D(a, b, c, d, reto, suma)Tipo entero

3-I(a0, b0, c0, d0, resto0, suma0)

4-Leer (a)

5-Si a<20

Resto (a modulo2)

Y resto=0 entonces

Comienzo del si
Suma(suma+a)

Fin del si

6-Si b<20

Resto (b modulo2)

Y resto=0 entonces

Comienzo del si

Suma(suma+b)

Fin del si

7-Si c<20

Resto (c modulo2)

Y resto=0 entonces

Comienzo del si

Suma(suma+ c)

Fin del si

8-Si d<20

Resto (d modulo2)

Y resto=0 entonces

Comienzo del si

Suma( suma+d )

Fin del si

9- Escribir(suma)

10-Fin

10. Dados 5 números indicar cuales son pares y cuales impares

Diagrama de bloque

E- a3, b7, c9, d4, e12

P-Determinar cuáles son los números pares e impares

S-Números impares son: a3, b7, c9.


Números pares son: d4, e12.

1-inicio

2-D(a, b, c, d, e, resto)Tipo entero

3-I(a0, b0, c0, d0, e0, resto0)

4-Leer (a)

5-resto (a modulo 2)

Si resto=0 entonces

Comienza el si

Escribir (a “es un numero par”)

Fin del si

6-Sino

Comienzo del si no

Escribir (a,” es un número impar”)

Fin del sino

7-Leer (b)

8-resto (a módulo 2)

Si resto=0 entonces

Comienza el si

Escribir (b, “es un numero par”)

Fin del si

9-Sino

Comienzo del sino

Escribir (b,” es un número impar”)

Fin del sino

10-Leer (c)

11-resto (c módulo 2)

Si resto=0 entonces
Comienza el si

Escribir (c, “es un numero par”)

Fin del si

12-Sino

Comienzo del si no

Escribir (c,” es un número impar”)

Fin del sino

13-Leer (d)

14-resto (d módulo 2)

Si resto=0 entonces

Comienza el si

Escribir (d, “es un numero par”)

Fin del si

15-Sino

Comienzo del sino

Escribir (d,” es un número impar”)

Fin del sino

16-Leer (e)

17-resto (e módulo 2)

Si resto=0 entonces

Comienza el si

Escribir (e, “es un numero par”)

Fin del si

17-Sino

Comienzo del sino

Escribir (e, ” es un número impar”)

Fin del sino


18-Fin

11.Dado un número entero positivo determinar si está comprendido entre


5 y 20.

Diagrama de bloque

E- a7

P- Determinar si el numero dado esta comprendido entre 5 y 20

S- a7 si está comprendido entre 5 y 20

1- Inicio

2-D(a)Tipo entero positivo

3-I(a0)

4-Leer (a)

5-Si a>=5 y a<=20 entonces

Comienzo del si

Escribir(a, “ si está comprendido entre 5 y 20”)

Fin del si

6-Fin.

12.- Resolver una ecuación de Segundo Grado, dados los coeficientes a,


b, y c como números enteros.

1)Inicio

2)D(a, b, c, d, x, x1, x2) Tipo Entero

3)I(a= 0, b= 0, c= 0, d = 0, x= 0, x1= 0 =,x2= 0)

4)Leer (a)

5)Leer (b)

6(Leer (c)

7)d= b * b - 4 * a *c

8)Si d = 0 entonces

Comienzo del si

Escribir (La ecuación no tiene solución)


Fin del si

9)Sino

Comienzo del sino

10)Si d >0 entonces

Comienzo del si

x = -b / (2 * a)

Escribir (La solucinon Unica es, x)

11) Sino

Comienzo del sino

x1= (-b- √d) / (2 * a)

x2 = (-b + √d) / (2 * a)

Escribir (Las dos soluciones reales son: x1, x2)

Fin del sino

Fin del sino

12)Fin

13. Validar un número dado comprendido dentro de un criterio de


validación.

Diagrama de bloque

E-a15, b10, c20

P-determinar si a15 está comprendido entre b10 y c20, si es así validarlo.

S-a15 es un número valido.

1-Inicio

2-D(a,b,c)Tipo entero

3-I(a0,b0, c0)

4-Leer (a)

5-Leer(b)

6-Leer(c)
7-Si a>=b y a<=c entonces

Comienzo del si

Escribir(a, ”Es un numero valido”)

Fin del si

8-Fin.

14. Dados 2 números verificar si uno es divisor de otro

Diagrama de bloque

E- a4, b20

P- Verificar sin un número es divisor de otro

S- a4 es divisor de b20

1- Inicio

2-D( a, b,resto)Tipo entero

3-I( a0, b0, resto0)

4-Leer (a)

5-Leer (b)

6-resto(a MOD b)

7-Si resto=0 entonces

Comienzo del si

Escribir (a, ”es divisor de b”)

Fin del si

8-Sino

Comienzo del sino

resto(b MOD a)

Si resto=0 entonces

Escribir (b, “es divisor de a”)

Fin del sino

9-Sino
Comienzo del sino

Escribir (“ninguno es divisor del otro”)

Fin del sino

10-Fin

15.- Resolver una ecuación de Segundo Grado, dados los coeficientes a,


b, y c como números enteros.

1)Inicio

2)D (a, b, c, d, x, x1, x2

3)I(a= 0, b= 0, c= 0, d = 0, x= 0, x1= 0 =,x2= 0 Tipo Entero

4)Leer (a)

5)Leer (b)

6(Leer (c)

7)d= b * b - 4 * a *c

8)Si d = 0 entonces

Comienzo del si

Escribir (La ecuacion no tiene solucion

Fin del si

9)Sino

Comienzo del sino

10)Si d >0 entonces

Comienzo del si

x = -b / 2 * a

Escribir (La solucinon Unica es, x)

11) Sino

Comienzo del sino

x1= (-b- √d) / 2 * a

x2 = (-b + √d) / 2 * a
Escribir (Las dos soluciones reales son: x1, x2)

Fin del sino

Fin del sino

12)Fin

16. Validar un número dado comprendido dentro de un criterio de


validación dado.

Diagrama de bloque

E-a7

P-Validar el número dado si está comprendido entre 5 y 20.

S-a7 es un número valido.

1-Inicio

2-D(a) Entero positivo

3-I(a0)

4-Leer(a)

5-Si a>=5 y a<=20 entonces

Comienzo del si

Escribir (a, ”Es un numero valido”)

Fin del si

6-Fin.

17.- Diseñar un Algoritmo para determinar el tiempo y pago de un


automóvil cuando utiliza un estacionamiento cuyo pago es por hora.

1)Inicio

2)D (He, Hs, Hser, Imp, tarifa) Tipo entero

3)I (He= 0, Hs= 0, Hser= 0, Imp= 0, Tarifa= 100Bs)

4)Leer (He) <--------------------------------------- //Hora de entrada

5)Leer (Hs) <----------------------------------------//Hora de salida

6)Hser= Hs - He <----------------------------//Hser es Hora de servicio


7)Imp= Hser * Tarifa <---------------------------//Imp es el Importe a pagar

8)Escribir (Horas de servicio, Hser)

9)Escribir (Importe a pagar, Imp)

10)Fin

18.- Dado un número entero cuya cantidad de dígitos es igual a 5,


determine si es capicúa.

1)Inicio

2)D(a, b, c, d, e) Tipo entero

3)I(a = 0, b= 0, c= 0, d= 0, e= 0)

4)Leer (a)

5)Leer (b)

6)Leer (c)

7)Leer (d)

8)Leer (e)

9)SI a=e entonces

Comienzo del si

10)Si b=d Entonces

Comienzo del si

Escribir (Los numeros son capicua)

Fin del si

Fin del si

11)Fin

19-Cree un algoritmo que tome por entrada las horas y minutos de un día
y dé como resultado su equivalente en segundos.

Diagrama de bloque

E- HD=24 MD=1440
P-Realizar cálculo de un día en segundos.

S- Un día=86400 segundos.

1-Inicio

2-D(hd, md, s)Tipo real

3-I(hd0, md0, s0)

4-Leer (hd)

5-Leer (md)

6-Si hd=24 y md=1440 Entonces

Comienzo del si

S((Md/hd)= *md= )

Escribir (“un día es igual a segundos:”, s )

Fin del si.

Sino

Comienzo del sino

Volver al paso 4

Fin del sino

7-Fin.

20-Para un valor entero positivo que representa una cantidad en


segundos, indicar su equivalente en minutos, horas y días.

E-Valor en segundos 172800

P-Calcular equivalencia de segundos a minutos, horas y días.

S- 172800seg= 2880min, 48horas, 2 dias.

1-Inicio

2-D(S,MIN,H,D)Tipo entero

3-I(S0, MIN0, H0, D0)

4-Leer(S)

5-MINS/60

6-HS/3600
7-DS/86400

8-Escribir S, “segundos son: ”

9-Escribir MIN, “ minutos ”

10-Escribir H, “ horas”

11-Escribir D, “ días”

12-Fin