Está en la página 1de 31

PROGRAMACION ORIENTADA AL OBJECTO

«Cualquiera puede hablar. Enséñame el código.»

-Yoggi Berra:
Programación orientada a objeto
Gerlen Elivet Aquino Zorrilla
Instituto Tecnológico de las Américas

Notas del Autor


Gerlen Elivet Aquino Zorrilla (Matricula 2018-6497)
Julio 2019
Instituto Tecnológico de las Américas.
Desarrollo de Software.
Programación
Este trabajo va dirigido a Miguel Moreta
Introducción

En la programación orientada a objetos, los datos y el código que actúan sobre los datos
se convierten en una única entidad denominada clase. La clase es una evolución del
concepto de estructura, ya que contiene la declaración de los datos. Pero se le añade la
declaración de las funciones que manipulan dichos datos, denominadas función
miembro o, también, métodos. Además, en la clase se establecen unos permisos de
acceso a sus miembros. Por defecto, en una clase los datos y las funciones se declaran
como privados. Este ocultamiento de la información niega a las entidades exteriores el
acceso a los miembros privados de un objeto. De este modo, las entidades exteriores
acceden a los datos de una manera controlada a través de alguna función miembro.
1

Usando estructuras de control de flujo realizar los siguientes ejercicios


Pedir el nombre de la semana al usuario y decirle si es fin de semana o no. En caso
de error, indicarlo.
Diagrama de flujo
2

Pseudocodigo

1. INICIO
2. Declaramos una variable de tipo entero d
3. Mostrar ("Introduce un número del 1 al 7");
4. LEER( d );
5. SI (d >=1 ) AND (d <= 7)
6. EN_CASO_DE d HACER
7. 1: ESCRIBIR("Lunes");
8. 2: ESCRIBIR("Martes");
9. 3: ESCRIBIR("Miércoles");
10. 4: ESCRIBIR("Jueves");
11. 5: ESCRIBIR("Viernes");
12. 6: ESCRIBIR("Sábado");
13. 7: ESCRIBIR("Domingo") FIN CASO
14. SINO
15. ESCRIBIR("El valor no es válido");
16. FIN SI
17. FIN
3

Código por consola

using System;

namespace ejercio3
{
class Program
{
static void Main(string[] args)
{
int d;
string linea;
Console.WriteLine("introdusca el numero del dia de la semana que desea ");
Console.WriteLine("1 domingo ");
Console.WriteLine("2 lunes ");
Console.WriteLine("3 martes");
Console.WriteLine("4 miercoles");
Console.WriteLine("5 jueves");
Console.WriteLine("6 viernes");
Console.WriteLine("7 sabado");
linea = Console.ReadLine();
d = int.Parse(linea);
if ((d == 2) || (d == 3) || (d == 4) || (d == 5) || (d == 6))
{
Console.Write("No es fin de semana");
}
else
{
4

if ((d == 1) || (d == 7))
{
Console.Write("Es fin de semana");
}
else
{
Console.Write("el numero es incorrecto");
}
}
Console.ReadKey();
}
}
}
5

Pantallas

En caso de que no sea fin de semana

En caso de que si sea fin de semana

En caso de que no sea correcto


6

3. Crear un bucle que recorra los números del 1 al 50 y los muestre por pantalla.
Usa un bucle for.

Diagrama de flujos
7

Pseudocodigo
1. Inicio
2. Declaramos una variable entera
3. Para contar desde n sea 1 hasta sea 50
4. Mostrar n
5. Fin para
6. Fin
8

Código por consola

using System;

namespace ejercio4
{
class Program
{
static void Main(string[] args)
{

for (int n = 1; n <= 50; n++)


{
Console.WriteLine(n);
}

Console.WriteLine("gracias por usar este programa");


Console.ReadLine();
Console.ReadKey();

}
}
}
9

Pantalla por consola


En esta imagen solo se puede visualizar la parte inferior de la pantalla
10

4. Crear un bucle que recorra los números del 1 al 30 y los muestre por pantalla.
Usa un bucle while.
11

Pseudocodigo
1. Inicio
2. Declaramos una variable entera
3. mientras n sea 1 hasta sea 30
4. Mostrar n
5. Fin para
6. Fin
12

Código por consola

using System;

namespace codigo
{
class MainClass
{
public static void Main(string[] args)
{

int i = 1;
while (i <= 30)
{
Console.WriteLine(i);
i++;
}

Console.ReadLine();
}
}
}
13

Pantalla
14

5. Recorre los números del 1 al 80. Muestra los números pares.


Usar el tipo de bucle que desees.
15

Pseudocodigo
1. Inicio
2. Declaramos una variable entera
3. Para contar desde n sea 1 hasta sea 80
4. si n es par
5. Mostrar n
6. Fin para
7. Fin
16

Código
using System;

namespace numeros
{
class MainClass
{
public static void Main(string[] args)
{

for (int i = 2; i <=80 ; i += 2)


{
Console.WriteLine(i);
}

Console.ReadLine();
}
}
}
17

Pantalla
18

6. Recorre los números del 1 al 100.


Muestra los números pares o divisibles entre 3.

Diagrama de flujo
19

Pseudocodigo

1. Inicio
2. Declaramos una variable entera
3. Para contar desde n sea 1 hasta sea 100
4. si es múltiplo de dos o de tres
5. Mostrar n
6. Fin para
7. Fin

\
20

Código por consola

namespace numeros
{
class MainClass
{
public static void Main(string[] args)
{

for (int i = 1; i <= 100; i++)


{
if (i % 2 == 0 || i % 3 == 0)
{
Console.WriteLine(i);
}

Console.ReadLine();
}
}
}
21

Pantalla
22

2. Pedir al usuario el precio de un producto (valor positivo) y la forma de pagar


(efectivo o tarjeta) si la forma de pago es mediante tarjeta, pedir el número de cuenta
(inventado)
Código
using System;

namespace pago
{
class MainClass
{
public static void Main(string[] args)
{

double precio;
string linea, forma;
int numero;

Console.WriteLine("Escribe el precio del producto");


linea = Console.ReadLine();
precio = double.Parse(linea);

Console.WriteLine("Escribe la forma de pago: tarjeta o efectivo");


forma = (Console.ReadLine()).ToLower();

if (forma.Equals("tarjeta"))
{

Console.WriteLine("Introduce el numero de tarjeta");


23

linea = Console.ReadLine();
numero = int.Parse(linea);

Console.WriteLine("El producto con precio " + precio + " se ha pagado " +


"con el numero de cuenta " + numero);
}

else if (forma.Equals("efectivo"))
{

Console.WriteLine("El producto con precio " + precio + " se ha pagado");

}
else
{

Console.WriteLine("La forma de pago no es correcta");


}

Console.ReadLine();
}
}
}
24

Pantalla

En caso de que el producto se pague en efectivo

En caso de que el producto se pague con tarjetas

En caso de que se ingrese un dato incorrecto a


25

Conclusión

«Durante mucho tiempo me extrañó el hecho de que algo tan caro y tan vanguardista
fuera tan inútil. Y luego pensé que la computadora es una máquina estúpida con la
capacidad de hacer cosas increíblemente inteligentes, mientras que los programadores
de computadoras son gente inteligente con la capacidad de hacer cosas increíblemente
estúpidas. En pocas palabras, son la pareja perfecta.»
-Linus Torvalds: