Está en la página 1de 2

1-A un trabajador le descuentan de su sueldo el 10% si su sueldo es menor o igual a

1000, por encima de 1000 hasta 2000 el 5% del adicional, y por encima de 2000 el 3% del
adicional. Calcular el descuento y sueldo neto que recibe el trabajador dado un sueldo.
Proceso DescuentoYSueldo
Escribir "Ingrese el valor de sueldo:";
Leer sueldo;
descuento <- 0;
Si sueldo<=1000 Entonces
descuento <- sueldo*0.1;
sino
Si sueldo>1000 Y sueldo<=2000 Entonces
descuento <- sueldo*0.05;
sino
Si sueldo>2000 Entonces
descuento <- sueldo*0.03;
finSi
fnsi
finsi
sueldo neto <- sueldo-descuento;
Escribir "Valor de descuento: ", descuento;
Escribir "Valor de sueldo neto: ", sueldo neto;
FinProceso

2-Calcular el pago semanal de un trabajador. Los datos a ingresar son: total de horas trabajadas y
el pago por hora.Si el total de horas trabajadas es mayor a 40 la diferencia se considera como
horas extras y se paga un 50% más que una hora normal.Si el sueldo bruto es mayor a s/. 500.00,
se descuenta un 10% en caso contrario el descuento es 0.

Proceso PagoSemanal
Escribir "Ingrese el valor de horas trabajadas:";
Leer horas trabajadas;
Escribir Sin Saltar "Ingrese el valor de pago por hora:";
Leer pago por hora;
pago normal <- horas trabajadas*pago por hora;
Si horas trabajadas>40 Entonces
pago extra <- (horas trabajadas-40)*0.5;
SiNo
pago extra <- 0;
FinSi
sueldo bruto <- pago normal+pago extra;
Si sueldo bruto>500 Entonces
descuento <- sueldo bruto*0.1;
SiNo
descuento <- 0;
FinSi
pago semanal <- sueldo bruto-descuento;
Escribir "Valor de descuento: ", descuento;
Escribir "Valor de pago extra: ", pago extra;
Escribir "Valor de pago normal: ", pago normal;
Escribir "Valor de pago semanal: ", pago semanal;
Escribir "Valor de sueldo bruto: ", sueldo bruto;
FinProceso

3-Una compañía de alquiler de autos emite la factura de sus clientes teniendo en cuenta
la distancia recorrida, si la distancia no rebasa los 300 km., se cobra una tarifa fija de
S/.250, si la distancia recorrida es mayor a 300 km. y hasta 1000 km. se cobra la tarifa fija
más el exceso de kilómetros a razón de S/. 30 por km. y si la distancia recorrida es mayor a 1000
km., la compañía cobra la tarifa fija más los kilómetros recorridos entre 300 hasta 1000 a razón de
S/. 30, más S/.20 por Kilómetro de exceso en distancias mayores de 1000 km. Calcular el
monto que pagará un cliente.

Proceso Compañia
Escribir "Ingrese el valor de distancia recorrida en km:";
Leer distancia recorrida en km;
tarifa fija <- 250;
monto del pago <- tarifa fija;
Si distancia recorrida en km>300 Y distancia_recorrida_en_km<=1000 Entonces
monto del pago <- tarifa fija+(distancia_recorrida_en_km-300)*30;
FinSi
Si distancia recorrida en km>1000 Entonces
monto del pago <- tarifa fija+700*30+(distancia recorrida en km 1000)*20;
FinSi
Escribir "Valor de monto del pago: ", monto del pago;
Escribir "Valor de tarifa fija: ", tarifa fija;
FinProceso

4-Dado un número entero; determinar si el mismo es par, impar o nulo.

Proceso numero
definir num como entero
escribir “ingrese un numero:”;
leer num;
Si num<>0 Entonces
residuo<-num mod 2;
Si residuo=0 Entonces
Escribir “es par”;
Sino
Escribir “es impar”;
FinSi
FinSi
FinProceso