Está en la página 1de 42

MAE-CTT-BCA

MikroTik Administration Engineer


Control de Tráfico
Balanceo de Carga
v6.44.2
Libro de Estudio &
Manual de Laboratorio

ABC Xperts ®
Network Xperts ®
Academy Xperts ®

Derechos de autor y marcas registradas


Todos los derechos de autor y marcas registradas son propiedad del titular de los derechos de autor respectivo

Derechos de autor © por Academy Xperts


Todos los derechos reservados. Ninguna parte de este libro puede ser reproducido, almacenado, o transmitido por cualquier
medio ya sea este un auditorio, medio gráfico, mecánico, o electrónico sin el permiso escrito del autor, excepto en los casos
en que se utilicen breves extractos para usarlos en artículos o revisiones. La reproducción no autorizada de cualquier parte
de este libro es ilegal y sujeta a sanciones legales.
RouterOS v6.44.2 – MAE-CTT-BCA, Balanceo de Carga con MikroTik RouterOS, Capítulo 1: Introducción

Tabla de Contenido
Prólogo ................................................................................................................................................................. ii
Resumen........................................................................................................................................................................... iii
Audiencia .......................................................................................................................................................................... iii
Convenciones usadas en este libro .................................................................................................................................. iii
Comentarios y preguntas ................................................................................................................................................. iv
Partners de Academy Xperts en Latinoamérica ............................................................................................... v
Empresas Asociadas ........................................................................................................................................................ v
Universidades e Institutos Superiores ............................................................................................................................. vi
Deseas convertirte en Academia o ser Partner de Academy Xperts? ............................................................................. vi
Un poco de Historia (Costa Rica) .................................................................................................................................... vii
Cubriendo un País con MikroTik. ............................................................................................................................. vii
Capítulo 1: Introducción a Balanceo de Carga................................................................................................. 1
Función principal de los métodos de balanceo ................................................................................................................. 1
Bonding ..................................................................................................................................................................... 1
Actualización RouterOS a la última versión ...................................................................................................................... 2
Capítulo 2: ECMP ................................................................................................................................................ 4
Características .......................................................................................................................................................... 4
Opción “Check-Gateway”.................................................................................................................................................. 4
Balanceo Simétrico ................................................................................................................................................... 5
Balanceo Asimétrico ................................................................................................................................................. 5
Laboratorio 2.1: Balanceo ECMP ..................................................................................................................................... 6
Laboratorio 2.2: Balanceo ECMP Asimétrico ................................................................................................................... 8
Capítulo 3: PCC ................................................................................................................................................. 11
PCC ................................................................................................................................................................................ 13
Load balancing using PCC ............................................................................................................................................. 13
Ejemplo de balanceo de carga utilizando PCC....................................................................................................... 16
Laboratorio 3.1: Balanceo PCC ...................................................................................................................................... 17
Laboratorio 3.2: Balanceo PCC asimétrico ..................................................................................................................... 21
Capítulo 4: Nth ................................................................................................................................................... 26
Conexiones y paquetes .......................................................................................................................................... 26
Etiquetado de paquetes en Nth ...................................................................................................................................... 26
Balanceador NTH ................................................................................................................................................... 28
Laboratorio 4: Balanceo NTH ......................................................................................................................................... 30

A c a d e my X p e r t s i
RouterOS v6.44.2 – MAE-CTT-BCA, Balanceo de Carga con MikroTik RouterOS, Capítulo 1: Introducción

Prólogo
MikroTik es una empresa que nace en Latvia (Letonia) en 1996 con el claro objetivo de proveer un sistema operativo de red
altamente robusto y eficiente al cual llamó RouterOS en 1997. La evolución del mismo llevó a la creación y lanzamiento al
mercado en el 2002 de un hardware que aprovechara al máximo sus grandes capacidades de multiprocesamiento simétrico
y multi-núcleo, este hardware es el RouterBOARD.
A lo largo de los años a partir del nacimiento del Internet, los administradores de red hemos visto desfilar varios fabricantes
por nuestros racks, habiendo estado siempre Cisco como referente, sin embargo, siempre había representado un costo más
o menos importante a la hora de implementar una solución de red ruteada en especial si se trataba de un ISP/WISP.
No es sino hasta hace una década aproximadamente en que MikroTik se empieza a hacer conocer en Latinoamérica y varios
emprendedores y por sobre entusiastas, se vuelcan a la implementación de soluciones basadas en RouterOS y
RouterBOARD. Claros ejemplos de ello son nuestros grandes amigos de Index México (Ezequiel García) y REICO Costa
Rica (Miguel Solís) quienes se volcaron a confiar en los productos ofrecidos por MikroTik. Es muy interesante y gratificante
conversar con ellos y escuchar los relatos sobre los primeros pasos del fabricante letón en tierras americanas.
Estoy convencido de que MikroTik llegó no solo para quedarse sino para formar una parte muy importante en la historia del
networking y de las telecomunicaciones. De hecho, cientos de miles (quizá millones a esta fecha, Mayo 2015) obtienen su
internet de banda ancha a un bajo costo a través de una red ruteada gracias a que los proveedores de Internet, pequeños y
medianos, pueden estructurar e implementar redes sumamente complejas y completas usando equipos MikroTik.
Las soluciones en RouterOS y RouterBOARD no se han quedado estancadas en las empresas de Telecom pequeñas, sino
que han ido escalando en credibilidad en las empresa medianas y grandes en Latinoamérica, rompiendo paradigmas de
fabricantes y costos de implementación.
Este libro nace como un aporte a la comunidad tecnológica de habla hispana y latinoamericana que ha decidido incursionar
en MikroTik y desea obtener un conocimiento formal. De igual manera queremos que esta guía constituya una fuente
importante de aprendizaje para quienes empiezan a realizar sus primeras configuraciones en RouterOS.

Mauro Escalante
CEO Academy Xperts
CEO Network Xperts

A c a d e my X p e r t s ii
RouterOS v6.44.2 – MAE-CTT-BCA, Balanceo de Carga con MikroTik RouterOS, Capítulo 1: Introducción

Resumen
Hemos tenido un especial cuidado en ampliar la información de aquellos puntos que no se profundizan en los cursos de
certificación, pero que resultan claves para el correcto entendimiento de la materia.
La información aquí presentada se complementa con nuestros recursos en www.abcxperts.com y
www.youtube.com/abcxperts
Este libro no pretende reemplazar la interacción face-to-face con un instructor ya que su experiencia y conocimiento es
invaluable y únicamente explotable a través del contacto interpersonal de un curso de certificación. Sin embargo, todo el
material de apoyo junto con los videos tutoriales, webinars, tips, etc., representan un importante aporte para aquellos colegas
que optan por leer un libro y estudiar a su propio ritmo.
Las posteriores revisiones al material y a los nuevos releases de RouterOS serán agregadas a esta edición y estarán a
disponibilidad de las personas que compren la suscripción.
Tenemos una tarea inmensa por delante, pero estamos muy claros en nuestro objetivo de hacer de este libro la mejor guía
de autoestudio MikroTik.
Audiencia
Las personas que leen este libro deben estar familiarizados con:
• Operaciones de red en Capa 2, 3
• Conjunto de protocolos IP, incluyendo TCP. UDP e ICMP
Este libro está dirigido a:
• Ingenieros y Técnicos en Redes, Telecomunicaciones y afines, que desea implementar y dar soporte a:
§ Redes Corporativas
§ Clientes WISP e ISP
• Ingenieros de Redes involucrados en actividades de pre-venta y post-venta en soporte e instalación de redes
corporativa y PYMES
• Ingenieros de Redes, Administradores de Red, Técnicos en Soporte de Redes, y Técnicos de Soporte a Usuario
(Help Desk)
Convenciones usadas en este libro
En este libro se utilizarán las siguientes convenciones tipográficas:
Itálicas
Indica comandos, direcciones de correo, claves, mensajes de error, nombres de archivos, énfasis, y el primer uso
de términos técnicos
Courier new
Indica direcciones IP y ejemplos de línea de comando
Courier new en itálica
Indica texto que puede ser reemplazado
Courier new en negrita
Indica datos de entrada del usuario
Este icono significa un consejo, sugerencia, o una nota general.
Este icono indica una advertencia o precaución.

A c a d e my X p e r t s iii
RouterOS v6.44.2 – MAE-CTT-BCA, Balanceo de Carga con MikroTik RouterOS, Capítulo 1: Introducción

Comentarios y preguntas
Puede enviar sus comentarios y preguntas sobre este libro por correo tradicional a la siguiente dirección:
Network Xperts S.A. / Academy Xperts
Av. Juan T. Marengo y J. Orrantia
Edificio Professional Center, Piso 5, Ofic. 507
Guayaquil, ECUADOR
+593-4-600-8590
+593-9-9535-2132

A través del sitio web y por medio de su usuario y contraseña, tendrá acceso a las actualizaciones, ejemplos, e información
adicional:
http://cursos.abcxperts.com

Puede enviarnos sus comentarios o preguntas técnicas sobre este libro enviándonos un email a:
libro@abcxperts.com

Para más información sobre libros, conferencias, centros de recursos, y la red educativa de Academy Xperts, visite nuestros
Websites y canal de YouTube
http://www.abcxperts.com
http://www.academyxperts.com
http://www.youtube.com/abcxperts

A c a d e my X p e r t s iv
RouterOS v6.44.2 – MAE-CTT-BCA, Balanceo de Carga con MikroTik RouterOS, Capítulo 1: Introducción

Partners de Academy Xperts en Latinoamérica


Nuestro recorrido por América Latina nos ha comprometido de una manera muy importante con nuestros alumnos, amigos
y socios. Y este compromiso conlleva la enorme responsabilidad de estar siempre a la vanguardia, de presentar a nuestros
estudiantes el mejor y más completo material de estudio & laboratorio, y lo que es muy importante… que el contenido siempre
esté actualizado.
Nos encantaría estar presente en cada uno de los 15 países y las más de 65 ciudades que recorremos todos los años, pero
el tiempo y la disponibilidad física nos es un obstáculo.
Por este motivo hemos desarrollado un esquema de Partnership con empresas, universidades e institutos superiores en
diferentes países que trabajan junto con nosotros en sus respetivos ambientes, y que entregan a sus estudiantes el contenido
y el acceso a la suscripción de este libro (y todos sus recursos) por un cómodo valor.
Empresas Asociadas

Blazar Communications
Writel Bolivia S.R.L. S.A. de C.V. Andrickson
Bolivia, Santa Cruz de la Sierra México, Mérida - Yucatán República Dominicana, Sto.Dgo.
www.writelbolivia.com www.blazar.com.mx www.andrickson-wireless.com

MikroTik Trainer Partner Wireless ISP Distribuidores Autorizados


Ubiquiti Trainer Partner MikroTik Consultant Ubiquiti
Cursos de Certificación MikroTik y Ubiquiti Consultant MikroTik
Ubiquiti. Cursos de Certificación MikroTik y Epcom
Master Distributor MikroTik, Ubiquiti. RF Armor
Ubiquiti, iboss, Denwa, Cambium, Reseller MikroTik, Ubiquiti, L-com, Grandstream
itelite, L-com Grandstream, Hikvision

Winex Sisbit IndyNet


Paraguay, Asunción Ecuador, Gualaceo Ecuador, San Lucas - Loja
www.winex.com.py www.sisbit.net www.indynet.net.ec
maraujo@winex.com.py info@sisbit.net tlgo.manuellozano@gmail.com

MikroTik Trainer Partner MikroTik Trainer Partner Academy Xperts Partner


Cursos de Certificación MikroTik, Cursos de Certificación MikroTik, Cursos de Certificación Academy
Ubiquiti y Academy Xperts Ubiquiti y Academy Xperts Xperts, MikroTik y Ubiquiti

A c a d e my X p e r t s v
RouterOS v6.44.2 – MAE-CTT-BCA, Balanceo de Carga con MikroTik RouterOS, Capítulo 1: Introducción

Macrotics SAS CQNet


Colombia, Cali & Bogotá Costa Rica, San Carlos, Alajuela
www.macrotics.co www.cqnetcr.com
info@cqnetcr.com

MikroTik Official Distributor Tienda OnLine


Ubiquiti Distributor & Master Redes, Componentes PC,
Reseller Computadoras, Audio & Video…

Universidades e Institutos Superiores

Deseas convertirte en Academia o ser Partner de Academy Xperts?


• Si eres Universidad o Instituto Superior que cuenta con el respectivo acuerdo ministerial de tu país, puedes
optar por convertirte en una Academia MikroTik. Escríbenos a libro@abcxperts.com para darte más información.
• Si eres Trainer Partner y quieres explotar junto a tus alumnos nuestro material y portal de capacitación, te
invitamos escribirnos a mescalante@academyxperts.com para proporcionarte los detalles.
• Si deseas que organicemos cursos en tu ciudad/país de residencia, escríbenos a cursos@academyxperts.com

A c a d e my X p e r t s vi
RouterOS v6.44.2 – MAE-CTT-BCA, Balanceo de Carga con MikroTik RouterOS, Capítulo 1: Introducción

Un poco de Historia (Costa Rica)


Cubriendo un País con MikroTik.
En el año 1998, estando en una empresa de servicios públicos en Costa Rica, el Ing. Miguel Solís en conjunto con el Ing.
Paulino Solano, comenzaron a utilizar MikroTik con gran éxito en las telecomunicaciones de esta empresa. Se lograron 2
Mbps en una distancia de 8 Km, una velocidad record para aquellos tiempos en que la velocidad rondaba los 256 Kbps.
En esta empresa de Servicios Públicos, se logró la interconexión de 52 sucursales mediante tecnología inalámbrica, todas
bajo la misma marca MikroTik y su sistema operativo RouterOS.
Dado el éxito alcanzado en este proyecto, ambos ingenieros en conjunto con uno más llamado Olman González, decidieron
formar una empresa que se dedicara a solventar los problemas de telecomunicaciones en donde el cobre no fuera factible o
se necesitara más velocidad. Esta empresa fue nombrada Redes Inalámbricas de Costa Rica S.A (REICO).
Es así como a la fecha (Julio 2015), REICO, con solo Miguel Solís como propietario, tiene el liderato en telecomunicaciones
inalámbricas en el país Centroamericano Costa Rica. REICO posee más de 3,800 Km de red troncal inalámbrica y más de
80,000 Km de red de acceso. Posee más de 100 radio bases instaladas estratégicamente para alcanzar una cobertura de
más del 80% del territorio y a más del 90% de la población.
La empresa se dedica 100% a proveer transporte de datos corporativos y sirve a sectores financieros, agroindustriales,
turísticos, comerciales, etc.
Su plataforma tiene una particularidad única en el mundo, con sus más de 1,000 clientes corporativos y empresariales y sus
más de 1,500 equipos de acceso, CPE, transporte, Core secundario y Core primario: EL 100% SON MARCA MIKROTIK.
REICO es un ejemplo del gran potencial que tiene MikroTik y RouterOS ya que esta empresa compite en el mercado con
grandes de las telecomunicaciones y aun así mantiene una posición privilegiada, siendo el cuarto operador en Costa Rica
en importancia en Transporte de Datos Corporativos, por debajo de ICE, Tigo y de RACSA pero por encima de Claro,
Telefónica, Cables & Wireless, etc. Esto según el último informe de Estadísticas del Sector de Telecomunicaciones de Costa
Rica 2014.

Texto desarrollado por el Ing. Miguel Solís, a quien agradezco por su aporte histórico
sobre los inicios de MikroTik en Latinoamérica.

A c a d e my X p e r t s vii
• RouterOS v6.44.2 – MAE Load Balancing MikroTik RouterOS, Capítulo 2: ECMP

Capítulo 1: Introducción a Balanceo de Carga


El balanceo de carga es un método que tiene como objetivo distribuir el tráfico a través de múltiples enlaces para obtener un
mejor uso del ancho de banda. Esto se puede hacer por paquete o por conexión. Cuando se emplea algún mecanismo de
balanceo, lo que realmente se balancea son el número de conexiones entre la cantidad de enlaces disponibles, eso quiere
decir que no se balancea el consumo de tráfico ni se “suma”.
Es importante mencionar que existe una diferencia entre balanceo de carga y channel bonding:
• Balanceo de carga – Divide el tráfico entre interfaces (Capa 4 del modelo OSI)
• Channel Bonding – Implica una división de tráfico entre interfaces física en un nivel más bajo, ya sea por
paquete (Capa 3) o por enlaces de datos (Capa 2, utilizando el protocolo 802’1aq – SPB, Shortest Path
Bridging)
Los métodos de balanceo son sumamente útiles donde existen enlaces de comunicación redundantes, ya que todos los
enlaces se pueden utilizar al mismo tiempo. Al utilizar múltiples enlaces de forma simultánea, se incrementa la disponibilidad
del ancho de banda. De esa forma se evita la congestión o saturación de la red en un solo enlace.
En RouterOS el balanceo de carga puede ser realizado basado en paquete (per-packet) o basado en conexión
(per-connection).

Métodos Por conexión Por paquetes


ECMP Yes No
PCC Yes No
NTH Yes Yes
Bonding No Yes
OSPF Yes No
BGP Yes No

Como objetivo principal el balanceo ayuda a optimizar la utilización de recursos, maximizar el throughput, minimizar los
tiempos de respuestas, y evitar la sobrecarga de un único recurso. De esta forma se logra confiabilidad y disponibilidad a
través de redundancia.

Función principal de los métodos de balanceo


Dividir el Tráfico entre las diversas interfaces que llevan a los proveedores permitiendo que las conexiones o paquetes
puedan gestionarse de forma recíproca (equitativa).

Internet

ISP 1 ISP 2

50% 50%
Balanceador

Bonding
Proceso que permite la agregación de múltiples interfaces similares a Ethernet en un solo enlace virtual, obteniendo así
mayores tasas de datos y proporcionando conmutación por error.

A c a d e my X p e r t s 1
• RouterOS v6.44.2 – MAE Load Balancing MikroTik RouterOS, Capítulo 2: ECMP

Ether2 Ether2
MikroTik A MikroTik B
Ether3 Ether3

Bonding

El proceso de bonding proporciona diversos métodos de balanceo estos métodos se definirán dependiendo de los
proveedores que tengamos en especial por la simetría de ancho de banda o la asimetría entre los proveedores.

Actualización RouterOS a la última versión


1. Probar que se tenga salida hacia internet para esta actividad se debe realizar un ping a los DNS de Google y realizar
un nuevo ping hacia algún dominio en este caso tomaremos el dominio mikrotik.com.

A c a d e my X p e r t s 2
• RouterOS v6.44.2 – MAE Load Balancing MikroTik RouterOS, Capítulo 2: ECMP

2. Actualizar a la última versión de RouterOS

A c a d e my X p e r t s 3
RouterOS v6.44.2 – MAE-CTT-BCA, Balanceo de Carga con MikroTik RouterOS, Capítulo 3: PCC

Capítulo 2: ECMP
ECMP = Equal Cost Multi-Path (Múltiples trayectorias de costo iguales)
Para implementar algunas configuraciones, como por ejemplo balanceo (load balancing) puede ser necesario utilizar más
de un camino (path) hacia un destino dado. Sin embargo, no es posible tener más de una ruta activa hacia un mismo destino
en una tabla de ruteo simple.
Las rutas ECMP tienen múltiples valores de gateway de siguiente salto (nexthop). Todos los nexthop (siguientes saltos) son
copias al FIB (Forwarding information base- Se utiliza para realizar las decisiones de reenvío de paquetes). Uno de los
protocolos que puede crear rutas ECMP es OSPF de forma dinámica siempre y cuando exista redundancia dentro de la red,
estas rutas también pueden ser creadas manualmente. Este mecanismo de ruteo habilita el ruteo de paquetes entre múltiples
caminos (paths) y asegura el balanceo de carga.
Con ruteo ECMP se puede usar más de un gateway para una red de destino. Esto NO significa que provee Failover, el
objetivo de tener varios gateway en una ruta es que el balanceado ECMP elegirá un nuevo Gateway para cada nuevo per IP
source/destination. Esto significa que, por ejemplo, una conexión FTP usará solo un enlace, pero una nueva conexión a un
servidor diferente usará otro enlace (proveedor).
Características
• Las rutas ECMP tiene más de un gateway a la misma red remota
• Los gateway serán usados en un esquema de combinación de direcciones Round Robin per SRC/DST.
• El mismo gateway puede ser escrito muchas veces.

Opción “Check-Gateway”
EL objetivo del balanceador ECMP es poder utilizar varios gateway usando el esquema de combinación Round Robin per
SRC/DST, sin embargo, las rutas pueden chequear sus respectivos Gateway, el objetivo de realizar esta configuración dentro
de las rutas ECMP es poder determinar, cuando una de las líneas(proveedor) se ha caído. Lo hace a través de la opción
check-Gateway la cual se puede configurar en las rutas con el objetivo de chequear la accesibilidad del gateway usando
protocolos ICMP (ping) o ARP. Si un gateway en ruteo ECMP no puede ser alcanzado al tener activa la opción Check gateway
permitirá que solo se utilicen los gateway que puedan ser alcanzados de tal forma el algoritmo Round Robin generará una
nueva distribución entre dicho gateway activos.

A c a d e my X p e r t s 4
RouterOS v6.44.2 – MAE-CTT-BCA, Balanceo de Carga con MikroTik RouterOS, Capítulo 3: PCC

Balanceo Simétrico
La capacidad de poder tener 2 o más Gateway en una ruta por defecto permitirá que se realice un proceso conocido como
ponderación.
Cuando se tiene rutas ECMP el router por medio del algoritmo Round Robin envira las conexiones 1 a 1 por cada gateway
permitiendo el proceso de equidad.
Balanceo Asimétrico
Cuando se tiene proveedores con diferente ancho de banda las conexiones se deberán dividir de tal forma que el proveedor
que tenga más ancho de banda sea más utilizado por Round Robin. Por ejemplo:
o Se asumirá que tenemos dos proveedores
o El primer proveedor tiene 10M de ancho de banda
o El segundo proveedor tiene solamente 5M, eso quiere decir que el proveedor uno es a quien se le debe
enviar más cantidades de conexiones ya que el proveedor que tiene más ancho de banda.

Para generar una ponderación del 66.66 % para el proveedor uno y del 33,33 % del proveedor dos, se debe duplicar el
Gateway del proveedor con más ancho de banda, de esta forma el algoritmo Round Robin dividirá la cantidad de conexiones
para la cantidad de gateway activos.

A c a d e my X p e r t s 5
RouterOS v6.44.2 – MAE-CTT-BCA, Balanceo de Carga con MikroTik RouterOS, Capítulo 3: PCC

Laboratorio 2.1: Balanceo ECMP

eth1
172.16.1.1/26
Proveedor 1

eth1
172.16.1.18/26

eth2
Internet 192.168.100.254/24 192.168.100.0/24
Balanceador

wlan1
172.16.10.25/26

wlan2
Proveedor 2
172.16.10.1/26

Diagrama elaborado por:


Academy Xperts
Figura: Detalle:
2.1 Balanceo ECMP

Tarea 1: Él estudiante deberá configurar el direccionamiento IP tanto el de los proveedores como él direccionamiento para
la red lan.
Configuración del RB-Balanceador
• Ip -> Addresses
• Se recomienda comentar cada entrada nueva, por ejemplo “ISP 1”
• El objetivo de comentar es tener una mejor organización.

Comand line interface


/ip address
add address=192.168.100.254/24 comment=LAN interface=ether2 network=192.168.100.0
add address=172.16.1.18/26 comment="ISP 1" interface=ether1 network=172.16.1.0
add address=172.16.10.25/26 comment="ISP 2" interface=wlan1 network=172.16.10.0

A c a d e my X p e r t s 6
RouterOS v6.44.2 – MAE-CTT-BCA, Balanceo de Carga con MikroTik RouterOS, Capítulo 3: PCC

Tarea 2: Configurar los pasos mínimos para salir hacía internet, lo pasos son los siguientes:
o 2.1 - DNS
o 2.2 - NAT
o 2.3 - Ruta por defecto
Configuración del RB-Balanceador
• Ip -> DNS
• Como servidores DNS se están utilizando actualmente a los proveedores, esto puede variar dependiendo de los
DNS que tengamos con los proveedores.
• Se habilitará la opción Allow Remote Requests, para que el rb-balanceador se convierte en DNS transparente

Comand line interface


/ip dns
set allow-remote-requests=yes servers=172.16.1.1, 172.16.10.1

Tarea 2.2: NAT (Network address translation)


• Ip -> Firewall => NAT
• Se requiere que se genere el enmascaramiento de las interfaces de los dos proveedores (wlan1, ether1)

Comand line interface


/ip firewall nat
add action=masquerade chain=srcnat out-interface=ether1
add action=masquerade chain=srcnat out-interface=wlan1

A c a d e my X p e r t s 7
RouterOS v6.44.2 – MAE-CTT-BCA, Balanceo de Carga con MikroTik RouterOS, Capítulo 3: PCC

Tarea 2.3: Route


• Ip -> Route
• Creación de rutas ECMP

Comand line interface


/ip route
add check-gateway=ping gateway=172.16.1.1,172.16.10.1 dst.address=0.0.0.0/0

Laboratorio 2.2: Balanceo ECMP Asimétrico

Proveedor 1 33.33%
eth1
172.16.1.18/26
eth2
Internet 192.168.100.254/24 192.168.100.0/24
Balanceador

wlan1
172.16.10.25/26

66.66%
Proveedor 2

Diagrama elaborado por:


Academy Xperts
Figura: Detalle:
2.2 Balanceo ECMP Asimétrico

A c a d e my X p e r t s 8
RouterOS v6.44.2 – MAE-CTT-BCA, Balanceo de Carga con MikroTik RouterOS, Capítulo 3: PCC

Tarea 1: Él estudiante deberá configurar el direccionamiento IP tanto el de los proveedores como él direccionamiento para
la red lan.
Configuración del RB-Balanceador
• Ip -> Addresses
• Se recomienda comentar cada entrada nueva, por ejemplo “ISP 1”
• El objetivo de comentar es tener una mejor organización.

Comand line interface


/ip address
add address=192.168.100.254/24 comment=LAN interface=ether2 network=192.168.100.0
add address=172.16.1.18/26 comment="ISP 1“ interface=ether1 network=172.16.1.0
add address=172.16.10.25/26 comment="ISP 2" interface=wlan1 network=172.16.10.0
Tarea 2: Configurar los pasos mínimos para salir hacía internet, lo pasos son los siguientes:
o 2.1 - DNS
o 2.2 - NAT
o 2.3 - Ruta por defecto
Configuración del RB-Balanceador
• Ip -> DNS
• Como servidores DNS se están utilizando actualmente a los proveedores, esto puede variar dependiendo de los
DNS que tengamos con los proveedores.
• Se habilitará la opción Allow Remote Requests, para que el rb-balanceador se convierte en DNS transparente

A c a d e my X p e r t s 9
RouterOS v6.44.2 – MAE-CTT-BCA, Balanceo de Carga con MikroTik RouterOS, Capítulo 3: PCC

Comand line interface


/ip dns
set allow-remote-requests=yes servers=172.16.1.1, 172.16.10.1

Tarea 2.2: NAT (Network address translation)


• Ip -> Firewall => NAT
• Se requiere que se genere el enmascaramiento de las interfaces de los dos proveedores (wlan1, ether1)

Comand line interface


/ip firewall nat
add action=masquerade chain=srcnat out-interface=ether1
add action=masquerade chain=srcnat out-interface=wlan1

Tarea 3: Route
• Ip -> Route
• Creación de rutas ECMP con ponderación

Comand line interface


/ip route
add check-gateway=ping distance=1 gateway=172.16.1.1,172.16.10.1,172.16.10.1

A c a d e my X p e r t s 10
RouterOS v6.44.2 – MAE-CTT-BCA, Balanceo de Carga con MikroTik RouterOS, Capítulo 4: NTH

Capítulo 3: PCC
PCC (Per Connection Classifier) tiene como función principal permitir dividir el tráfico en flujos iguales con la capacidad de
mantener paquetes con un conjunto especifico de opciones en un flujo particular realizando varias combinaciones que van
desde src-address, src-port, dst-address, dst-port. Per Connection Classifier, es una función contenida en el Mangle el objetivo
de esa función es poder clasificar el flujo del tráfico mediante varios parámetros los cuales son los siguientes:
• Packet: Contenedor utilizado por los datos el cual esta dividido en carga útil y cabecera.

• Ejemplo: Un paquete es como una carta la cual está compuesta por un remitente (Origen) y un destinatario. El
router funcionará como si fuera un correo y es él, quien se encargará de encaminar dicho paquete por medio de el
para que pueda alcanzar su destino final esto es posible mediante rutas.

• Connections: Conductores por los cuales la comunicación host to host se produce, según las direcciones y puertos
SRC/DST. Las conexiones que se generan en la red pasaran por la función conocida como connections tracking la
cual permitirá ver sus respectivos origines y hacia dónde van (destino). Dichas conexiones tienen varios estados:
o Establecidas
o Relacionadas
o Nuevas
o Invalidas, etc.

A c a d e my X p e r t s 11
RouterOS v6.44.2 – MAE-CTT-BCA, Balanceo de Carga con MikroTik RouterOS, Capítulo 4: NTH

• Mangle Facility: Función de firewall dentro del RouterOS la cual permite generar marcas de tráfico especiales, así
como la de generar varios cambios especiales en la cabecera IP. Al igual que la opción filter rule las reglas de
mangle funcionan como una condicionante If-Then. Las reglas de mangle permitirán marcar los paquetes IP con
marcas especiales, estas marcas son usadas por otros recursos tales como los de ruteo y administración de ancho
de banda. Sin embargo, Mangle puede generar funciones adicionales tales como algunas modificaciones de
algunos campos de la cabecera IP, como los capos TOS (DSCP) y TTL.
Las reglas de mangle están organizadas en cadenas, existen 5 cadenas predeterminadas:
o Prerouting: hace una marca antes del queue Global-In
o Posrouting: hace una marca antes del queue Global-Out
o Input: hace una marca antes del filtro Input
o Output: hace una marca antes del filtro Output
o Forward: hace una marca antes del filtro Forward

Al igual que en las reglas de filter en mangle también se pueden añadir nuevos Chains definidos por el usuario,
tantos como sean necesarios.

A c a d e my X p e r t s 12
RouterOS v6.44.2 – MAE-CTT-BCA, Balanceo de Carga con MikroTik RouterOS, Capítulo 4: NTH

• Routing Table: Reglas que el enrutador usa para determinar el camino que deberá seguir el paquete para de esa
forma poder alcanzar su destino final, en PCC generalmente se utilizan marcas de paquetes asociadas a las rutas
para determinar hacia que proveedor se enviaran las conexiones etiquetados en mangle, estas marcas son usadas
por otros recursos como ruteo y administración de ancho de banda para identificar los paquetes y conexiones, asi
como generar marcas y poderla asociar rutas estas marcas son conocidas como mark-routing.

PCC
Es un tipo de balanceo el cual permite dividir las conexiones entre las líneas (proveedores), Peer Connection Classifier es una
opción que se encuentra dentro de mangle que permite clasificar los datos en flujos que pueden marcarse para su respectiva
identiticación con el objetivo de poder definir mediante rutas hacia que proveedor se enviaran dichos flujos de datos.

Load balancing using PCC


PCC toma los campos seleccionados de la cabecera IP, y con la ayuda de un algoritmo de hashing convierte los campos
seleccionados en un valor de 32-bits, este valor se dividirá por un denominador especifico y el resto se compara con un
restante especificado; si hace match entonces se captura el paquete. Se puede elegir de los siguientes campos de las
cabeceras IP y TCP para utilizarlos en esta operación:
• Src-address (cabecera IP)
• Dst-address (cabecera IP)
• Src-port (cabecera TCP)
• Dst-port (cabecera TCP)

Load balancing PCC por medio del algoritmo hashing, el cual es una función matemática cuando obtiene una entra y devuelve
una salida, permite por medio de reglas de mangle etiquetar las conexiones con el objetivo de distribuir las conexiones hacia
los distintos proveedores.

A c a d e my X p e r t s 13
RouterOS v6.44.2 – MAE-CTT-BCA, Balanceo de Carga con MikroTik RouterOS, Capítulo 4: NTH

Para el caso de PCC, hash se alimenta de entadas (conexiones).

Denominadores y Restos son partes de operaciones de módulos.


Una operación de módulo produce un valor entero que sobra cuando se divide dos números y solo uno acepta la porción del
número completo del resultado. Se representa con un signo %
Ejemplos de esta operación:
• 3 % 3 = 0, porque 3 se divide limpiamente para 3
• 4 % 3 = 1, porque el siguiente número más pequeño al que 4 se divide limpiamente por 3 es 3, y 4 – 3= 1
• 5 % 3 = 2, porque el siguiente número más pequeño al que 5 se divide limpiamente por 3 es 3, y 5 - 3 = 2
• 6 % 3 = 0, porque 6 se divide limpiamente para 3
Basándose en los diferentes de la cabecera IP, el balanceador PCC permite realizar varias combinaciones:
• Booth-addresses
• Both-ports
• Dst-address-and-port
• Src-address
• Src-port
• Both-addresses-and-ports
• Dst-address
• Dst-port
• Src-address-and port

Hash dividirá SRC/DST en valores de 32 bits, permitiendo salidas que sumaran dichos valores, por ejemplo:
Para el caso de PCC, cuando se alimenta las direcciones IP y puertos, solo se agrega los octetos de las direcciones IP como
números decimales al igual que los puertos, y luego se toma el ultimo digito y lo produce como salida
Asumiendo que se generó una nueva conexión con los siguientes datos.

Dirección de origen Puerto de origen Dirección de destino Puerto de destino

1.1.1.1 10000 2.2.2.2 80

La salida será:

A c a d e my X p e r t s 14
RouterOS v6.44.2 – MAE-CTT-BCA, Balanceo de Carga con MikroTik RouterOS, Capítulo 4: NTH

1 + 1 + 1 + 1 + 1 000 + 2 + 2 + 2 + 2 + 80 = 1092
El resultado de la salida generada por hash será dividirá para la cantidad de proveedores, para este ejemplo asumiremos
que contamos con dos proveedores, el residuo de esta operación permitirá conocer por cual proveedor dicha conexión
siempre saldrá hasta que su SRC/DST cambie.

1092 / 2 = 546
Residuo = 0 Conexión enviada hacia el proveedor uno

Si queremos revisar la sintaxis completa a través del CLI (línea de comandos) utilizamos el signo “?” al final del comando:
/ip route
mangle add chain=prerouting per-connection-clssifier=?
Per-connection-classifier=
PerConnectionCLassifier :: = [!] ValuesToHash:Denominator/Remainder
Remainder ::= 0..4294967295 (Integer number)
Denominator :: 1..4294967295 (Integer number)
ValuesToHash::= both-addresses|both-ports|dst-address-and-port|src-addess|both-
a addesses-and-ports|dst-addess|dst-port|src-address-and-port

Es importante notar que, aunque PCC es muy utilizado para balancear carga entre circuitos de red. Sin embargo, PCC por
sí mismo no tiene nada que ver con el enrutamiento, con los routing-mark, con la distribución de la carga. PCC es
simplemente una forma para hacer coincidir (match)a los paquetes, y no esta relacionado directamente con la acción de
marcar los paquetes que coinciden, aunque ese sea su propósito principal.
Las siguientes son líneas que comúnmente se utilizan en PCC:
1. /ip firewall
mangle add chain=prerouting action=mark-connection new-connection-mark=1st_conn per-connection-
classifier=src-address-and-port:2/0
2. /ip firewall
mangle add chain=prerouting action=mark-connection new-connection-mark=2st_conn per-connection-
classifier=src-address-and-port:2/1

La primera línea significa: Producir la salida de la función hash dada la dirección IP y puerto origen del paquete, dividirlo por
2, y si el resto es 0, realizará la acción de marcar la conexión como 1st_conn
La primera línea significa: Producir la salida de la función hash dada la dirección IP y puerto origen del paquete, dividirlo por
2, y si el resto es 1, realizará la acción de marcar la conexión como 2st_conn

A c a d e my X p e r t s 15
RouterOS v6.44.2 – MAE-CTT-BCA, Balanceo de Carga con MikroTik RouterOS, Capítulo 4: NTH

Ejemplo de balanceo de carga utilizando PCC

Direcciones IP
/ip adress
add address=192.168.0.1/24 interface=ether3 comment=”LAN”
add address=10.1.1.2/30 interface=eth1
add address=10.20.1.2/30 interface=eth2

Políticas de ruteo
El objetivo de las políticas de ruteo es forzar el tráfico hacia un gateway específico, incluso si estuviera destinado a otro
gateway. Las siguientes 2 reglas permiten el uso de las tablas de ruteo por default para el tráfico que está conectado a
dichas redes (10.1.10/30 y 10.20.1.0/30) siempre y cuando el tráfico provenga de la LAN (ether3, 192.168.0.1/24)
/ip firewall mangle
add chain=prerouting dst-address=10.1.1.0/30 action=accept int-interface= LAN
add chain=prerouting dst-address=10.20.1.0/30 action=accept int-interface= LAN

En las siguientes 2 reglas se manejarán las conexiones iniciadas en el exterior (en la WAN), ya que las respuestas deben
salir por la misma interface (desde la misma IP pública) por donde vino el requerimiento. Se marcarán únicamente las
nuevas conexiones entrantes.

add chain=prerouting in-interface=eth1 connection-mark=no-mark action=mark-


connection new-connection- mark=ISP1_conn
add chain=prerouting in-interface=eth2 connection-mark=no-mark action=mark-
connection new-connection- mark=ISP2_conn

En las siguiente 2 reglas se utiliza PCC para dividir el tráfico LAN (ether3, 192.168.0.1/24) en dos grupos (en este ejemplo
solo hay 2 interfaces WAN/internet) para lo cual se utiliza both-addresses (basado en direcciones origen y destino).
Puesto que el tráfico filtrado por chain=prerouting captura todo el tráfico que va hacia el mismo router, y se necesita
filtrar el tráfico cuyo destino No es la red local (LAN, ether3), entonces se utiliza dst-address-type=!local

add chain=prerouting in-interface= LAN connection-mark=no-mark dst-address-


type=!local per-connection-classifier=both-addresses:2/0 action=mark-connection new-
connection-mark=ISP1_conn
add chain=prerouting in-interface= LAN connection-mark=no-mark dst-address-
type=!local per-connection-classifier=both-addresses:2/1 action=mark-connection new-
connection-mark=ISP2_conn

A c a d e my X p e r t s 16
RouterOS v6.44.2 – MAE-CTT-BCA, Balanceo de Carga con MikroTik RouterOS, Capítulo 4: NTH

Cuando se trabaja con mark-routing debemos recordar que únicamente se puede utilizar chain=output y
chain=prerouting. Por este motivo el tráfico de conexión LAN (ether3) se filtra con prerouting, y el tráfico de
conexioón WAN/Internet se filtra y marca (mark-routing) con chain=output.

add chain=prerouting connection-mark=ISP1_conn in-interface=LAN action=mark-routing


new-routing-mark=to_ISP1
add chain=prerouting connection-mark=ISP2_conn in-interface=LAN action=mark-routing
new-routing-mark=to_ISP2
add chain=output connection-mark=ISP1_conn action=mark-routing new-routing-
mark=to_ISP1
add chain=output connection-mark=ISP2_conn action=mark-routing new-routing-
mark=to_ISP2

En las siguientes 2 reglas se crean las rutas para cada routing-mark


/ ip route
add dst-address=0.0.0.0/0 gateway=10.111.0.1 routing-mark=to_ISP1 check-gateway=ping
add dst-address=0.0.0.0/0 gateway=10.112.0.1 routing-mark=to_ISP2 check-gateway=ping

En las siguientes 2 reglas habilitan el failover cuando uno de los Gateway falla. Para esto es necesario que este activada la
opción check-gateway

add dst-address=0.0.0.0/0 gateway=10.111.0.1 distance=1 check-gateway=ping


add dst-address=0.0.0.0/0 gateway=10.112.0.1 distance=2 check-gateway=ping
NAT
Finalmente, puesto que las decisiones de ruteo ya fueron realizadas en las reglas anteriores, tan solo se necesita
enmascarar (NATear) los paquetes que saldrán por cada interface WAN/Internet.

/ ip firewall nat
add chain=srcnat out-interface=ISP1 action=masquerade
add chain=srcnat out-interface=ISP2 action=masquerade

Laboratorio 3.1: Balanceo PCC

eth1
172.16.1.1/26
Proveedor 1

eth1
172.16.1.18/26

eth2
Internet 192.168.100.254/24 192.168.100.0/24
Balanceador

wlan1
172.16.10.25/26

wlan2
Proveedor 2
172.16.10.1/26

Diagrama elaborado por:


Academy Xperts
Figura: Detalle:
3.1 Balanceo PCC

Tarea 1: Él estudiante deberá configurar el direccionamiento IP tanto el de los proveedores como él direccionamiento para
la red lan.
Configuración del RB-Balanceador

A c a d e my X p e r t s 17
RouterOS v6.44.2 – MAE-CTT-BCA, Balanceo de Carga con MikroTik RouterOS, Capítulo 4: NTH

• Ip -> Addresses
• Se recomienda comentar cada entrada nueva, por ejemplo “ISP 1”
• El objetivo de comentar es tener una mejor organización.

Comand line interface


/ip address
add address=192.168.100.254/24 comment=LAN interface=ether2 network=192.168.100.0
add address=172.16.1.18/26 comment="ISP 1“ interface=ether1 network=172.16.1.0
add address=172.16.10.25/26 comment="ISP 2" interface=wlan1 network=172.16.10.0
Tarea 2: Configurar los pasos mínimos para salir hacía internet, lo pasos son los siguientes:
o 2.1 - DNS
o 2.2 - NAT
o 2.3 - Ruta por defecto
Configuración del RB-Balanceador
• Ip -> DNS
• Como servidores DNS se están utilizando actualmente a los proveedores, esto puede variar dependiendo de los
DNS que tengamos con los proveedores.
• Se habilitará la opción Allow Remote Requests, para que el rb-balanceador se convierte en DNS transparente

A c a d e my X p e r t s 18
RouterOS v6.44.2 – MAE-CTT-BCA, Balanceo de Carga con MikroTik RouterOS, Capítulo 4: NTH

Comand line interface


/ip dns
set allow-remote-requests=yes servers=172.16.1.1, 172.16.10.1

Tarea 2.2: NAT (Network address translation)


• Ip -> Firewall => NAT
• Se requiere que se genere el enmascaramiento de las interfaces de los dos proveedores (wlan1, ether1)

Comand line interface


/ip firewall nat
add action=masquerade chain=srcnat out-interface=ether1
add action=masquerade chain=srcnat out-interface=wlan1
Tarea 3: Mangle (Marca de conexiones, PCC, Mara de rutas)
• Ip -> Firewall => Mangle
• Permitir conexiones hacia los proveedores siempre y cuando sean generados desde la LAN.

Comand line interface


/ip firewall mangle
add action=accept chain=prerouting comment="Permitir conexiones hacia los
proveedorees" dst-address=172.16.1.0/26 in-interface=ether2
add action=accept chain=prerouting dst-address=172.16.10.0/26 in-interface=ether2

Tarea 3.1: Mangle (Marca de conexiones, PCC, Mara de rutas)


• Ip -> Firewall => Mangle
• La segunda fase de configuración consiste en etiquetar las nuevas conexiones que vengan desde el exterior.

Comand line interface


/ip firewall mangle

A c a d e my X p e r t s 19
RouterOS v6.44.2 – MAE-CTT-BCA, Balanceo de Carga con MikroTik RouterOS, Capítulo 4: NTH

add action=mark-connection chain=prerouting connection-mark=no-mark in-


interface=ether1 new-connection-mark=conn_prov_1 passthrough=yes
add action=mark-connection chain=prerouting connection-mark=no-mark in-
interface=wlan1 new-connection-mark=conn_prov_2 passthrough=yes
Tarea 3.2: Mangle (Marca de conexiones, PCC, Mara de rutas)
• Ip -> Firewall => Mangle
• La tercera fase y quizás una de las más importante consiste en la ponderación de las conexiones hacia los
proveedores.

Comand line interface


/ip firewall mangle

add action=mark-connection chain=prerouting comment="Ponderaic\F3n-PCC" connection-


mark=no-mark dst-address-type=!local in-interface=ether2 new-connection-mark=\
conn_prov_1 passthrough=yes per-connection-classifier=both-addresses:2/0
add action=mark-connection chain=prerouting connection-mark=no-mark dst-address-
type=!local in-interface=ether2 new-connection-mark=conn_prov_2 passthrough=yes \
per-connection-classifier=both-addresses:2/1

Tarea 3.3: Mangle (Marca de conexiones, PCC, Mara de rutas)


• Ip -> Firewall => Mangle
• Cuarta fase, Filtrado de conexiones por medio entrantes (prerouting)y salientes (output) por medio de mark-
routing.

Comand line interface


/ip firewall mangle
add action=mark-routing chain=prerouting connection-mark=conn_prov_1 in-
interface=ether2 new-routing-mark=rounting_prov_1 passthrough=no
add action=mark-routing chain=prerouting connection-mark=conn_prov_2 in-
interface=ether2 new-routing-mark=rounting_prov_2 passthrough=no

A c a d e my X p e r t s 20
RouterOS v6.44.2 – MAE-CTT-BCA, Balanceo de Carga con MikroTik RouterOS, Capítulo 4: NTH

add action=mark-routing chain=output connection-mark=conn_prov_2 new-routing-


mark=rounting_prov_2 passthrough=no
add action=mark-routing chain=output connection-mark=conn_prov_1 new-routing-
mark=rounting_prov_1 passthrough=no

Tarea 4: Route
• Ip -> Firewall => Route
• Creación de rutas.

Comand line interface


/ip firewall mangle
add dst-address=0.0.0.0/0 check-gateway=ping distance=1 gateway=172.16.1.1 routing-
mark=rounting_prov_1
add dst-address=0.0.0.0/0 check-gateway=ping comment="Ruta por default distance 2"
distance=1 gateway=172.16.10.1 routing-mark=rounting_prov_2
add dst-address=0.0.0.0/0 check-gateway=ping comment="Ruta por default distance 1"
distance=1 gateway=172.16.1.1
add dst-address=0.0.0.0/0 check-gateway=ping distance=2 gateway=172.16.10.1

Laboratorio 3.2: Balanceo PCC asimétrico

Proveedor 1 33.33%
eth1
172.16.1.18/26
eth2
Internet 192.168.100.254/24 192.168.100.0/24
Balanceador

wlan1
172.16.10.25/26

66.66%
Proveedor 2

Diagrama elaborado por:


Academy Xperts
Figura: Detalle:
3.2 Balanceo PCC

Tarea 1: Él estudiante deberá configurar el direccionamiento IP tanto el de los proveedores como él direccionamiento para
la red lan.

A c a d e my X p e r t s 21
RouterOS v6.44.2 – MAE-CTT-BCA, Balanceo de Carga con MikroTik RouterOS, Capítulo 4: NTH

Configuración del RB-Balanceador


Ip -> Addresses Diagrama elaborado por:

• Se recomienda comentar cada entrada nueva, por ejemplo “ISP 1”
• El objetivo de comentar es tener una mejor organización.

Comand line interface


/ip address
add address=192.168.100.254/24 comment=LAN interface=ether2 network=192.168.100.0
add address=172.16.1.18/26 comment="ISP 1“ interface=ether1 network=172.16.1.0
add address=172.16.10.25/26 comment="ISP 2" interface=wlan1 network=172.16.10.0
Tarea 2: Configurar los pasos mínimos para salir hacía internet, lo pasos son los siguientes:
o 2.1 - DNS
o 2.2 - NAT
o 2.3 - Ruta por defecto
Configuración del RB-Balanceador
• Ip -> DNS
• Como servidores DNS se están utilizando actualmente a los proveedores, esto puede variar dependiendo de los
DNS que tengamos con los proveedores.
• Se habilitará la opción Allow Remote Requests, para que el rb-balanceador se convierte en DNS transparente

A c a d e my X p e r t s 22
RouterOS v6.44.2 – MAE-CTT-BCA, Balanceo de Carga con MikroTik RouterOS, Capítulo 4: NTH

Comand line interface


/ip dns
set allow-remote-requests=yes servers=172.16.1.1, 172.16.10.1

Tarea 2.2: NAT (Network address translation)


• Ip -> Firewall => NAT
• Se requiere que se genere el enmascaramiento de las interfaces de los dos proveedores (wlan1, ether1)

Comand line interface


/ip firewall nat

add action=masquerade chain=srcnat out-interface=ether1


add action=masquerade chain=srcnat out-interface=wlan1

Tarea 3: Mangle (Marca de conexiones, PCC, Mara de rutas)


• Ip -> Firewall => Mangle
• Permitir conexiones hacia los proveedores siempre y cuando sean generados desde la LAN.

Comand line interface


/ip firewall mangle

add action=accept chain=prerouting comment="Permitir conexiones hacia los


proveedorees" dst-address=172.16.1.0/26 in-interface=ether2
add action=accept chain=prerouting dst-address=172.16.10.0/26 in-interface=ether2

Tarea 3.1: Mangle (Marca de conexiones, PCC, Mara de rutas)


• Ip -> Firewall => Mangle
• La segunda fase de configuración consiste en etiquetar las nuevas conexiones que vengan desde el exterior.

A c a d e my X p e r t s 23
RouterOS v6.44.2 – MAE-CTT-BCA, Balanceo de Carga con MikroTik RouterOS, Capítulo 4: NTH

Comand line interface


/ip firewall mangle

add action=mark-connection chain=prerouting connection-mark=no-mark in-


interface=ether1 new-connection-mark=conn_prov_1 passthrough=yes
add action=mark-connection chain=prerouting connection-mark=no-mark in-
interface=wlan1 new-connection-mark=conn_prov_2 passthrough=yes

Tarea 3.2: Mangle (Marca de conexiones, PCC, Mara de rutas)


• Ip -> Firewall => Mangle
• La tercera fase y quizás una de las más importante consiste en la ponderación de las conexiones hacia los
proveedores.

Comand line interface


/ip firewall mangle

add action=mark-connection chain=prerouting comment="Enviando mas conexiones al


proveedor 1- 75%" connection-mark=no-mark dst-address-type=!local new-connection-
mark=conn_prov_1 passthrough=yes per-connection-classifier=both-addresses:3/0
add action=mark-connection chain=prerouting connection-mark=no-mark dst-address-
type=!local new-connection-mark=conn_prov_1 passthrough=yes per-connection-
classifier=both-addresses:3/1
add action=mark-connection chain=prerouting comment="Enviando conexiones hacia el
proveedor 2-25%" connection-mark=no-mark dst-address-type=!local new-connection-
mark=conn_prov_2 passthrough=yes per-connection-classifier=both-addresses:3/2

Tarea 3.3: Mangle (Marca de conexiones, PCC, Mara de rutas)


• Ip -> Firewall => Mangle
• Cuarta fase, Filtrado de conexiones por medio entrantes (prerouting) y salientes (output) por medio de mark-
routing.

A c a d e my X p e r t s 24
RouterOS v6.44.2 – MAE-CTT-BCA, Balanceo de Carga con MikroTik RouterOS, Capítulo 4: NTH

Comand line interface


/ip firewall mangle

add action=mark-routing chain=prerouting connection-mark=conn_prov_1 in-


interface=ether2 new-routing-mark=rounting_prov_1 passthrough=no
add action=mark-routing chain=prerouting connection-mark=conn_prov_2 in-
interface=ether2 new-routing-mark=rounting_prov_2 passthrough=no
add action=mark-routing chain=output connection-mark=conn_prov_2 new-routing-
mark=rounting_prov_2 passthrough=no
add action=mark-routing chain=output connection-mark=conn_prov_1 new-routing-
mark=rounting_prov_1 passthrough=no
Tarea 4: Route
• Ip -> Firewall => Route
• Creación de rutas.

Comand line interface


/ip firewall mangle

add dst-address=0.0.0.0/0 check-gateway=ping distance=1 gateway=172.16.1.1 routing-


mark=rounting_prov_1
add dst-address=0.0.0.0/0 check-gateway=ping comment="Ruta por default distance 2"
distance=1 gateway=172.16.10.1 routing-mark=rounting_prov_2
add dst-address=0.0.0.0/0 check-gateway=ping comment="Ruta por default distance 1"
distance=1 gateway=172.16.1.1
add dst-address=0.0.0.0/0 ch peck-gateway=ping distance=2 gateway=172.16.10.1

A c a d e my X p e r t s 25
RouterOS v6.44.2 – MAE-CTT-BCA, Balanceo de Carga con MikroTik RouterOS, Capítulo 4: NTH

Capítulo 4: Nth
El balanceador Nth es un método para la selección de elementos en una posición “N” dentro de una secuencia, este
balanceador se centra en el rendimiento. Lo que significa que se deba verificar menos reglas ya sean de paquetes o de
conexiones y por ende también utilizaran menos cantidades de reglas de atributos.
Conexiones y paquetes
Una conexión puede generar “N” cantidades de paquetes, por ejemplo:

Paquete N
Conexión
El balanceo Nth utiliza los paquetes generados en las conexiones, con el objetivo de distribuir dichos paquetes para la
cantidad de proveedores.

En Nth se balancea por paquetes esto lo hace mediante el parámetro Nth que se encuentra dentro de las opciones de
mangle.

Etiquetado de paquetes en Nth


Como ya se conoce en una conexión puede existir una gran cantidad de paquetes, para este ejemplo se asumirá que se
tienen tres líneas (proveedores).

A c a d e my X p e r t s 26
RouterOS v6.44.2 – MAE-CTT-BCA, Balanceo de Carga con MikroTik RouterOS, Capítulo 4: NTH

NTH seleccionara siempre al paquete que se encuentre en la posición uno de toda la ráfaga que se encuentren dentro de
una conexión, de esa forma llevara una elección organizada. Esta función va asociada al parámetro en mangle conocido
como packet.

Para la línea dos NTH etiquetará los paquetes en la posición “2”.

Finalmente, para la línea tres NTH etiquetará los paquetes en la posición “3”. Este proceso se seguirá repitiendo con todos
los paquetes.

A c a d e my X p e r t s 27
RouterOS v6.44.2 – MAE-CTT-BCA, Balanceo de Carga con MikroTik RouterOS, Capítulo 4: NTH

Balanceador NTH
En el balanceador de carga NTH, cada regla tiene su propio contador. Cuando la regla recibe un paquete, el contador de la
regla actual se incremente en uno, Si el contador coincide con el valor cada paquete será emparejado (match) y el contador
se pondrá a cero. Ejemplo:

Direcciones IP
En este ejercicio, el router tiene 2 interfaces WAN don direcciones eth1=10.1.1.2/30 y ethe2=10.20.1.2/30. La interface
LAN (eth3) tiene la dirección eth3=192.168.0.1/24
/ip address

add address=192.168.0.1/24 interface=ether3 comment= ”LAN”


add address=10.1.1.2/30 interface=eth1
add address=10.20.1.2/30 interface =eth2

Mangle
Se crearán dos address list con el objetivo de dividir el tráfico en dos listas “par” e” impar”.
De esta forma todo el tráfico de los clientes cuya Dirección IP coincide con el address-list=impar se marca con las marcas
de conexión y marcas de ruteo “impar”. Después, el tráfico se excluye del procesamiento de sucesivas reglas de mangle
en chain=prerouting.

/ip firewall mangle

add chain=prerouting src-address-list=impar in-interface=LAN action=mark-connection


new-connection-mark=impar passthrough=yes
add chain=prerouting src-address-list=impar in-interface=LAN action=mark-routing
new-routing-mark=impar passthrough=no

Lo mismo sucederá con los clientes cuya dirección IP coincide con el address-list=par.

/ip firewall mangle

add chain=prerouting src-address-list=impar in-interface=LAN action=mark-connection


new-connection-mark=par passthrough=yes
add chain=prerouting src-address-list=impar in-interface=LAN action=mark-routing
new-routing-mark=par passthrough=no

A c a d e my X p e r t s 28
RouterOS v6.44.2 – MAE-CTT-BCA, Balanceo de Carga con MikroTik RouterOS, Capítulo 4: NTH

A continuación, lo que se hará es tomar cada “segundo paquete” que establece una nueva conexión (connection-state=new),
y se lo marcará como “impar”. Consecuentemente todos los paquetes sucesivos que pertenezcan a la misma sesión llevarán
la marca de conexión “impar”.
Nótese que:
• Se pasarán estos paquetes a la segunda y tercera regla (passthrough=yes)
• La segunda regla añade la dirección IP del cliente al address-list para habilitarlo en todas las sucesivas
sesiones que pasan a través de este Gateway.
• La tercera regla establece el routing-mark=impar en todos los paquetes que pertenecen a la conexión “impar”
y detiene el procesamiento de todas las otras reglas de mangle en chain=prerouting

/ip firewall mangle

add chain=prerouting in-interface=LAN connection-state=new nth=2,1 action=mark-


connection new-connection-mark=impar passthrough=yes
add chain=prerouting in-interface=LAN action=add-src-to-address-list address-
list=impar address-list-timeout=1d connection-mark=impar passthrough=yes
add chain=prerouting in-interface=LAN connection-mark=impar action=mark-routing new-
routing-mark=impar passthrough=no
Las siguientes reglas hacen lo mismo que el grupo anterior para la mitad del tráfico restante. En estas nuevas reglas por
cada nueva conexión que se inicia y pase por el router desde la red local será marcada como “impar” o “par” con ambas
reglas de marcado de conexión y de ruteo.

/ ip firewall mangle

add chain=prerouting in-interface=LAN connection-state=new nth=2,2 action=mark-


connection new-connection-mark=par passthrough=yes
add chain=prerouting in-interface=LAN action=add-src-to-address-list address-list=par
address-list-timeout=1d connection-mark=even passthrough=yes
add chain=prerouting in-interface=LAN connection-mark= par action=mark-routing new-
routing-mark=par passthrough=no

Existen casos en donde la IP de los clientes pueden estar listadas en los dos addresses-list es podría ocasionar
problemas cuando las aplicaciones requieren conexiones persistentes. Para solucionar este inconveniente se debe agregar
la siguiente regla de mangle. Esto asegurará que las nuevas conexiones no sean parte del src-address-list=impar.
Se tendrá que hacer lo mismo para las reglas de mangle “impar” y de esta forma excluir las direcciones IP que ya son parte
del src-address-list=par

add chain=prerouting in-interface=LAN connection-state=new nth=2,2 src-address-


list=!impar action=mark-connection new-connection-mark=par passthrough=yes
NAT
Se realiza el NATeo por las interfaces de salida correspondientes

/ ip firewall NAT

add chain=srcnat out-interface=eth1 action=masquerade


add chain=srcnat out-interface=eth2 action=masquerade

Routing
Todo el tráfico como “impar” saldrá por el Gateway 10.1.1.1, y rodo el tráfico marcado como “par” saldrá por el Gateway
10.20.1.1, y como ultimo paso se add adicional especificando que el tráfico del propio router deberá salir por el Gateway
10.20.1.1.

/ ip route
add dst-address=0.0.0.0/0 gateway=10.1.1.1 scope=255 target-scope=10
routingmark=impar
add dst-address=0.0.0.0/0 gateway=10.20.1.1 scope=255 target-scope=10 routing-
mark=par
add dst-address=0.0.0.0/0 gateway=10.20.1.1 scope=255 target-scope=10

A c a d e my X p e r t s 29
RouterOS v6.44.2 – MAE-CTT-BCA, Balanceo de Carga con MikroTik RouterOS, Capítulo 4: NTH

Laboratorio 4: Balanceo NTH

eth1
172.16.1.1/26
Proveedor 1

eth1
172.16.1.18/26

eth2
Internet 192.168.100.254/24 192.168.100.0/24
Balanceador

wlan1
172.16.10.25/26

wlan2
Proveedor 2
172.16.10.1/26

Diagrama elaborado por:


Academy Xperts
Figura: Detalle:
4.1 Balanceo NTH

Tarea 1: Él estudiante deberá configurar el direccionamiento IP tanto el de los proveedores como él direccionamiento para
la red lan.
Configuración del RB-Balanceador
Ip -> Addresses Diagrama elaborado por:

• Se recomienda comentar cada entrada nueva, por ejemplo “ISP 1”
• El objetivo de comentar es tener una mejor organización.

Comand line interface


/ip address
add address=192.168.100.254/24 comment=LAN interface=ether2 network=192.168.100.0
add address=172.16.1.18/26 comment="ISP 1“ interface=ether1 network=172.16.1.0
add address=172.16.10.25/26 comment="ISP 2" interface=wlan1 network=172.16.10.0
Tarea 2: Configurar los pasos mínimos para salir hacía internet, lo pasos son los siguientes:
o 2.1 - DNS
o 2.2 - NAT

A c a d e my X p e r t s 30
RouterOS v6.44.2 – MAE-CTT-BCA, Balanceo de Carga con MikroTik RouterOS, Capítulo 4: NTH

o 2.3 - Ruta por defecto


Configuración del RB-Balanceador
• Ip -> DNS
• Como servidores DNS se están utilizando actualmente a los proveedores, esto puede variar dependiendo de los
DNS que tengamos con los proveedores.
• Se habilitará la opción Allow Remote Requests, para que el rb-balanceador se convierte en DNS transparente

Comand line interface


/ip dns
set allow-remote-requests=yes servers=172.16.1.1, 172.16.10.1

Tarea 2.2: NAT (Network address translation)


• Ip -> Firewall => NAT
• Se requiere que se genere el enmascaramiento de las interfaces de los dos proveedores (wlan1, ether1)

Comand line interface


/ip firewall nat

add action=masquerade chain=srcnat out-interface=ether1


add action=masquerade chain=srcnat out-interface=wlan1

A c a d e my X p e r t s 31
RouterOS v6.44.2 – MAE-CTT-BCA, Balanceo de Carga con MikroTik RouterOS, Capítulo 4: NTH

Tarea 3: Mangle (Marca de conexiones, PCC, Mara de rutas)


• Ip -> Firewall => Mangle
• Permitir conexiones hacia los proveedores siempre y cuando sean generados desde la LAN.

Comand line interface


/ip firewall mangle

add action=accept chain=prerouting dst-address=172.16.1.0/26 in-interface=ether2


add action=accept in-interface=ether2 chain=prerouting dst-address=172.16.10.0/26

Tarea 3.2: Mangle (Marca de conexiones, PCC, Mara de rutas)


• Ip -> Firewall => Mangle
• Segunda fase y quizás una de las más importante consiste en la ponderación de paquetes de forma equitativa
hacia los proveedores.

Comand line interface


/ip firewall mangle

add action=mark-connection chain=prerouting connection-state=new in-interface=ether2


new-connection-mark= conn_prov_1 nth=2,1 passthrough=yes
add action=mark-connection chain=prerouting connection-state=new in-interface=ether2
new-connection-mark=conn_prov_2 nth=2,2 passthrough=yes

Tarea 3.3: Mangle (Marca de conexiones, PCC, Mara de rutas)


• Ip -> Firewall => Mangle
• Cuarta fase, Filtrado de conexiones por medio entrantes (prerouting)y salientes (output) por medio de mark-
routing.

A c a d e my X p e r t s 32
RouterOS v6.44.2 – MAE-CTT-BCA, Balanceo de Carga con MikroTik RouterOS, Capítulo 4: NTH

Comand line interface

/ip firewall mangle

add action=mark-routing chain=prerouting connection-mark=conn_prov_1


in-interface=ether2 new-routing-mark=rounting_prov_1 passthrough=no
add action=mark-routing chain=prerouting connection-mark=conn_prov_2 in-
interface=ether2 new-routing-mark=rounting_prov_2 passthrough=no
add action=mark-routing chain=output connection-mark=conn_prov_2 new-routing-
mark=rounting_prov_2 passthrough=no
add action=mark-routing chain=output connection-mark=conn_prov_1 new-routing-
mark=rounting_prov_1 passthrough=no
Tarea 4: Route
• Ip -> Firewall => Route
• Creación de rutas.

Comand line interface

/ip firewall mangle

add dst-address=0.0.0.0/0 check-gateway=ping distance=1 gateway=172.16.1.1 routing-


mark=rounting_prov_1
add dst-address=0.0.0.0/0 check-gateway=ping comment="Ruta por default distance 2"
distance=1 gateway=172.16.10.1 routing-mark=rounting_prov_2
add dst-address=0.0.0.0/0 check-gateway=ping comment="Ruta por default distance 1"
distance=1 gateway=172.16.1.1
add dst-address=0.0.0.0/0 ch peck-gateway=ping distance=2 gateway=172.16.10.1

A c a d e my X p e r t s 33