Está en la página 1de 2

Actividad 3 - Evidencia 2 Informe

Por: Gonzalo Hernando Ramírez Zuluaga

Sustentación de situación problémica “docente Universidad del Cauca”. El docente


Juan Carlos Martínez de la Universidad del Cauca, requiere un programa el cual le
permita realizar los cálculos necesarios, para determinar si los estudiantes de lógica
de programación aprueban o no aprueban la materia al finalizar su semestre.

 El programa debe permitir capturar el nombre de cada estudiante y su


respectivo código.
 El programa debe permitir capturar la nota del primer parcial.
 El programa debe permitir capturar la nota del segundo parcial.
 El programa debe permitir capturar la nota del examen final.
 El primer parcial equivale a un 35%, el segundo parcial equivale a un 35% y
el final al 30%.
 La nota máxima de un parcial no debe superar 5.0 y la nota mínima es de
0.0.
 La nota definitiva=PrimerP*35% + SegundoP*35% + Final*30%
 Los estudiantes aprueban si la definitiva es superior a 3.5

Solución

1. Análisis

El ejercicio solicita un programa que permita realizar los cálculos que se requieran
para determinar si los estudiantes de una asignatura aprueban o no la materia. Las
condiciones principales del programa deben ser las siguientes: - Debe permitir
capturar los datos del estudiante (nombre código) - Debe permitir capturar las 3
notas parciales y examen final - Parcial 1 = 35% De la nota Final - Parcial 2 = 35%
De la nota Final - Examen final = 30% De la nota Final - La nota máxima de un
parcial es = 5.0 - La nota mínima de un parcial es = 0.0 - La nota final o definitiva es
igual a la suma de las notas de cada parcial y el examen final de acuerdo a sus
porcentajes - Un estudiante aprueba si su nota definitiva es Mayor que 3.5

Declaración de variables Las variables que se necesitan para desarrollar el


programa serían las siguientes:
 String: Nombre
 Int: código
 Double: Parcial1, Parcial2, Examen_Final, Nota_Definitiva
2. Pseudocódigo

Inicio
String Nombre;
Int código; Double Parcial1, Parcial2, Examen_Final, Nota_definitiva;
Escribir “Ingrese nombre del alumno”
Lea Nombre
Escribir “Ingrese código del alumno”
Lea código
Escribir “Ingrese Nota del primer parcial”
Lea Parcial1
Escribir “Ingrese Nota del Segundo parcial”
Lea Parcial2
Escribir “Ingrese Nota del examen final”
Lea examen Final
Nota_Definitiva = (Parcial1*35%) + (Parcial2*35%) + (Examen_Final*30%)
Si Nota_definitiva > 3.5
Imprima “Aprobado”
Sino
Imprima ”Desaprobado”
Fin si
Fin

3. Algoritmo

Algoritmo notas
definir Nombre Como Caracter;
definir código como entero
definir Parcial1, Parcial2, Examen_Final, Nota_definitiva Como Real;
Escribir "Ingrese nombre del alumno"
Leer Nombre
Escribir "Ingrese código del alumno"
Leer código
Escribir "Ingrese Nota del primer parcial un valor entre 0 a 5"
Leer Parcial1
Escribir "Ingrese Nota del Segundo parcial un valor entre 0 a 5"
Leer Parcial2
Escribir "Ingrese Nota del examen final un valor entre 0 a 5"
Leer Examen_Final
Nota_definitiva= (Parcial1*0.35)+(Parcial2*0.35)+(Examen_Final*0.30)
Si Nota_definitiva > 3.5 entonces
escribir "Aprobado con una nota de:",Nota_definitiva
Sino
escribir "Desaprobado con una nota de:" ,Nota_definitiva
Fin si
FinAlgoritmo