Está en la página 1de 5

Componente practico

Grabar el Archivo: practica_estudiante1_Stiven _Paez

Nombre del Estudiante:


Fecha: 10/07/2019 Lugar:CEAD JOSE Y ACEVEDO Y GOMEZ
Contacto: paez.stiven
Doy fe que los siguientes ejercicios son de mi autoría, en caso de encontrar plagio
la nota de todo mí trabajo debe ser de CERO además de las respectivas sanciones
a que haya lugar, El profesor en cualquier momento puede solicitar la sustentación
de uno o más ejercicios

1. Planteamiento del problema a resolver: convertir el diagrama proporcionado en


un seudocódigo, haciendo el análisis del mismo y utilizando las buenas
prácticas de programación.

El diagrama convierte un numero decimal en número binario, lo puede


descargar de aquí

Antes de salir debe mostrar su nombre y el de su empresa(ficticia)

Que datos no Que datos Tipo Formulas a Requiere Requiere


conozco y se no conozco, Variables aplicar si se condicio ciclos (si
deben solicitar pero los requeridas requieren nal (si / / no)
(si se requiere puedo Tipo Variable no)
más filas por calcular
favor anexarlas)
NUMERO NUMERO ENTERA NUM NUM=TRUN SI SI
DECIMAL BINARIO C(CAD/2)
REAL CAD TRUNC CAD
MOD
Diagrama
Seudocódigo en PSeint

Proceso Algoritmo_sin_titulo
Escribir 'introduzca el numero a convertir'
Leer NUM
NUM<-trunc(NUM)
CAD<-''
Si NUM>0 Entonces
Mientras NUM>0 Hacer
PAR<-NUM MOD 2=0
Si PAR Entonces
CAD<-'0'+CAD
SiNo
CAD<-'1'+CAD

Fin Si
NUM<-TRUNC(NUM/2)
Fin Mientras
Escribir 'El número en binario es: ', CAD
SiNo
Si NUM=0 Entonces
Escribir '0'
SiNo
Escribir 'No se convierten números negativos'
Fin Si
Fin Si
FinProceso
Copiar captura de resultados con diferentes valores