Está en la página 1de 6

1.

Planteamiento del problema a resolver: convertir el diagrama proporcionado en


un seudocódigo, haciendo el análisis del mismo y utilizando las buenas
prácticas de programación.

El diagrama convierte un numero decimal en número binario, lo puede


descargar de aquí

Antes de salir debe mostrar su nombre y el de su empresa(ficticia)

Que datos no Que datos no Tipo Formulas a Requier Requiere


conozco y se conozco, pero aplicar si se e ciclos (si
Variables
deben solicitar los puedo requieren condicio / no)
requeridas
(si se requiere calcular nal (si /
más filas por Tipo Variable no)
favor anexarlas)

Numero decimal Numero Entera NUM NUM=trunc SI NUM. MIENTRA


binario (CAD/2) ES PAR, S QUE
ENTONC NÚM>0,
ES SU ENTONCE
RESIDU S, QUE
O ES 0, PREGUNT
PERO SI E SI ES
NOI, SU PAR O
RESUDU IMPAR, Y
O ES 0 DE ESTA
MANERA
SE
EXTRAIG
A LA
PARTE
ENTERA
DEL
NÚMERO
CON LA
FUNCIÓN
TRUNC.

Real CAD TRUNC: SE USA


PARA CAD
EXTRAER COMO
LA PARTE ACUMUL
ENTERA ADOR
DEL DE
DECIMAL. TEXTO
PARA
FORMAR
EL
NÚMER
O
BINARI
O

MOD PARA
REALIZAR
LA DIVISIO.

Diagrama
Producto a entregar

Seudocódigo en Pisen
Algoritmo sin_titulo
Escribir ‘DIGITE EL NUMERO QUE DESEA CONVERTIR’
Leer NUM
NUM<-trunc(NUM)
CAD<-''
Si NUM>0 Entonces
Mientras NUM>0 Hacer
PAR<-NUM MOD 2=0
Si PAR Entonces
CAD<-'0'+CAD
SiNo
CAD<-'1'+CAD

Fin Si
NUM<-TRUNC(NUM/2)
Fin Mientras
Escribir 'El número en binario es: ', CAD
SiNo
Si NUM=0 Entonces
Escribir '0'
SiNo
Escribir 'No se convierten números negativos'
Fin Si
Fin Si
FinAlgoritmo

Copiar captura de resultados con diferentes valores