Está en la página 1de 47

TALLER ESTUDIANTE 1

Grabar el Archivo: Taller_estudiante1_Nombre_Apellido


Al final está el anexo para revisión de taller a sus compañeros

Nombre del Estudiante: Carlos Arturo Prieto Fernández


Fecha: 2 de julio del 2019 Lugar: Cead_Santander_de_Quilichao
Contacto: Skype: cp534496
Doy fe que los siguientes ejercicios son de mi autoría, en caso de encontrar plagio
la nota de todo mí trabajo debe ser de CERO además de las respectivas sanciones
a que haya lugar, El profesor en cualquier momento puede solicitar la sustentación
de uno o más ejercicios

En este taller Usted encontrará 9 problemas los cuales los debe analizar de
forma individual
Este taller pretende que usted realice un análisis de los problemas
presentados y Una de las formas es haciéndose algunas preguntas que no
le han quedado claras después de leer el planteamiento del problema, por
ejemplo, saber cuáles son los datos que no se conocen, identificar los datos
que son posibles de calcular, determinar con claridad las variables que se
pueden utilizar e indagar sobre las fórmulas que se deben utilizar en los
problemas que así lo requieran.
Con tal propósito usted debe leer y re-leer el ejercicio para comprender lo
que se requiere y proceder a realizar su análisis en el cuadro contiguo al
planteamiento
1. Planteamiento del problema a resolver: Se desea realizar el análisis de un problema
que permita calcular el Área de un Cilindro.

Que datos no Que datos no Tipo Formulas a Requie Requiere


conozco y se conozco, pero Variables requeridas aplicar si se re ciclos (si
deben solicitar los puedo Tipo Variable requieren condici / no)
(si se requiere calcular onal
más filas por (si /
favor no)
anexarlas)
Radio (r) Área del Cilindro Real Radio (r) A=2 𝜋𝑟 2 + 2𝜋𝑟ℎ no si
Altura (h) Pi 𝜋 Real Altura (h)

Copiar el seudocódigo (no la imagen)


Algoritmo AREA_DE_UN_CILINDRO
//CALCULAREMOS CUAL ES EL AREA DE UN CILINDRO EN DONDE
SUMINISTRAMOS EL VALOR DEL RADIO Y LA ALTURA
Escribir "CARLOS PRIETO----------VERIFICAR LTDA NIT 5626543-0"
Definir r , h , operacion , RADIO Como Real
Escribir "Por favor ingresar el valor del radio"
Leer r
Escribir "Por favor ingresar el valor de la altura"
Leer h
RADIO <- r*r
operacion <- 2*pi*RADIO+2*pi*r*h
Escribir "El resultado es" , operacion
FinAlgoritmo
Copiar captura de resultados con diferentes valores
1 Resultado
*** Ejecución Iniciada. ***
CARLOS PRIETO----------VERIFICAR LTDA NIT 5626543-0
Por favor ingresar el valor del radio
> 12
Por favor ingresar el valor de la altura
>6
El resultado es1357.1680263508
*** Ejecución Finalizada. ***
2 Resultado
*** Ejecución Iniciada. ***
CARLOS PRIETO----------VERIFICAR LTDA NIT 5626543-0
Por favor ingresar el valor del radio
>5
Por favor ingresar el valor de la altura
> 17
El resultado es691.1503837898
*** Ejecución Finalizada. ***
3 Resultado
*** Ejecución Iniciada. ***
CARLOS PRIETO----------VERIFICAR LTDA NIT 5626543-0
Por favor ingresar el valor del radio
> 25
Por favor ingresar el valor de la altura
> 64
El resultado es13980.0873084746
*** Ejecución Finalizada. ***

¿En qué aspectos ha cambiado el análisis de ejercicio desde el


diseño inicial o este ha permanecido consistente?
Respuesta: Ha permanecido consistente
2. Planteamiento del problema a resolver: realizar el análisis para solucionar el problema
que permita ingresar un valor expresado en centímetros, y entregar la respuesta
tanto en yardas como en pies.

Que datos no Que Tipo Formulas a aplicar si se Requi Requi


conozco y se datos no Variables requeridas requieren ere ere
deben solicitar conozco, Tipo Variable condic ciclos
(si se requiere pero los ional (si /
más filas por puedo (si / no) _
favor calcular no) cuales
anexarlas)
Centímetros Yardas Real Cm centímetros 1𝑚 1𝑦𝑑 no si
𝑐𝑚 ∗ ∗
(cm) (yd) 100𝑐𝑚 0.9144𝑚
Pies (ft) Real Yd yardas 1𝑓𝑡
𝑐𝑚 ∗
30.47
Real Ft pies

Copiar el seudocódigo (no la imagen)


Algoritmo CENTIMETROS_A_YARDAS_Y_A_PIES
//SE CONVERTIRA DE LA UNIDAD CENTIMETROS A YARDAS
Escribir "CARLOS PRIETO----------VERIFICAR LTDA NIT 5626543-0"
Definir cm , yardas , pies Como Real
Escribir "Por favor ingresa el valor en Centimetros"
Leer cm
yardas <- cm*1/100*1/0.9144
Escribir "El resultado en yardas es" , yardas
pies <- cm*1/30.47
Escribir "El resultado en pies es" , pies
FinAlgoritmo
Copiar captura de resultados con diferentes valores
1 Resultado
*** Ejecución Iniciada. ***
CARLOS PRIETO----------VERIFICAR LTDA NIT 5626543-0
Por favor ingresa el valor en Centimetros
>5
El resultado en yardas es0.0546806649
El resultado en pies es0.164095832
*** Ejecución Finalizada. ***
2 Resultado
*** Ejecución Iniciada. ***
CARLOS PRIETO----------VERIFICAR LTDA NIT 5626543-0
Por favor ingresa el valor en Centimetros
> 25
El resultado en yardas es0.2734033246
El resultado en pies es0.8204791598
*** Ejecución Finalizada. ***
3 Resultado
*** Ejecución Iniciada. ***
CARLOS PRIETO----------VERIFICAR LTDA NIT 5626543-0
Por favor ingresa el valor en Centimetros
> 100
El resultado en yardas es1.0936132983
El resultado en pies es3.2819166393
*** Ejecución Finalizada. ***
¿En qué aspectos ha cambiado el análisis de ejercicio desde el diseño inicial
o este ha permanecido consistente?
Respuesta: Ha permanecido consistente
3. Planteamiento del problema a resolver: Uno de sus amigos ha “montado” una fábrica de
confecciones de ropa, por lo pronto está en producción de Pantalones, Camisas y
bufandas y cuneta con 2 trabajadores, los cuales deben en un día tener producción
de los 3 artículos y el pago que se hace al final del día es por cantidad realizada, así:
 Pantalón = $5000
 Camisas = $2500
 Bufandas =$ 800
Su amigo le ha el análisis para la solución del problema que al final del día pida el
ingreso de cada una de las cantidades producidas, para determinar el valor que
debe pagarle a cada empleado.

Que datos no Que datos Tipo Formulas a aplicar Requie Requie


conozco y se no Variables requeridas si se requieren re re
deben solicitar (si conozco, Tipo Variable condici ciclos
se requiere más pero los onal (si (si /
filas por favor puedo / no) no) _
anexarlas) calcular cuales
Cantidad de Valor total Entero CanCamisas CanCamisas*Cami no si
Pantalones por pagar sas=ValorPagar
Cantidad de Entero CanPantalon CanPantalon*Pant
Camisas alon=ValorPagar
Cantidad de Entero CanBufandas CanBufandas*Bufa
Bufandas ndas=ValorPagar
Entero ValorPagar CanPantalon*Pant
alon+CanCamisas*
Camisas+CanBufa
ndas*Bufandas=V
alorPagar

Copiar el seudocódigo (no la imagen)


Algoritmo VALOR_A_PAGAR_A_CADA_EMPLEADO
// SE CALCULARA EL TOTAL A PAGAR A CADA EMPLEADO
DEPENDIENDO DEL PRODUCIDO EN LAS DIFERENTES AREAS
Escribir "CARLOS PRIETO----------VERIFICAR LTDA NIT 5626543-0"
Definir
Pantalon,Camisas,Bufandas,CanPantalon,CanCamisas,CanBufandas,ValorP
agar Como Entero
Pantalon <- 5000
Camisas <- 2500
Bufandas <- 800
Escribir 'Por favor ingrese la cantidad de Pantalones'
Leer CanPantalon
Escribir 'Por favor ingrese la cantidad de Camisas'
Leer CanCamisas
Escribir 'Por favor ingrese la cantidad de bufandas'
Leer CanBufandas
ValorPagar <-
CanPantalon*Pantalon+CanCamisas*Camisas+CanBufandas*Bufandas
Escribir 'El valor a Pagar es',ValorPagar
FinAlgoritmo

Copiar captura de resultados con diferentes valores


1 Resultado
*** Ejecución Iniciada. ***
CARLOS PRIETO----------VERIFICAR LTDA NIT 5626543-0
Por favor ingrese la cantidad de Pantalones
> 25
Por favor ingrese la cantidad de Camisas
> 36
Por favor ingrese la cantidad de bufandas
> 85
El valor a Pagar es283000
*** Ejecución Finalizada. ***
2 Resultado
*** Ejecución Iniciada. ***
CARLOS PRIETO----------VERIFICAR LTDA NIT 5626543-0
Por favor ingrese la cantidad de Pantalones
> 125
Por favor ingrese la cantidad de Camisas
> 658
Por favor ingrese la cantidad de bufandas
> 145
El valor a Pagar es2386000
*** Ejecución Finalizada. ***
3 Resultado
*** Ejecución Iniciada. ***
CARLOS PRIETO----------VERIFICAR LTDA NIT 5626543-0
Por favor ingrese la cantidad de Pantalones
> 526
Por favor ingrese la cantidad de Camisas
> 458
Por favor ingrese la cantidad de bufandas
> 320
El valor a Pagar es4031000
*** Ejecución Finalizada. ***
¿En qué aspectos ha cambiado el análisis de ejercicio desde el
diseño inicial o este ha permanecido consistente?
Respuesta: Ha permanecido consistente
4. Planteamiento del problema a resolver: Usted va a adquirir un disco duro para su
computador y el vendedor le ofrece tamaños de disco duro expresados en Terabit.
Para lo cual usted realiza análisis del problema que le permite convertir ese valor
en Megabyte y en Gigabyte.

Que datos no Que datos no Tipo Formulas a Requier Requier


conozco y se deben conozco, pero Variables aplicar si se e e ciclos
solicitar (si se los puedo requeridas requieren condicio (si / no)
requiere más filas calcular Tipo Variable nal (si / _ cuales
por favor anexarlas) no)
Tamaño del disco en Megabyte Real Tb Tb*EquiMega no si
Terabit
Gigabyte Real Gigabyte Tb*EquiGiga
Megabyte
EquiGiga
EquiMega

Copiar el seudocódigo (no la imagen)


Algoritmo CALCULAR_TERABITS_EN_GIGABYTES_Y_MEGABYTES
Escribir "CARLOS PRIETO----------VERIFICAR LTDA NIT 5626543-0"
Definir Tb , Gigabytes , Megabytes , EquiGiga , EquiMega Como Real
EquiGiga=137.43895
EquiMega=137438.9534

Escribir "Por favor ingresa el valor en Terabits"


Leer Tb
Megabytes <- Tb*EquiMega
Escribir "El tamaño en Megabytes es de" , Megabytes
Gigabytes <- Tb*EquiGiga
Escribir "El tamaño en Gigabytes es de" , Gigabytes
FinAlgoritmo
Copiar captura de resultados con diferentes valores
1 Resultado
*** Ejecución Iniciada. ***
CARLOS PRIETO----------VERIFICAR LTDA NIT 5626543-0
Por favor ingresa el valor en Terabits
>1
El tamaño en Megabytes es de137438.9534
El tamaño en Gigabytes es de116.41532
*** Ejecución Finalizada. ***
2 Resultado
*** Ejecución Iniciada. ***
CARLOS PRIETO----------VERIFICAR LTDA NIT 5626543-0
Por favor ingresa el valor en Terabits
> 10
El tamaño en Megabytes es de1374389.534
El tamaño en Gigabytes es de1164.1532
*** Ejecución Finalizada. ***
3 Resultado
*** Ejecución Iniciada. ***
CARLOS PRIETO----------VERIFICAR LTDA NIT 5626543-0
Por favor ingresa el valor en Terabits
> 125
El tamaño en Megabytes es de17179869.175000001
El tamaño en Gigabytes es de14551.915
*** Ejecución Finalizada. ***
¿En qué aspectos ha cambiado el análisis de ejercicio desde el
diseño inicial o este ha permanecido consistente?
Respuesta: Ha permanecido consistente
5. Planteamiento del problema a resolver: Le han solicitado que diseñe un algoritmo que
permita determinar si una persona ya puede tener su cedula de ciudanía o si aún no
tiene la edad necesaria.

Antes de salir debe mostrar su nombre y el de su empresa(ficticia)

Que datos no Que datos no Tipo Formulas a Requiere Requiere


conozco y se conozco, Variables requeridas aplicar si se condicio ciclos (si /
deben solicitar (si pero los Tipo Variable requieren nal (si / no) _
se requiere más puedo no) cuales
filas por favor calcular
anexarlas)
Edad de la Si ya puede Entero Edad Edad>17:SI” si no
Persona Tener la Puede tener
Cedula cedula”, NO”
No puede tener
cedula”

Copiar el seudocódigo (no la imagen)


Algoritmo PLANTEAMIENTO_5
// PROGRAMA QUE PERMITE DETERMINAR SI UNA PERSONA YA TIENE
LA EDAD NECESARIA PARA TENER SU CEDULA
Escribir "CARLOS PRIETO----------VERIFICAR LTDA NIT 5626543-0"
Escribir
"________________________________________________________"
Escribir ""
Definir EDAD Como Entero
Escribir "Por favor ingrese su edad"
Leer EDAD
Escribir
"_______________________________________________________"
Escribir ""
Si EDAD>17 Entonces
Escribir "Cumples con la edad, continua el proceso para sacar la
cedula :)"
SiNo
Escribir "No tienes la edad para sacar la cedula :("
FinSi
FinAlgoritmo

Copiar captura de resultados con diferentes valores


1 Resultado
*** Ejecución Iniciada. ***
CARLOS PRIETO----------VERIFICAR LTDA NIT 5626543-0
________________________________________________________

Por favor ingrese su edad


> 18
_______________________________________________________

Cumples con la edad, continua el proceso para sacar la ce


dula :)
*** Ejecución Finalizada. ***
2 Resultado
*** Ejecución Iniciada. ***
CARLOS PRIETO----------VERIFICAR LTDA NIT 5626543-0
________________________________________________________
Por favor ingrese su edad
> 17
_______________________________________________________

No tienes la edad para sacar la cedula :(


*** Ejecución Finalizada. ***
3 Resultado
*** Ejecución Iniciada. ***
CARLOS PRIETO----------VERIFICAR LTDA NIT 5626543-0
________________________________________________________

Por favor ingrese su edad


> 85
_______________________________________________________

Cumples con la edad, continua el proceso para sacar la ce


dula :)
*** Ejecución Finalizada. ***

¿En qué aspectos ha cambiado el análisis de ejercicio desde el


diseño inicial o este ha permanecido consistente?
Respuesta: Pues si es con respecto al desarrollo del algoritmo, para este
problema, se implementó un condicional para darle solución.
6. Planteamiento del problema a resolver: Se debe diseñar un algoritmo para determinar
si una persona es apta para prestar el servicio militar, bajo las condiciones: debe
ser de nacionalidad colombiana, mayor de edad, de género masculino, soltero y
además debe tener hermanos.

Antes de salir debe mostrar su nombre y el de su empresa(ficticia)

Que datos no Que datos no Tipo Formulas a Requier Requier


conozco y se conozco, Variables requeridas aplicar si se e e ciclos
deben pero los Tipo Variable requieren condicio (si / no)
solicitar (si puedo nal (si / _ cuales
se requiere calcular no)
más filas por
favor
anexarlas)
Edad Si es apto Entero MaEda (Edad) Si (MaEda>17) y si no
para prestar (NacCol="colombi
el servicio ano") y
(GeMa="m") y
(Solt="soltero") y
(Her="si")
Nacionalidad Carácter NacCol
(Nacionalidad)
Tipo de Carácter GeMa
Genero (Genero)
Estado Civil Carácter Solt (Estado
Civil)
¿Si tiene Carácter Her
Hermanos? (Hermanos)

Copiar el seudocódigo (no la imagen)


Algoritmo PLANTEAMIENTO_6
//PROGRAMA QUE PERMITE DETERMINAR SI UNA PERSONA ES APTA
PARA PRESTAR EL SERVICIO MILITAR
Definir NacCol , GeMa , Solt , Her Como Caracter
Definir MaEda como entero
Escribir "CARLOS PRIETO----------VERIFICAR LTDA NIT 5626543-0"
Escribir
"________________________________________________________"
Escribir "Por Favor responda las siguientes preguntas con letra
minuscula, sin puntos, ni caracteres especiales y como se le indica en la
pregunta"
Escribir ""
Escribir "Por Favor ingrese su Edad"
Leer MaEda
Escribir ""
Escribir "Por Favor ingrese su tipo de Nacionalidad"
Leer NacCol
Escribir ""
Escribir "Por Favor ingrese su tipo de genero (m/f)"
Leer GeMa
Escribir ""
Escribir "Por Favor ingrese su estado civil"
Leer Solt
Escribir ""
Escribir "Por favor responda Usted Tiene Hermanos si o no"
Leer Her
Escribir ""
Si (MaEda>17 ) y (NacCol="colombiano") y (GeMa="m") y
(Solt="soltero") y (Her="si") Entonces
Escribir "ES APTO PARA PRESTAR EL SERVICIO MILITAR"
SiNo
Escribir "NO ES APTO PARA PRESTAR EL SERVICIO MILITAR"
FinSi
FinAlgoritmo

Copiar captura de resultados con diferentes valores


1 Resultado
*** Ejecución Iniciada. ***
CARLOS PRIETO----------VERIFICAR LTDA NIT 5626543-0
________________________________________________________
Por Favor responda las siguientes preguntas con letra minuscula, sin puntos,
ni caracteres especiales y como se le indica en la pregunta

Por Favor ingrese su Edad


> 17

Por Favor ingrese su tipo de Nacionalidad


> colombiano

Por Favor ingrese su tipo de genero (m/f)


>m

Por Favor ingrese su estado civil


> soltero

Por favor responda Usted Tiene Hermanos si o no


> si
NO ES APTO PARA PRESTAR EL SERVICIO MILITAR
*** Ejecución Finalizada. ***
2 Resultado
*** Ejecución Iniciada. ***
CARLOS PRIETO----------VERIFICAR LTDA NIT 5626543-0
________________________________________________________
Por Favor responda las siguientes preguntas con letra minuscula, sin puntos,
ni caracteres especiales y como se le indica en la pregunta

Por Favor ingrese su Edad


> 18

Por Favor ingrese su tipo de Nacionalidad


> colombiano

Por Favor ingrese su tipo de genero (m/f)


>m

Por Favor ingrese su estado civil


> soltero

Por favor responda Usted Tiene Hermanos si o no


> si

ES APTO PARA PRESTAR EL SERVICIO MILITAR


*** Ejecución Finalizada. ***
3 Resultado
*** Ejecución Iniciada. ***
CARLOS PRIETO----------VERIFICAR LTDA NIT 5626543-0
________________________________________________________
Por Favor responda las siguientes preguntas con letra minuscula, sin puntos,
ni caracteres especi
ales y como se le indica en la pregunta

Por Favor ingrese su Edad


> 18

Por Favor ingrese su tipo de Nacionalidad


> colombiano

Por Favor ingrese su tipo de genero (m/f)


>f

Por Favor ingrese su estado civil


> soltero

Por favor responda Usted Tiene Hermanos si o no


> si

NO ES APTO PARA PRESTAR EL SERVICIO MILITAR


*** Ejecución Finalizada. ***
¿En qué aspectos ha cambiado el análisis de ejercicio desde el
diseño inicial o este ha permanecido consistente?
Respuesta: Pues si es con respecto al desarrollo del algoritmo, para este
problema, se implementó un condicional para darle solución y se evaluaron
diferentes condiciones que debía cumplir para obtener un resultado
favorable.
7. Planteamiento del problema a resolver: Se les han pedido que diseñe un
algoritmo que de dé una proyección positiva de su futuro inmediato de
acuerdo con su signo zodiacal.

Antes de salir debe mostrar su nombre y el de su empresa(ficticia)

Que datos no Que datos Tipo Formulas a Requier Requiere


conozco y se no Variables aplicar si se e ciclos (si
deben solicitar conozco, requeridas requieren condicio / no) _
(si se requiere pero los Tipo Variab nal (si / cuales
más filas por puedo le no)
favor anexarlas) calcular
Dia Nacimiento Signo Numero Dia Si (Dia>=21 Si Si
Zodiacal y Mes=3) o
(Dia<=20 y
Mes=4)
Mes Nacimiento Numero Mes

Copiar el seudocódigo (no la imagen)


Algoritmo PLANTEAMIENTO_7
Definir Dia , Mes como numero
Escribir "CARLOS PRIETO----------VERIFICAR LTDA NIT 5626543-0"
Escribir ""
Escribir "DESEA CONOCER UNA PROYECCION POSITIVA DE SU
FUTURO"
Escribir ""
Escribir "Ingresa tu Dia de nacimiento "
Leer Dia
Escribir "Ingresa tu mes de nacimiento en numeros"
Leer Mes
Si (Dia>=21 y Mes=3) o (Dia<=20 y Mes=4) Entonces
Escribir "Aries"
Escribir"La vida tiende a ser positiva si se lo permites."
FinSi
Si (Dia>=21 y Mes=4) o (Dia<=20 y Mes=5) Entonces
Escribir "Tauro"
Escribir"Esperar duele, pero recoger los frutos de tu siembra es
un gozo."
FinSi
Si (Dia>=21 y Mes=5) o (Dia<=21 y Mes=6) Entonces
Escribir "Geminis"
Escribir"La clave del éxito reside en las decisiones."
FinSi
Si (Dia>=22 y Mes=6) o (Dia<=22 y Mes=7) Entonces
Escribir "Cancer"
Escribir"Cualquier sueño es plausible si eres lo suficientemente
tenaz como para luchar por él."
FinSi
Si (Dia>=23 y Mes=7) o (Dia<=23 y Mes=8) Entonces
Escribir "Leo"
Escribir"Si está en tu mente, puedes convertirlo en real."
FinSi
Si (Dia>=24 y Mes=8) o (Dia<=23 y Mes=9) Entonces
Escribir "Virgo"
Escribir"Si la vida te da limones, haz limonada."
FinSi
Si (Dia>=24 y Mes=9) o (Dia<=22 y Mes=10) Entonces
Escribir "Libra"
Escribir"La paz interior surge cuando uno aprende a amarse a sí
mismo."
FinSi
Si (Dia>=23 y Mes=10) o (Dia<=22 y Mes=11) Entonces
Escribir "Escorpio"
Escribir"Inténtalo de nuevo, inténtalo mejor. Fracasa de nuevo,
fracasa mejor."
FinSi
Si (Dia>=23 y Mes=11) o (Dia<=21 y Mes=12) Entonces
Escribir "Sagitario"
Escribir"El día puede ser bueno o malo, eso depende de tu
conducta."
FinSi
Si (Dia>=22 y Mes=12) o (Dia<=19 y Mes=1) Entonces
Escribir "Capricornio"
Escribir"Levantarse cada día es como volver a nacer, una nueva
oportunidad."
FinSi
Si (Dia>=20 y Mes=1) o (Dia<=19 y Mes=2) Entonces
Escribir "Acuario"
Escribir"La alegría suele entrar por esa puerta que se te había
olvidado cerrar."
FinSi
Si (Dia>=20 y Mes=2) o (Dia<=20 y Mes=3) Entonces
Escribir "Piscis"
Escribir"La fuerza de voluntad es mucho más poderosa que
cualquier estímulo externo."
FinSi
FinAlgoritmo
Copiar captura de resultados con diferentes valores
1 Resultado
*** Ejecución Iniciada. ***
CARLOS PRIETO----------VERIFICAR LTDA NIT 5626543-0

DESEA CONOCER UNA PROYECCION POSITIVA DE SU FUTURO

Ingresa tu Dia de nacimiento


>4
Ingresa tu mes de nacimiento en numeros
> 12
Sagitario
El día puede ser bueno o malo, eso depende de tu conducta
.
*** Ejecución Finalizada. ***
2 Resultado
*** Ejecución Iniciada. ***
CARLOS PRIETO----------VERIFICAR LTDA NIT 5626543-0

DESEA CONOCER UNA PROYECCION POSITIVA DE SU FUTURO

Ingresa tu Dia de nacimiento


> 15
Ingresa tu mes de nacimiento en numeros
> 09
Virgo
Si la vida te da limones, haz limonada.
*** Ejecución Finalizada. ***
3 Resultado
CARLOS PRIETO----------VERIFICAR LTDA NIT 5626543-0

DESEA CONOCER UNA PROYECCION POSITIVA DE SU FUTURO

Ingresa tu Dia de nacimiento


> 31
Ingresa tu mes de nacimiento en numeros
> 03
Aries
La vida tiende a ser positiva si se lo permites.
*** Ejecución Finalizada. **

¿En qué aspectos ha cambiado el análisis de ejercicio desde el


diseño inicial o este ha permanecido consistente?
Respuesta: En este caso particular cambiamos de implementar 1 condicional
a implementar 12 condicionales, es decir, 1 por signo para lograr que el
resultado sea el esperado.
8. Planteamiento del problema a resolver: Se ha solicitado que Construya un algoritmo
que permita determinar el promedio de las edades de 50 personas, solo si estas
son mayores de edad, en caso de no ser mayor de edad, se debe indicar cuantos no
cumplen con esa condición, además del promedio de peso de todo el grupo.

Antes de salir debe mostrar su nombre y el de su empresa(ficticia)

Que datos no Que datos Tipo Formulas a Requier Requiere


conozco y se no conozco, Variables requeridas aplicar si se e ciclos (si /
deben solicitar (si pero los Tipo Variable requieren condicio no) _ cuales
se requiere más puedo nal (si /
filas por favor calcular no)
anexarlas)
Edad Personas Peso PromPeso = si si
Mayores PesoT / 50
Peso Peso Edad PromEdad<-
Promedio Acum/Acum1
Promedio Acum <-
Acum + Edad
PesoT
Personas

Copiar el seudocódigo (no la imagen)


Algoritmo Planteamiento_8
// PROGRAMA QUE PERMITE DETERMINAR EL PROMEDIO DE LAS
EDADES DE 50 PERSONAS SOLO SI SON MAYORES
//INDICAR CUANTAS PERSONAS NO CUMPLEN CON LA EDAD
//DETERMINAR EL PROMEDIO DEL PESO DE TODO EL GRUPO
Escribir "CARLOS PRIETO----------VERIFICAR LTDA NIT 5626543-0"
Escribir
"________________________________________________________"
Escribir ""
Definir Peso, Edad, Personas, PesoT, PromPeso, MayorEdad, Menores,
PromEdad, Acum, Acum1 como numero
MayorEdad<-0
PesoT<-0
Acum<-0
Acum1<-0

Para Personas<-1 Hasta 50 Con Paso 1 Hacer


Escribir "Por Favor Ingrese la edad"
Leer Edad
Escribir "Por Favor Ingrese el peso"
Leer Peso

Si Edad >=18 Entonces


MayorEdad = MayorEdad+1
SiNo
Si Edad <=17 Entonces
Menores = Menores+1
FinSi

FinSi

Si Peso >=0 Entonces


PesoT = PesoT + Peso
SiNo
Escribir "Por Favor digite un peso mayor a 0"
FinSi
Acum1=MayorEdad

Si Edad >=18 Entonces


Acum <- Acum + Edad
FinSi

Si Edad >=18 Entonces


PromEdad<-Acum/Acum1
FinSi

PromPeso = PesoT / 50

FinPara

Escribir "Cantidad de mayores de edad: ", MayorEdad


Escribir "Cantidad de Personas que no cumplen: ", Menores
Escribir "El promedio de peso de las personas es de: ", PromPeso
Escribir "El promedio de edad de las personas mayores de edad es de:
", PromEdad

Copiar captura de resultados con diferentes valores


NOTA: Apreciada tutora el resultado lo implemente con 4 intervalos, para
hacerlo tan extenso porque en realidad debería ser con 50, pero el
seudocódigo si quedo funcionando con 50.
1 Resultado
*** Ejecución Iniciada. ***
CARLOS PRIETO----------VERIFICAR LTDA NIT 5626543-0
________________________________________________________

Por Favor Ingrese la edad


> 17
Por Favor Ingrese el peso
> 45
Por Favor Ingrese la edad
> 18
Por Favor Ingrese el peso
> 65
Por Favor Ingrese la edad
> 19
Por Favor Ingrese el peso
> 36
Por Favor Ingrese la edad
> 15
Por Favor Ingrese el peso
> 48
Cantidad de mayores de edad: 2
Cantidad de Personas que no cumplen: 2
El promedio de peso de las personas es de: 48.5
El promedio de edad de las personas mayores de edad es de
: 18.5
*** Ejecución Finalizada. ***
2 Resultado
*** Ejecución Iniciada. ***
CARLOS PRIETO----------VERIFICAR LTDA NIT 5626543-0
________________________________________________________

Por Favor Ingrese la edad


> 16
Por Favor Ingrese el peso
> 45
Por Favor Ingrese la edad
> 15
Por Favor Ingrese el peso
> 78
Por Favor Ingrese la edad
> 19
Por Favor Ingrese el peso
> 36
Por Favor Ingrese la edad
> 13
Por Favor Ingrese el peso
> 45
Cantidad de mayores de edad: 1
Cantidad de Personas que no cumplen: 3
El promedio de peso de las personas es de: 51
El promedio de edad de las personas mayores de edad es de
: 19
*** Ejecución Finalizada. ***
3 Resultado
*** Ejecución Iniciada. ***
CARLOS PRIETO----------VERIFICAR LTDA NIT 5626543-0
________________________________________________________

Por Favor Ingrese la edad


> 18
Por Favor Ingrese el peso
> 45
Por Favor Ingrese la edad
> 19
Por Favor Ingrese el peso
> 65
Por Favor Ingrese la edad
> 20
Por Favor Ingrese el peso
> 36
Por Favor Ingrese la edad
> 21
Por Favor Ingrese el peso
> 96
Cantidad de mayores de edad: 4
Cantidad de Personas que no cumplen: 0
El promedio de peso de las personas es de: 60.5
El promedio de edad de las personas mayores de edad es de
: 19.5
*** Ejecución Finalizada. ***
¿En qué aspectos ha cambiado el análisis de ejercicio desde el diseño inicial
o este ha permanecido consistente?
Respuesta: En mi opinión en este ejercicio me toco jugar un poco con las
fórmulas para lograr el resultado que esperaba
9. Planteamiento del problema a resolver: Se debe Construir un algoritmo que permita
realizar una encuesta a N personas, de los cuales se pretende identificar lo
siguiente:
a- Estrato social al que pertenece (1 a 6), no se deben permitir otro
b- Salario mensual, no se aceptan salarios negativos
c- Tipo de trabajo (1- sin trabajo, 2- independiente, 3- empleado público, 4 –
empleo privado), no se admite otra opción
El programa garantiza que los datos ingresados sean correctos y al final debe reportar
lo siguiente:
1. Cantidad de persona encuestadas
2. Cantidad de persona por estrato
3. Promedio del salario de las personas encuestadas
4. Cuál es el tipo de trabajo predominante.

Antes de salir debe mostrar su nombre y el de su empresa(ficticia)

Que datos no Que datos no Tipo Formulas a aplicar si se Req Req


conozco y se conozco, pero Variables requeridas requieren uier uier
deben solicitar los puedo Tipo Variable e e
(si se requiere calcular con cicl
más filas por dici os
favor ona (si
anexarlas) l (si /
/ no)
no) _
cual
es
Estrato social Cantidad de Entero Estrato Si(EstratoSocial>6; si si
personas entonces: “No puede
encuestadas continuar”)
Salario Cantidad de Entero Salario Si(EstratoSocial<1;
mensual personas por entonces: “No puede
estrato continuar”)
Tipo de trabajo Promedio de Entero TipoTra Contador =Contador +
salario Cantidad
Tipo de trabajo Entero Cantidad Acumulador=Acumulador
predominante +Salario
Entero Estra1,2,3.. Promedio=Acumulador /
6 Contador
Entero Promedio Promedio = (Acumulador
/ Contador)
Caracter Trabajo

Copiar el seudocódigo (no la imagen)


Algoritmo Planteamiento_9
// PROGRAMA QUE PERMITE DETERMINAR SI UNA PERSONA YA TIENE
LA EDAD NECESARIA PARA TENER SU CEDULA
Escribir "CARLOS PRIETO----------VERIFICAR LTDA NIT 5626543-0"
Escribir
"________________________________________________________"
Escribir ""
Definir Salario, Cantidad, Estrato, Trabajo, Promedio Como Real
Definir Estra1, Estra2, Estra3, Estra4, Estra5, Estra6, Contador Como
Entero
Definir TipoTra1, TipoTra2, TipoTra3, TipoTra4, Acumulador Como
Entero

Salario<-0
Cantidad<-0
Estra1<-0
Estra2<-0
Estra3<-0
Estra4<-0
Estra5<-0
Estra6<-0
Contador<-0
TipoTra1<-0
TipoTra2<-0
TipoTra3<-0
TipoTra4<-0
Acumulador<-0

Escribir"Por Favor ingrese Cuantas personas realizaran la encuesta"


Leer Cantidad
Contador = Contador + Cantidad
Para Cantidad<-1 Hasta Cantidad Con Paso 1 Hacer
Escribir "Ha iniciado la encuesta"
Escribir "Por Favor ingresa tu estrato social: Tener en cuenta
que el estrato es del 1 a 6"
Leer Estrato
Escribir "Por Favor ingrese su salario:"
Leer Salario
Escribir "Por Favor ingrese su tipo de trabajo tenga en cuenta
las opciones: (1)Sin trabajo (2)Independiente (3)Empleado Publico
(4)Empleado Privado"
Leer Trabajo
Si Estrato=1 Entonces
Estra1=Estra1+1
SiNo
Si Estrato=2 Entonces
Estra2=Estra2+1
SiNo
Si Estrato=3 Entonces
Estra3=Estra3+1
SiNo
Si Estrato=4 Entonces
Estra4=Estra4+1
SiNo
Si Estrato=5 Entonces
Estra5=Estra5+1
SiNo
Si Estrato=6 Entonces
Estra6=Estra6+1
SiNo
Escribir "Por Favor digite el
estrato de 1 a 6."
FinSi
FinSi
FinSi
FinSi
FinSi
FinSi
Si Salario<>0 Entonces
Acumulador=Acumulador+Salario
SiNo
Escribir "Por Favor ingrese el salario nuevamente. No debe
ser menor a 0."
FinSi
Promedio = Acumulador / Contador
Si Trabajo=1 Entonces
TipoTra1=TipoTra1+1
SiNo
Si Trabajo=2 Entonces
TipoTra2=TipoTra2+1
SiNo
Si Trabajo=3 Entonces
TipoTra3=TipoTra3+1
SiNo
Si Trabajo=4 Entonces
TipoTra4=TipoTra4+1
SiNo
Escribir "Por Favor seleccione una de
estas opciones: (1)Sin trabajo (2)Independiente (3)Empleado Publico
(4)Empleado Privado"
FinSi
FinSi
FinSi
FinSi
Si TipoTra1>TipoTra2 y TipoTra1>TipoTra3 Entonces
Escribir "Tipo de trabajo predominante"
Escribir " SIN TRABAJO"
SiNo
Si TipoTra2>TipoTra3 y TipoTra2>TipoTra4 Entonces
Escribir "Tipo de trabajo predominante"
Escribir "INDEPENDIENTE"
SiNo
Si TipoTra3>TipoTra4 Entonces
Escribir "Tipo de trabajo predominante"
Escribir "EMPLEADO PUBLICO"
SiNo
Escribir "Tipo de trabajo predominante"
Escribir "EMPLEADO PRIVADO"
FinSi
FinSi
FinSi
FinPara
Escribir "Cantidad de personas que participaron en la encuesta",
Contador
Escribir "Cantidad de personas por estrato"
Escribir "Estrato (1)", Estra1
Escribir "Estrato (2)", Estra2
Escribir "Estrato (3)", Estra3
Escribir "Estrato (4)", Estra4
Escribir "Estrato (5)", Estra5
Escribir "Estrato (6)", Estra6

Promedio = (Acumulador / Contador)


Escribir "Promedio del salario de las personas encuestadas: $",
Promedio
FinAlgoritmo

Copiar captura de resultados con diferentes valores


1 Resultado
*** Ejecución Iniciada. ***
CARLOS PRIETO----------VERIFICAR LTDA NIT 5626543-0
________________________________________________________

Por Favor ingrese Cuantas personas realizaran la encuesta


>1
Ha iniciado la encuesta
Por Favor ingresa tu estrato social: Tener en cuenta que el estrato es del 1
a6
>2
Por Favor ingrese su salario:
> 737000
Por Favor ingrese su tipo de trabajo tenga en cuenta las opciones: (1)Sin
trabajo (2)Independiente (3)Emple
ado Publico (4)Empleado Privado
>2
Tipo de trabajo predominante
INDEPENDIENTE
Cantidad de personas que participaron en la encuesta1
Cantidad de personas por estrato
Estrato (1)0
Estrato (2)1
Estrato (3)0
Estrato (4)0
Estrato (5)0
Estrato (6)0
Promedio del salario de las personas encuestadas: $737000
*** Ejecución Finalizada. ***
2 Resultado
*** Ejecución Iniciada. ***
CARLOS PRIETO----------VERIFICAR LTDA NIT 5626543-0
________________________________________________________
Por Favor ingrese Cuantas personas realizaran la encuesta
>2
Ha iniciado la encuesta
Por Favor ingresa tu estrato social: Tener en cuenta que el estrato es del 1
a6
>2
Por Favor ingrese su salario:
> 500000
Por Favor ingrese su tipo de trabajo tenga en cuenta las opciones: (1)Sin
trabajo (2)Independiente (3)Emple
ado Publico (4)Empleado Privado
>3
Tipo de trabajo predominante
EMPLEADO PUBLICO
Ha iniciado la encuesta
Por Favor ingresa tu estrato social: Tener en cuenta que el estrato es del 1
a6
>4
Por Favor ingrese su salario:
> 800000
Por Favor ingrese su tipo de trabajo tenga en cuenta las opciones: (1)Sin
trabajo (2)Independiente (3)Emple
ado Publico (4)Empleado Privado
>4
Tipo de trabajo predominante
EMPLEADO PRIVADO
Cantidad de personas que participaron en la encuesta2
Cantidad de personas por estrato
Estrato (1)0
Estrato (2)1
Estrato (3)0
Estrato (4)1
Estrato (5)0
Estrato (6)0
Promedio del salario de las personas encuestadas: $650000
*** Ejecución Finalizada. ***
3 Resultado
*** Ejecución Iniciada. ***
CARLOS PRIETO----------VERIFICAR LTDA NIT 5626543-0
________________________________________________________

Por Favor ingrese Cuantas personas realizaran la encuesta


>3
Ha iniciado la encuesta
Por Favor ingresa tu estrato social: Tener en cuenta que el estrato es del 1
a6
>2
Por Favor ingrese su salario:
> 5245
Por Favor ingrese su tipo de trabajo tenga en cuenta las opciones: (1)Sin
trabajo (2)Independiente (3)Emple
ado Publico (4)Empleado Privado
>1
Tipo de trabajo predominante
SIN TRABAJO
Ha iniciado la encuesta
Por Favor ingresa tu estrato social: Tener en cuenta que el estrato es del 1
a6
>3
Por Favor ingrese su salario:
> 685458
Por Favor ingrese su tipo de trabajo tenga en cuenta las opciones: (1)Sin
trabajo (2)Independiente (3)Emple
ado Publico (4)Empleado Privado
>2
Tipo de trabajo predominante
INDEPENDIENTE
Ha iniciado la encuesta
Por Favor ingresa tu estrato social: Tener en cuenta que el estrato es del 1
a6
>6
Por Favor ingrese su salario:
> 1458525
Por Favor ingrese su tipo de trabajo tenga en cuenta las opciones: (1)Sin
trabajo (2)Independiente (3)Emple
ado Publico (4)Empleado Privado
>3
Tipo de trabajo predominante
EMPLEADO PUBLICO
Cantidad de personas que participaron en la encuesta3
Cantidad de personas por estrato
Estrato (1)0
Estrato (2)1
Estrato (3)1
Estrato (4)0
Estrato (5)0
Estrato (6)1
Promedio del salario de las personas encuestadas: $716409.3333333334
*** Ejecución Finalizada. ***

¿En qué aspectos ha cambiado el análisis de ejercicio desde el diseño inicial


o este ha permanecido consistente?
Respuesta: En este ejercicio claramente las exigencias fueron mayores en
donde los condicionales y los ciclos juegan un papel muy importante en la
ejecución del algoritmo
Anexo
REVISIÓN DE APORTES

Favor diligencie el siguiente cuestionario y comparta en el foro para la


revisión de los ejercicios propuestos por ellos, por lo menos 1 por compañero

 Nombre de su compañero

 Planteamiento del Problema revisado

 Hace uso adecuado del nombre de la variable // revisar el documento


buenas prácticas de programación, referencia complementaria

 Es posible encontrar una solución diferente y óptima para solucionar


el problema

 Los resultados obtenidos son los esperados o entrega datos errados.

 Observación adicional