Está en la página 1de 3

CURSO: PRINCIPIO DE ALGORITMO LAB 4

ALUMNA: HERRERA ZEVALLOS MICHELLE Código: U18200044

1) Hacer un algoritmo que permita hallar el promedio simple de notas de un alumno sabiendo que
tiene practica1, practica2, parcial, final y proyecto.
2) Escribir un pseudocodigo para hallar el IGV de un producto según su precio.
3) Escribir un pseudocodigo que haga el cambio de moneda de soles a dólares , euros y yenes

FORMULA 1

Proceso promedio simple


Definir practica1, practica2, parcial, final, proyecto, promedio_simple Como Real
Escribir “Digite nota practica 1 ”
Leer practica1
Escribir “Digite nota practica 2 ”
Leer practica2
Escribir “Digite nota parcial ”
Leer parcial
Escribir “Digite nota proyecto ”
Leer proyecto
promedio_simple<-(practica1+practica2+parcial proyecto)/4
Escribir “Promedio simple es: ”,promedio_simple
FinProceso

FORMULA 2

Proceso IGV del producto


Definir precio, igv_del_producto Como Real
Escribir “Digite precio ”
Leer precio
Igv_del_producto<-(precio*18) / 100
Escribir “IGV del producto es: ”, Igv_del_producto
FinProceso

FORMULA 3

Proceso Cambio de Moneda


Definir monto_soles, cambio_dolar, cambio_euro, cambio_yenes Como Real
Escribir “Digite monto en soles”
Leer monto_soles
cambio_dolar<-monto_soles/2.8
Escribir “Cambio en dólar es: ”, cambio_dolar
cambio_euro<-monto_soles/3.5
Escribir “Cambio en euro es: ”, cambio_euro
cambio_yenes<-monto_soles/0.03
Escribir “Cambio en yenes es: ”, cambio_yenes
FinProceso
TAREA

1) Hacer un algoritmo que calcule la edad de una persona ingresando su año de nacimiento.
2) Hacer un algoritmo que calcule el total a pagar si compro x entradas para ver a Perú a la Copa
América. Las entradas tiene un valor de s/45
3) Hacer un algoritmo que calcule cuanto incerto en recargar la tarjeta del Metropolitano sabiendo
que la ruta es de Matellini al Naranjal . La tarifa es de s/2.5 por viaje . Por 7 días
4) Hacer un algoritmo que permita hallar la propina al mes sabiendo que cada día se reciben s/ 5 (de
lunes a viernes
5) Hacer un algoritmo que calcule cuanto tendría que ahorra para comprar un auto de s/10 000 si
ahorro cada día s/250

FORMULA 1

Proceso Calcula edad


Definir año_de_nacimiento, edad Como Real
Escribir “Digite año de nacimiento ”
Leer año_de_nacimiento
Edad<-año_de_nacimiento-2019
Escribir “Tu edad es: ”, edad
Finproceso

FORMULA 2

Proceso entradas
Definir entradas, total_pagar Como Real
Escribir “Digite cantidad de entradas”
Leer entradas
total_pagar<-entradas*45
Escribir “Monto a pagar es: ” , total_pagar
FinProceso

FORMULA 3

Proceso recarga
Definir total_recarga Como Real
total_recarga<-2.5*7
Escribir “El monto a recargado es : ” , total_recarga
Finproceso

FORMULA 4

Proceso ahorro auto


Definir meses, total_ahorrado Como Real
Escribir “Digite meses de propina”
Leer meses
total_ahorrado<-(5*5*4)*meses
Escribir “Monto ahorrado es: ” , total_ahorrado
FinProceso
FORMULA 5

Proceso ahorro auto


Definir dias, total_ahorrado, faltante Como Real
Escribir “Digite los días ahorrado”
Leer dias
total_ahorrado<-dias*250
Escribir “Monto ahorrado es: ” , total_ahorrado
faltante<-10000-total_ahorrado
Escribir “Faltante es: “ , faltante
FinProceso