Está en la página 1de 4

INTRODUCCIÓN A ALGORITMOS

FORMATO ENTREGA DE EJERCICIOS


20182578068 Nombres y Apellidos
Código
Dilan Stivenson Castro Bermudez

Realizar un algoritmo que le permita al usuario calcular la conversión de un valor digitado en


PROBLEMA
Dólares y presentarlo en Pesos Colombianos.

ANALISIS
ENTRADAS

Dólar

PROCESOS
Dólar*3070.65
Mostrar pesos
SALIDA
Mensaje con la conversión de dólar a pesos colombianos

ALGORITMO
Algoritmo Convertir
definir dolar,pesos Como Real;
Escribir "digite la cantidad de dolares";
leer dolar;
pesos<-dolar *3070.65;
Escribir "el valor de: ", dolar," dolares";
Escribir "es igual a: ", pesos , " pesos colombianos";

FinAlgoritmo

Ing. Sonia Alexandra Pinzón Nuñez


INTRODUCCIÓN A ALGORITMOS

20182578068 Nombres y Apellidos Juan


Código
d

Realizar un algoritmo que calcule la tarifa del consumo de energía de un usuario de


PROBLEMA acuerdo a la siguiente tabla de Watios/hora: Consumo Tarifa( 0 a 100 )=15000 (101 a
200)= $30000 (201 a 300)= $60000 más de (301) =$400 pesos cada Watio/hora.

ANALISIS
ENTRADAS

Watios

PROCESOS
Generar condicionales de tarifas a pagar por watios ingresados (si entonces)
Comparar los valores de condicionales y escoger de acuerdo a los valores ingresados
Definir tarifa a pagar
SALIDA
Mensaje con tarifa a pagar
ALGORITMO
Proceso consumo
definir Watios Como Real;
Escribir "digite la cantidad de Watios/hora";
leer Watios;
si Watios<=100 entonces
Escribir "valor tarifa es: 15.000 pesos";
FinSi
si Watios>100 &Watios<=200 entonces
escribir "valor tarifa es: 30.000 pesos";
FinSi
si Watios>200 &Watios<=300 Entonces
Escribir "valor tarifa es: 60.000 pesos ";
FinSi
si Watios>300 entonces

Ing. Sonia Alexandra Pinzón Nuñez


INTRODUCCIÓN A ALGORITMOS
Watios<-Watios*400;
escribir "valor tarifa es:",Watios," pesos ";
FinSi
FinProceso

Ing. Sonia Alexandra Pinzón Nuñez


INTRODUCCIÓN A ALGORITMOS

Ing. Sonia Alexandra Pinzón Nuñez