Está en la página 1de 13

Lab ID: 9.9K1116A216.SNI2.

VTP Modes
Objective
In this lab, you will learn about VLAN Trunking Protocol (VTP) modes and how they are relevant when a
switch is added or replaced on a network.

Lab Topology
The topology diagram below represents the NetMap in the Simulator.
1 1 1
5 9 7 0

ASW1 2 2 DSW1 10 8 CSW1 R1


3 4 3 4 5 6
PC1 5 6 7 8 34 2 1

5 6 7 34 2
3 4 3 4 8 5 6 1
1 1 9 7
5
ASW2 2 2 DSW2 10 8 CSW2 1 0
R2
PC2

Command Summary
Command Description
configure terminal enters global configuration mode from privileged EXEC mode
enable enters privileged EXEC mode
end ends and exits configuration mode
exit exits one level in the menu structure
interface range fastethernet slot/ configures a range of interfaces
starting-port - ending-port
no shutdown enables an interface
show ip interface brief displays a brief summary of interface status and configuration
show running-config displays the active configuration file
show vlan brief displays parameters for all virtual LANs (VLANs); contains the
VLAN name, status, and ports assigned to it
show vlan displays VLAN information
show vtp status displays VTP configuration
vlan vlan-id creates a VLAN
vtp domain domain-name assigns the domain name for VTP
vtp mode [client | server | transparent] configures the VTP mode

1 Boson NetSim Lab Manual


Lab Tasks
Task 1: Determine Network Status
Switch CSW1 has failed, and you are replacing it with a spare switch that has been removed from another
network. In this task, you will determine the state of the network switches.
1. What is the state of the interfaces on each switch on the network? __________________________

2. What is the VTP status of each switch on the network? __________________________________


______________________________________________________________________________

3. You should be able to determine that the FastEthernet and GigabitEthernet interfaces on CSW1
have all been administratively shut down. If you enable the interfaces on CSW1, what will occur to
the configurations on other switches in the network? _____________________________________
______________________________________________________________________________

4. Why does the VTP mode matter when a switch is being added to an existing network? _________

5. Describe the different VTP modes, and explain why they are relevant when a switch is being added
to an existing network. ____________________________________________________________
______________________________________________________________________________

6. What is the VTP revision number on CSW1, and how is it significant? _______________________
______________________________________________________________________________

7. Are all of the switches in the network configured to use the same VTP mode? _________________

8. What is the VTP revision number on ASW1 and ASW2? __________________________________

9. Is the revision number synchronized between switches in the same VTP domain? _____________

10. How many VLANs are configured on the switches on the network? _________________________
Fill in the table below with the number of VLANs on each device.

ASW1 ASW2 DSW1 DSW2 CSW1 CSW2

2 Boson NetSim Lab Manual


Task 2: Optimize Switch Configurations
When you have completed this task, you should be able to add a VLAN to a switch that is centrally located
in the topology and the VLAN should propagate to the other network switches. Because DSW1 is centrally
located, it should be the primary switch where VLAN changes are configured. You should configure the
other switches on the network so that they will receive VLAN updates from DSW1 and so that VLANs
cannot be added locally on the other switches. All switches on the network should have the same VLAN
configuration as that currently configured on DSW1.
1. Which VLANs are configured on DSW1? ______________________________________________

2. Configure DSW1 to become the source of VLAN propagation for the other switches in the network.

3. Now that DSW1 is the switch where VLAN configurations will be performed, which other network
switches require configuration changes in order for the network to be optimized? ______________

4. What is the VTP mode of ASW1 and ASW2? __________________________________________

5. How many VLANs are configured on ASW1 and ASW2? _________________________________

6. If you change the VTP mode on ASW1 and ASW2 to client mode, will ASW1 and ASW2 synchronize
VLAN information with DSW1? _____________________________________________________

7. Configure ASW1 so that it will synchronize VLAN information with DSW1.

8. Configure ASW2 so that it will synchronize VLAN information with DSW1.

9. Verify that ASW1 and ASW2 have the same VLAN configuration as DSW1.

10. Enable the interfaces on CSW1.

11. Did CSW1 synchronize VLAN information with DSW1 or any of the other switches on the network?

12. Configure CSW1 to synchronize VLAN information with DSW1.

13. If you added a VLAN to DSW2, would the VLAN be added to other switches on the network? ____
Would the new VLAN propagate to CSW2? ____________________________________________

14. Configure the appropriate devices so that DSW2 and CSW2 are able to synchronize VLAN
information with DSW1 but VLAN changes are prevented from the console of DSW2 or CSW2.

15. On DSW1, add VLAN 21.

16. Verify that VLAN 21 was added to all other switches on the network.

Once you have completed this lab, be sure to check your work by using the grading function.
You can do so by clicking the Grade Lab icon ( ) in the toolbar or by pressing Ctrl+G.

3 Boson NetSim Lab Manual


Lab Solutions
Task 1: Determine Network Status
1. You should issue the show ip interface brief command on each switch in the network to determine
the state of the interfaces. The following sample output is from CSW1 and CSW2:

CSW1#show ip interface brief


Interface IP-Address OK? Method Status Protocol
Vlan 1 192.168.1.2 YES unset up down
FastEthernet0/1 unassigned YES unset administratively down down
FastEthernet0/2 unassigned YES unset administratively down down
FastEthernet0/3 unassigned YES unset administratively down down
FastEthernet0/4 unassigned YES unset administratively down down
FastEthernet0/5 unassigned YES unset administratively down down
FastEthernet0/6 unassigned YES unset administratively down down
FastEthernet0/7 unassigned YES unset administratively down down
FastEthernet0/8 unassigned YES unset administratively down down
FastEthernet0/9 unassigned YES unset administratively down down
FastEthernet0/10 unassigned YES unset administratively down down
FastEthernet0/11 unassigned YES unset administratively down down
FastEthernet0/12 unassigned YES unset administratively down down
GigabitEthernet0/1 unassigned YES unset down down
GigabitEthernet0/2 unassigned YES unset down down

CSW2#show ip interface brief


Interface IP-Address OK? Method Status Protocol
Vlan 1 192.168.1.13 YES unset up up
FastEthernet0/1 unassigned YES unset up up
FastEthernet0/2 unassigned YES unset down down
FastEthernet0/3 unassigned YES unset down down
FastEthernet0/4 unassigned YES unset down down
FastEthernet0/5 unassigned YES unset up up
FastEthernet0/6 unassigned YES unset up up
FastEthernet0/7 unassigned YES unset up up
FastEthernet0/8 unassigned YES unset up up
FastEthernet0/9 unassigned YES unset down down
FastEthernet0/10 unassigned YES unset down down
FastEthernet0/11 unassigned YES unset down down
FastEthernet0/12 unassigned YES unset down down
GigabitEthernet0/1 unassigned YES unset down down
GigabitEthernet0/2 unassigned YES unset down down

4 Boson NetSim Lab Manual


2. You should issue the following command to determine the VTP status of each switch in the network.
Sample output from CSW1 and CSW2 is below:

CSW1#show vtp status


VTP Version : 2
Configuration Revision : 8
Maximum VLANs supported locally : 64
Number of existing VLANs : 13

VTP Operating Mode : Server


VTP Domain Name : cisco
VTP Pruning Mode : Disabled
VTP V2 Mode : Disabled
VTP Traps Generation : Disabled
MD5 digest : 0xEE 0xB3 0xDC 0x9F 0xE2 0xE0 0x25 0xDF
Configuration last modified by 0.0.0.0 at 3-1-2012 04:55:57
Local updater ID is 0.0.0.0 (no valid interface found)

CSW2#show vtp status


VTP Version : 2
Configuration Revision : 0
Maximum VLANs supported locally : 64
Number of existing VLANs : 5

VTP Operating Mode : Client


VTP Domain Name : cisco
VTP Pruning Mode : Disabled
VTP V2 Mode : Disabled
VTP Traps Generation : Disabled
MD5 digest : 0xEE 0xB3 0xDC 0x9F 0xE2 0xE0 0x25 0xDF
Configuration last modified by 0.0.0.0 at 3-1-2012 04:55:57
Local updater ID is 0.0.0.0 (no valid interface found)

3. If you enable the interfaces on CSW1, CSW2 will synchronize VLAN information with CSW1
because these two switches are configured with the same VTP domain name and password. CSW2
is configured as a VTP client and has a lower VTP revision number than CSW1; therefore, CSW2
will inherit the VLANs configured on CSW1. All other switches in the network are configured with a
different VTP domain name than CSW1, or they are configured to operate in VTP transparent mode
and will not be affected when the interfaces on CSW1 are enabled.

4. VTP mode matters because, when a switch is added to an existing network, VLAN synchronization
can cause configuration changes to other switches on the network. For example, in this lab, enabling
the interfaces on CSW1 would add multiple VLANs to CSW2. However, in another situation, adding
a switch to a network could just as easily remove VLANs. Adding or removing VLANs could have
negative effects on a network.

5 Boson NetSim Lab Manual


5. When VTP is being implemented on a network, at least one switch must be in server mode. Server
mode allows the user to create, modify, or delete any VLAN on VTP clients and VTP servers in the
VTP domain. These changes are then advertised to other switches participating in the same VTP
domain.

Switches that operate in VTP client mode store the same VTP information as switches that operate
in VTP server mode; they receive the advertisements that are sent out by the VTP server. Switches
that are in client mode are prevented from having VLANs added or deleted from the command
prompt. Yet, if a switch in VTP client mode that has a higher revision number than other network
switches (and is configured with the same VTP domain and password) is added to an existing
network, the VLAN configuration will propagate to the other switches in the network regardless of
whether those switches are VTP servers or VTP clients. VTP transparent mode switches would not
be affected by the addition of the switch to the network.

Conversely, switches that operate in VTP transparent mode forward the VTP advertisements they
receive from other switches, but they do not act upon that information. Transparent-mode switches
do not advertise their own VLAN information, nor do they participate in the VLANs advertised by the
other switches. Changes to VLAN configurations on a switch operating in transparent mode only
affect that switch and are not forwarded to other switches in the VTP domain.

6. The VTP revision number on CSW1 is 8. This is significant because CSW1 has a higher revision
number than any other switch in the network. VTP clients and VTP servers will synchronize VLAN
configurations with other network switches that are configured with the same VTP domain name
and VTP password. The switch with the highest revision number will propagate its VLANs and
VTP revision number to the other switches in the same VTP domain. VLAN information on VTP
Client and VTP Server switches in the same VTP domain but with lower revision numbers will be
overwritten. For example, in this scenario, the VLAN information on CSW1 will propagate to CSW2
and will overwrite CSW2’s current VLAN configuration.

7. All of the switches in the network are not configured to use the same VTP mode. ASW1 and ASW2
are configured to use VTP transparent mode. DSW1 and CSW2 are configured to use VTP client
mode. DSW2 and CSW1 are configured to use VTP server mode.

8. The VTP revision number on ASW1 and ASW2 is 0 and will not increment if VLANs are added.
Switches configured to operate in VTP transparent mode always have a revision number of 0; this is
why changing a switch from VTP server mode to VTP transparent mode resets the revision number
on the switch to 0. Additionally, changing the VTP domain name on a switch will reset the VTP
revision number to 0.

9. All switches that are configured with the same VTP domain name and password will synchronize
VTP revision numbers with the switch that has the highest revision number. Transparent switches
always have a revision number of 0.

6 Boson NetSim Lab Manual


10. You should issue the show vlan command or show vlan brief command on all switches on the
network to determine how many VLANs are configured on each of the switches. The following is
sample output from CSW1:

CSW1#show vlan brief

VLAN Name Status Ports


---- -------------------------------- --------- -------------------------------
1 default active Fa0/1, Fa0/2, Fa0/3, Fa0/4
Fa0/5, Fa0/6, Fa0/7, Fa0/8
Fa0/9, Fa0/10, Fa0/11, Fa0/12
Gi0/1, Gi0/2
2 VLAN0002 active
22 VLAN0022 active
33 VLAN0033 active
44 VLAN0044 active
45 VLAN0045 active
54 VLAN0054 active
62 VLAN0062 active
77 VLAN0077 active
<output omitted>

The following table shows how many VLANs are configured on each of the switches on the network:

ASW1 ASW2 DSW1 DSW2 CSW1 CSW2


5 7 4 4 9 1

Task 2: Optimize Switch Configurations


1. The output of the following command shows that VLANs 1, 22, 23, and 24 are configured on DSW1.
The following is sample output:

DSW1#show vlan brief

VLAN Name Status Ports


---- -------------------------------- --------- -------------------------------
1 default active Fa0/9, Fa0/10, Fa0/11, Fa0/12
Gi0/1, Gi0/2
22 VLAN0022 active
23 VLAN0023 active
24 VLAN0024 active
<output omitted>

2. You should issue the following command on DSW1 to configure it to be the source of VLAN
propagation for the other switches in the network:

DSW1(config)#vtp mode server

3. All of the network switches other than DSW1 require configuration changes in order for the network
to be optimized.

7 Boson NetSim Lab Manual


4. ASW1 and ASW2 are configured to operate in VTP transparent mode.

5. ASW1 has five VLANs, and ASW2 has seven VLANs.

6. If you change the VTP mode on ASW2 from transparent mode to client mode, it will synchronize with
DSW1.

Changing ASW1 from transparent mode to client mode will not enable it to synchronize VLAN
information with DSW1, because ASW1 is configured with a different VTP domain name.

The following sample output from DSW1, ASW1, and ASW2 shows that ASW1 and ASW2 have
different VTP domain names and that only ASW2’s VTP domain name matches DSW1’s:

DSW1#show vtp status


VTP Version : 2
Configuration Revision : 3
Maximum VLANs supported locally : 64
Number of existing VLANs : 8

VTP Operating Mode : Server


VTP Domain Name : boson
VTP Pruning Mode : Disabled
VTP V2 Mode : Disabled
VTP Traps Generation : Disabled
MD5 digest : 0xEE 0xB3 0xDC 0x9F 0xE2 0xE0 0x25 0xDF
Configuration last modified by 0.0.0.0 at 3-1-2012 04:55:57
Local updater ID is 0.0.0.0 (no valid interface found)

ASW1#show vtp status


VTP Version : 2
Configuration Revision : 0
Maximum VLANs supported locally : 64
Number of existing VLANs : 9

VTP Operating Mode : Transparent


VTP Domain Name : cisco
VTP Pruning Mode : Disabled
VTP V2 Mode : Disabled
VTP Traps Generation : Disabled
MD5 digest : 0xEE 0xB3 0xDC 0x9F 0xE2 0xE0 0x25 0xDF
Configuration last modified by 0.0.0.0 at 3-1-2012 04:55:57
Local updater ID is 0.0.0.0 (no valid interface found)

ASW2#show vtp status


VTP Version : 2
Configuration Revision : 0
Maximum VLANs supported locally : 64
Number of existing VLANs : 11

VTP Operating Mode : Transparent


VTP Domain Name : boson
VTP Pruning Mode : Disabled
VTP V2 Mode : Disabled
VTP Traps Generation : Disabled
MD5 digest : 0xEE 0xB3 0xDC 0x9F 0xE2 0xE0 0x25 0xDF
Configuration last modified by 0.0.0.0 at 3-1-2012 04:55:57
Local updater ID is 0.0.0.0 (no valid interface found)

8 Boson NetSim Lab Manual


7. You should issue the following commands to configure ASW1 so that it will synchronize VLAN
information with DSW1 as a VTP client:

ASW1(config)#vtp mode client


ASW1(config)#vtp domain boson
Changing VTP domain from cisco to boson

8. You should issue the following command to configure ASW2 so that it will synchronize VLAN
information with DSW1 as a VTP client:

ASW2(config)#vtp mode client

9. You should issue the following command on DSW1, ASW1, and ASW2 to verify that all three devices
have the same VLAN configuration. The following is sample output from all three devices:

DSW1#show vlan brief


VLAN Name Status Ports
---- -------------------------------- --------- -------------------------------
1 default active Fa0/9, Fa0/10, Fa0/11, Fa0/12
Gi0/1, Gi0/2
22 VLAN0022 active
23 VLAN0023 active
24 VLAN0024 active
<output omitted>

ASW1#show vlan brief


VLAN Name Status Ports
---- -------------------------------- --------- -------------------------------
1 default active Fa0/5, Fa0/6, Fa0/7, Fa0/8
Gi0/1
22 VLAN0022 active
23 VLAN0023 active
24 VLAN0024 active
<output omitted>

ASW2#show vlan brief


VLAN Name Status Ports
---- -------------------------------- --------- -------------------------------
1 default active Fa0/5, Fa0/6, Fa0/7, Fa0/8
Gi0/1
22 VLAN0022 active
23 VLAN0023 active
24 VLAN0024 active
<output omitted>

9 Boson NetSim Lab Manual


10. You can set the VTP revision number to 0 on a switch by either changing the domain name or
switching to VTP transparent mode and then to VTP server or client mode. Typically, you would
ensure that CSW1 would not cause changes to the production network by resetting the revision
number to 0. However, in this lab, you will observe the changes that occur when a switch with a
higher revision number is added to an operating network.

You should issue the following commands on CSW1 to enable the interfaces:

CSW1(config)#interface range fastethernet 0/1 - 8


CSW1(config-if-range)#no shutdown

11. After allowing enough time for the network to converge, you can issue the following command on
CSW1 to verify that it did not synchronize VLAN information with DSW1. However, CSW2 now
has the same VLANs as CSW1 because the two switches are now in the same VTP domain. The
following is sample output from all three devices:

CSW1#show vlan brief


VLAN Name Status Ports
---- -------------------------------- --------- -------------------------------
1 default active Fa0/1, Fa0/2, Fa0/9, Fa0/10
Fa0/11, Fa0/12, Gi0/1, Gi0/2
2 VLAN0002 active
22 VLAN0022 active
33 VLAN0033 active
44 VLAN0044 active
45 VLAN0045 active
54 VLAN0054 active
62 VLAN0062 active
77 VLAN0077 active
<output omitted>

DSW1#show vlan brief


VLAN Name Status Ports
---- -------------------------------- --------- -------------------------------
1 default active Fa0/11, Fa0/12, Gi0/1, Gi0/2
22 VLAN0022 active
23 VLAN0023 active
24 VLAN0024 active
<output omitted>

CSW2#show vlan brief


VLAN Name Status Ports
---- -------------------------------- --------- -------------------------------
1 default active Fa0/1, Fa0/2, Fa0/9, Fa0/10
Fa0/11, Fa0/12, Gi0/1, Gi0/2
2 VLAN0002 active
22 VLAN0022 active
33 VLAN0033 active
44 VLAN0044 active
45 VLAN0045 active
54 VLAN0054 active
62 VLAN0062 active
77 VLAN0077 active
<output omitted>

10 Boson NetSim Lab Manual


12. On CSW1, you should issue the following commands so that the switch will synchronize VLAN
information with DSW1:

CSW1(config)#vtp mode client


CSW1(config)#vtp domain boson
VTP domain boson modified

13. If you added a VLAN to DSW2, the VLAN would be added to all of the other switches on the
network, with the exception of CSW2. CSW2 is in a different VTP domain than DSW2. In this lab,
only one switch is to be configured as the VTP server, and that switch should be DSW1, not DSW2.
Therefore, DSW2 still requires a configuration change.

14. You should issue the following commands so that DSW2 and CSW2 are both VTP clients within the
same VTP domain as DSW1. This will enable them to synchronize VLAN information with DSW1 but
will prevent VLAN changes from the console of DSW2 or CSW2.

DSW2(config)#vtp mode client

CSW2(config)#vtp domain boson


VTP domain boson modified

15. On DSW1, you should issue the following command to add VLAN 21:

DSW1(config)#vlan 21
VLAN 21 added:
Name:VLAN0021

16. You should issue the following command to verify that VLAN 21 was added to all other switches on
the network. Sample output from DSW2 is below:

DSW2#show vlan brief


VLAN Name Status Ports
---- -------------------------------- --------- -------------------------------
1 default active Fa0/11, Fa0/12, Gi0/1, Gi0/2
21 VLAN0021 active
22 VLAN0022 active
23 VLAN0023 active
24 VLAN0024 active
<output omitted>

11 Boson NetSim Lab Manual


Sample Configuration Scripts
DSW1 DSW1 (continued)
DSW1#show running-config interface FastEthernet0/7
Building configuration... switchport trunk encapsulation dot1q
Current configuration : 1652 bytes switchport mode trunk
! !
Version 15.b interface FastEthernet0/8
service timestamps debug uptime switchport trunk encapsulation dot1q
service timestamps log uptime switchport mode trunk
no service password-encryption !
! interface FastEthernet0/9
hostname DSW1 switchport trunk encapsulation dot1q
! switchport mode trunk
ip subnet-zero !
! interface FastEthernet0/10
ip cef switchport trunk encapsulation dot1q
no ip domain-lookup switchport mode trunk
spanning-tree mode pvst !
spanning-tree extend system-id interface FastEthernet0/11
! !
interface FastEthernet0/1 interface FastEthernet0/12
switchport trunk encapsulation dot1q !
switchport mode trunk interface GigabitEthernet0/1
! !
interface FastEthernet0/2 interface GigabitEthernet0/2
switchport trunk encapsulation dot1q !
switchport mode trunk interface Vlan 1
! ip address 192.168.1.3 255.255.255.0
interface FastEthernet0/3 no ip route-cache
switchport trunk encapsulation dot1q !
switchport mode trunk vlan 21 name VLAN0021
! vlan 22 name VLAN0022
interface FastEthernet0/4 vlan 23 name VLAN0023
switchport trunk encapsulation dot1q vlan 24 name VLAN0024
switchport mode trunk !
! ip classless
interface FastEthernet0/5 no ip http server
switchport trunk encapsulation dot1q !
switchport mode trunk line con 0
! line aux 0
interface FastEthernet0/6 line vty 0 4
switchport trunk encapsulation dot1q login
switchport mode trunk !
! no scheduler allocate
end

12 Boson NetSim Lab Manual


CSW1 CSW1 (continued)
CSW1#show running-config interface FastEthernet0/7
Building configuration... switchport trunk encapsulation dot1q
Current configuration : 1507 bytes switchport mode trunk
! !
Version 15.b interface FastEthernet0/8
service timestamps debug uptime switchport trunk encapsulation dot1q
service timestamps log uptime switchport mode trunk
no service password-encryption !
! interface FastEthernet0/9
hostname CSW1 shutdown
! !
ip subnet-zero interface FastEthernet0/10
! shutdown
ip cef !
no ip domain-lookup interface FastEthernet0/11
spanning-tree mode pvst shutdown
spanning-tree extend system-id !
! interface FastEthernet0/12
interface FastEthernet0/1 shutdown
! !
interface FastEthernet0/2 interface GigabitEthernet0/1
switchport trunk encapsulation dot1q !
switchport mode trunk interface GigabitEthernet0/2
! !
interface FastEthernet0/3 interface Vlan 1
switchport trunk encapsulation dot1q ip address 192.168.1.2 255.255.255.0
switchport mode trunk no ip route-cache
! !
interface FastEthernet0/4 vlan 21 name VLAN0021
switchport trunk encapsulation dot1q vlan 22 name VLAN0022
switchport mode trunk vlan 23 name VLAN0023
! vlan 24 name VLAN0024
interface FastEthernet0/5 !
switchport trunk encapsulation dot1q ip classless
switchport mode trunk no ip http server
! !
interface FastEthernet0/6 line con 0
switchport trunk encapsulation dot1q line aux 0
switchport mode trunk line vty 0 4
! login
!
no scheduler allocate
end

Copyright © 1996–2017 Boson Software, LLC. All rights reserved. NetSim software and documentation are protected by copyright law.

13 Boson NetSim Lab Manual