Está en la página 1de 10

Lab ID: 9.9K1116A062.SNI2.

VTP
Objective
Learn to configure virtual LANs (VLANs) and VLAN Trunking Protocol (VTP) on Cisco Catalyst 2950
switches. Configure the appropriate settings on Switch1 and Switch2.

Lab Topology
The topology diagram below represents the NetMap in the Simulator.

S0/1
Frame
Fa0/0
Router1 Relay
S0/0

S0/0

Fa0/0
Router2 Router5

S0/0

S0/1 S0/0

Router3 Router4
Fa0/0 Fa0/0

Switch3 Switch1

Switch4 Switch2
Fa0/1 Fa0/2 Fa0/1 Fa0/2

PC2 PC4 PC1 PC3

1 Boson NetSim Lab Manual


Command Summary
Command Description
configure terminal enters global configuration mode from privileged EXEC mode
enable enters privileged EXEC mode
end ends and exits configuration mode
exit exits one level in the menu structure
hostname host-name sets the device name
interface type number changes from global configuration mode to interface
configuration mode
interface range fastethernet slot/ configures a range of interfaces
starting-port - ending-port
ip address ip-address subnet-mask assigns an IP address to an interface
no shutdown enables an interface
ping ip-address sends an Internet Control Message Protocol (ICMP) echo
request to the specified address
show running-config displays the active configuration file
show vlan displays VLAN information
show vtp status displays VTP configuration
switchport access vlan vlan-id assigns the default VLAN for a port
switchport mode {access | dynamic configures the VLAN membership mode of a port
{auto | desirable} | trunk}
switchport trunk encapsulation sets the trunk encapsulation format to 802.1Q
dot1q
vlan vlan-id creates a VLAN
vtp domain domain-name assigns the domain name for VTP
vtp mode [client | server | configures the VTP mode
transparent]
vtp password password assigns the VTP password; switches must be configured with
the same VTP domain and VTP password in order for VTP to
propagate VLAN information between the switches

The IP addresses and subnet masks used in this lab are shown in the table below:

IP Addresses
Device Interface IP Address Subnet Mask
Switch1 VLAN 1 10.1.1.1 255.255.255.0
Switch2 VLAN 1 10.1.1.2 255.255.255.0

2 Boson NetSim Lab Manual


Lab Tasks
Task 1: Configure the Switches
This task involves configuring VLAN 1 on Switch1 and Switch2.
1. Configure Switch1 with the appropriate host name.

2. On Switch1, configure interface VLAN 1 with the appropriate IP address and subnet mask; refer to
the IP Addresses table.

3. Why is it necessary to configure trunking? _____________________________________________


______________________________________________________________________________

4. On Switch1, configure trunking on the FastEthernet 0/12 port.

5. Configure Switch2 with the appropriate host name.

6. On Switch2, configure interface VLAN 1 with the appropriate IP address and subnet mask; refer to
the IP Addresses table.

7. On Switch2, configure trunking on the FastEthernet 0/12 port.

8. From Switch2, ping Switch1 (10.1.1.1). The ping should succeed.

Task 2: Configure VTP and Create VLANs


This task involves configuring and reviewing VTP modes and creating new VLANs.
1. When a Catalyst 2950 switch is powered up with factory settings, what is the default mode? _____

2. On Switch1, configure the VTP domain to boson and configure a VTP password of cisco.

3. Verify Switch1’s VTP configuration. What is the advantage of configuring a single switch on a
network as a VTP server? _________________________________________________________

4. On Switch 1, create VLAN 8 and VLAN 14.

5. On Switch 1, assign FastEthernet ports 0/2 through 0/5 to VLAN 8, and assign FastEthernet ports
0/6 through 0/10 to VLAN 14.

6. On Switch1, verify that the configurations you have made are correct.

3 Boson NetSim Lab Manual


7. On Switch2, view the current VLAN database. Why do the two VLANs configured on Switch1 not
appear on Switch2? ______________________________________________________________
______________________________________________________________________________

8. Configure Switch2 as a VTP client. Change the VTP domain to boson, and configure a VTP
password of cisco.

9. What VTP information will Switch2 store in the VTP database, and how will it receive the
information? ____________________________________________________________________
______________________________________________________________________________

10. Allow 30 seconds for the network to converge, and then verify the Switch2 VTP configuration.

Note: While NetSim sends VTP packets every 30 seconds, you may need to wait up to five minutes
for some switches to send VTP packets.

11. On Switch2, verify that the VLAN database was updated. Switch2 should now show VLAN 8 and
VLAN 14.

Once you have completed this lab, be sure to check your work by using the grading function.
You can do so by clicking the Grade Lab icon ( ) in the toolbar or by pressing Ctrl+G.

4 Boson NetSim Lab Manual


Lab Solutions
Task 1: Configure the Switches
1. Issue the following command to configure Switch1 with the appropriate host name:

Switch(config)#hostname Switch1

2. On Switch1, issue the following commands to configure interface VLAN 1 with the appropriate IP
address and subnet mask:

Switch1(config)#interface vlan 1
Switch1(config-if)#ip address 10.1.1.1 255.255.255.0

3. Trunking is required to carry traffic from multiple VLANs over a single link. To configure a port to
allow interVLAN communication, trunking must be enabled with the same trunking encapsulation
configured on both ends of the link.

A port that is not configured for trunking is called an access port. Access ports carry traffic for a
single VLAN and are typically used to connect a workstation to a switch. To configure a port for
access mode, you must enter interface configuration mode and issue the switchport mode access
command.

There are two trunking encapsulation methods: Inter-Switch Link (ISL) and 802.1Q. ISL is a Cisco-
proprietary trunking encapsulation method and works only when you are configuring trunking
between Cisco devices. The Institute of Electrical and Electronics Engineers (IEEE) 802.1Q
standard can be used to trunk between any two industry-standard switches.

You can issue the switchport trunk encapsulation dot1q command in interface configuration
mode for the FastEthernet 0/12 interfaces on both switches. However, issuing the command is not
necessary, because a Catalyst 2950 switch only supports dot1q encapsulation and this is the default
configuration. To enable trunking on the interfaces, you must issue the switchport mode trunk
command.

4. On Switch1, issue the following commands to configure trunking on the FastEthernet 0/12 port:

Switch1(config-if)#interface fastethernet 0/12


Switch1(config-if)#switchport mode trunk

5. Issue the following command to configure Switch2 with the appropriate host name:

Switch(config)#hostname Switch2

6. On Switch2, issue the following commands to configure interface VLAN 1 with the appropriate IP
address:

Switch2(config)#interface vlan 1
Switch2(config-if)#ip address 10.1.1.2 255.255.255.0

5 Boson NetSim Lab Manual


7. On Switch2, issue the following commands to configure trunking on the FastEthernet 0/12:

Switch2(config-if)#interface fastethernet 0/12


Switch2(config-if)#switchport mode trunk

8. A ping from Switch2 to Switch1 (10.1.1.1) should succeed.

Task 2: Configure VTP and Create VLANs


1. When a Catalyst 2950 switch is powered up with factory settings, the default VTP mode is server
mode. Server mode is required on at least one switch in a network when VTP is being implemented.
Server mode allows the user to create, modify, or delete any VLAN in the VTP domain. These
changes are then advertised to other switches participating in the same VTP domain.

2. On Switch1, issue the following commands to configure the VTP domain to boson and configure a
VTP password of cisco:

Switch1(config)#vtp domain boson


Changing VTP domain from NULL to boson

Switch1(config)#vtp password cisco

3. The advantage of configuring a single switch on a network to be a VTP server is that changes need
to be made on only one switch in VTP server mode in order for the change to propagate throughout
the VTP domain. A switch in VTP server mode can create, modify, and delete VLANs as well as
configure parameters for the VTP domain. VTP server mode enables a switch to create, receive,
and forward VTP advertisements for the VTP domain.

You should issue the following command to verify Switch1’s VTP configuration; sample output is
shown below:

Switch1#show vtp status


VTP Version : 2
Configuration Revision : 0
Maximum VLANs supported locally : 64
Number of existing VLANs : 5

VTP Operating Mode : Server


VTP Domain Name : boson
VTP Pruning Mode : Disabled
VTP V2 Mode : Disabled
VTP Traps Generation : Disabled
MD5 digest : 0xEE 0xB3 0xDC 0x9F 0xE2 0xE0 0x25 0xDF
Configuration last modified by 0.0.0.0 at 3-1-2012 04:55:57
Local updater ID is 0.0.0.0 (no valid interface found)

6 Boson NetSim Lab Manual


4. On Switch1, issue the following commands to create VLAN 8 and VLAN 14:

Switch1(config)#vlan 8
VLAN 8 added:
Name:VLAN0008

Switch1(config-vlan)#vlan 14
VLAN 14 added:
Name:VLAN0014

5. On Switch1, issue the following commands to assign FastEthernet ports 0/2 through 0/5 to VLAN 8
and to assign FastEthernet ports 0/6 through 0/10 to VLAN 14:

Switch1(config-vlan)#interface range fastethernet 0/2 – 5


Switch1(config-if-range)#switchport access vlan 8
Switch1(config-if-range)#interface range fastethernet 0/6 – 10
Switch1(config-if-range)#switchport access vlan 14

6. You should issue the following command on Switch1 to verify that the current configurations are
correct. Sample output is shown below:

Switch1#show vlan

VLAN Name Status Ports


---- ---------------------------- --------- -------------------------------
1 default active Fa0/1, Fa0/11
8 VLAN0008 active Fa0/2, Fa0/3, Fa0/4, Fa0/5
14 VLAN0014 active Fa0/6, Fa0/7, Fa0/8, Fa0/9
Fa0/10

1002 fddi-default active


1003 token-ring-default active
1004 fddinet-default active
1005 trnet-default active

VLAN Type SAID MTU Parent RingNo BridgeNo Stp BrdgMode Trans1 Trans2
---- ----- ------- ----- ------ ------ -------- ---- -------- ------ ------
1 enet 100001 1500 - - - - - 0 0
8 enet 100008 1500 - - - - - 0 0
14 enet 100014 1500 - - - - - 0 0
1002 fddi 101002 1500 - - - - - 0 0
1003 tr 101003 1500 - - - - - 0 0
1004 fdnet 101004 1500 - - - ieee - 0 0
1005 trnet 101005 1500 - - - ibm - 0 0

7 Boson NetSim Lab Manual


7. The two VLANS created on Switch1 do not appear on Switch2 because, even though both switches
are configured as VTP servers and VTP servers can synchronize VTP databases, the two VLANs
are configured with different VTP domain names and passwords. Switch2 must be configured with
the same VTP domain name and VTP password to receive VLAN database updates from Switch1.
You should issue the following command to determine which VLANs are configured on a switch.
Sample output is shown below:

Switch2#show vlan

VLAN Name Status Ports


---- --------------------------- --------- -----------------------------
1 default active Fa0/1, Fa0/2, Fa0/3, Fa0/4
Fa0/5, Fa0/6, Fa0/7, Fa0/8
Fa0/9, Fa0/10, Fa0/11

1002 fddi-default active


1003 token-ring-default active
1004 fddinet-default active
1005 trnet-default active

VLAN Type SAID MTU Parent RingNo BridgeNo Stp BrdgMode Trans1 Trans2
---- ----- ------- ----- ------ ------ -------- ---- -------- ------ ------
1 enet 100001 1500 - - - - - 0 0
1002 fddi 101002 1500 - - - - - 0 0
1003 tr 101003 1500 - - - - - 0 0
1004 fdnet 101004 1500 - - - ieee - 0 0
1005 trnet 101005 1500 - - - ibm - 0 0

8. On Switch2, issue the following commands to configure the switch as a VTP client, to change the
VTP domain to boson, and to configure a VTP password of cisco:

Switch2(config)#vtp mode client


Switch2(config)#vtp domain boson
Changing VTP domain from NULL to boson

Switch2(config)#vtp password cisco

Note: Depending on the VTP hello timing status when you issued the vtp password cisco
command on Switch1, Switch2 might have updated its domain to boson during VTP convergence. If
this is the case, you will see Changing VTP domain from boson to boson instead of Changing
VTP domain from NULL to boson. If a password had been configured on Switch2 prior to the
commands being issued on Switch1, VTP convergence would not have occurred until the passwords
and domains matched.

9. Switches that operate in client mode store the same VTP information as switches that are in server
mode; they receive the advertisements that are sent out by the VTP server. A switch in VTP client
mode can receive and forward VTP advertisements. However, you cannot create, modify, or delete
VLANs on a VTP client nor can you modify VTP parameters on a VTP client.

8 Boson NetSim Lab Manual


10. Allow 30 seconds for the network to converge, and then verify the Switch2 VTP configuration by
issuing the following command. Sample output is shown below:

Switch2#show vtp status


VTP Version : 2
Configuration Revision : 2
Maximum VLANs supported locally : 64
Number of existing VLANs : 7

VTP Operating Mode : Client


VTP Domain Name : boson
VTP Pruning Mode : Disabled
VTP V2 Mode : Disabled
VTP Traps Generation : Disabled
MD5 digest : 0xEE 0xB3 0xDC 0x9F 0xE2 0xE0 0x25 0xDF
Configuration last modified by 0.0.0.0 at 3-1-2012 04:55:57
Local updater ID is 0.0.0.0 (no valid interface found)

Note: NetSim sends VTP packets every 30 seconds; however, you might need to wait up to five
minutes for some switches to send VTP packets.

11. Issue the following command on Switch2 to verify that the VLAN database was updated. Switch2
should now show VLAN 8 and VLAN 14. Sample output is shown below:

Switch2#show vlan

VLAN Name Status Ports


---- ------------------------------- --------- ----------------------------
1 default active Fa0/1, Fa0/2, Fa0/3, Fa0/4
Fa0/5, Fa0/6, Fa0/7, Fa0/8
Fa0/9, Fa0/10, Fa0/11
8 VLAN0008 active
14 VLAN0014 active

1002 fddi-default active


1003 token-ring-default active
1004 fddinet-default active
1005 trnet-default active

VLAN Type SAID MTU Parent RingNo BridgeNo Stp BrdgMode Trans1 Trans2
---- ----- ------- ----- ------ ------ -------- ---- -------- ------ ------
1 enet 100001 1500 - - - - - 0 0
8 enet 100008 1500 - - - - - 0 0
14 enet 100014 1500 - - - - - 0 0
1002 fddi 101002 1500 - - - - - 0 0
1003 tr 101003 1500 - - - - - 0 0
1004 fdnet 101004 1500 - - - ieee - 0 0
1005 trnet 101005 1500 - - - ibm - 0 0

9 Boson NetSim Lab Manual


Sample Configuration Script
Switch2 Switch2 (continued)
Switch2#show running-config interface FastEthernet0/8
Building configuration... !
Current configuration : 934 bytes interface FastEthernet0/9
! !
Version 15.b interface FastEthernet0/10
service timestamps debug uptime !
service timestamps log uptime interface FastEthernet0/11
no service password-encryption !
! interface FastEthernet0/12
hostname Switch2 switchport mode trunk
! !
ip subnet-zero interface Vlan 1
! ip address 10.1.1.2 255.255.255.0
ip cef no ip route-cache
no ip domain-lookup !
spanning-tree mode pvst vlan 8 name VLAN0008
spanning-tree extend system-id vlan 14 name VLAN0014
! !
interface FastEthernet0/1 ip classless
! no ip http server
interface FastEthernet0/2 !
! line con 0
interface FastEthernet0/3 line aux 0
! line vty 0 15
interface FastEthernet0/4 login
! !
interface FastEthernet0/5 no scheduler allocate
! end
interface FastEthernet0/6
!
interface FastEthernet0/7
!

Copyright © 1996–2017 Boson Software, LLC. All rights reserved. NetSim software and documentation are protected by copyright law.

10 Boson NetSim Lab Manual