Está en la página 1de 26

Casa to Cisco Command Reference

For Commands Contained in the C100G Lab

May 2016
© 2016 Casa Systems, Inc.
All rights reserved. Licensed software products are owned by Casa Systems or its suppliers and are protected by United States
copyright laws and international treaty provisions.

The information regarding the product in this manual is subject to change without notice. All statements, information, and
recommendations in this manual are believed to be accurate but are presented without warranty of any kind, express of implied.
Users must take full responsibility for their application of the product.

In no event shall Casa or its suppliers be liable for any indirect, special, consequential, or incidental damages, including, without
limitation, lost profits or loss or damage to data arising out of the use or inability to use this manual, even if Casa or its suppliers
have been advised of the possibility of such damages.
Lab Guide CLI Conversion
Table; Casa to Cisco

Function Casa Command Cisco Command


show cable modem show cable modem
show ip route show ip route
enable
exit
ping <ipaddr>
show run
config configure terminal
copy <orig> <dest>
copy run start copy running-config startup-config
or
write
del <filename>
del startup-config
Redundancy
High Availability on by default. Supervisor redundancy automatically enabled
when two Supervisors are installed in the
Cisco cBR chassis.
CPU Redundancy SMM HA:
show current status show system show redundancy
force failover ha module <module #> protect config-register 0x02
boot system bootflash:<image name>
redundancy force-switchover
show sync status show smm sync-status show redundancy
I/O Module Redundancy I/O HA:
show current status show ha configuration
force failover ha module <module #> protect

Image and File


Management
copy a configuration file copy nvram startup-config nvram copy nvram startup-config nvram prep-
prep-upgradeX upgradeX
show files and directories ls dir
tftp config file to server copy nvram prep-upgradeX tftp copy nvram prep-upgradeX
10.4.1.3 tftp://10.4.1.3/prep-upgradeX
show current software show bootdev show version
version
ftp a new software version copy ftp <your username> 10.4.1.3 copy ftp://<your username>@10.4.1.3/
to the CCAP ccsi.gz.rel7.7.0.0_build4479 nvram ccsi.gz.rel7.7.0.0_build4479 bootflash/
ccsi.gz.rel7.7.0.0_build4479

1
Casa Command Cisco Command
apply a service patch to an system patch apply request platform software package expand
image classpatch_p31ba.tgz file bootflash/classpatch_p31ba.tgz
request platform software package install rp
<rp-slot-number> file bootflash:
classpatch_p31ba.tgz

remove a patch remove patch classpatch_p31ba.tgz


configure image to load on system bootdev nvram boot system bootflash:<image name>
next reboot ccsi.gz.rel7.7.0.0_build4479
reboot system system reboot reload
view system module status show system

Enable LACP
configure trunking interface trunk <trunk #> The cBR pulls a configuration file from a TFTP
<interface> mode active server. Assign an IP address to your network
<interface> mode active connection:
no shutdown enable
configure terminal
interface TenGigabitEthernet4/01/0
ip address <ip-address><subnet-mask>
load-interval <seconds>
no shutdown
end

Connect the router to the network. After the


router successfully resolves its host name,
new router sends a TFTP broadcast
requesting the file name-confg or name.cfg.
The router name must be in all lowercase,
even if the true host name is not. The file is
downloaded to the new router, where
the configuration commands take effect
immediately. If the configuration file is
complete, the new router should be fully
operational.
view LACP information show lacp summary

Configure a VLAN with the interface vlan <vlan id>


Trunk as an Interface trunk <trunk #>
ip address <ip address> <mask>
ipv6 address <ipv6 address>/64
bdf interval 100 min_rx 100
multiplier 4
no shutdown

2
Casa Command Cisco Command
Configure a Loopback interface loopback <#> {interface loopback <#>}
Interface ip address <loopback ip address> {ip address <loopback ip address>/32}
255.255.255.255

Configure DHCP Relay for interface ip-bundle <#>


CMs and CPEs ip address <ipaddress> <mask> cable dhcp-giaddr <ip address>
ip address <ip address> <mask> cable dhcp-giaddr policy host <ip address>
secondary
cable helper-address <dhcp server cable helper-address <ip address> cable-
ip address> modem
cable helper-address <ip address> host

ipv6 address <ipv6 address/mask>


cable helper-ipv6-address <dhcp
server ipv6 address>

Configure OSPF v2
create an OSPF routing router ospf 1 {router ospf 1}
instance passive-interface ip-bundle 1
network <network ip>/30 area 0 {network <network ip. 0.0.0.3 area 0}
network <loopback ip address>/32 network <loopback ip address> 0.0.0.0 area
area 0 0}
network <CM network>/24 area 0 {network <CM network> 0.0.0.255 area 0}
network <CPE subnet>/24 area 0 {network <CPE subnet> 0.0.0.255 area 0}
area 0 authentication message- {area 0 authentication message-digest}
digest
log-adjacency-changes {log-adjacency-changes}

assign routing to a VLAN interface vlan <vlan id> {interface gigabitEthernet 0}


interface ip ospf network point-to-point {ip ospf network point-to-point}
ipv6 ospf network point-to-point
ipb6 router ospf 1 area 0.0.0.0 {ospfv3 multi-area 0.0.0.0}
ip ospf authentication message- {area 0 authentication message-digest}
digest
ip ospf message-digest-key 1 md5 {ip ospf message-digets-key 1 md5
are2@casa are2@casa”
no shutdown {no shutdown}
end

3
Casa commands Cisco commands
Configure OSPFv3
configure global OSPv3 {ipv6 unicast-routing}
parameters {ipv6 cef}
router ospf6 1 {ipv6 router ospf 1}
router-id <router id> {router-id <router id>}
redistribute connected {ipv6 rip EXT enable}
end
end
clear ipv6 ospf process {clear ipv6 ospf traffic}
yes

Verify BFD
verify BFD show bfd session {show ip ospf}
show bfd session detail

Verify OSPFv4
verify OSPFv4 show ip ospf {show ip ospf}
show ip ospf interface vlan <vlan {show ip ospf interface}
id>
show ip ospf neighbor detail {show ip ospf neighbor detail}
show ip ospf database {show ip ospf database}

Verify OSPFv3
verify OSPFv3 show ipv6 ospf {show ipv6 ospf}
show ipv6 ospf interface vlan <vlan {show ipv6 ospf interface}
id>
show ipv6 ospf neighbor detail {show ipv6 ospf neighbor detail}
show ipv6 ospf neighbor {show ipv6 ospf neighbor}
show ipv6 route ospf {show ipv6 route ospf}
show ipv6 ospf database {show ipv6 ospf database}

OSPF ASBR Configuration


create a RIP instance interface ip-bundle 1.2
ip address <ip address>/24
exit
router rip
network <IP Bundle 1.2 CPE IP
address> 255.255.255.0
create an IP Prefix List ip prefix-list redistribute_rip permit {ip prefix-list redistribute_rip permit
172.16.1x.1/24 172.16.1x.1.24}
exit
show ip prefix-list detail

4
Casa commands Cisco commands
create a Route Map route-map connect_rip_to_ospf {route-map connect_rip_to_ospf permit 10}
permit 10
match ip address prefix-list {match ip address prefix-list redistribute_rip}
redistribute_rip
redistribute the RIP route router ospf 1
redistribute connected route-map {redistributed connected route-map
connect_rip_to_ospf connect_rip_to_ospf}
show this
check your work show ip ospf database {show ip ospf database}
show ip route {show ip route}
show ip ospf {show ip ospf}
show ip ospf border-routers {show ip ospf border-routers}
Casa Commands Cisco Commands
IBGP/LDP/MPLS
Configuration
create a VRF table vrf definition <vrf name> vrf definition <vrf name>
definition rd 1:1 rd 1:1

address-family ipv4

route-target export 1:1 route-target both 1:1


route-target import 1:1
route-target import isp1-vpn-rd
exit ip vrf isp1-vpn
rd <mgmt-rd>
route-target export isp1-vpn-rd
route-target import mgmt-vpn-rd

create a network to interface ip-bundle 1.1 interface bundle n.x


associate with the VRF vrf forwarding casalabs ip vrf forwarding mgmt-vpn
ip address <ip address> ip address <ip address> <mask>
255.255.255.0 cable helper-address <ip address> cable
modem
cable helper-address <ip address> host

interface bundle n.x


ip vrf forwarding isp1-vpn
ip address <ip address> <mask>
cable helper-address <ip address> cable
modem
cable helper-address <ip address> host

5
Casa commands Cisco commands
enable MPLS and LDP on interface vlan <vlan id> interface gigabitethernet<slot/subslot/port>
the trunk interface mpls ip mpls ip
mpls ldp router-id loopback <interface #>
enable-ldp ipv4 mpls label protocol ldp
create the LDP peering to router ldp
your neighbor router router-id <your loopback address>
transport-address ipv4 <your
loopback address>
exit

Verify IBGP/LDP/MPLS
verify BGP/MPLS show ip bgp neighbor
show ip route vrf casalabs show ip route vrf casalabs
show mpls ldp neighbor show mpls forwarding-table

show ip vrf
show

Configuring EoMPLS
establish LDP targeted router ldp {mpls ip}
peers {mpls label protocol ldp}
{interface tunnel#}
targeted-peer ipv4 <peer device IP> {tunnel destination <ip address>}
{mpls ip}
show ldp targeted-peers
exit {exit}
create EoMPLS instances cable l2-vpn-service xconnect nsi mpls
to each targeted peer
mpls vpws <vpws name> cable l2vpn <mac-address> [customer name]
service instance <id> ethernet
peer <peer ip address> <virtual xconnect <peer ip address> <vc-id>
circuit ID> encapsulation mpls

exit end
show mpls vpws xconnect
assign cable modem to show cable modem
each VPWS cable modem <cm MAC address> cable l2vpn <mac-address> [customer name]
mpls vpnid <vpws name> service instance <id> ethernet
clear cable modem reset
show mpls vpws xconnect show cable l2-vpn xconnect
show xconnect
show mpls l2transport vc

6
Casa commands Cisco commands
Configuring VPLS
establish LDP targeted
peers

router ldp

targeted-peer ipv4 <peer device IP>

show ldp targeted-peers


exit
add routers to your BGP router bgp 64512 {router bgp 64512}
instance as neighbors neighbor <neighbor IP address> {neighbor <neighbor IP address>
remote-as 64512 remote-as 64512}
neighbor <neighbor IP address> {neighbor <neighbor IP address> update-
update-source loopback 0 source Loopback0}
add routers to your L2VPN address-family l2vpn vpls {address-family l2vpn vpls}
address family neighbor <neighbor ip address> {neighbor <neighbor ip address> activate}
activate
neighbor <neighbor ip address> neighbor <neighbor ip address> send
send-community extended community extended}
{neighbor <neighbor ip address>
suppress-signaling-protocol ldp}
exit-address-family {exit-address-family}
establish your VPLS name mpls vpls casalab_vpls 1000 {l2vpn vfi context casalab_vpls 1000}
and instance identifier
configure BGP as your signaling bgp ve-id <ve-id> {autodiscovery bgp signaling bgp}
signaling protocol {ve id <ve id>
{ve range <ve range number>}
signaling bgp route-distinguisher {rd <rd>}
<rd>
signaling bgp route-target <rt> {route-target <rt>

show this
exit

7
Casa commands Cisco commands
add a BPI-enabled cable cable modem <cm MAC address>
modem to the VPLS mpls vpnid casalabs_vpls

clear cable modem <cm MAC


address>
show mpls vpls casalab_vpls detail

SysAdmin Configurations
enable “Save system reboot confirm
Configuration” message
configure SSH keys ssh-server gen-hostkey ?
set system time show timezone list
system timezone <string> {clock timezone <timezone> <GMT
offset>}
system clock <MMDDhhmmYYYY> {clock set <HH:mm:ss month-abbreviation
DD YYYY}
show clock {show clock}
configure NTP ntp server 10.4.1.3 ntp server vrf Mgmt-intf 10.4.1.3

ntp sync 10.4.1.3

configure DNS nameserver 10.4.1.3 {ip name-server 10.4.1.3}

configure Privileged Mode password <password> {enable password <password>}


password
encrypt passwords in service password-encryption Passwords are encrypted by default
running config
add local user adduser ckent privilege 15 {username ckent privilege 15 password 7
Superman15 Superman15}
delete local user deluser jimmy {no username jimmy}

8
Casa commands Cisco commands
create CLI aliases alias ccm “clear cable modem” {alias exec ccm clear cable modem reset}
alias cpu “show cpu-process | esc
00:00:00
alias du “show docsis downstream
channel utilization”
alias scgv “show service group {alias exec scgv show cable fiber-node
verbose” <fiber node id> mapping}
alias scm “show cable modem” {alias exec scm show cable modem}
alias scmv “show cable modem {alias exec scm show cable modem
verbose” verbose}
alias uptime “show cpuinfo all | i
up”
alias crs “copy running-config {alias exec crs copy running-config
startup-config” startup-config

{show alias}
configure local logging show logging all {show logging summary}
logging system informational {logging synchronous level 1 all}
logging system errors {logging synchronous level 3 all}
configure Syslog logging host 10.4.1.3 logging host 10.4.1.3 vrf Mgmt-intf
logging syslog warning {snmp-server enable traps syslog}
{logging history warning 4}
show syslog
logging source-interface loopback snmp-server source-interface traps
gigabitEthernet 0
configure SNMP snmp default
snmp community readmibs ro {snmp-server community readmibs ro}
snmp community letmewrite rw {snmp-server community letmewrite rw}
device contact admin@casa- {snmp-server contact admin@casa-
systems.net systems.net}
device location training_lab {snmp-server location training_lab}

{show snmp community

9
Casa commands Cisco commands
configure SNMPv2 {snmp-server enable traps}
snmp tgt-addr class-srv2 {snmp-server host class-srv2}
snmpUDPDomain 10.4.1.4 500 1
TrapV2cSNMPv2cTrapsTagList
TrapV2cSNMPv2cTraps non-
volatile 0.0.0.0 500

snmp inform version 2


snmp notify tapUserTrapTagList
tapUserTrapTagList trap non-
volatile
snmp trap-source loopback 0
device contact admin@www.casa-
systems.net {snmp-server contact admin@www/casa-
device location training_lab systems.net}
{snmp-server location training_lab}

configuring traps interface docsis-mac 1 snmp-server enable traps cable


cm trap snmp-server enable traps docsis-cmts
cm trap interval 10
exit
configure SNMP snmp community casaadmin rw {snmp-server community casaadmin rw}
communities snmp community casastudent ro {snmp-server community casastudent ro}

create SNMP community ip access-list limit-snmp


with restricted access to permit snmp 10.4.1.4
the MIB tree 255.255.255.255 <your loopback
IP>
deny snmp any any
exit
show ip access-list limit-snmp

snmp tree-family scout


1.3.6.1.4.1.20858.10.24 – include
non-volatile

snmp access scout-grp – snmpv2c


no-auth exact scout scout scout
non-volatile
snmp security snmpv2c scoutgrp-
usr scout-grp non-volatile
snmp community imagereader ro
security scoutgrp-usr access-group
limit-snmp

10
Casa commands Cisco commands
configure PIM traps ip pim trap invalid-pim-message {snmp-server enable traps pim}
enable
ip pim trap neighbor-change enable
ip pim trap rp-mapping-change
enable

configuring TACACS+ tacacs-server host 10.4.1.4


tacacs-server key
bl@hbl@hwh@t3v3r

aaa authentication login default {aaa authentication login default group


group tacacsplus tacacs+ local}
aaa authentication login
tacacsplus-local
aaa authentication enable default {aaa authentication enable default group
group tacacsplus enable tacacs+}
aaa authorization command 0 {aaa authorization commands 0 default
default if-authenticated tacacs+ local}
aaa authorization command 15 aaa authorization commands 15 default
default if-authenticated tacacs+ local}
aaa accounting {aaa accounting}
aaa accounting commands 0
default stop-only
aaa accounting commands 1
default stop-only
aaa accounting commands 15
default stop-only

aaa tacacs-source loopback 0 {ip tacacs source-interface loopback 0}

Access Control Lists


create an access list to ip access-list restrict-telnet {access-list extended restrict_telnet deny
restrict telnet remark “deny TELNET access to tcp 10.4.1.4 0.0.0.0 operator 23 any}
class-srv2”
deny telnet 10.4.1.4
255.255.255.255 any
exit
apply the ACL to your interface vlan 200 {interface gigabitethernet 0}
VLAN ip access-group restrict-telnet {ip access-group restrict_telnet in}
remove the ACL no ip access-group {no ip access-group in}

11
Casa commands Cisco commands
Create a Global Access
Class
create an ACL ip access-list restrict-ssh {ip access-list extended restrict_ssh
remark “allow ssh only to the permit ssh any <your loopback IP
loopback address” address> 0.0.0.0
permit ssh any <your loopback IP deny ssh any any}
address> 255.255.255.255
deny ssh any any
exit

apply the ACL as an access access-class in restrict-ssh


class
remove the access class no access-class in

Diagnosing NSI Interface


Issues
diagnose interface issues show ip interface brief {show ip interface brief}
show controller eth {show controller gigabitethernet}
show controller upstream {show interface cable upstream
show controller qam {show controller integrated-cable}
show iftable eth
diagnose memory issues show meminfo {meminfo}
show cpu-memory process list {show platform software process list}
show gigabit-rx-cpu-rate
show debugging {show debugging}
diagnose DHCP issues show dhcp-trace {debug dhcp detail}
diagnose High Availability show ha configuration
issues show ha hardware qam 8x96
recovery
show ha switch fault monitor status
diagnose Trunking issues show lacp summary {show lacp}
obtain System Information show bootdev {show bootflash all}
show envm {show environment all}
diagnose Initialization show alarm {show alarm-interface summary}
Processes show dmesg
show log {show logging summary}
show tech show cable tech-support

12
Casa commands Cisco commands
RFI Configurations
configure Downstream cable downstream qam-profile 1
Transmitters (Annex B) annex B
modulation 256
interleaver-depth I32-J4
symbol-rate 5361
spectrum-inversion off
description default-annex-b-256-qam

cable downstream freq-profile 0


lane 1 start-freq 555000000
block1 start-freq 555000000
block 2 start-freq 561000000
block 3 start-freq 567000000
block4 start-freq 573000000
lane 2 start-freq 579000000
block1 start-freq 579000000
block 2 start-freq 585000000
block 3 start-freq 591000000
block4 start-freq 597000000

interface qam 0/0 controller Integrated-Cable 0/0/0


no shutdown no shutdown
power 550 base-channel-power 55
channel 0 frequency 555000000 8 freq-profile 0
rf-chan 0 95
type DOCSIS
frequency 555000000
rf-output NORMAL
power-adjust 0
docsis-channel-id 1
qam-profile 1
channel 0 description FNB
no channel 0 shutdown 8

13
Casa commands Cisco commands
configure Upstream show interface upstream brief
Receivers interface upstream 13/0.0 controller upstream-cable 13/0/0
frequency 20000000 us-channel 0 frequency 20000000
no shutdown no us-channel 0 shutdown
no logical-channel 0 shut

interface upstream 13/0.1 controller upstream-cable 13/0/1


frequency 24000000 us-channel 1 frequency 24000000
no shutdown no us-channel 1 shutdown
no logical-channel 0 shutdown

interface upstream 13/0.2 controller upstream-cable 13/0/2


frequency 28000000 us-channel 2 frequency 28000000
no shutdown no us-channel 2 shutdown
no logical-channel 0 shutdown

interface upstream 13/0.3 controller upstream-cable 13/0/3


frequency 32000000 us-channel 3 frequency 32000000
no shutdown no us-channel 3 shutdown
no logical-channel 0 shutdown

show interface upstream brief


configure Downstream cable downstream qam-profile 2
Transmitters (Annex A) annex A
modulation 256
interleaver-depth I32-J4
symbol-rate 5361
spectrum-inversion off
description default-annex-b-256-qam

cable downstream freq-profile 1


lane 1 start-freq 650000000
block1 start-freq 650000000
block 2 start-freq 658000000
block 3 start-freq 666000000
block4 start-freq 674000000
lane 2 start-freq 682000000
block1 start-freq 682000000
block 2 start-freq 690000000
block 3 start-freq 698000000
block4 start-freq 706000000

interface qam 0/1 controller Integrated-Cable 0/1/0


no shutdown no shutdown
annex A

14
power 550 base-channel-power 55
freq-profile 1
rf-chan 0 95
type DOCSIS
channel 0 frequency 650000000 8 frequency 650000000
rf-output NORMAL
power-adjust 0
docsis-channel-id 2
qam-profile 2
channel 0 description FNA
no channel 0 shutdown 8

configure Upstream interface upstream 13/1.0 controller upstream-cable 13/1/0


Receivers (Annex A) frequency 20000000 us-channel 0 frequency 20000000
no shutdown no us-channel 0 shutdown
no logical-channel 0 shutdown

interface upstream 13/1.1 controller upstream-cable 13/1/1


frequency 24000000 us-channel 1 frequency 24000000
no shutdown no us-channel 1 shutdown
no logical-channel 0 shutdown

interface upstream 13/1.2 controller upstream-cable 13/1/2


frequency 28000000 us-channel 2 frequency 28000000
no shutdown no us-channel 2 shutdown
no logical-channel 0 shutdown

interface upstream 13/1.3 controller upstream-cable 13/1/3


frequency 32000000 us-channel 3 frequency 32000000
no shutdown no us-channel 3 shutdown
no logical-channel 0 shutdown

show interface upstream brief

15
Casa commands Cisco commands
configure DOCSIS MAC interface docsis-mac 1 interface cable 0/0/0
interface for Annex B downstream 1 interface qam 0/0/0 interface Integrated-Cable 0/0/0:0
downstream 2 interface qam 0/0/1 interface Integrated-Cable 0/0/0:1
downstream 3 interface qam 0/0/2 interface Integrated-Cable 0/0/0:2
downstream 4 interface qam 0/0/3 interface Integrated-Cable 0/0/0:3
downstream 5 interface qam 0/0/4 interface Integrated-Cable 0/0/0:4
downstream 6 interface qam 0/0/5 interface Integrated-Cable 0/0/0:5
downstream 7 interface qam 0/0/6 interface Integrated-Cable 0/0/0:6
downstream 8 interface qam 0/0/7 interface Integrated-Cable 0/0/0:7
downstream Integrated-Cable 0/0/0 rf-
channels 0-7

upstream 1 interface upstream upstream 1 upstream-cable 9/0/0 us-


13/0.0/0 channel 0
upstream 2 interface upstream upstream 2 upstream-cable 9/0/0 us-
13/0.1/0 channel 1
upstream 3 interface upstream upstream 3 upstream-cable 9/0/0 us-
13/0.2/0 channel 2
upstream 4 interface upstream upstream 4 upstream-cable 9/0/0 us-
13/0.3/0 channel 3

ip bundle 1 cable helper-address <ip address> cable-


modem
cable helper-address <ip address> host

show cable mac-domain c0/0/0 cgd-


associations

16
Casa commands Cisco commands
configure DOCSIS MAC interface docsis-mac 2 interface cable 0/0/1
interface for Annex A downstream 1 interface qam 0/1/0 interface Integrated-Cable 0/0/1:0
downstream 2 interface qam 0/1/1 interface Integrated-Cable 0/0/1:1
downstream 3 interface qam 0/1/2 interface Integrated-Cable 0/0/1:2
downstream 4 interface qam 0/1/3 interface Integrated-Cable 0/0/1:3
downstream 5 interface qam 0/1/4 interface Integrated-Cable 0/0/1:4
downstream 6 interface qam 0/1/5 interface Integrated-Cable 0/0/1:5
downstream 7 interface qam 0/1/6 interface Integrated-Cable 0/0/1:6
downstream 8 interface qam 0/1/7 interface Integrated-Cable 0/0/1:7
downstream Integrated-Cable 0/0/1 rf-
channels 0-7

upstream 1 interface upstream upstream 1 upstream-cable 9/0/2 us-


13/2.0/0 channel 0
upstream 2 interface upstream upstream 2 upstream-cable 9/0/2 us-
13/2.1/0 channel 1
upstream 3 interface upstream upstream 3 upstream-cable 9/0/2 us-
13/2.2/0 channel 2
upstream 4 interface upstream upstream 4 upstream-cable 9/0/2 us-
13/2.3/0 channel 3

ip bundle 1 cable helper-address <ip address> cable-


modem
cable helper-address <ip address> host

show cable mac-domain c0/0/0 cgd-


associations

DOCSIS Security
Configurations
enable Early early-authentication-encryption cable privacy eae-policy ranging-
Authentication and ranging enforcement
Encryption
enable TFTP Proxy/TFTP tftp enforce cable tftp-enforce
Enforce
enable BPI enforce cable privacy bpi-enforce
mandatory
cable privacy bpi-plus-enforce cable privacy bpi-plus-policy total-
mandatory enforcement

17
Casa commands Cisco commands
PHY and DOCSIS MAC Best
Practices
configure Static MAP map-advance static 200 cable map-advance static 200
Advance
configure Interleave level interleave 16 cable downstream interleave-depth 16
enable pre-equalization logical-channel 0 pre-equalization
auto reset auto-reset

Modulation Profiles
examine current show modulation-profile show cable modulation-profile
Modulation Profiles show interface upstream 13/0.0 |
in profile
configure a Modulation modulation-profile 6 cable modulation-profile global-scheme 6
Profile <profile> <operation_mode> cable modulation-profile profile atdma
<modulation_type> Diff encoding {on | iuc fec-tbytes fec-len burst-len guard-t
off} preamble length <1:1024> FEC-T<0:16> mod scrambler seed diff
FEC-K
<16:255> seed <0:32767> pre-len last-cw uw-len
max burst
<0:255> guard time<4:255>
code word length
{fixed | shortened}
scrambler
{on |off} interleav depth <0:2048>
interleave block
<0:2048> preamble
type
{qpsk0 | qpsk1}

request atdma qpsk off 64 0 16 338 cable modulation-profile 6 atdma request


0 16 fixed on 1 1536 qpsk0 0 16 0 16 qpsk scrambler 338 no-diff 64
fixed

initial atdma qpsk off 640 5 34 338 cable modulation-profile 6 atdma initial 5
0 48 fixed on 1 1536 qpsk0 34 0 48 qpsk scrambler 338 no-diff 640
fixed

station atdma qpsk off 384 5 34 338 cable modulation-profile 6 atdma station
0 48 fixed on 1 1536 qpsk0 5 34 0 48 qpsk scrambler 338 no-diff 640
fixed

a-short atdma qpsk off 104 12 75 cable modulation-profile 6 atdma a-short


338 13 8 shortened on 0 2048 12 75 13 8 qpsk scrambler 338 no-diff 104
qpsk1

a-long atdma qpsk off 104 16 223 cable modulation-profile 6 atdma a-long
338 0 8 shortened on 0 2048 qpsk1 16 223 0 8 qpsk scrambler 338 no-diff 104
shortened

ugs atdma qpsk off 104 16 223 338 cable modulation-profile 6 atdma a-ugs
0 8 shortened on 0 2048 qpsk1 16 223 0 8 qpsk scrambler 338 no-diff
104 shortened

18
Casa commands Cisco commands
Small Signal
Compensation
enable Small Signal small-signal-compensation
Compensation

Load Balancing and


Channel Bonding
Configurations
configure Service Groups service group CCAPx_FNA cable fiber-node <id>
upstream 13/0.0 upstream upstream-Cable 9/0/0
upstream 13/0.1 upstream upstream-Cable 9/0/1
upstream 13/0.2 upstream upstream-Cable 9/0/2
upstream 13/0.3 upstream upstream-Cable 9/0/3
qam 0/0/0 downstream Integrated-Cable 0/0/0
qam 0/0/1 downstream Integrated-Cable 0/0/1
qam 0/0/2 downstream Integrated-Cable 0/0/2
qam 0/0/3 downstream Integrated-Cable 0/0/3
qam 0/0/4 downstream Integrated-Cable 0/0/4
qam 0/0/5 downstream Integrated-Cable 0/0/5
qam 0/0/6 downstream Integrated-Cable 0/0/6
qam 0/0/7 downstream Integrated-Cable 0/0/7

enable Load Balancing load-balance enable cable load-balance d30-ggrp-default


method modem

load-balance execution-rule 1
method modem
cable load-balance group 1 method
method utilization dynamic modem
threshold load 10 enforce 20 cable load-balance group 1 method
minimum 20 dynamic minimum 60 utilization
cable load-balance group 1 threshold load
load-balance policy 1 10 enforce 20 load minimum 60
rule execution 1

load-balance general-group default- cable load-balance d30-ggrp-default


settings method modem us-method modem
enable
initial-tech broadcast-ranging
policy-id 1
clear cable modem reset clear cable modem reset

show load-balance static show cable load-balance

19
Casa commands Cisco commands
Channel Bonding
confirm Bonding Note: channel bonding is enabled by interface wideband-Cable 0/0/0:0
default in any intersection of a cable bundle 1
DOCSIS MAC domain and a service interface wideband-Cable 0/0/0:1
group. cable bundle 1
interface wideband-Cable 0/0/0:2
cable bundle 1
interface wideband-Cable 0/0/0:3
cable bundle 1
interface wideband-Cable 0/0/0:4
cable bundle 1
interface wideband-Cable 0/0/0:5
cable bundle 1
interface wideband-Cable 0/0/0:6
cable bundle 1
interface wideband-Cable 0/0/0:7
cable bundle 1

interface cable 9/0/0


cable upstream bonding-group 200
upstream 0
upstream 1
upstream 2
upstream 3

show cable modem show cable modem


show cable modem bonding show interface cable upstream bonding-
group
show controllers integrated-cable 0/0/0
wideband-channel
show downstream channel set show cable modem wideband rcs-status
show upstream channel set

Partial Service
configure Partial Service cable cm-status-report event-list
best practices 1,4,7,8
show cable modem cm-status log
cable partial-service continue-
ranging

20
Casa commands Cisco commands
CCAP/CM Diagnostics
display statistics for RFI show interface qam brief show interface cable <interface>
interfaces show interface qam stat downstream

show interface upstream brief show interface cable <interface>


show interface upstream stat upstream

Diagnostic Mode Interface


Commands
check gige interface errors show module 0 stat gige show interface gigabitethernet 0/0/0
show memory on a show module <module #> stat
downstream module himem
show downstream card show module <module #> stat qam show interface integrated-cable
statistics <interface> counters
show upstream card show interface upstream 13/0.0 show interface cable 9/0 upstream 0
statistics stat
enable logging of logging debugging
debugging messges
turn on CM debugging debug cable macaddress <mac debug cable mac-address <mac address>
address> verbose
clear cable modem <mac address>
reset
debug cable
turn off logging and no logging
debugging no debug cable

Cable Modem Show


Commands
show cable modem show cable modem
show cable modem verbose show cable modem verbose
show cable modem mac show cable modem mac
show cable modem verbose | inc
Stn
show cable modem verbose | inc
US
show cable modem verbose | inc
DS
show cable modem verbose | inc
Online
show cable modem counters show cable modem counters
show cable modem errors show cable modem errors
show cable modem dropped
show docsis downstream channel
utilization

21
show cable modem docsis-mac 1 show cable modem mac-domain fiber-
service-group FNA downstream node
throughput show cable load-balance docsis-group 1
rfch-util
show upstream signal-quality
show spectrum upstream 13/0
show cable signal-quality upstream
show upstream burst-noise show cable spectrum-analysis upstream
show cable modem partial service 9/0
show cable <interface> noise
show cable modem partial-service

Remote Query
perform a Remote Query cable modem remote-query 30
show cable modem remote-query
immediate
show cable modem <mac address |
ip address> remote-query verbose
immediate

DOCSIS Ping
issue a DOCSIS ping ping docsis <mac address>

Cable Flap List


configure the Cable Flap show cable flap-list config
list cable flap-list power-adjust
threshold 1
cable flap-list miss threshold 7
cable flap-list insertion-time 90

22
100 Old River Road Suite 100
Andover, MA 01810 USA
978-688-6706

Casa Educational Services


© 2016 Casa Systems, Inc.
All rights reserved.

También podría gustarte