Está en la página 1de 10

Comunicación de datos I.

Guía 7 1
Facultad: Ingeniería
Escuela: Electrónica
Asignatura: Comunicación de datos I

Tema: Enrutamiento estático

Contenidos

 Verificación de las tablas de enrutamiento.


 Configuración de rutas estáticas.
 Configuración de rutas por defecto.

Objetivos Específicos
 Conocer los conceptos del enrutamiento estático en un Router.
 Configurar una red básica para que exista comunicación por parte de los host.

Materiales y Equipo

 Computadora con simulador Packet Tracer

Procedimiento

Configuración Básica de los Router.


Bibliografía
1. Realizar la siguiente configuración de red.
Guía 1
2 Comunicación de datos I. Guía 7

2. El Packet Tracer le proporciona la oportunidad de instalar diferentes dispositivos a


los routers; Siempre y cuando este los soporte.

3. Para realizar este procedimiento se apaga el router y se elige el modulo que


queremos instalar lo arrastramos a la ranura que este utiliza y encendemos
nuevamente el router para proceder a realizar las conexiones respectivas.

Apagamos y encendemos el
router
Ranuras para instalar los módulos
complementarios del router

4. Configurar los routers.

Configuración en el Router 0

Router>enable
Router#configure terminal
Comunicación de datos I. Guía 7 3

Router(config)#hostname Router0
Router0(config)#enable secret redes
Router0(config)#interface fastEthernet 0/0
Router0(config-if)#ip address 192.168.3.1 255.255.255.0
Router0(config-if)#no shutdown
Router0(config-if)#exit
Router0(config)#interface serial 0/1
Router0(config-if)#ip address 10.0.2.1 255.255.255.0
Router0(config-if)#no shutdown
Router0(config-if)#description Conexion del Router0 por la serial 1 hacia el Router1
Router0(config-if)#exit
Router0(config)#line console 0
Router0(config-line)#password redes
Router0(config-line)#login
Router0(config-line)#line vty 0 4
Router0(config-line)#password redes
Router0(config-line)#login
Router0(config-line)#exit
Router0(config)#exit
Router0#copy running-config startup-config

Configuración en el Router1

Router>enable
Router#configure terminal
Router(config)#hostname Router1
Router1(config)#enable secret redes
Router1(config)#interface fastEthernet 0/0
Router1(config-if)#ip address 192.168.1.1 255.255.255.0
Router1(config-if)#no shutdown
Router1(config-if)#exit
Router1(config)#interface serial 0/1
Router1(config-if)#ip address 10.0.2.2 255.255.255.0
Router1(config-if)#clock rate 56000
Router1(config-if)#no shutdown
Router1(config-if)#description Conexion del Router1 por la serial 1 hacia el Router0
Router1(config-if)#exit
Router1(config)#interface serial 0/0
Router1(config-if)#ip address 10.0.1.2 255.255.255.0
Router1(config-if)#clock rate 56000
Router1(config-if)#no shutdown
Router1(config-if)#description Conexion del Router1 por la serial 0 hacia el Router2
Router1(config-if)#exit
Router1(config)#line console 0
Router1(config-line)#password redes
Router1(config-line)#login
Router1(config-line)#line vty 0 4
Router1(config-line)#password redes
Router1(config-line)#login
4 Comunicación de datos I. Guía 7

Router1(config-line)#exit
Router1(config)#exit
Router1#copy running-config startup-config

Configuración en el Router2

Router>enable
Router#configure terminal
Router(config)#hostname Router2
Router2(config)#enable secret redes
Router2(config)#interface fastEthernet 0/0
Router2(config-if)#ip address 192.168.2.1 255.255.255.0
Router2(config-if)#no shutdown
Router2(config-if)#exit
Router2(config)#interface serial 0/1
Router2(config-if)#ip address 10.0.1.1 255.255.255.0
Router2(config-if)#no shutdown
Router2(config-if)#description Conexion del Router2 por la serial 0 hacia el Router1
Router2(config-if)#exit
Router2(config)#line console 0
Router2(config-line)#password redes
Router2(config-line)#login
Router2(config-line)#line vty 0 4
Router2(config-line)#password redes
Router2(config-line)#login
Router2(config-line)#exit
Router2(config)#exit
Router2#copy running-config startup-config

5. Las configuraciones de las PC’s se realizaran en la pestaña Desktop.

PC0
Ip Address 192.168.3.2
Subnet Mask 255.255.255.0
Default Gateway 192.168.3.1
Comunicación de datos I. Guía 7 5

PC1
Ip Address 192.168.1.2
Subnet Mask 255.255.255.0
Default Gateway 192.168.1.1

PC2
Ip Address 192.168.2.2
Subnet Mask 255.255.255.0
Default Gateway 192.168.2.1

Configuración de rutas estáticas.

6. Ahora procedemos a utilizar el comando ip route, la sintaxis de este comando es la


siguiente:

ip route [destination_network] [mask] [next-hop_address or next_interface]


[administrative_distance] [permanent]

7. En el modo de configuración global de cada router, colocamos las configuraciones


del enrutamiento.

En el Router0
Router0(config)#ip route 192.168.1.0 255.255.255.0 10.0.2.2
Router0(config)#ip route 10.0.1.0 255.255.255.0 10.0.2.2
Router0(config)#ip route 192.168.2.0 255.255.255.0 10.0.2.2
Router0(config)#exit
Router0#

En el Router1
Router1(config)#ip route 192.168.3.0 255.255.255.0 10.0.2.1
Router1(config)#ip route 192.168.2.0 255.255.255.0 10.0.1.1
Router1(config)#exit
Router1#

En el Router2
Router2(config)#ip route 192.168.3.0 255.255.255.0 10.0.1.2
Router2(config)#ip route 192.168.1.0 255.255.255.0 10.0.1.2
Router2(config)#ip route 10.0.2.0 255.255.255.0 10.0.1.2
Router2(config)#exit
Router2#

8. Utilice los comandos ping en las PC así como en los routers, para verificar
interconexión.

Verificación de las tablas de enrutamiento.

9. Utilice el comando show ip route de la siguiente forma:


6 Comunicación de datos I. Guía 7

Router2#show ip route

10. Complete la información que le muestra el comando show ip route en cada router

Router0

Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP


D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route

Gateway of last resort is not set

10.0.0.0/24 is subnetted, 2 subnets


S 10.0.1.0 [1/0] via 10.0.2.2
C 10.0.2.0 is directly connected, Serial0/1
S 192.168.1.0/24 [1/0] via 10.0.2.2
S 192.168.2.0/24 [1/0] via 10.0.2.2
C 192.168.3.0/24 is directly connected, FastEthernet0/0

Router1

Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP

D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area


N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route

Gateway of last resort is not set

10.0.0.0/24 is subnetted, 2 subnets


C 10.0.1.0 is directly connected, Serial0/0
C 10.0.2.0 is directly connected, Serial0/1
C 192.168.1.0/24 is directly connected, FastEthernet0/0
S 192.168.2.0/24 [1/0] via 10.0.1.1
S 192.168.3.0/24 [1/0] via 10.0.2.1

Router2
Complete la información que le muestra el comando show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP

D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area


Comunicación de datos I. Guía 7 7

N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2


E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route

Gateway of last resort is not set


10.0.0.0/24 is subnetted, 2 subnets
C 10.0.1.0 is directly connected, Serial0/1
S 10.0.2.0 [1/0] via 10.0.1.2
S 192.168.1.0/24 [1/0] via 10.0.1.2
C 192.168.2.0/24 is directly connected, FastEthernet0/0
S 192.168.3.0/24 [1/0] via 10.0.1.2
NOTA:
Si en el router no aparece la tabla de enrutamiento, es porque el router no se
puede comunicar con el próximo salto ó la dirección de la siguiente interfaz que
se ha configurado.
11. Haga un análisis sobre la información mostrada por los Router.
como se puede apreciar según los resultados obtenidos tras ejecutar el comando " show ip
route" en cada uno de los routers del presente ejercicio, todos los routers configurados po-
seen 2 subredes a las que se hace la respectiva conexión, se puede apreciar cuales son las
redes que se conectan directamente, y cuales a partir del enrutamiento estatico con sus
respectivas interfaces de salida
Configuración de rutas por defecto.
Las rutas por defecto se utilizan para poder enviar tráfico a destinos que no
concuerden con las tablas de enrutamiento de los dispositivos que integran la red.
El caso más común para su implementación sería el de redes con acceso a Internet
ya que sería imposible contener en las tablas de enrutamiento de los dispositivos
todas las rutas que la componen.
12. Agregue un router (router3) a la topología e interconéctelo utilizando la interface
serial 0/0 con el serial 0/0 de router2, agregue las siguientes líneas de comando.

En Router2

Router2>enable
Router2#configure terminal
Router2(config)#interface serial 0/0
Router2(config-if)#ip address 10.0.5.1 255.255.255.0
Router2(config-if)#no shutdown
Router2(config-if)#exit
Router2(config)#exit
Router2#copy running-config startup-config

En Router3

Router>enable
Router#configure terminal
8 Comunicación de datos I. Guía 7

Router(config)#interface serial 0/0


Router(config-if)#ip address 10.0.5.2 255.255.255.0
Router(config)#clock rate 56000
Router(config-if)#no shutdown
Router(config-if)#exit
Router(config)#exit
Router#copy running-config startup-config

Como podrá observar se ha agregado una nueva red a la topología (10.0.5.0), la


cual no se encuentra en las tablas de enrutamiento de los router (verificar las
tablas de enrutamiento nuevamente), por tanto no habría comunicación con esta
nueva red.
Una solución sería configurar en cada uno de los router, rutas estáticas dirigidas a
esta red, pero esto implicaría proporcionarle la ubicación de la red 10.0.5.0, lo cual
es lo que no se desea. La mejor solución es utilizar rutas por defecto ya que estas
permiten comunicación sin conocer la red destino.

Router (config)# ip route 0.0.0.0 0.0.0.0 [IP del siguiente salto ó interfaz de salida ]

13. Configure lo siguiente:

Configuración en el Router 0

Router0>enable
Router0#configure terminal
Router0(config)#ip route 0.0.0.0 0.0.0.0 s0/1
Router0(config)#exit

Configuración en el Router 1

Router1>enable
Router1#configure terminal
Router1(config)#ip route 0.0.0.0 0.0.0.0 s0/0
Router1(config)#exit

Configuración en el Router 2

Router2>enable
Router2#configure terminal
Router2(config)#ip route 0.0.0.0 0.0.0.0 s0/0
Router2(config)#exit

Configuración en el Router 3

Router>enable
Router#configure terminal
Router(config)#ip route 0.0.0.0 0.0.0.0 s0/0
Router(config)#exit

14. Analice las configuraciones anteriores y pregunte al instructor si tiene dudas.


15. Verifique las tablas de enrutamiento ubicando en ellas las rutas por defecto.
16. Realice pruebas de conectividad de las PCs hacia la interfaz serial 0/0del router3
(10.0.5.2)

1. A partir de esta guía usted realizará un manual de comandos que se utilizan en la práctica

MODO EXEC USUARIO

Comando Descripción
connect {dirección_ip|nombre} Permite conectarse remotamente a un host

disconnect conexión Desconecta una sesión telnet establecida desde el router


Guía 3
enable Ingresa al modo EXEC Privilegiado
logout Sale del modo EXEC
ping Guía|nombre
{dirección_ip 4 } Envía una petición de eco para diagnosticar la conectividad básica de red

Muestra el contenido de la tabla de enrutamiento IP. El parámetro dirección per-


fía [dirección |protocolo] mite acotar la información que se desea visualizar, exclusivamente a la dirección
show ip route
Guía 3 ingresada. El parámetro protocolo permite indicar la fuente de aprendizaje de las
rutas que se desean visualizar, como por ejemplo rip, igrp, static y connected

M O D O E XGuía
E C P4
RIVILEGIADO
Comando Descripción
fía
configure terminal Configura la terminal manualmente desde la terminal de consola
copy running-config startup-config Guarda la configuración activa en la NVRAM
show running-config Muestra la configuración actual en la RAM
show startup-config Muestra la configuración que se ha guardado, que es el contenido de la NVRAM

MODO DE CONFIGURACIÓN GLOBAL


Comando Descripción
Cambia los valores del registro de configuración.
config-register valor_registro_configuración
Ej: config-register 0x2142
Establece una contraseña local para controlar el acceso a los diversos niveles de
enable password contraseña
privilegio. Ej: enable password class
Especifica una capa de seguridad adicional mediante el comando enable pass-
enable secret contraseña
word. Ej: enable secret class
hostname nombre Modifica el nombre del router. Ej: hostname Lab_A
Configura un tipo de interfaz y entra al modo de configuración de interfaz.
interface tipo número
Ej: interface ethernet 0
Ip route dirección_red máscara dir_ip_salto Establece rutas estáticas.
[distancia_administrativa] Ej: ip route 210.42.3.0 255.255.255.0 211.1.2.1

SUBMODO DE CONFIGURACIÓN DE INTERFAZ


Comando Descripción
Configura la velocidad de reloj para las conexiones de hardware en interfaces
clock rate velocidad seriales, como módulos de interfaz de red y procesadores de interfaz a una velo-
cidad de bits aceptable. Ej: clock rate 56000
Agrega una descripción a la interfaz.
description descripción
Ej: description Conectada a Internet
no shutdown Reinicia una interfaz desactivada
shutdown Inhabilita una interfaz
login Habilita la verificación de contraseña en el momento de la conexión.
password contraseña Asigna la contraseña a ser solicitada en el momento de la conexión
10 Comunicación de datos I. Guía 7

Hoja de cotejo: 7
Guía 7: Enrutamiento estático
Docente: 1
Máquina No:
Tema: Presentación del programa
Alumno: Máquina No:
GL:
Alumno:
Docente: Máquina No: Fecha:
GL:
a
Docente: GL:

EVALUACION
% 1-4 5-7 8-10 Nota
CONOCIMIENTO 25 Demostró poco Demostró Demostró buen
conocimiento sobre conocimiento medio conocimiento sobre
el tema de la sobre el tema de la el tema de la
práctica. práctica. práctica.
APLICACIÓN DEL 70 Configuro y Configuro y comprobó Configuro y comprobó
CONOCIMIENTO comprobó el el funcionamiento de el funcionamiento de
funcionamiento de la topología con rutas la topología con rutas
la topología con estáticas y sabe estáticas
rutas estáticas, utilizar la información sabe utilizar la
pero no sabe obtenida con el información obtenida
utilizar la comando show ip con el comando show
información route ip route
obtenida con el Configuro rutas por
comando show ip defecto en los router
route y comprendió su uso

2.5 Es un observador Participa Participa propositiva e


ACTITUD
pasivo. ocasionalmente o lo integralmente en toda
hace constantemente la práctica.
pero sin coordinarse
con su compañero.
2.5 Es ordenado pero Hace un uso adecuado Hace un manejo
no hace un uso de recursos responsable y
adecuado de los respetando las pautas adecuado de los
recursos. de seguridad, pero es recursos conforme a
desordenado. pautas de seguridad e
higiene.
TOTAL 100