Está en la página 1de 8

FACULTAD DE INGENIERÍA INDUSTRIAL Y

MECANICA

PSEUDOCODIGO

PROFESOR : ING. YURI POMACHAGUA BASUALDO

CURSO : PRINCIPIOS DE ALGORITMOS

INTEGRANTES : CODIGO :

 ANGEL MANUEL MORENO VILA 0810606


 JONATHAN ENRIQUE ZAPATA ALLAUCA U17101660
 EDWIN RICHARD VALDIGLESIAS SULLCAHUAMAN U17107773
 JORGE DANIEL REGALADO FUSTER 1511599

ESPECIALIDAD : INGENIERIA CIVIL


1. RESOLVER LOS PROBLEMAS PLANTEADOS

1.1. Hallar la suma de tres números


1.2. Hallar el área de un cuadrado
1.3. Hallar el área de un triangulo
1.4. Calcular el 25 % de descuento de un artefacto
1.5. Calcular el promedio de uno de sus cursos
1.6. Cuantos meses debe ahorrar para comprar un celular de 500 soles si recibe
mensualmente p soles
1.7. Hallar el área de un circulo
1.8. Hallar las raíces de la ecuación cuadrática

RESOLUCION

1.1. Hallar la suma de tres números


Proceso calculo_de_la_suma_de_3_numeros
Escribir " calculo de la suma de los 3 numeros "
Escribir "ingrese el primer numero"
Escribir "ingrese el segundo numero"
Escribir "ingrese el tercer numero"
Leer a
leer b
Leer c
n<-a+b+c
Escribir " la suma de los tres numeros ingresados es ",n
FinProceso
1.2. Hallar el área de un cuadrado
Proceso calculo_del_area_del_cuadrado
Escribir " calcular el area del cuadrado "
Escribir "el lado del cuadrado"
Leer a
n<-a*a
Escribir " el area del cuadrado es ",n
FinProceso
1.3. Hallar el área de un triangulo

Proceso calculo_del_area_del_triangulo
Escribir " calcular el area del triangulo "
Escribir "la altura del triangulo es "
Escribir "la base del triangulo es "
Leer a,b
n<-(a*b)/2
Escribir " el area del triangulo es ",n
FinProceso
1.4. Calcular el 25 % de descuento de un artefacto

Proceso calculo_del_descuento_de_un_artefacto
Escribir " calculo del descuento del artefacto "
Escribir "ingrese costo del artefacto "
Leer a
n<-a*0.25
Escribir " el descuento del artefacto es ",n
FinProceso

1.5. Calcular el promedio de uno de sus cursos

Proceso calculo_de_promedio_de_principio_de_algoritmos
Escribir " ingrese la nota de la primera practica a"
Escribir " ingrese la nota de la segunda practica b"
Escribir " ingrese la nota de la tercera practica c"
Escribir " ingrese la nota del examen final f "
Leer a
Leer b
Leer c
Leer f
n<-(a*0.20)+(b*0.20)+(c*0.20)+(f*0.40)
Escribir " el promedio del curso de algoritmos es ",n
FinProceso

1.6. Cuantos meses debe ahorrar para comprar un celular de 500 soles si
recibe mensualmente p soles
Proceso meses_de_ahorro
Escribir " ingrese el numero de meses"
Escribir " ingrese la cantidad mensual "
leer p
n<-500/p
Escribir " el numero de meses es ",n
FinProceso
1.7. Hallar el área de un circulo

Proceso el_area_del_circulo
Escribir " ingrese el radio del circulo "
leer r
s<-pi()*r*r
Escribir " el area del circulo es ",s
FinProceso
1.8. Hallar las raíces de la ecuación cuadrática

Proceso calculo_de_las_raices_de_la_ecuacion_cuadratica
Escribir " ingrese la primera constante del la variable cuadratica"
Escribir " ingrese la segunda constante del la variable lineal"
Escribir " ingrese la tercera constante del la variable independiente"
leer a
leer b
leer c
r<- ((-b)+((b*b)-(4*a*c))^0.5)/2*a
s<- ((-b)-((b*b)-(4*a*c))^0.5)/2*a
Escribir " el resultado de la primera raiz es ",r
Escribir " el resultado de la segunda raiz es ",s
FinProceso