Está en la página 1de 3

Fórmulas y funciones

Función CONTAR.SI
Use CONTAR.SI, una de las funciones estadísticas, para contar el número de celdas
que cumplen un criterio; por ejemplo, para contar el número de veces que una
ciudad determinada aparece en una lista de clientes.

En su forma más sencilla, CONTAR.SI indica lo siguiente:

 =CONTRAR.SI(¿Dónde quiere realizar la búsqueda y qué quiere buscar?)

Por ejemplo:

 =CONTAR.SI(A2:A5,"Londres")
 =CONTAR.SI(A2:A5;A4)

Sintaxis

Ejemplos
Para usar estos ejemplos de Excel, copie los datos de la tabla de abajo y péguelos
en la celda A1 de una nueva hoja de cálculo.

Datos Datos
manzanas 32
naranjas 54
melocotones 75
manzanas 86
Fórmula Descripción
=CONTAR.SI(A2:A5;"manzanas") Cuenta el número de celdas con manzanas entre las celdas A2 y A5. El resultado es 2.
=CONTAR.SI(A2:A5;A4) Cuenta el número de celdas con melocotones, el valor de A4, entre las celdas A2 y A5. El resultado es 1.
=CONTAR.SI(A2:A5,A2)+CONTAR.SI(A2:A5,A3) Cuenta el número de manzanas, el valor de A2, y de naranjas, el valor de A3, entre las celdas A2 y A5. El result
Esta fórmula usa CONTAR.SI dos veces para especificar varios criterios, un criterio por expresión. También pue
utilizar la función CONTAR.SI.CONJUNTO.
=CONTAR.SI(B2:B5;">55") Cuenta el número de celdas con un valor superior a 55 entre las celdas B2 y B5. El resultado es 2.
=CONTAR.SI(B2:B5;"<>"&B4) Cuenta el número de celdas con un valor distinto de 75 entre las celdas B2 y B5. El símbolo de la "y" (&) comb
operador de comparación "<>" (no es igual a) y el valor de B4 para leer =CONTAR.SI(B2:B5,"<>75"). El resultad
Datos Datos
=CONTAR.SI(B2:B5;">=32")- Cuenta el número de celdas con un valor superior o igual a 32 e inferior o igual a 85 entre las celdas B2 y A5. E
CONTAR.SI(B2:B5;">85") resultado es 3.
=CONTAR.SI(A2:A5,"*") Cuenta el número de celdas que contienen texto entre las celdas A2 y A5. El carácter comodín * se usa para re
cualquier carácter. El resultado es 4.
=CONTAR.SI(A2:A5,"?????es") Cuenta el número de celdas que tienen exactamente 7 caracteres y que terminan con las letras es entre las ce
A5. El carácter comodín ? se usa para reemplazar caracteres individuales. El resultado es 2.

Problemas comunes

Problema Qué ha fallado


Se devolvió un valor incorrecto para La función CONTAR.SI devuelve resultados incorrectos cuando se usa para comparar cade
cadenas largas. más de 255 caracteres.

Para comparar cadenas de más de 255 caracteres, use la función CONCATENAR o el opera
concatenar &. Por ejemplo, =CONTAR.SI(A2:A5,"cadena larga"&"otra cadena larga").
No se devolvió ningún valor cuando Asegúrese de encerrar el argumento de criterios entre comillas.
se esperaba uno.
Si una fórmula CONTAR.SI hace Este error se produce cuando la fórmula que contiene la función hace referencia a celdas
referencia a otro libro, se recibe un rango de un libro cerrado y se calculan las celdas. Para que esta característica funcione, e
error #VALOR! libro debe estar abierto.

Prácticas recomendadas

Realice este procedimiento ¿Por qué?


Tenga en cuenta que CONTAR.SI Los criterios no distinguen entre mayúsculas y minúsculas. En otras palabras, la cadena "manzanas" y la
pasa por alto mayúsculas y "MANZANAS" darán como resultado la misma cantidad de celdas.
minúsculas en las cadenas de texto.
Use caracteres comodín. Los caracteres comodín, que son el signo de interrogación (?) y el asterisco (*), pueden usarse en los crit
signo de interrogación corresponde a un solo carácter cualquiera, y el asterisco equivale a cualquier secu
caracteres. Si desea buscar un signo de interrogación o un asterisco reales, escriba una tilde (~) detrás de
carácter.

Por ejemplo, =CONTAR.SI(A2:A5,"manzana?") contará todas las instancias de "manzana" con una última
que podrá variar.
Asegúrese de que los datos no Al contar valores de texto, asegúrese de que los datos no contienen espacios al principio ni al final, de qu
contienen caracteres incorrectos. haya un uso incoherente de las comillas rectas (' o ") ni tipográficas (‘ o “) y de que no haya caracteres no
imprimibles. En estos casos, CONTAR.SI puede devolver un valor inesperado o incorrecto.

Intente usar la función LIMPIAR o la función ESPACIOS.


Para mayor comodidad, use rangos CONTAR.SI admite el uso de rangos con nombre en una fórmula (por ejemplo, =CONTAR.SI(fruta,">=32"
con nombre. CONTAR.SI(fruta,">85"). El rango con nombre puede estar en la hoja de cálculo actual, en otra hoja de cá
del mismo libro o en una hoja de cálculo de otro libro. Para hacer referencia a otro libro, ese libro tambié
Realice este procedimiento ¿Por qué?
estar abierto.

Nota: La función CONTAR.SI no contará celdas según el color de la fuente o el fondo de la


celda. Pero Excel es compatible con funciones definidas por el usuario (UDF) con las
operaciones de Microsoft Visual Basic para Aplicaciones (VBA) en celdas basadas en el color de
la fuente o el fondo. Este es un ejemplo de cómo puede contar el número de celdas con un
color de celda específico con VBA.

También podría gustarte