Está en la página 1de 14

Universidad Tecnológica de Panamá

Facultad de Ingeniería Mecánica

Programación

Profesora Lourdes Jaramillo

Proyecto 2

Estudiantes: Juan Carlos Filós; Máximo Cedeño

Grupo INI 112

Fecha 31 de Octubre de 2018


1. Sección de Algoritmo:
2. Diseño de Pantalla:

Programa Para Clasificación de Fabricas


Introduzca Ganancia trimestral de la Fabrica1, Fabrica2 ,Fabrica3:
1_____ 1_____ 1____
2_____ 2_____ 2____
3_____ 3_____ 3____
4_____ 4_____ 4_____.

Escoja que opción quiere Proceder


a) Los totales anuales de producción de cada fábrica.
b) Información de la fábrica que más produjo en el año. Indica también el total de la
producción.
c) Información de la fábrica que menos produjo en el año. Indica también el total de la
producción.
d) Imprimir las fábricas cuyas producciones para el segundo trimestre superaron los 3
Millones.
e) Escribir la información de todas las fábricas en orden de menor a mayor.

Y dependiendo de la Opción que escoja se va a ver su Resultado.


3. Diagrama de Flujo:
4. Pseudocódigo:

1. Inicio
2. Declaramos las variables {
op,op2,Conf1, Conf2, Conf3; variable de tipo simple, numero entero
Tfabrica1=0, Tfabrica2=0, Tfabrica3=0, Tsegundo1, Tsegundo2, Tsegundo3, gananciaf3,
gananciaf1, gananciaf2; variable de tipo simple, número real}
3. Escribir “programa para clasificar fabricas”
4. Escribir “Ingres información de la fabricas”
5. Para conf1=1 hasta 4 hacer
6. Escribir “información de fábrica 1”
7. Leer ganaciaf1
8. Hacer Tfabrica1<Tfabrica1+gananciaf1
9. Si (gananciaf1==2)
10. Hacer psegundo1<Tsegundo1

Incremento del contador:

11. Fin para


12. Para conf2 =1 hasta 4 hacer
13. Escribir “información de fábrica 2”
14. Leer ganaciaf2
15. Hacer Tfabrica2<Tfabrica2+gananciaf2
16. Si (gananciaf2==2)
17. Hacer psegundo2<Tsegundo2
18. Fin para
19. Para conf1=1 hasta 4 hacer
20. Escribir “información de fábrica 1”
21. Leer ganaciaf1
22. Hacer Tfabrica1<Tfabrica1+gananciaf1
23. Si (gananciaf1==2)
24. Hacer psegundo1<Tsegundo1
25. Fin para
26. Hacer
27. Escribir “Seleccione la opción (1,2,3,4 o 5) acorde a la información que desea hacer”
28. Escribir “1.Los totales anuales de producción de cada fábrica.”
29. Escribir “2.Información de la fábrica que más produjo en el año.”
30. Escribir “3.Información de la fábrica que menos produjo en el año.”
31. Escribir “4.Imprimir las fábricas cuyas producciones para el segundo trimestre superaron los 3
Millones.”
32. 41. Escribir “Escribir la información de todas las fábricas en orden de menor a mayor.”
33. Leer op
34. Evaluar (op)
35. Caso 1:
36. Función ftotal (Tfabrica1, Tfabrica2, Tfabrica3)
37. Caso 2
38. Función fmayoriproduccion (Tfabrica1, Tfabrica2, Tfabrica3)
39. Caso 3
40. Función fmenorproduccion (Tfabrica1, Tfabrica2, Tfabrica3)
41. Caso 4
42. Función fmillones (Tfabrica1, Tfabrica2, Tfabrica3)
43. Caso 5
44. Función forden (Tfabrica1, Tfabrica2, Tfabrica3)
45. Fin evaluar
46. Escribir “salir del programa (presione 6 si desea seguir o cualquier tecla para salir”
47. Leer op2
48. Minetras (op=6)
49. Fin

Seudocódigo de función ftotal:

1. Inicio
2. Se declaran las variables{
Tfabrica1, Tfabrica2, Tfabrica3. Variable de tipo simple, numero real}
3. Escribir "el total anual de las fabricas son: fabrica 1",Tfabrica1
4. Escribir "fabrica 2:”,Tfabrica2
5. Escribir Escribir "fabrica 3:”,Tfabrica3
6. fin

Seudocódigo de función fmayorproduccion:

1. Inicio
2. Se declaran las variables{
Tfabrica1, Tfabrica2, Tfabrica3. Variable de tipo simple, número real}
3. Si (Tfabrica1>Tfabrica2) y (Tfabrica1>Tfabrica2) entonces
4. Escribir "la fábrica 1 es la que produjo mayor número de ingresos con:",Tfabrica1
5. De lo contrario
6. Si (Tfabrica2>Tfabrica1) y (Tfabrica2>Tfabrica3) entonces
7. escribir "la fábrica 1 es la que produjo mayor número de ingresos con:",Tfabrica2
8. de lo contrario
9. Si (Tfabrica3>Tfabrica1) y (Tfabrica3>Tfabrica2) entonces
10. escribir "la fábrica 3 es la que produjo mayor número de ingresos con:",Tfabrica3
11. fin si
12. fin si
13. fin si
14. fin
Pseudocódigo de función fmenorproduccion:

1. Inicio
2. Se declaran las variables{
Tfabrica1, Tfabrica2, Tfabrica3. Variable de tipo simple, número real}
3. Si (Tfabrica1<Tfabrica2) y (Tfabrica1<Tfabrica2) entonces
4. Escribir "la fábrica 1 es la que produjo menor número de ingresos con:",Tfabrica1
5. De lo contrario
6. Si (Tfabrica2<Tfabrica1) y (Tfabrica2<Tfabrica3) entonces
7. escribir "la fábrica 1 es la que produjo menor número de ingresos con:",Tfabrica2
8. de lo contrario
9. Si (Tfabrica3<Tfabrica1) y (Tfabrica3<Tfabrica2) entonces
10. escribir "la fábrica 3 es la que produjo menor número de ingresos con:",Tfabrica3
11. fin si
12. fin si
13. fin si
14. fin

Seudocódigo de la función fmillones:

1. Inicio
2. Se declaran las variables{
3. Tfabrica1, Tfabrica2, Tfabrica3. Variable de tipo simple, número real}
4. Si (psegundo1>3000000)
5. Escribir “"la fábrica 1 supero ingresos superiores a 3.000.000 para el segundo trimestre"
6. De lo contrario
7. Si (psegundo2>3000000)
8. Escribir “"la fábrica 2 supero ingresos superiores a 3.000.000 para el segundo trimestre "
9. De lo contrario
10. Si (psegundo3>3000000)
11. Escribir “"la fábrica 3 supero ingresos superiores a 3.000.000 para el segundo trimestre "
12. Fin si
13. Fin si
14. Fin si
15. fin
Seudocódigo de la función forden:

1. inicio
2. Se declaran las variables{
3. Tfabrica1, Tfabrica2, Tfabrica3. Variable de tipo simple, número real}
4. si (Tfabrica1<Tfabrica2)y(Tfabrica1>Tfabrica3)
5. escribir “la información de las fabrica de menor a mayor es: Fabrica 3 con: Fabrica 1 con:
Fabrica 2 con: ",Tfabrica3Tfabrica1,Tfabrica2)
6. de lo contrario
7. si (Tfabrica2<Tfabrica3)y(Tfabrica2>Tfabrica1)
8. escribir “la información de las fabrica de menor a mayor es: Fabrica 1 con: Fabrica 2 con:
Fabrica 3 con: ",Tfabrica1,Tfabrica2,Tfabrica3)
9. de lo contrario
10. si (Tfabrica3<Tfabrica2)y(Tfabrica3>Tfabrica1)
11. escribir “la información de las fabrica de menor a mayor es: Fabrica 2 con: Fabrica 3 con:
Fabrica 1 con: ",Tfabrica2,Tfabrica3,Tfabrica1)
12. de lo contrario
13. si (Tfabrica3<Tfabrica2)y(Tfabrica1>Tfabrica2)
14. escribir “la información de las fabrica de menor a mayor es: Fabrica 3 con: Fabrica 2 con:
Fabrica 1 con: ",Tfabrica3,Tfabrica2,Tfabrica1)
15. de lo contrario
16. Escribir “este caso no está contemplado”
17. Fin si
18. Fin si
19. Fin si
20. Fin si
21. Fin si
22. fin
5. Prueba de Escritorio:

Ganancias While(OP!=6) Fsuma


fSuma (SF1, SF2, SF3);
de las break; Fmayor
fabricas } Fmenor
A,B,C,D case 2: F3m
{
fMayor (SF1, SF2, SF3); Forden
E,F,G,H break;
}
case 3:
I,J,K,L {
fMenor (SF1, SF2, SF3);
break;
}
case 4:
{
f3M (Tr2F1, Tr2F2, Tr2F3);
break;
}
case 5:
{
fOrden (SF1, SF2, SF3);
break;

1 5000,100,200 OP=1 Fabrica1=1.600


,800 5000+100+200+800=1.6 Fabrica2=7.000
800,900,1000 00 Fabrica3=66.243
,5800 800+900+1000+5800=7.
8000,1243,50 000
00,40000 8000+1243+5000+40000
=66.243