Está en la página 1de 6

1

UNIVERSIDAD POLITÉCNICA ESTATAL DEL CARCHI


CARRERA DE COMPUTACIÓN
FUNDAMENTOS DE PROGRAMACIÓN

DOCENTE: GEORGINA ARCOS


PERÍODO ACADÉMICO: OCTUBRE 2018-FEBRERO 2019
SEMESTRE: PRIMERO
FECHA: 15 DE NOVIEMBRE,2018
INTEGRANTES: GUERRERO JOSÉ-CALPA HECTOR
PRÁCTICA N°: 2

TEMA: Flujograma y Pseudocódigo

INTRODUCCIÓN
PSEINT resulta ser muy útil para poder resolver problemas o realizar cálculos de
diversos tipos, en este trabajo vamos a realizar ejercicios aplicando los conocimientos
obtenidos durante el estudio de PSEINT.

OBJETIVOS
 Resolver los ejercicios y realizar su ejecución para obtener los resultados
deseados.
 Desarrollar los ejercicios y su pseudocódigo de una manera organizada y
correcta para que el ejecutar el programa no se presenten errores.

MATERIALES, EQUIPOS Y SOFTWARE.


 Computador
 Programa PSEINT.
2

PROCEDIMIENTO O DESARROLLO
1. Realizar una aplicación que permita ingresar el nombre, año de nacimiento.
Se pide devuelva como resultado Soy NOMBRE en el año 2020 tendré N
años
Pseudocódigo
Proceso sin título
definir b,c Como Real
definir a Como Carácter
escribir " ingrese su nombre"
leer a
escribir "ingrese el año de nacimiento"
leer b
c=2020-b
escribir " Soy " (a) " en el año 2020 tendré " (c) " años."
FinProceso
Diagrama de flujo
3

2. Realizar el flujograma y pseudocódigo del programa que permita ingresar por


teclado una frase e imprima el número de palabras que existen en el texto.
Pseudocódigo.
Algoritmo sin título
definir frase,b Como Carácter
definir m,n,p Como Entero
Escribir "ingrese texto"
leer frase
m<-longitud(frase)
si Subcadena(frase,1,1)!=" " Entonces
n<-n+1
FinSi
Para p<-1 hasta m Hacer
si (Subcadena(frase,p,p)!=" " y subcadena(frase,p-1,p-1)==" ") entonces
n<-n+1
FinSi
FinPara
Escribir "el número de palabras es:" ,n
FinAlgoritmo
Diagrama de flujo
4

3. Realizar un programa que calcule e imprima la suma de los múltiplos de 5


comprendidos entre dos valores a y b. Si a es mayor que b, intercambiará
estos valores.

Pseudocódigo.

proceso
definir a,b Como Real
escribir " ingrese el numero inicial"
leer a
escribir " ingrese el número final"
leer b
si a>b entonces
aux<-a
a=b
b=aux
FinSi
para i=a hasta b Hacer
si i MOD 5=0 Entonces
cont=cont+1
suma=suma+i
FinSi

FinPara
escribir " los múltiplos de 5 entre: " ,a, " y " , b ," es de " cont
escribir "la suma es " ,suma
FinProceso
Diagrama de flujo
5

RESULTADOS
Ejecución 1

Ejecución 2

Ejecución 3

CONCLUSIONES
 Obtenemos los resultados de cada ejercicio aplicando los diferentes códigos
para realizar cada uno de los ejercicios realizados en clase
6

 Aplicamos los conocimientos adquiridos utilizando la aplicación de PSEINT


en donde nos ayuda a realizar problemas para obtener los resultados de cada
ejercicio

RECOMENDACIONES
 En la aplicación de PSEINT nos permite obtener los resultados muy eficaces
en donde nos brinda una ayuda en donde cometemos los errores y la
aplicación nos permite corregir de manera organizada y correcta
 Nos brinda un mejor rendimiento en realizar un ejercicio para fortalecer
nuestros conocimientos de aprendizaje

BIBLIOGRAFÍA
García S. (2014). Fundamentos de programación usando PSeint. Tulcán. IMAGO