Está en la página 1de 6

UNIVERSIDAD TECNOLÓGICA DEL PERÚ

Principios de Algoritmos

Estructuras Secuenciales

Trabajo Autónomo Reflexivo 1

Barboza Arteaga Joe Alonso


Contreras Romeo Fernando Donato
Mamani Javier Gianmarco Leonel
Miniano Ipanaqué Edward Anthony

Lima 20 de setiembre de 2017


Este informe contiene soluciones para cada
problemática propuesta. Nosotros, el grupo de
trabajo, analizamos, planteamos, diseñamos y
desarrollamos las soluciones utilizando
pseudocódigos en PSeInt según lo aprendido en
clase.
PRIMER PROBLEMA
Un tonel es un recipiente, generalmente de madera, muy utilizado para almacenar y
mejorar un vino. La forma de un tonel es muy característica y es un cilindro en el que
la parte central es más gruesa, es decir, tiene un diámetro mayor que los extremos.
Escriba un programa que lea las medidas de un tonel y nos devuelva su capacidad,
teniendo en cuenta que el volumen (V) de un tonel viene dado por la siguiente fórmula
𝑉 = 𝜋 × 𝑙 × 𝑎2 donde:
𝑑 2 𝐷 𝑑
-𝑙 es la longitud del tonel, su altura. 𝑎 = 2 + 3 ( 2 − 2 ) 𝑑 es el diámetro del
tonel en sus extremos. D es el diámetro del tonel en el centro: D>d
Nota: Observe que si las medidas se dan en centímetros el resultado lo obtenemos en
centímetros cúbicos.

PSEUDOCÓDIGO
Proceso volumentonel
Definir l,a,d1,d2,p,v Como Real
Escribir "Ingrese la longitud(en cm): " Sin Saltar
leer l
Escribir "Ingrese el diámetro de las bases(en cm): " Sin Saltar
leer d1
Escribir "Ingrese el diámetro central(en cm): " sin saltar
leer d2
p<-3.1416
a<-d1/2+(2/3)*(d2/2-d1/2)
v<-p*l*a^2
Escribir "El volúmen del tonel es: ",v,"cm3"
FinProceso
SEGUNDO PROBLEMA

El precio de un automóvil nuevo para un comprador es la suma total de: el costo del
vehículo, porcentaje de la ganancia del vendedor y de los impuestos aplicables.
Suponer una ganancia del vendedor del 12% en todas las unidades y un impuesto del
6% y diseñar un algoritmo para mostrar el precio para el comprador.

PSEUDOCÓDIGO
Proceso pauto
Definir c,pv,ia,p Como Real
Escribir "Ingrese el costo del vehículo:" Sin Saltar
Leer c
pv<-0.12*c
ia<-0.06*c
p<-c+pv+ia
Escribir "El precio del vehículo para el vendedor es: ",p
FinProceso