Está en la página 1de 10

FUNCIONES INTERNAS DEL EXCEL.

Las funciones internas disponibles en el Excel permiten la realización automática de diversos cálculos y
operaciones extremadamente útiles, que completan todo el poder del aplicativo de la planilla. Todas las
funciones internas del Excel poseen el siguiente formato general.

Nombre_de_la_Función(X1; X2,....; Xn)

Nombre_de_la_Función es un nombre abreviado que identifica a la función.

(X1; X2,....; Xn) son los argumentos de la función (valores, expresiones, direcciones de celdas y nombres de
rangos) sobre los cuales la función va a operar y proveer un resultado.

El separador de argumentos es definido en la opción Separador de lista en la caja de diálogo de Inicio,


Panel de control, Configuración regional. Utilice el separador Punto y coma (;), pues la coma será
utilizada como separador decimal. Sin embargo, esta última definición también puede ser alterada por la
opción en este mismo cuadro de diálogo.

Una función puede ser colocada directamente en una celda, precedida por la señal de igual (=), para que
en ella sea provisto el resultado, o puede ser parte de una fórmula. Por ejemplo:

=SUMA(B4:B40)/2+RAIZ(D30)

Las funciones internas del Excel deben ser utilizadas principalmente en la Planilla de Cálculo para
completar las fórmulas en ella definidas, pero también pueden ser utilizadas en la Base de Datos, para
realizar cálculos y operaciones sobre los valores almacenados en los archivos de Datos.

El Excel para Windows posee un conjunto amplio de funciones internas, cuya forma de utilización y
resultados son resumidamente descriptas a continuación:

ABS(valor)

Provee el valor absoluto de un argumento numérico.

=ABS(-1) resulta 1

=ABS(COS(B2)) resulta el valor absoluto del coseno del valor de la celda B2

ACOS(valor)

Provee el arco cuyo coseno es el valor. O argumento valor varía de 1 a -1.

=ACOS(-0,5) resulta 2?/3 radianes = 2,094

=ACOS(-0,5)*180/PI() resulta 120 grados

AHORA()

Provee un valor numérico que puede ser formateado para ser fecha u hora actual.

Si la fecha es 24/3/93 y el horario es 23:45:40, entonces.

=AHORA() resulta 34052,99

Si formateamos la celda donde está =AHORA, como fecha tendremos 24/03/93.


Si formateamos la celda donde está =AHORA, como horario tendremos 23:45:40.

EL valor de la función AHORA() será actualizado cuando una celda fuera completada o alterada.

ALEATORIO()

Provee un valor aleatorio entre 0 (inclusive) y 1 (exclusive). A función ALEATORIO()

Provee un valor siempre que ocurre un recálculo en la planilla. Por eso, si una simulación estuviera
siempre ejecutada, active el recálculo manual.

=ALEATORIO()*9+1 resulta un número aleatorio entre 1 e 10 (exclusive)

=ENTEIO(ALEATORIO()*100) resulta un número aleatorio entre 0 e 99

AÑO(fecha)

Retorna el año correspondiente a la fecha. El año es provisto como un entero del intervalo 1900-2078.

=AÑO("7/5/90") resulta 1990

REDONDEAR(x; y)

Provee el resultado del argumento x con redondeo en la y - ésima posición decimal o en -y-ésimo
algoritmo entero; y varia de 14 a -14.

=REDONDEAR(2,15;1) resulta 2,2

=REDONDEAR(2,149;1) resulta 2,1

=REDONDEAR(-1,457;2) resulta -1,48

=REDONDEAR(891;-2) resulta 900

ASENO(valor)

Provee el arco cuyo seno es el valor. El argumento valor varia de 1 a -1.

=ASENO(-0,5) resulta -?/6 radianes=-0,524

=ASENO(-0,5)*180/PI() resulta -30 grados

ATAN(valor)

Provee el arco cuya tangente es el valor.

=ATAN(1) resulta ?/4 radianes=0,785

=ATAN(1)*180/PI() resulta 45 grados

ATAN2(x; y)

Provee o ángulo en radianes del punto descripto por las coordenadas (x, y).
Si x es Si y es ATAN(x;y) resulta

Positivo Positivo entre 0 y π /2


Negativo Positivo entre π /2 y π
Negativo Negativo entre -π y -π /2
positivo Negativo entre -π /2 y 0

=ATAN2(1;1) resulta π /4 radianes=0,785

=ATAN2(-1;-1) resulta -3π /4 radianes=-2,356

=ATAN2(-1,-1)*180/PI() resulta -135 grados

COLUMNAS(referencia)

Provee el número de columnas de celdas reverenciadas en el argumento.

=COLUMNAS(B3:E12) resulta 4

CONTAR(X1 ; X2 ; ...; Xn )

Cuenta el número de celdas no vacías de los rangos especificados. Las celdas con un valor numérico,
fórmula, texto, ERRO e #N/A también son contabilizadas.

Suponga que la celda A1 contenga el valor 5, la celda A2 esté vacía y la celda A3 contenga el texto
"Brasil".

=CONTAR(A1;A2) resulta 1

=CONTAR(A1:A3) resulta 2

COS(radianes)

Provee el coseno de un ángulo en radianes.

=COS(1,047) resulta 0,5

=COS(60*PI()/180) resulta 0,5

FECHA(año; mes; día)

Provee un número entre 1 (1º de enero de 1900) e 65.380 (31 de diciembre de 2078) que representa una
fecha. Utilice la opción <Formato><Fehca/Hora> para dar formato fecha. El año puede variar de 0 (1900)
a 179 (2079).

=FECHA(93; 3; 23) resulta 23/03/93

Si B15 contiene el valor 12 e B16 o valor 25, entonces:

=FECHA(93; B15; B16-2) resulta 23/12/93


DESVESTA(X1 ;X2 ; ...;Xn )

Calcula el desvío - estándar de la población de los valores referenciados por los rangos X1a Xn.

Desvío- estándar es una medida estadística de la dispersión de los valores en torno de la media.

Celdas referenciadas aisladamente (A1, B12 etc.) son siempre contabilizadas en el cálculo, así estén
vacías.

=DESVESTA(10; 10; 10) resulta 0

= DESVESTA (1; 2; 3) equivale a RAIZ(VAR(1; 2; 3)) o, aún:

{[(1-2)^2+(2-2)^2+(3-2)^2]/3}^(1/2) que resulta 0,8165

=DESVESTA(SUMA(Rango1); C23:E30; Enero) resulta del desvío - Estándar del resultado de cada
argumento.

DIA(fecha)

Provee el día del mes de determinada fecha.

=DIA("12/03/93") resulta 12

=DIA(FECHA(93; 3; 13)) resulta 13

ESNOD(X)

Provee el valor 1 si el argumento x provee el valor #N/A (valor no disponible) y 0 en caso contrario.

Si A1 contiene el valor #N/A, entonces:

=ESNOD(A1) resulta VERDADERO

=ESNOD(SI(ESNOD(A1);0;1)) resulta FALSO

=SI(ESNOD(A1);10;20) resulta 10

ESERR(X)

Provee el valor VERDADERO si el argumento x provee cualquier valor de error (#N/D, #VALOR!,
#REF!, #DIV/0!, #NÚM!, #NOME? o #NULO!) y FALSO en caso contrario.

=ESERR(1/0) resulta VERDADERO

=ESERR(1/2) resulta FALSO

Si A1 contiene cualquier valor de error, entonces:

=SI(ESERR(A1);10;20) resulta 10

ELEGIR(X; X0 ; X1 ; ...; Xn-1 )

El argumento X pode ser un número entero que varía de 0 a n. Si X asume el valor i, entonces la función
devuelve la i-enésima opción entre los argumentos X0a Xn-1.
Si la celda A1 contiene el valor 4, entonces:

=ELEGIR(A1-2; 100; 200; 300) resulta 200

=ELEGIR(Valor; A4-1;SUMA(Total)/25)

EXP(x)

Provee el número e elevado a x: EXP(x) = e x .

=EXP(1) resulta 2,78... (número e)

=EXP(LOG(12)) resulta 12

FALSO()

Provee el valor 0 (cero). Utilice esta función para tornar las fórmulas mas legibles.

Si A1 contiene el valor 10, entonces:

=SI(A1=0;VERDADE();FALSO()) resulta FALSO

HORA(horario)

Provee el valor de la hora de determinado horario.

=HORA("22:38") resulta 22

Si D12 contiene un horario 15:30, entonces:

=HORA(D12) resulta 15

INDICE(RNAGO;FILA;COLUMNA)

Provee el valor de la intersección de la columna con la fila de determinado rango de celdas.

Si A1 contiene el valor 1, B1 contiene el valor 2, A2 contiene el valor 3, B2 contiene el valor 4, A3


contiene el valor 5, B3 contiene el valor 6.

=INDICE(A1:B3;3;2) resulta 6

REDONDEAR(Número;Número_decimales)

Redondea un número al número de decimales específicos.

=REDONDEAR(9,5;0) resulta 10.

=REDONDEAR.MENOS(8,9;0) resulta 8.

=REDONDEAR.MAS(8,9;0) resulta 9.

FILAS(MATRIZ)

Provee el número de filas del rango de celdas referenciadas.


=FILAS(B3:E12) resulta 10

LN(NÚMERO)

Provee el logaritmo del valor del argumento en base e.

ln(x)=log e (x)=log 10 (x)/log 10 (e)

=LN(2,7182818) resulta 1

=LN(EXP(12)) resulta 12

=LN(3)/LN(10) equivale a LOG(3), que resulta 0,47712

LOG10(número)

Provee el logaritmo del valor del argumento en base 10.

log(x)=log

=LOG10(10) resulta 1

=LOG10(1000) resulta 3

=LOG10(3)/LOG10(8) equivale a log 8 (3), que resulta 0,52832

MAX (X1 ;X2 ; ...;Xn )

Provee el mayor valor encontrado en las celdas referenciadas por los argumentos X1 a Xn.

=MAX(1; 2; 4; 5; -3; 7; 6; 12; 10) resulta 12

PROMEDIO(X1 ;X2 ; ...;Xn )

Calcula el promedio de los valores de los argumentos. Los argumentos pueden ser: valores numéricos,
direcciones de celdas, Rangos de celdas, Nombre de rangos, fórmulas. Celdas que contengan texto,
valores lógicos o vacías serán ignoradas en el cálculo.

=PROMEDIO(12; 3,5; 200)

=PROMEDIO(H9; A3:B5; 24,13; Total)

=PROMEDIO(A1; A2; A3; A4)

=RPOMEDIO(A1:A4)

MINIMO(X1 ;X2 ; ...;Xn )

Provee el menor valor encontrado en las celdas referenciadas por los argumentos X1 a Xn .

=MIN(1; 2; 4; 5; -3; 7; 6; 12; 10) resulta

MINUTO(horario)

Provee los minutos de determinado horario.


=MINUTO("2:38")resulta 38

Si D12 contiene un horario 15:30, entonces:

=MINUTO(D12) resulta 30

MES(FECHA)

Provee el mes de determinada fecha.

=MES("12/3/93") resulta 3

=MES(FECHA(93; 3; 13)) resulta 3.

PI()

Provee el valor aproximado del número PI: π =3,14159...

=COS(60*PI()/180) resulta 0,5 (coseno de 60 grados)

BUSCARH(busca; RANGO; FILA) y BUSCARV(busca; RANGO; columna)

Las funciones BUSCARH (busca horizontal o por FILAS) e BUSCARV (busca vertical o por columnas)
realizan búsquedas de valores dentro de las celdas de determinado rango.

Valor_buscado: valor de búsqueda en la primera fila/columna del rango;

Matríz_buscar_en: referencia al rango (coordenadas) donde será hecha la búsqueda;

Indicador_finla/coluna: número de la fila/columna donde se desea leer el valor investigado en el rango.

Usando la función BUSCARH, la primera fila del rango referido es la fila en la cual será investigado el
valor de búsqueda. Encontrada la columna donde está el valor de búsqueda, la función provee el valor de
la fila donde se desea leer el valor. La fila de código es designada por 0, la próxima fila por 1, y así
sucesivamente. Con BUSCARV la búsqueda ocurre en la primera columna del rango de celdas referido
por el argumento rango.
Figura 15 Ejemplo de aplicación de la función Interna BUSCARV.
Figura 16 Hoja anterior con la opción de Herramientas, Opción, Ver, Mostrar fórmulas Activada.

RAIZ(valor)

Provee la raíz cuadrada de un valor positivo.

=RAIZ(4) resulta 2.

SI(condición; verdadero; falso)

La función SI() provee el resultado del argumento verdadero si la condición fuese convalidada como
verdadera (condición resulta 1) e el resultado del argumento falso se a condición fuese convalidada como
falsa (condición resulta 0).

=SI(1;2;3) resulta 2

=SI(0;2;3) resulta 3

Si la celda D10 contiene el valor 0 o está vacía, entonces:

=SI(D10<>0;1/D10;#¡DIV/0!) resulta #¡DIV/0!

SUMA(X1 ;X2 ; ...;Xn )

Provee la suma de los valores referidos por los argumentos x 1 a x n .

=SUMA(1; 2; 3) resulta 6
VARP(X1 ;X2 ; ...;Xn )

Calcula la varianza de la población de los valores referidos en los argumentos X1 a Xn. La varianza es una
medida estadística de la dispersión de valores en torno de la media. La raíz cuadrada de la varianza de la
población es el desvío – Estándar de la población. Celdas referidas aisladamente (A1, B12 etc.) son
siempre contabilizadas en el cálculo, aunque estén vacías.

=VAR(200; 200; 200) resulta 0

=VAR(1; 2; 3) resulta [(1-2)^2+(2-2)^2+(3-2)^2]/3=2/3=0,6666...

VERDADERO()

Provee el valor 1. Utilice esta función para hacer las fórmulas mas legibles.

=SI(A1=10;VERDADERO();FALSO()) resulta 1 si A1 contiene el valor 10.

http://www.cyta.com.ar/biblioteca/bddoc/bdlibros/manualdeexcel/funcion.htm