Está en la página 1de 6

GUIA

PROGRAMACIÓN
DECIMO GRADO (10°)
CANADIAN INTERNATIONAL SCHOOL

FORMACION PARA EL TRABAJO Y DESARROLLO HUMANO

GUIA DE AULA No. 1 INSTRUCCIONES DE REPETICIÓN Y INSTRUCCIÓN PARA


PROGRAMA: Sistemas y computación
MATERIA: Programación
SEMESTRE: III Profesor: Oliver Pascual Vallejos

RECUPERACION DE SABERES Y EXPERIENCIAS PREVIAS

En un almacén de camisas se tiene la siguiente promoción: si se compran 10 camisas o más se aplica un descuento
del 20% sobre el total de la compra, si son menos de 10 y al menos5 camisas un descuento del 10% y en cantidades
menores a 5 no hay descuento.

Definición del problema


Calcular el descuento y el valor a pagar por una compra.
Análisis del problema
Para solucionar este problema, lo más importante es determinar qué porcentaje se aplicará para calcular el valor
del descuento, este puede ser:

Porcentaje descuento
= 0% para cantidad < 5
Porcentaje descuento
= 10% para 5 <= cantidad < 10
Porcentaje descuento
= 20% para cantidad >=10

Datos de entrada:
valor unitario, cantidad

Datos de salida:
valor total, valor descuento, valor a pagar

Proceso:
Valor total=valor unitario * cantidadValor descuento=valor total * porcentaje descuento/100Valor a
pagar= valor total – valor descuento

Pseudocódigo

INICIO
Entero: can
Real: valUnit, valtot, pordes, valdes, valpag
Escribir(“Ingrese la cantidad:”)
Leer(can)Escribir(“ingrese valor unitario:)
Leer(valUnit)Si (can < 5) entonces
pordes=0SinoSi (can<10) entoncespordes=10Sinopordes=20fin sifin sivaltot = can * valUnitvaldes=valtot *
pordes/100valpag=valtot-valdesescribir(“ValorTotal:”,valtot)escribir(“Descuento:”,valdes)escribir(“valor a
pagar:”,valpag)
FIN

INSTRUCCIONES DE REPETICIÓN
En la solución de algunos problemas es necesario ejecutar repetidas veces una instrucción o un conjunto de
instrucciones. En algunos casos, el número de repeticiones se conoce con anterioridad, mientras que en otras depende
de cálculos o estados de variables que se dan dentro de la solución del problema. Para solucionar este tipo de
problemas se utiliza un tipo de estructuras a las que se conocen como estructuras de repetición, bucles o ciclos. Un
ciclo consiste en un grupo de acciones que se ejecutan repetidas veces dependiendo del cumplimiento de una
condición.1.1

CICLO PARA
Este ciclo al igual que los demás, permite ejecutar repetidas veces una instrucción o un grupo de ellas, pero a
diferencia de otras instrucciones de repetición, esta maneja el valor inicial, el valor de incremento o decremento y el
valor final de la variable de control como parte de la instrucción. Cuando al ejecutar un algoritmo se encuentra una
instrucción para la variable de control(contador) toma el valor inicial, se verifica que el valor inicial no sobrepase al
valor final y luego se ejecutan las instrucciones del ciclo. Al encontrar la instrucción fin para, se produce el incremento
y se vuelve a verificar que la variable de control no haya superado el límite admitido, y se vuelven a ejecutar las
instrucciones que están dentro del ciclo, y así sucesivamente tantas veces como sea necesario hasta que supere el
valor final establecido. El ciclo para termina en el momento en que la variable de control (Contador) sobrepasa el
valor final; es decir, que la igualdad está permitida y las instrucciones se ejecutan cuando el contador es igual al valor
final. Este ciclo puede presentarse de tres maneras: la primera es la más común cuando se produce un incremento
de 1 en cada iteración, en cuyo caso no es necesario escribir explícitamente.

En Pseudocódigo Para
variable= valor_inicial
hasta
valor_final
hacer
Bloque de instrucciones
Fin para
Imprimir los números del 5 al 50 con intervalos de 5.

Definición del problema


Imprimir números de cinco en cinco

Análisis del problema


Datos de entrada:
ninguno
Datos de salida:
números (5…50 )

Proceso:
Ninguno

Diseño de la solución
Pseudocódigo

INICIO
Entero:num
para
(num=5; num<=50; num=num+5)
escribir
(num)
fin para
FIN
En DFD

Dado un numero cualquiera determinar si es número primo

Definición del problema


Determinar si un número es primo

Análisis del problema


Se dice que un número es primo si solo es divisible enteramente para la unida (1) y para sí mismo. Con base en este
criterio, se trata de demostrar que el número en cuestión no es divisible para ningún número menor a este y mayor
a 1, en caso de encontrarse un caso de división exacta, la posibilidad de que sea número primo queda descartada.

Datos de entrada:
numero
Datos de salida:
mensaje“numero primo”o“numero no primo”

Proceso:
r=numero mod i (i: 2…. -1)
INICIO
Entero:num, i, r
Logico:sw=1
Escribir(“Ingrese número”)
Leer
(num)
Para
(i=2; i<=num-1 ; i++)r= num mod i
Si
r=0
entonces
Sw= 0
Fin si
Fin para
Si(sw=1) Entonces
Escribir(“El número es primo”)
Si no
Escribir(“El número no es primo”)
Fin
siFIN