Está en la página 1de 3

EJERCISIOS DE ALGORITMOS

1)

Proceso suma_tres_numeros
Definir x,y,z,p como entero
Escribir ”ingrese tres números:”;
Leer x1
Leer x2
Leer x3
P x+y+z
Escribir “El resultado es :“; P
Finproceso
2)
Proceso promedio
Definir x,y,z,R, como real
Escribir “Ingrese los tres promedios:”;
Leer x
Leer y
Leer z
R(x+y+z)/3
Escribir “El promedio es:”;R;
3)
Proceso Area_triangulo
Definir
Escribir “Ingrese la base:”;
Leer b
Escribir “ingrese la altura:”;
Leer h
Area(b*h)/2
Escribir “El resultado es:”; Area;
Finproceso
4)
Proceso Descuento
Definir x,P como real
Escribir “Ingrese el precio del artefacto:”;
Leer x
P 0,25 /X
Escribir “El precio es :“;P
Finproceso
5)
Proceso_promedio_algoritmo
Definir “a,b,c,d,P como real
Escribir “Ingrese los promedios:”;
Leer a
Leer b
Leer c
Leer d
P(0,2*a)+(0,2*b)+(0,2*c)+(0,2*d)
Escribir “tu promedio es:”;P;
Finproceso
6)
Proceso Ahorro_mesual
Defiinir p,m,como real
Escribir "Ingrese la cantidad que tiene mesualmente:";
Leer P
M500/P
Escribir"Mensualmete recibe:";M;
Finproceso
7)
Proceso Raiz_cuadratica
Definir a,b,c,R1,R2 como real
Escribir"ingrese la variables:";
leer a,b,c
R1b-Rc((b*b)-(4*a*c))/2a
R2b-Rc((b*b)-(4*a*c))/2a
escribir "las raices son:";R1;R2;
Finproceso
8)
Proceso Banco
Definir c,p como real
Escribir "ingrese el monto de la capital:";
Leer c
P0,02*c
Escribir " Usted gana:";P;
Finproceso
9)
Proceso Porcentual
Definir Cm ,Cn,como real ,PM, Pn ,t como real
Escribir "ingrese la cantidad de M y n:";
leer Cm,Cn
Pmcm/t
Pncn/t
tpm+pn
Escribir"el total es:";T
Fiproceso
10)
proceso Triangulo_Equilatero
Definir h ,
Escribir" indique la altura :";
leer h
Escribir"
H