Está en la página 1de 15

Programación Funcional

Función: Una función es un bloque de código que ejecuta determinadas


acciones de forma independiente al programa principal.

Modulo: Principal
Var
Declaración de variables
Inicio
Acción (opcional)
Llamada a la Función1
Acción (opcional)
Fin_Principal

Modulo: Funcion1
Accion1
Accion2
.
.
.
Retorno(A la función donde fue llamada)

Ejemplo:

Pseudocódigo que permita visualizar el mensaje “HOLA”, utilizando una función


para la visualización de dicho mensaje.

Modulo: Principal
Inicio
Llama: VISUALIZA

Fin_Principal

Modulo: VISUALIZA

Escribir “Hola”

Retorno_Principal

Algoritmo ‘Conversiones_Fahrenheit_a_Celcius’

1
Modulo: Principal
Var
Tc,tf:Real
Inicio
Escribir “Da grados farenheit”
Leer tf
Llama: CONVERSIÓN_GRADOS
Escribir”Conversión a grados Celcius”,Tc

Fin_Principal

Modulo: CONVERSIÓN_GRADOS

Tc(5/9)*(tf-32)

Retorno_Principal

Algoritmo ‘Conversiones_Fahrenheit_a_Celsius_V2’
Modulo: Principal
Var
Tc,tf:Real
Inicio

Llama: CONVERSIÓN_GRADOS

Fin_Principal

Modulo: CONVERSIÓN_GRADOS

Escribir “Da grados farenheit”


Leer tf
Tc(5/9)*(tf-32)
Escribir”Conversión a grados Celcius”,Tc

Retorno_Principal

2
Algoritmo ‘Calculo_Sueldo_Porcentajes’
Modulo: Principal
Var
S,porcent:Real
Inicio
Escribir”Solicitar Sueldo”
Leer S
Llama: Calculo_sueldo

Escribir”Calculo del sueldo por el 30%”,porcent

Fin_Principal

Modulo: Calculo_sueldo

porcent S*.30

Retorno_Principal

3
Algoritmo ‘EDADES’
Modulo: Principal
Var
Edad:Entero
Inicio
Llama:Introducir
Llama:Mensajes

Fin_Principal

Modulo: Mensajes

Si Edad>80 Entonces
Escribir”Persona sabia”,Edad
Sino
Escribir”Todavía tienes muchos años por delante”,Edad
Retorno_Principal

Modulo: Introducir

Escribir “Dar edad”


Leer Edad

Retorno_Principal

4
Algoritmo ‘Menus’
Modulo: Principal
Var
opcion:Entero
Inicio
Llama: Menu
Llama: Elegir

Fin_Principal

Modulo: Menu
Escribir ”Menu de opciones”
Escribir ”1)Suma”
Escribir ”2)Resta”
Escribir ”3)Multiplicacion”
Escribir “4)Division”
Retorno_Principal

Modulo: Elegir
Escribir “Da tu opcion”
Leer opcion
Escribir “Tu opcion que elegiste es”,opcion
Retorno_Principal

5
Algoritmo ‘Menus2’
Modulo: Principal
Var
opcion:Caracter
Inicio
Llama: Menu
Llama: Elegir

Fin_Principal

Modulo: Menu
Escribir ”Menu de opciones”
Escribir ”+)Suma”
Escribir ”-)Resta”
Escribir ”*)Multiplicacion”
Escribir “/)Division”
Retorno_Principal

Modulo: Elegir
Escribir “Da tu opcion”
Leer opcion

Retorno_Principal

6
Algoritmo ‘Menus3_oper’
Modulo: Principal
Var
opcion:Carácter
R,N1,N2:Entero
Inicio
Llama: Menu
Llama: Elegir

Fin_Principal

Modulo: Menu
Escribir ”Menu de opciones”
Escribir ”+)Suma”
Escribir ”-)Resta”
Escribir ”*)Multiplicacion”
Escribir “/)Division”
Retorno_Principal

Modulo: Elegir
Escribir “Da tu opcion”
Leer opcion
Si opcion=’+’ Entonces
Escribir ”Da primer numero:”
Leer N1
Escribir “Da segundo numero”
Leer N2
RN1+N2
Escribir “Suma”,R
Sino
Si opcion=’-’ Entonces
Escribir ”Da primer numero:”
Leer N1
Escribir “Da segundo numero”
Leer N2
RN1-N2
Escribir “Resta”,R
Sino
Si opcion=’*’ Entonces
Escribir ”Da primer numero:”
Leer N1

7
Escribir “Da segundo numero”
Leer N2
RN1*N2
Escribir “Multiplicacion”,R
Sino
Si opcion=’/’ Entonces
Escribir ”Da primer numero:”
Leer N1
Escribir “Da segundo numero”
Leer N2
RN1/N2
Escribir “Division”,R
Fin_si
Fin_si
Fin_si
Fin_si
Retorno_Principal

8
Algoritmo ‘Menus3_oper’
Modulo: Principal
Var
opcion:Carácter
R,N1,N2:Entero
Inicio
Llama: Menu
Llama: Elegir

Fin_Principal

Modulo: Menu
Escribir ”Menu de opciones”
Escribir ”+)Suma”
Escribir ”-)Resta”
Escribir ”*)Multiplicacion”
Escribir “/)Division”
Retorno_Principal

Modulo: Elegir
Escribir ”Da primer numero:”
Leer N1
Escribir “Da segundo numero”
Leer N2

Escribir “Da tu opcion”


Leer opcion

Si opcion=’+’ Entonces
RN1+N2
Escribir “Suma”R
Sino
Si opcion=’-’ Entonces
RN1-N2
Escribir “Resta”R
Sino
Si opcion=’*’ Entonces
RN1*N2
Escribir “Multiplicacion”R
Sino
Si opcion=’/’ Entonces

9
RN1/N2
Escribir “Division”R
Fin_si
Fin_si
Fin_si
Fin_si
Retorno_Principal

10
Funciones con Pase de Parámetros

Las variables pueden ser declaradas de tres formas.


Forma 1: Como variables globales las cuales se declaran ANTES del inicio y su
valor puede ser utilizado en todo el pseudocódigo (todas las funciones).
Forma 2: Como variables locales las cuales se declaran después del inicio o
dentro de cada función y su valor sólo se puede utilizar en la función donde fue
declarada.

Modulo: Principal
Inicio Declaración
Var local
x:Entero
x5
Llama: Reporte

Fin_Principal

Modulo: Reporte x no vale nada


solo se utiliza
Inicio en principal
Escribir x

Retorno_Principal

11
Forma 3: Como pase de parámetros los cuales inmediatamente después del
nombre del módulo encerradas entre paréntesis.

Modulo: Principal
Inicio Declaración
Var local
x:Entero
x5
Llama: Reporte(x)

Fin_Principal

Modulo: Reporte(x:Entero) x no vale nada


solo se utiliza
Inicio en principal
Escribir x
Retorno_Principal

Ejercicio: Pseudocódigo que permite leer un número y determinar cuantos


números pares han dicho número.

Nota: la lectura del número se hará en el módulo principal y la determinación de


cuantos números pares tiene será en una función a parte.

Modulo: Principal
Inicio Declaración
Var local
Num:Entero

Escribir “Numero”
Leer Num

Llama: Pares(Num)

Fin_Principal
Parámetro
Modulo: Pares(Num:Entero)
Inicio
Var
CP:Entero
CP(N DIV 2)+1

12
Escribir “Total de dígitos pares”,CP
Escribir “Del numero”,N
Retorno_Principal

Tarea: Escribir “total de dígitos pares” visualizarlo en el modulo principal.

Modulo: Principal Declaración


Var global
CP:Entero
Inicio Declaración
Var local
Num:Entero

Escribir “Numero”
Leer Num

Llama: Pares(Num)
Escribir “Total de dígitos pares”,CP

Fin_Principal

Modulo: Pares(Num:Entero)
Inicio

CP(Num DIV 2)+1


Escribir “Del numero”,Num
Retorno_Principal

13
Modulo: Principal
Var
opc:Entero
Inicio
Llama:Menu
Llama:Escoge

Escribir”Elegiste”,opc

Fin_Principal

Modulo: Menu
Escribir”Menu Principal”
Escribir”1)Suma”
Escribir”2)Resta”
Escribir”3)Multiplicación”
Escribir”4)División”
Retorno_Principal

Modulo: Escoge

Escribir”Dar opción”
Leer opc

Retorno_Principal

14
Modulo: Principal
Var
opc:Entero
Inicio
Llama:Menu
Llama:Escoge

Escribir”Elegiste”,opc

Fin_Principal

Modulo: Menu
Escribir”Menu Principal”
Escribir”1)Suma”
Escribir”2)Resta”
Escribir”3)Multiplicación”
Escribir”4)División”
Retorno_Principal

Modulo: Escoge

Escribir”Dar opción”
Leer opc

Retorno_Principal

15