Está en la página 1de 5

Pontificia Universidad Católica de Chile

Escuela de Ingeniería
Departamento de Computación

Ejercicios
CURSO : Introducción a las Aplicaciones Computacionales (IIC1062 sección 1)
PROFESORA : Marcia Barrera Briceño (mbarrerb@uc.cl)

TAREA 2
Válida por 0,5 puntos para la I-1

 Baje el archivo Excel “TAREA 2” de la plataforma Siding y guárdelo con sus apellidos y
nombre como nombre del archivo. Ejemplo: Barrera Marcia.xlsx
NO ESTA EN SIDING, SE DESCARGÓ EN WEBCURSO POR PROBLEMAS!
 La primera hoja debe tener tamaño carta, márgenes estrechos y estar en orientación
horizontal. (configurar página)
 El encabezado debe tener el nombre del archivo y el pie de página debe tener el número
de página. (Vista > Diseño de página > Herramientas “específicas”)

Filtro avanzado
1. Se encuentra en Datos > Ordenar y filtrar. Es útil cuando queremos saber cuáles datos
cumplen un criterio dado.
OJO, FILTROS SOLO AGARRAN Y, NO O.
COPIO EN OTRO LUGAR PARA TENER RESPALDO DEL ORIGINAL
SELECCIONO SHIFT CTRL ABAJO Y AL LADO
EL RANGO DE CRITERIOS ES UN CONJUNTO DE PARES DONDE ESTA EL NOMBRE DEL CRITERIO Y UN
VALOR, EL PRIMERO ES IDENTICO AL NOMBRE DE UNA DE LAS COLUMNAS; LOQUE HACE ES
COPIUARLO MAS ABAJO!

a. Muestre una nueva lista con los estudiantes que trabajan.


b. Muestre una nueva lista con los estudiantes que trabajan y NO tienen beca.
c. Muestre una nueva lista con los estudiantes que TIENEN beca.
=">"&0
>0 es lo mismo a la anterior, pero como atrás es mejor acostumbrarse.

1
d. Muestre una nueva lista con los estudiantes que trabajan y tienen beca
Funcionario o Excelencia académica. En este caso, los criterios tienen 2 filas y 2
columnas: las columnas indican “Y”, las filas indican “O”.
LOS “O” SE PONEN HACIA ABAJO CADA UNO O

Funciones lógicas
2. Podemos tener búsquedas por criterios más específicos y que permiten realizar acciones
dependiendo del resultado (funciones SI(), O() e Y() y operadores de comparación:
> mayor que; >= mayor o igual que; = igual que; <> distinto de; < menor que; <=menor o igual que)
a. En una nueva columna, indique “Tiene beca”, si el Código de Beca es distinto a cero, y
“Sin beca”, en otro caso.
=SI(E18<>0;”TIENE BECA”) *lo mejor es entenderlo así!
BROCHA COPIA FORMATO DE ORIGEN AL DE DESTINO.
PARA NO ARRASTRAR PUEDO PEGAR APRETANDO DOBLE CLICK
b. En una nueva columna, indique “Novato(a)” si el estudiante está en el semestre 1 o 2.
“” significa celda en blanco
=SI(O(H5=1;H5=2);”Novato (a)”;””)
c. En una nueva columna, indique “Novato(a)” si el estudiante está en los semestres 1 o
2, y “Por egresar”, si está en el semestre 10.
3 argumentos, el primero es valor lógico de si es verdadero, el segundo es preguntar y
el tercero es que hacer en caso de que sea falso (si es que no era uno o dos y a edmas
es igual a 10 le pone egresear y si no es as es nada)
=SI(O(H5=1;H5=2);"novato(a)";SI(H5=10;"Por egresar";""))
d. En una nueva columna, indique “Novato primer ingreso”, si la edad es menor o igual
que 18 y el semestre es 1 o 2. Parametrice la edad, de modo que sea posible indicar
otra edad.
*parametrizar es comparar con un dato fijo.
Solicitar función.
=SI(Y(O(H5=1;H5=2);G5<=18);"novato(a) primer ingreso";" ")
JUEGO NUEVO:
=SI(Y(O(H5=1;H5=2);G5<=$N$2);"novato(a) primer ingreso";" ")

e. Extra: el texto “Por egresar” debe mostrarse dinámicamente en negritas verdes.

2
Nombres de rangos y administrador de nombres
3. Asigne el nombre “Edad” al rango de celdas que contiene las edades (rango columna).
Calcule el promedio de edades utilizando el rango “Edad”. Practique con el máximo,
mínimo y suma de las edades.
Botón derecho y le pongo definir nombre, esto me permite calcular sólo digitando un
nombre.
=promedio(edad)+5
=promedio(edad)+g3 (no es un parametro, si arrastrase la celda g3 iria cambiando)
=promedio(edad)+$g$3
4. Abra el Administrador de nombres y observe su contenido. Note que aparecen los rangos
seleccionados por Ud. en la parte a. y los seleccionados por Excel para marcar la fila de la
tabla que se repite en cada página.
5. Calcule, en otra celda, el promedio más 5 años, usando el rango “Edad”. Parametrice los
años que se suman al promedio, de modo que se pueda cambiar de 5 años a cualquier
otro número.

Función Buscarv()
6. Sirve para mostrar los valores que corresponden a los códigos que puedan usarse en una
tabla. Por ejemplo: Una tabla de direcciones tiene las columnas calle, número,
villa/población, comuna. Tenemos los dos casos siguientes:
 Sin código de comuna
Tabla Direcciones: podría tener variadas denominaciones para la comuna.
Calle Las Hortensias; 45; Las Flores; P.Alto
Calle Las Hortensias; 45; Las Flores; Puente Alto
Calle Las Hortensias; 45; Las Flores; Pte. Alto
Calle Las Hortensias; 45; Las Flores; Pte Alto

 Con código de comuna


Tabla comunas:
1 Angol

32 Puente Alto

Tabla Direcciones: solo hay una posibilidad para la comuna.


Calle Las Hortensias; 45; Las Flores; 32

La función Buscarv() sirve para mostrar cuál es el valor que representa el código.

Buscar v tiene 4 argumentos, el 4to es opcional.

3
El primero es cual estoy buscando, el siguiente es donde, matriz buscarv es un rango def por
referencias absolutas o un nombre (rango de preferencias absolutas).
Verdadero, con rep
Falso, sin rep
=BUSCARV(D5;carrera;5;FALSO)
El d5 es la primera columna, match de l que debe coincidir con lo que busco (la llave esta al
principio de la tabla.
Si fuese traspuesto pondría buscarh
7. Use la tabla del ejercicio para mostrar:
a. ¿Cuál es el nombre de la carrera de cada estudiante?
b. ¿Cuál es el arancel UC de la carrera de cada estudiante?
Arancel anual es el UC
=BUSCARV(D5;carrera;8;FALSO)
Le puedo chantar el símbolo peso en la cinta debajo de general.
c. Algunos estudiantes tienen beca, ¿cuál es el nombre de la beca?
=SI(E5>0;BUSCARV(E5;beca;2;FALSO);" ")
Ojo cuando formula la pregunta!
8. Podemos tener búsquedas “anidadas” (también llamadas “recursivas”), que corresponden
a llamar funciones dentro de otra función.
a. ¿Cuál es el monto real a pagar por cada estudiante?
=SI(E7=0;P7;SI(E7=0;P7*(100%-BUSCARV(Estudiantes!E7;beca;3;FALSO));" "))
Ojo, no usa todos los valores xq no calcula para cada beca! (faltan, igual es un chorizo
maoma)
¿En qué campus se ofrece la carrera de cada estudiante?
=buscarv(d5;carrera;4;falso)

Función CONTAR.SI.CONJUNTO()
Cuando queremos contar valores que cumplen un criterio: CONTAR.SI()
Cuando queremos contar valores que cumplen más de un criterio: CONTAR.SI.CONJUNTO()
9. ¿Cuántos estudiantes hay por cada campus?
Primero requiero nueva tablita!
Primero copio datos, voy a pestaña datos y elimino duplicados, luego los ordeno
alfabéticamente.

4
Luego
=CONTAR.SI(S5:S36;V5)
=CONTAR.SI(todosloscampus;V5)
 Criterio: campus. Necesitamos obtener la lista de campus diferentes (Datos > Quitar
duplicados).
a. Contar si los valores de un conjunto cumplen un criterio (en este caso, pertenecer
a un campus) usando referencias absolutas y, luego, asignando un nombre al
rango.
10. Exprese lo anterior como porcentaje del total de estudiantes (recuerde cuándo usar
referencias relativas y cuándo referencias absolutas)
Recordar fijar parámetros como referencias absolutas con $
11. ¿Cuál es el porcentaje de estudiantes que trabaja, por campus?
=CONTAR.SI.CONJUNTO(todosloscampus;V13;f5:f6;W12)
*oo con diferencias!
=CONTAR.SI.CONJUNTO(todosloscampus;V13;trabaja;$W$12)
Ahora para los que no trabajan
=CONTAR.SI.CONJUNTO(todosloscampus;V13;trabaja;$X$12)