Está en la página 1de 5

1.

Introduction

Each hardware model of Oracle Solaris has a life time and support time; they are
named as �End of Life� and �End of Support� by the vendor. After those time limits
vendor won�t provide support to that particular hardware model and the OS.

Users are in a position to upgrade their hardware to the recent one which will
support only Oracle Solaris 10 / 11 runtime environments, but unfortunately there
application may not work the OS environment.

BrandZ provides the framework to create branded zones, which are used to run
applications that cannot be run in an Oracle Solaris 10 / Oracle Solaris 11
environment. This helps the user to run their application on latest hardware with
Solaris 8 / Solaris 9 Operating system.
BrandZ is a framework that extends the Solaris Zones infrastructure to create
Branded Zones, which are zones that contain non-native operating environments. The
term "non-native" is intentionally vague, as the infrastructure allows for the
creation of a wide range of operating environments.
Each operating environment is provided by a brand that plugs into the BrandZ
framework. A brand may be as simple as an environment with the standard Solaris
utilities replaced by their GNU equivalents, or as complex as a complete Linux
userspace.
BrandZ extends the Zones infrastructure in user space:
A brand is an attribute of a zone, set at zone create time
Each brand provides its own installation routine, which allows us to install an
arbitrary collection of software in the branded zone.
Each brand may provide pre/post-boot scripts that allows us to do any final boot-
time setup or configuration.
The zoneadm and zonecfg tools can set and report a zone's brand type.
BrandZ provides a set of interposition points in the kernel:
These points are found in the syscall path, process loading path, thread creation
path, etc.
At each of these points, a brand may choose to supplement or replace the standard
Solaris behavior.
These interposition points are only applied to processes in a branded zone
Fundamentally different brands may require new interposition points
Although all zones on the system share a common kernel, an additional feature set
has been added called branded zones (BrandZ for short). This allows individual
zones to behave in a manner other than the default brand of the global zone. The
existing brands (October 2009) can be grouped into two categories:
brands which do not perform system call translation:
'native' is the default for Solaris 10
'ipkg' is the default for OpenSolaris
'cluster' is used for Solaris Cluster zones
'labeled' is used for zones in a Solaris Trusted Extensions environment

brands which perform system call translation:


'solaris8' provides a Solaris 8 environment on a Solaris 10 system, including
translation from Solaris 8 system calls to Solaris 10 system calls (available only
on SPARC systems)
'solaris9' provides a Solaris 9 environment on a Solaris 10 system, including
translation from Solaris 9 system calls to Solaris 10 system calls (available only
on SPARC systems)
'lx' provides a Red Hat Enterprise Linux 3 environment on a Solaris 10 system,
including translation from RHEL 3 system calls to Solaris 10 system calls
(available only on x86 systems)
's10brand' provides a Solaris 10 environment on an OpenSolaris or Oracle Solaris 11
system, including translation from Solaris 10 system calls to OpenSolaris/Oracle
Solaris 11 system calls
1.1 Intended Audience of the Document

Learning and Development


Location IDM Teams
Remote Management Teams
IDM Heads
TCS Management
Internal and External Auditors after the Final Approval

1.2 Stake Holders

Stake Holder
Responsible
Chennai Unix Team
Owner for this Documentation process
IDM Heads & ISM
Approval and Authorization
Local IDM Team
End users
TCS Management
Approval and Authorization

1.3 Definitions and Acronyms

The definitions and acronyms that are used in the document are
Acronym
Description
ACL
Access Control List
CR
Change Request
GL
Infrastructure Services
IS
Infrastructure Services
ISC
Information Security Coordinator
ISM
Information Security Manager
OS
Operating system
PL
Project leader
SCH
Solution Center Head
SDO
Service Delivery owner
SP
Service Practice
TCS
Tata consultancy Services

1.4 Contact Information


Role
Name
Email-id
Landline
Mobile
RMT Team Lead
Madhankumar P
madhankumar.p@tcs.com
66163939
9282241217
RMT Server Team
Server Administrators
chennai.unix@tcs.com
66163969
66163979
9282241217

2. Pre-Requirements

Branded zone can be only created on Oracle Sun SPRAC servers with Solaris 10 or
Solaris 11 running on it.
We need to install the below packages on the Solaris server
SUNWs8brandr ? Solaris 8 Containers: solaris8 brand support (Root)
SUNWs8brandu ?Solaris 8 Containers: solaris8 brand support (Usr)
SUNWs9brandr ? Solaris 9 Containers: solaris9 brand support (Root)
SUNWs9brandu ? Solaris 9 Containers: solaris9 brand support (Usr)
All the above 4 packages are comes with Solaris 10 DVD itself, we can install this
from the OS media.
Additionally we need 2 more packages to create branded zones on a solaris services
which can be downloaded from
https://edelivery.oracle.com/ ? With a valid Oracle support Login ID
Additional Packages as below:
SUNWs9brandk ? Solaris 9 Containers: solaris9 brand support RTU
SUNWs8brandk ? Solaris 8 Containers: solaris8 brand support RTU
3. Installation Procedure

Copy all the packages to the server where you are going to create branded zones,
Run the commands from the directory where you have all the packages
# pkgadd �d /path_to_install .
��.
���
Installation of < SUNWs9brandu> was Successful.
Similar way you will get console messages for each package which gets
installed on it.
After the installation gets completed, please check it by
# pkginfo |grep -i brand
system FJSVs8brandr FUJITSU Solaris 8 Containers: solaris8
brand support (Root)
system FJSVs9brandr FUJITSU Solaris 9 Containers: solaris9
brand support (Root)
system SUNWs8brandr Solaris 8 Containers: solaris8 brand
support (Root)
system SUNWs8brandu Solaris 8 Containers: solaris8 brand
support (Usr)
system SUNWs9brandk Solaris 9 Containers: solaris9 brand
support RTU
system SUNWs9brandr Solaris 9 Containers: solaris9 brand
support (Root)
system SUNWs9brandu Solaris 9 Containers: solaris9 brand
support (Usr)

4. Branded Zone Creation


Before going to create the branded zones, make sure you have the respective OS flar
images, which is available on https://edelivery.oracle.com/ web site.

Branded zone creation as below :

global# zonecfg -z sol9-zone1


zonecfg:sol9-zone1> create -t SUNWsolaris9
zonecfg:sol9-zone1> set zonepath=/export/home/sol9-zone1
z onecfg:sol9-zone1> set autoboot=true
zonecfg:sol9-zone1> add net
zonecfg:sol9-zone1:net> set address=172.x.x.x
zonecfg:sol9-zone1:net> set physical=eri0
zonecfg:sol9-zone1:net> end
zonecfg:sol9-zone1>exit

For checking the list of available zones


# zoneadm list -cv
ID NAME STATUS PATH BRAND IP
0 global running / native shared
- sol9-zone1 incomplete /export/home/zones/solaris9 solaris9 shared
Here, the global zone represents the base OS running on the servers. And sol9-zone1
is the solaris 9 branded zone which we created above.

5. Branded Zone Installation

After creating the zone configuration the next to install solaris 9 / 8 on it. The
OS installation will be done by pushing the flar images.
Locate the solaris 9 flar image, let�s assume it�s available in the path
/export/home/solaris9-image.flar

Install the Zone by


# zoneadm -z sol9-zone1 install -u -a /export/home/solaris9-image.flar
Log File: /var/tmp/sol9-zone1.install.11913.log
Source: /export/home/solaris9-image.flar
Installing: This may take several minutes...
Postprocessing: This may take several minutes...
Result: Installation completed successfully.
Log File: /export/home/zones/solaris9/root/var/log/sol9-zone1.install.11913.log
We will get the console messages as above, during the zone installation

Now, when you run the zone list command, the status will be changed to installed
from incomplete
# zoneadm list �cv
ID NAME STATUS PATH BRAND IP
0 global running / native shared
- sol9-zone1 installed /export/home/zones/solaris9 solaris9 shared
5.1 Starting the zone
Once the zone creation and installation is completed, we can start the zone
by
# zoneadm -z sol9-zone1 boot
5.2 Stopping the Zone
# zoneadm -z sol9-zone1 halt
5.3 Uninstalling the Zone
If we feel to remove any zone, which is not required for us, then first halt
the zone and then run the below
# zoneadm -z <zonename> uninstall
# zoneadm -z <zonename> delete
This will permanently remove the zone from the server

También podría gustarte