Está en la página 1de 4

Jailer Polo

Universidad Americana
Fundamentos de Programación
Algoritmo 1.
escribir "ingrese los 8 digitos"

leer adjunto

anios<-adjunto/10000

aniosd<-trunc(anios)

mesesp<-trunc(anios)*10000

mesesp1<-adjunto-mesesp

meses<-mesesp1/100

mesesd<-trunc(meses)

diasp<-trunc(meses)*100

dias<-mesesp1-diasp

segun mesesd hacer

1: escribir dias,"-Enero-",aniosd

2: escribir dias,"-Febrero-",aniosd

3: escribir dias,"-Marzo-",aniosd

4: escribir dias,"-Abril-",aniosd

5: escribir dias,"-Mayo-",aniosd

6: escribir dias,"-Junio-",aniosd

7: escribir dias,"-Julio-",aniosd

8: escribir dias,"-Agosto-",aniosd

9: escribir dias,"-Septiembre-",aniosd

10: escribir dias,"-Octubre-",aniosd

11: escribir dias,"-Noviembre-",aniosd

12: escribir dias,"-Diciembre-",aniosd

FinSegun

FinAlgoritmo
Jailer Polo
Universidad Americana
Fundamentos de Programación
Algoritmo 2.
//Se requiere construir un algoritmo que permita imprimir el valor que

//debe pagar el huésped de un hotel, sabiendo que las habitaciones del

//mismo son de tres tipos y los valores, por noche, son los siguientes:

// Los precios son por persona.

//Adicionalmente el hotel está ofreciendo una promoción a sus clientes,

//la cual consiste en que si se realiza una reserva por más de 3 noches se le

//otorga un descuento del 15% sobre el valor total.

escribir "digite su nombre"

leer nombre

escribir "digite la cantidad de personas que se hospedaran en el hotel"

leer pers_hot

escribir "digite cuantas noches quiere hospedarse en el hotel"

leer no_hotel

escribir "digite el costo de cada noche por persona"

leer costo

sum<-(pers_hot*costo)*no_hotel

si no_hotel>=3 entonces

total_des<-sum*0.15

total_pagar<-sum-total_des

escribir "señor ",nombre ," el total a pagar con el descuento es: ",total_pagar

SiNo

si no_hotel<3 entonces

total_pagar<-sum

escribir "señor ",nombre ," el total a pagar es: ",total_pagar

FinSi

FinSi

FinAlgoritmo
Jailer Polo
Universidad Americana
Fundamentos de Programación
Algoritmo 3.
//Se necesita un construir un algoritmo que de tres opciones al usuario, si

//se selecciona la primera se calcula el área de un rectángulo; si la opción

//es la dos se calcula el área de un triángulo y cuando se elija la tres se

//calcula el área de un círculo (?? = ????

//(Nota: la opción ingresada por el

//usuario debe ser un número entero). En cualquier otro caso, se debe

//mostrar un mensaje de error. En casa caso, debe solicitar la información

//necesaria para realizar el cálculo correspondiente.

Escribir "para calcular el area de un rectangulo marque la opcion 1"

escribir "para calcular el area del triangulo marque la opcion 2"

Escribir "para calcular el area de un circulo marque la opcion 3"

escribir "elija la opcion"

leer calc

segun calc hacer

1:

escribir "a elegido calcular un rectangulo"

escribir "digite la base del rectangulo"

leer base

Escribir "digite la altura del rectangulo"

leer altura

area<-base*altura

escribir "el area del rectangulo es: ",area

2:

escribir "a elegido calcular un triangulo"

escribir "digite la base del triangulo"

leer base
Jailer Polo
Universidad Americana
Fundamentos de Programación
escribir "digite la altura del triangulo"

leer altura

area<-(base*altura)/2

escribir "el area del triangulo es: ",area

3:

escribir "a elegido calcular un circulo"

escribir "digite el radio"

leer radio

area<-PI*radio^2

escribir "el area del circulo es: ",area

FinSegun

FinAlgoritmo