Está en la página 1de 7

INCISO A

1. Dibujar el borde de un rectángulo en sentido horario, que mida 200 unidades de lado.
Codigo:
av 200
gd 90
av 400
gd 90
av 200
gd 90
av 400

2. Dibujar el borde de un triángulo equilátero en sentido antihorario, que mida 150 unds de lado.
Codigo:
gi 30
av 150
gi 60
gi 60
av 150
gi 120
av 150

3. Dibujar el borde de un cuadrado de centro el centro de pantalla, puede emplear la instrucciones


repite.

4. Dibujar el borde de un hexágono regular y rellénelo.


Código:
gd 30
av 150
gi 60
av 150
gi 30
gi 30
av 150
gi 60
av 150
gi 60
av150
av 150
gi 60
av150
av 150
gi 90
sl av 5
poccr 6 rellena

5. Dibujar el borde de un octágono regular, haciendo uso de Repite. Rellene su interior de color
azul.
Código:
para octagono
gd 90
av 150
repite 7[gi 45 av
150]
gi 135
sl av 10
bl
poccr 1 rellena
fin

6. Dibujar un rectángulo rellenando su interior, color libre


Código:
para
rectángulo
av 200
gd 90
av 400
gd 90
av 200
gd 90
av 400
gd 110
sl
av 5
poccr 5
rellena
fin

7. Dibujar los
radios de una
rueda con 4 radios. Tips emplee la formula 𝑙𝑙𝑙𝑙𝑙𝑙𝑙𝑙=2𝑙𝑙 donde r es radio.
8. Dibujar los radios de una rueda con 8 radios.
9. Dbujar los radios de una rueda con 24 radios. Se hace de uno a uno hasta llegar a 24

INCISO B
Los siguientes ejercicios deben ser resueltos nombrando procedimientos.
1. Procedimiento triangulo, que dibuje el borde de un triángulo equilátero, y rellene de color naranja.

2. Procedimiento hexágono, que dibuje el borde de un hexágono regular y lo rellene color libre
3. Procedimiento que dibuje una colección de hexágonos regulares con un vértice común, cada uno de
ellos girado 60 grados respecto del anterior.
CODIGO:
para hexagono
gi 30
av 100
repite 5 [gd 60 av 100]
gi 60
av 100

repite 5[gd
60 av 100]
gi 60
av 100
repite 4[gd 60 av 100]
fin
4. Procedimiento que dibuje y llerene un semi –cículo considere la formula 𝑙𝑙𝑙𝑙=𝑙𝑙2

5. Procedimiento triángulo, que dibuje un triángulo equilátero de lado L.

Codigo
para
triangulo
gd 90
av 200
repite 2[gi
120 av
200]
fin

7. Procedimiento bandera, que dibuje una bandera consistente en un mástil de longitud L y cuya
tela sea rectangular de lados A y B.(debe rellenarla de color)

INCISO C
Realice las siguientes figuras.
Codigo para Casa:

gi 90
sl
av 400
gd 90
bl
av 200
gd 90
av 600
gd 90
av 200
gd 90
av 600
gd 180
av 200
gi 90
av 200
gi 30
av 200
gi 120
av 200
sl
re 200
bl
gd 150
gd 90
av 400
gd 30
gd30
No se
como
gd30
gd 30
av 200
sl
gd 30
av 50
bl
gd 90
av 50
gd 90
av 50
gi 90
sl
av 300
gi 90
av 50
re 50
bl
av 50
gd 90
av 50
sl
av 50
bl
av 80
gi 90
av 150
gi 90
av 80
gi 90
av 150
sl
gi 120
av 5
poccr 6 rellena
gd 120
av 75
poccr 4 rellena
gd 90
av 70
poccr 4 rellena
gd 90
av 50
poccr 1 rellena
gi 90
av 300
av 50
poccr 1 rellena
gi 120
gi 60
av 50
poccr 8 rellena
av 350
poccr 8 rellena