Está en la página 1de 20

Práctica de Laboratorio 1

Práctica 1.1.
Configuración de NAT

Router 2

Router 1

Objetivo
Configurar un router para que ejecute la traducción de direcciones de red (NAT) para convertir
las direcciones IP internas, normalmente direcciones privadas, en direcciones públicas
externas.
Información básica / Preparación

Un ISP ha asignado a una empresa la dirección IP pública de enrutamiento entre dominios sin
clase (CIDR) 199.99.9.32/27. Esto es equivalente a 30 direcciones IP públicas. Como la
empresa tiene la necesidad interna de más de 30 direcciones, el gerente de TI ha decidido
implementar NAT. Las direcciones 199.99.9.33 – 199.99.9.39 para la asignación estática y
199.99.9.40 – 199.99.9.62 para la asignación dinámica. El enrutamiento se realizará entre el
ISP y el router del gateway de la empresa. Se utilizará una ruta estática entre el ISP y los
routers de gateway y una ruta por defecto entre el router de gateway y el ISP. La conexión del
ISP a la Internet se representará con una dirección de loopback en el router del ISP.

Crea una red con un cableado similar al del diagrama anterior. Se puede usar cualquier router
que cumpla con los requisitos de interfaz que se muestran en el diagrama anterior. Esto
incluye los siguientes y cualquiera de sus combinaciones posibles:

• Routers serie 800


• Routers serie 1600
• Routers serie 1700
• Routers serie 2500
• Routers serie 2600
Consulta la tabla al final de esta práctica de laboratorio para identificar correctamente los
identificadores de interfaz que se deben usar según el equipo disponible en el laboratorio. Los
resultados de la configuración utilizados en esta práctica se obtuvieron con los routers serie
1721.
El uso de cualquier otro router puede producir unos resultados ligeramente distintos. Ejecuta
los siguientes pasos en cada router a menos que se le indique específicamente lo contrario.

Inicie una sesión de HyperTerminal.


Nota: Observa las instrucciones de borrar y recargar al final de esta práctica de laboratorio.
Realiza ese procedimiento en todos los routers asignados a esta práctica antes de continuar.

 Paso 1. Configurar los routers.


Configura todo lo siguiente según el cuadro:

• El nombre de host
• La contraseña de consola
• La contraseña de terminal virtual
• La contraseña enable-secret
• Las interfaces

Si se producen problemas durante esta configuración, observa la hoja de consulta de


configuración que aparece al final de esta práctica de laboratorio para obtener ayuda.

 Paso 2. Guardar la configuración.


En la petición de entrada del modo EXEC privilegiado, en ambos routers, escribe el comando
copy running-config startup-config.

 Paso 3. Configurar los hosts con la dirección IP, máscara de subred y gateway por
defecto correspondientes.
Cada estación de trabajo debe poder hacer ping al router conectado. Si el ping no tiene éxito,
haga un diagnóstico de fallas según sea necesario. Verifica que se hayan asignado una
dirección IP y un gateway por defectos específicos a la estación de trabajo. En Windows 98,
verifica mediante Inicio > Ejecutar > winipcfg. En Windows 2000 o superior, verifica mediante
ipconfig en una ventana de DOS.

 Paso 4. Verificar que la red esté funcionando.


a. Desde los hosts conectados, haga ping a la interfaz FastEthernet del router del gateway por
defecto.

b. ¿El ping desde el primer host tuvo éxito?


R= Si

c. ¿El ping desde el segundo host tuvo éxito?


R= Si

d. Si la respuesta a cualquiera de las dos preguntas es no, realiza un diagnóstico de fallas en el


router y en las configuraciones del host para descubrir el error. Haga ping de nuevo hasta que
ambos tengan éxito.

 Paso 5. Crear una ruta estática.


a. Crea una ruta estática desde el ISP al router del Gateway. Se han asignado las direcciones
199.99.9.32/27 para el acceso a Internet fuera de la empresa. Usa el comando ip route para
crear una ruta estática.
ISP(config)#ip route 199.99.9.32 255.255.255.224 200.2.2.18

b. ¿La ruta estática aparece en la tabla de enrutamiento?


R= Si
c. ¿Qué comando verifica el contenido de la tabla de enrutamiento?
R= Show ip route en modo enable
d. Si la ruta no se encuentra en la tabla de enrutamiento, escribe una razón por la cual podría
ser así.
R= Los protocolos están mal configurados o podría haber una mala configuración entre las ip
dinámicas y estáticas. O Simplemente la interfaz está desactivada.

 Paso 6. Crear una ruta por defecto.


a. Desde el router del Gateway al router del ISP, crea una ruta estática a la red 0.0.0.0 0.0.0.0,
mediante el comando ip route. Esto enviará cualquier tráfico destinada a una dirección
desconocida al ISP, estableciendo así un Gateway de Último Recurso en el router de Gateway.

Gateway(config)#ip route 0.0.0.0 0.0.0.0 200.2.2.17

b. ¿La ruta estática aparece en la tabla de enrutamiento?


R= Si
c. Intenta hacer ping desde una de las estaciones de trabajo a la dirección IP de la interfaz
serial del ISP.

d. ¿El ping fue exitoso?


R= No
e. ¿Por qué?
R= No hay ruta de regreso a la red 10.10.10.0

 Paso 7. Definir el conjunto de direcciones IP públicas utilizables.


Para definir el conjunto de direcciones públicas, utiliza el comando ip nat pool:
Gateway(config)#ip nat pool public-access 199.99.9.40 199.99.9.62
netmask 255.255.255.224

 Paso 8. Definir una lista de acceso que coincida con las direcciones IP privadas
internas.
Para definir la lista de acceso de modo que coincida con las direcciones privadas internas, usa
el comando access list:
Gateway(config)#access-list 1 permit 10.10.10.0 0.0.0.255

 Paso 9. Definir la traducción NAT de la lista interna al conjunto externo.


Para definir la traducción NAT, utiliza el comando ip nat inside source:
Gateway(config)#ip nat inside source list 1 pool public-access

 Paso 10. Especificar las interfaces.


Las interfaces activas en el router necesitan especificarse como interfaces internas o externas
con respecto al NAT. Para hacer esto, usa el comando ip nat inside o ip nat outside:
Gateway(config)#interface fastethernet 0
Gateway(config-if)#ip nat inside
Gateway(config-if)#interface serial 0
Gateway(config-if)#ip nat outside
 Paso 11. Probar la configuración.
a. Configura una de las PC de la LAN con la dirección IP 10.10.10.10/24 y la dirección del
Gateway por defecto de 10.10.10.1. Desde el PC, haga ping a 172.16.1.1. Si tiene éxito,
observa la traducción NAT en el router de Gateway, mediante el comando show ip nat
translations.

b. ¿Cuál es la traducción de las direcciones host locales interiores?


R= 10.10.10.10 = 199.99.9.40
c. ¿Quién asigna la dirección global interna?
R= El router en el conjunto nat
d. ¿Quién asigna la dirección local interna?
R= El administrador para la estación de trabajo.

Una vez completados los pasos anteriores, termina la práctica haciendo lo siguiente:
• Desconéctate escribiendo exit
• Apaga el router
• Quita y guarda los cables y el adaptador.

Práctica 1.2.

Configuración de PAT

Router 2

Router 1
Objetivo
Configurar un router para usar la traducción de direcciones de puerto (PAT) para convertir las
direcciones IP internas, normalmente direcciones privadas, en una dirección pública externa.
Información básica / Preparación
Aidan McDonald acaba de recibir una conexión de línea de Internet DSL a un ISP local en su
hogar. El ISP le ha asignado sólo una dirección IP, la cual se puede utilizar en el puerto serial
del dispositivo de acceso remoto. Por lo tanto, todas las PC de la LAN de Aidan, cada una con
su propia dirección IP privada, compartirá una dirección IP pública en el router por medio de
PAT. El enrutamiento desde el hogar o el router de gateway al ISP se logrará mediante una ruta
por defecto a Serial 0 del router de Gateway. La conexión del ISP a la Internet se representará
con una dirección de loopback en el router del ISP.

Crea una red con un cableado similar al del diagrama. Se puede usar cualquier router que
cumpla con los requisitos de interfaz que se muestran en el diagrama anterior. Esto incluye los
siguientes y cualquiera de sus combinaciones posibles:

• Routers serie 800


• Routers serie 1600
• Routers serie 1700
• Routers serie 2500
• Routers serie 2600

Consulta la tabla al final de esta práctica de laboratorio para identificar correctamente los
identificadores de interfaz que se deben usar según el equipo disponible en este laboratorio.
Los resultados de la configuración utilizados en esta práctica se obtuvieron con los routers
serie 1721. El uso de cualquier otro router puede producir unos resultados ligeramente
distintos. Ejecute los siguientes pasos en cada router a menos que se le indique
específicamente lo contrario.

Inicie una sesión de HyperTerminal.


Nota: observa las instrucciones de borrar y recargar al final de esta práctica de laboratorio.
Realiza ese procedimiento en todos los routers asignados a esta práctica antes de continuar.

 Paso 1. Configurar los routers.


Configura todo lo siguiente según el cuadro:
• El nombre de host
• La contraseña de consola
• La contraseña de terminal virtual
• La contraseña enable-secret
• Las interfaces

Si se producen problemas durante esta configuración, consulta la Práctica de Laboratorio Lab


1.1.4ª Configuración de NAT.

 Paso 2. Guardar la configuración.


En la petición de entrada del modo EXEC privilegiado, en ambos routers, escribe el comando
copy running-config startup-config.
 Paso 3. Configurar los hosts con la dirección IP, máscara de subred y gateway por
defecto correspondientes.
Cada estación de trabajo debe poder hacer ping al router conectado. Si el ping no tiene éxito,
haz un diagnóstico de fallas según sea necesario. Verifica que se hayan asignado una dirección
IP y un gateway por defectos específicos a la estación de trabajo. En Windows 98, verifica
mediante Inicio > Ejecutar > winipcfg. En Windows 2000 o superior, verifica mediante ipconfig
en una ventana de DOS.

 Paso 4. Verificar que la red esté funcionando.


a. Desde los hosts conectados, haz ping a la interfaz FastEthernet del router del gateway por
defecto.

b. ¿El ping desde el primer host tuvo éxito?


R= Si

c. ¿El ping desde el segundo host tuvo éxito?


R= Si

d. Si la respuesta a cualquiera de las dos preguntas es no, realiza un diagnóstico de fallas en el


router y en las configuraciones del host para descubrir el error. Entonces, haz ping de nuevo
hasta que ambos tengan éxito.

 Paso 5. Crear una ruta por defecto.


a. Agrega una ruta por defecto a la interfaz serial 0 del router del gateway. Esto enviará
cualquier tráfico de dirección de destino desconocido al ISP. Usa el comando ip route para
crear la ruta por defecto.
Gateway(config)#ip route 0.0.0.0 0.0.0.0 serial 0

b. ¿La ruta aparece en la tabla de enrutamiento?


R= Si

c. Intenta hacer ping desde una de las estaciones de trabajo a la dirección IP de la interfaz
serial del ISP.

d. ¿El ping fue exitoso?


R= No

e. ¿Por qué?
R= No hay ruta de regreso a la red 10.10.10.0

f. ¿Qué comando verifica el contenido de la tabla de enrutamiento?


R= Show ip route

 Paso 6. Definir una lista de acceso que coincida con las direcciones IP privadas
internas.
Para definir la lista de acceso de modo que coincida con las direcciones privadas internas, usa
el comando access list:
Gateway(config)#access-list 1 permit 10.10.10.0 0.0.0.255

 Paso 7. Definir la traducción PAT de la lista interna a la dirección externa.


Para definir la traducción PAT, utiliza el comando ip nat inside source. Este comando, con la
opción de sobrecarga, creará la traducción de direcciones de puerto con la dirección IP serial
0.
Como base:
Gateway(config)#ip nat inside source list 1 interface serial 0 overload

 Paso 8. Especificar las interfaces.


Es necesario especificar si las interfaces activas del router son interfaces internas o externas
con respecto a PAT. Para hacer esto, usa el comando ip nat inside o ip nat outside:
Gateway(config)#interface fastethernet 0
Gateway(config-if)#ip nat inside
Gateway(config-if)#interface serial 0
Gateway(config-if)#ip nat outside

 Paso 9. Probar la configuración.


a. Configura un PC de la LAN interna con la dirección IP 10.10.10.10/24 y el gateway por
defecto 10.10.10.1. Desde los PC, haz ping a la dirección de Internet 172.16.1.1. Si tiene éxito,
haz Telnet a la misma dirección IP. Entonces, observa la traducción PAT en el router de
gateway, mediante el comando show ip nat translations.

b. ¿Cuál es la traducción de las direcciones host locales interiores?


R= 10.10.10.10:1086
c. ¿Qué significa el número después de los dos puntos (:)?
R= El puerto que está siendo utilizado por NAT
d. ¿Por qué todos los comandos para PAT dicen NAT?
R= Porque PAT es una extensión de NAT

Una vez completados los pasos anteriores, termina la práctica haciendo lo siguiente:
• Desconéctate escribiendo exit
• Apaga el router
• Quita y guarda los cables y el adaptador.

Práctica 1.3.
Configuración de direcciones estáticas NAT

Router 2

Router 1
Objetivos
• Configurar un router para que ejecute la traducción de direcciones de red (NAT) para
convertir las direcciones IP internas, normalmente direcciones privadas, en direcciones
públicas externas.
• Configurar el mapeo IP estático para permitir el acceso externo a un PC interno.

Información básica / Preparación.


El ISP ha asignado a una empresa la dirección IP pública de enrutamiento entre dominios sin
clase (CIDR) 199.99.9.32/27. Esto es equivalente a 30 direcciones IP públicas.
Como la empresa tiene la necesidad interna de más de 30 direcciones, el gerente de TI ha
decidido utilizar NAT. Las direcciones 199.99.9.33 – 199.99.9.39 se reservan para la asignación
estática y 199.99.9.40 – 199.99.9.62 para la asignación dinámica.
El enrutamiento entre el ISP y el router de gateway se realiza mediante una ruta estática entre
el ISP y el gateway, y una ruta por defecto entre el gateway y el ISP. La conexión del ISP a la
Internet se representará con una dirección de loopback en el router del ISP.

Crea una red con un cableado similar al del diagrama. Se puede usar cualquier router que
cumpla con los requisitos de interfaz que se muestran en el diagrama anterior. Esto incluye los
siguientes y cualquiera de sus combinaciones posibles:

• Routers serie 800


• Routers serie 1600
• Routers serie 1700
• Routers serie 2500
• Routers serie 2600

Consulta la tabla al final de esta práctica de laboratorio para identificar correctamente los
identificadores de interfaz que se deben usar según el equipo disponible en este laboratorio.
Los resultados de la configuración utilizados en esta práctica se obtuvieron con los routers
serie 1721. El uso de cualquier otro router puede producir unos resultados ligeramente
distintos. Ejecute los siguientes pasos en cada router a menos que se le indique
específicamente lo contrario.

Inicie una sesión de HyperTerminal.


Nota: Observa las instrucciones de borrar y recargar al final de esta práctica de laboratorio.
Realiza ese procedimiento en todos los routers asignados a esta práctica antes de continuar.

 Paso 1. Configurar los routers.


Configura todo lo siguiente según el cuadro:
• El nombre de host
• La contraseña de consola
• La contraseña de terminal virtual
• La contraseña enable-secret
• Las interfaces.

Si se producen problemas durante esta configuración, observa la hoja de consulta de


configuración que aparece al final de esta práctica de laboratorio para obtener ayuda.
 Paso 2. Guardar la configuración.
En la petición de entrada del modo EXEC privilegiado, en ambos routers, escribe el comando
copy running-config startup-config.

 Paso 3. Configurar los hosts con la dirección IP, máscara de subred y gateway por
defecto correspondientes.
Cada estación de trabajo debe poder hacer ping al router conectado. Si el ping no tiene éxito,
haz un diagnóstico de fallas según sea necesario. Verifica que se hayan asignado una dirección
IP y un gateway por defectos específicos a la estación de trabajo. En Windows 98, verifica
mediante Inicio > Ejecutar > winipcfg. En Windows 2000 o superior, verifica mediante ipconfig
en una ventana de DOS.
 Paso 4. Verificar que la red esté funcionando.
a. Desde los hosts conectados, haz ping a la interfaz FastEthernet del router del gateway por
defecto.

b. ¿El ping desde el primer host tuvo éxito? R= Si

c. ¿El ping desde el segundo host tuvo éxito? R= Si


d. Si la respuesta a cualquiera de las dos preguntas es no, realiza un diagnóstico de fallas en el
router y en las configuraciones del host para descubrir el error. Entonces, haz ping de nuevo
hasta que ambos tengan éxito.

 Paso 5. Crear una ruta estática.


a. Crea una ruta estática desde el ISP al router del Gateway. Se han asignado las direcciones
199.99.9.32/27 para el acceso a Internet fuera de la empresa. Use el comando ip route para
configurar una ruta estática:

ISP(config)#ip route 199.99.9.32 255.255.255.224 200.2.2.18

b. ¿La ruta aparece en la tabla de enrutamiento?


R= Si
c. ¿Qué comando verifica el contenido de la tabla de enrutamiento?
R= Show ip route
d. Si la ruta no se encuentra en la tabla de enrutamiento, escribe una razón por la cual podría
ser así.
R= Puede que la interfaz se encuentre desactivada

 Paso 6. Crear una ruta por defecto.


a. Agrega una ruta por defecto desde el Gateway al router del ISP mediante el comando ip
route. Esto enviará cualquier tráfico de dirección de destino desconocido al ISP:
Gateway(config)#ip route 0.0.0.0 0.0.0.0 200.2.2.17

b. ¿La ruta aparece en la tabla de enrutamiento?


R= Si

c. Intenta hacer ping desde una de las estaciones de trabajo a la dirección IP de la interfaz
serial del ISP.

d. ¿El ping fue exitoso? R= No


e. ¿Por qué?
R= No hay ruta de regreso a la red 10.10.10.0
 Paso 7. Definir el conjunto de direcciones IP públicas utilizables.
Para definir el conjunto de direcciones públicas, utiliza el comando ip nat pool:
Gateway(config)#ip nat pool public_access 199.99.9.40 199.99.9.62 netmask 255.255.255.224
 Paso 8. Definir una lista de acceso que coincida con las direcciones IP privadas
internas.
Para definir la lista de acceso de modo que coincida con las direcciones privadas internas, usa
el comando access list:
Gateway(config)#access-list 1 permit 10.10.10.0 0.0.0.255

 Paso 9. Definir la traducción NAT de la lista interna al conjunto externo.


Para definir la traducción NAT, utilice el comando ip nat inside source:
Gateway(config)#ip nat inside source list 1 pool public_access

 Paso 10. Especificar las interfaces.


Es necesario especificar si las interfaces activas en el router son interfaces internas o externas
con respecto a NAT. Para hacer esto, use el comando ip nat inside o ip nat outside:
Gateway(config)#interface fastethernet 0
Gateway(config-if)#ip nat inside
Gateway(config-if)#interface serial 0
Gateway(config-if)#ip nat outside

 Paso 11. Configuración de mapeo estático.


a. La Estación de Trabajo 1, 10.10.10.10/24, se designará como el servidor WWW público. Por
lo tanto, necesita una dirección IP pública permanente. Esta asignación se define mediante un
mapeo de NAT estático.

b. Configura una de las PC de la LAN con la dirección IP 10.10.10.10/24 y la dirección del


Gateway por defecto de 10.10.10.1. Para configurar un mapeo NAT de IP estática, usa el
comando ip nat inside source static en el indicador de modo EXEC privilegiado:
Gateway(config)#ip nat inside source static 10.10.10.10 199.99.9.33

Esto mapea 199.99.9.33 a la dirección interna 10.10.10.10 de forma permanente.

c. Observa la tabla de traducción:


Gateway#show ip nat translations

¿El mapeo aparece en el resultado del comando show? R= Si

 Paso 12. Probar la configuración.


a. Desde la estación de trabajo 10.10.10.10, verifique si puede hacer ping a 172.16.1.1

b. ¿El ping fue exitoso? R= Si


c. ¿Por qué?
R= NAT configurado apropiadamente

d. Desde el router del ISP, haga ping al host con la traducción NAT estática escribiendo ping
10.10.10.10.
e. ¿Cuáles fueron los resultados del ping? ¿Tuvo éxito?
R= No
f. ¿Por qué?
R= Porque no hay ruta a 10.10.10.10
g. Desde el router del ISP, haga ping a 199.99.9.33. Si tiene éxito, vea la traducción NAT en el
router de Gateway, mediante el comando show ip nat translations.

h. ¿Cuál es la traducción de las direcciones host locales interiores?


R= 10.10.10.10 = 199.99.9.33

Una vez completados los pasos anteriores, termina


• Desconecta escribiendo exit.
• Apaga el router.
• Quita y guarda los cables y el adaptador.

Práctica 1.4.
Verificación de la configuración de NAT y PAT
Router 2

Router 1

Objetivos
• Configurar un router para la Traducción de Direcciones de Red (NAT) y la Traducción de
Direcciones de Puerto (PAT)
• Probar la configuración y verificar las estadísticas de NAT/PAT

Información básica / Preparación.


El ISP ha asignado la dirección IP de CIDR pública 199.99.9.32/30 a una empresa. Esto es
equivalente a cuatro direcciones IP públicas. Como que la empresa tiene una necesidad
interna de más de 30 direcciones, el gerente de TI ha decidido usar NAT con PAT. El
enrutamiento entre el ISP y el router de gateway se realiza mediante una ruta estática entre el
ISP y el gateway y una ruta por defecto entre el gateway y el ISP. La conexión del ISP a la
Internet se representará con una dirección de loopback en el router del ISP.
Crea una red con un cableado similar al del diagrama anterior. Se puede usar cualquier router
que cumpla con los requisitos de interfaz que se muestran en el diagrama anterior. Esto
incluye los siguientes y cualquiera de sus combinaciones posibles:
• Routers serie 800
• Routers serie 1600
• Routers serie 1700
• Routers serie 2500
• Routers serie 2600
Consulta la tabla al final de esta práctica de laboratorio para identificar correctamente los
identificadores de interfaz que se deben usar según el equipo disponible en el laboratorio. Los
resultados de la configuración utilizados en esta práctica se obtuvieron con los routers serie
1721. El uso de cualquier otro router puede producir unos resultados ligeramente distintos.
Ejecuta los siguientes pasos en cada router a menos que se le indique específicamente lo
contrario.

Inicie una sesión de HyperTerminal.


Nota: Observa las instrucciones de borrar y recargar al final de esta práctica de laboratorio.
Realiza ese procedimiento en todos los routers asignados a esta práctica antes de continuar.

 Paso 1. Configurar los routers.


Configura todo lo siguiente según el cuadro:

• El nombre de host
• La contraseña de consola
• La contraseña de terminal virtual
• La contraseña enable-secret
• Las interfaces.

Si se producen problemas durante esta configuración, consulta la Práctica de Laboratorio Lab


1.1.4ª Configuración de NAT.

 Paso 2. Guardar la configuración.


En la petición de entrada del modo EXEC privilegiado, en ambos routers, escribe el comando
copy running-config startup-config.

 Paso 3. Configurar los hosts con la dirección IP, máscara de subred y gateway por
defecto correspondientes.
Cada estación de trabajo debe poder hacer ping al router conectado. Si el ping no tiene éxito,
haz un diagnóstico de fallas según sea necesario. Verifica que se hayan asignado una dirección
IP y un gateway por defectos específicos a la estación de trabajo. En Windows 98, verifica
mediante Inicio > Ejecutar > winipcfg. En Windows 2000 o superior, verifica mediante ipconfig
en una ventana de DOS.

 Paso 4. Verificar que la red esté funcionando.


a. Desde los hosts conectados, haga ping a la interfaz FastEthernet del router del gateway por
defecto.

b. ¿El ping desde el primer host tuvo éxito? R= Si

c. ¿El ping desde el segundo host tuvo éxito? R= Si


d. Si la respuesta a cualquiera de las dos preguntas es no, realiza un diagnóstico de fallas en el
router y en las configuraciones del host para descubrir el error. Entonces, haz ping de nuevo
hasta que ambos tengan éxito.

 Paso 5. Crear una ruta estática.


a. Crea una ruta estática desde el ISP al router del Gateway. Se han asignado las direcciones
199.99.9.32/30 para el acceso a Internet fuera de la empresa. Usa el comando ip route para
crear una ruta estática.
ISP(config)#ip route 199.99.9.32 255.255.255.252 200.2.2.18

b. ¿L a ruta estática aparece en la tabla de enrutamiento?


R= Si
c. ¿Qué comando verifica el contenido de la tabla de enrutamiento?
R= Show ip route
d. Si la ruta no se encuentra en la tabla de enrutamiento, escribe una razón por la cual podría
ser así.
R= La interfaz se encuentra desactivada

 Paso 6. Crear una ruta por defecto.


a. Agrega una ruta por defecto desde el Gateway al router del ISP mediante el comando ip
route. Esto enviará cualquier tráfico de dirección de destino desconocido al ISP:
Gateway(config)#ip route 0.0.0.0 0.0.0.0 200.2.2.17

b. ¿La ruta estática aparece en la tabla de enrutamiento?


R= Si

c. Intenta hacer ping desde una de las estaciones de trabajo a la dirección IP de la interfaz
serial del ISP.

d. ¿El ping fue exitoso?


R= No

e. ¿Por qué?
R= Porque no existe una ruta de regreso o retorno.

 Paso 7. Definir el conjunto de direcciones IP públicas utilizables.


Para definir el conjunto de direcciones públicas, utiliza el comando ip nat pool:
Gateway(config)#ip nat pool public-access 199.99.9.32 199.99.9.35 netmask
255.255.255.252

 Paso 8. Definir una lista de acceso que coincida con las direcciones IP privadas
internas.
Para definir la lista de acceso de modo que coincida con las direcciones privadas internas, usa
el comando access list:
Gateway(config)#access-list 1 permit 10.10.10.0 0.0.0.255

 Paso 9. Definir la traducción NAT de la lista interna al conjunto externo.


Para definir la traducción NAT, utiliza el comando ip nat inside source:
Gateway(config)#ip nat inside source list 1 pool public-access overload

 Paso 10. Especificar las interfaces.


Es necesario especificar si las interfaces activas en el router son interfaces internas o externas
con respecto a NAT. Para hacer esto, usa el comando ip nat inside o ip nat outside:
Gateway(config)#interface fastethernet 0
Gateway(config-if)#ip nat inside
Gateway(config-if)#interface serial 0
Gateway(config-if)#ip nat outside
 Paso 11. Probar la configuración.
a. Desde las estaciones de trabajo, haz ping a 172.16.1.1. Abra varias ventanas de DOS en cada
estación de trabajo y haga Telnet a la dirección 172.16.1.1. Entonces, observa las traducciones
NAT en el router de gateway, mediante el comando show ip nat translations.

b. ¿Cuál es la traducción de las direcciones host locales interiores?


R= 172.16.1.1:23

 Paso 12 .Verificación de las estadísticas de NAT y PAT.


a. Para ver las estadísticas de NAT y PAT, escribe el comando show ip nat statistics en el
indicador de modo EXEC privilegiado.

b. ¿Cuántas traducciones activas han ocurrido? R= 2

c. ¿Cuántas direcciones tiene el conjunto? R= 4

d. ¿Cuántas direcciones se han asignado hasta ahora? R= 1

Una vez completados los pasos anteriores, termina la práctica haciendo lo siguiente:
• Desconéctate escribiendo exit.
• Apaga el router.
• Quita y guarda los cables y el adaptador.

Práctica 1.5.
Diagnóstico de fallas de NAT y PAT

Router 2

Router 1
Objetivos
• Configurar un router para la Traducción de Direcciones de Red (NAT) y la Traducción de
Direcciones de Puerto (PAT)
• Diagnosticar las fallas de NAT y PAT mediante debug.

Información básica / Preparación


El ISP ha asignado la dirección IP de CIDR pública 199.99.9.32/30 a una empresa. Esto es
equivalente a cuatro direcciones IP públicas. Como que la empresa tiene una necesidad
interna de más de 30 direcciones, el gerente de TI ha decidido usar NAT con PAT. El
enrutamiento entre el ISP y el router de gateway se realiza mediante una ruta estática entre el
ISP y el gateway y una ruta por defecto entre el gateway y el ISP. La conexión del ISP a la
Internet se representará con una dirección de loopback en el router del ISP.

Crea una red con un cableado similar al del diagrama anterior. Se puede usar cualquier router
que cumpla con los requisitos de interfaz que se muestran en el diagrama anterior. Esto
incluye los siguientes y cualquiera de sus combinaciones posibles:
• Routers serie 800
• Routers serie 1600
• Routers serie 1700
• Routers serie 2500
• Routers serie 2600

Consulta la tabla al final de esta práctica de laboratorio para identificar correctamente los
identificadores de interfaz que se deben usar según el equipo disponible en el laboratorio. Los
resultados de la configuración utilizados en esta práctica se obtuvieron con los routers serie
1721. El uso de cualquier otro router puede producir unos resultados ligeramente distintos.
Ejecuta los siguientes pasos en cada router a menos que se le indique específicamente lo
contrario.

Inicie una sesión de HyperTerminal.


Nota: Observa las instrucciones de borrar y recargar al final de esta práctica de laboratorio.
Realiza ese procedimiento en todos los routers asignados a esta práctica antes de continuar.

 Paso 1 .Configurar los routers.


Configura todo lo siguiente según el cuadro:

• El nombre de host
• La contraseña de consola
• La contraseña de terminal virtual
• La contraseña enable-secret
• Las interfaces.

Si se producen problemas durante esta configuración, consulta la Práctica de Laboratorio Lab


1.1.4ª Configuración de NAT.
 Paso 2. Guardar la configuración.
En la petición de entrada del modo EXEC privilegiado, en ambos routers, escribe el comando
copy running-config startup-config.

 Paso 3. Configurar los hosts con la dirección IP, máscara de subred y gateway por
defecto correspondientes.
Cada estación de trabajo debe poder hacer ping al router conectado. Si el ping no tiene éxito,
haz un diagnóstico de fallas según sea necesario. Verifica que se hayan asignado una dirección
IP y un gateway por defecto específico a la estación de trabajo. En Windows 98, verifica
mediante Inicio > Ejecutar > winipcfg. En Windows 2000 o superior, verifica mediante ipconfig
en una ventana de DOS.

 Paso 4 .Verificar que la red esté funcionando.


a. Desde los hosts conectados, haz ping a la interfaz FastEthernet del router del gateway por
defecto.

b. ¿El ping desde el primer host tuvo éxito? R= Si

c. ¿El ping desde el segundo host tuvo éxito? R= Si

d. Si la respuesta a cualquiera de las dos preguntas es no, realiza un diagnóstico de fallas en el


router y en las configuraciones del host para descubrir el error. Entonces, haz ping de nuevo
hasta que ambos tengan éxito.

 Paso 5. Crear una ruta estática.


a. Crea una ruta estática desde el ISP al router del Gateway. Se han asignado las direcciones
199.99.9.32/30 para el acceso a Internet fuera de la empresa. Usa el comando ip route para
configurar una ruta estática:
ISP(config)#ip route 199.99.9.32 255.255.255.252 200.2.2.18

b. ¿La ruta estática aparece en la tabla de enrutamiento?


R= Si
c. ¿Qué comando verifica el contenido de la tabla de enrutamiento?
R= Show ip route
d. Si la ruta no se encuentra en la tabla de enrutamiento, escribe una razón por la cual podría
ser así. R= La interfaz está desactivada

 Paso 6. Crear una ruta por defecto.


a. Agrega una ruta por defecto mediante el comando ip route desde el router del Gateway al
router del ISP. Esto enviará cualquier tráfico de dirección de destino desconocido al ISP:
Gateway(config)#ip route 0.0.0.0 0.0.0.0 200.2.2.17

b. ¿La ruta estática aparece en la tabla de enrutamiento?


R= Si

c. Intenta hacer ping desde una de las estaciones de trabajo a la dirección IP de la interfaz
serial del ISP.

d. ¿El ping fue exitoso? R= No

e. ¿Por qué? R= No hay ruta de retorno a la red 10.10.10.0


 Paso 7. Definir el conjunto de direcciones IP públicas utilizables.
Para definir el conjunto de direcciones públicas, utiliza el comando ip nat pool:
Gateway(config)#ip nat pool public-access 199.99.9.32 199.99.9.35 netmask
255.255.255.252

 Paso 8. Definir una lista de acceso que coincida con las direcciones IP privadas
internas.
Para definir la lista de acceso de modo que coincida con las direcciones privadas internas, usa
el comando access list:
Gateway(config)#access-list 1 permit 10.10.10.0 0.0.0.255

 Paso 9.Definir la traducción NAT de la lista interna al conjunto externo.


Para definir la traducción NAT, utiliza el comando ip nat inside source:
Gateway(config)#ip nat inside source list 1 pool public-access overload

 Paso 10. Especificar las interfaces.


Es necesario especificar si las interfaces activas en el router son interfaces internas o externas
con respecto a NAT. Para hacer esto, usa el comando ip nat inside:
Gateway(config)#interface fastethernet 0
Gateway(config-if)#ip nat inside
 Paso 11. Probar la configuración.
a. Inicia la depuración del proceso NAT, escribiendo el comando debug ip nat en el indicador
de modo EXEC privilegiado.

b. ¿El comando debug muestra algún resultado?


R= No

c. Si la traducción se estuviera realizando, habría un resultado del comando debug. Al revisar


la configuración activa en el router del gateway, se observa que el comando ip nat outside no
se ha introducido en la interfaz serial 0. Para configurar esto, introduce lo siguiente:
Gateway(config)#interface serial 0
Gateway(config-if)#ip nat outside
Desde las estaciones de trabajo, haga ping a 172.16.1.1

Si la sentencia ip nat outside se introdujo correctamente, debe haber un resultado del


comando debug ip nat.

d. ¿Qué significa la línea NAT*: S=10.10.10.? -> 199.99.9.33?


R= Los Hosts Fuente y Destino

e. Para interrumpir el resultado del diagnóstico de fallas, escribe undebug all en el indicador
del modo EXEC privilegiado.

Una vez completados los pasos anteriores, termina la práctica haciendo lo siguiente:

• Desconéctate escribiendo exit.


• Apaga el router.
• Quita y guarda los cables y el adaptador.
Hoja de consulta de configuración.

Esta hoja contiene los comandos de configuración básicos para los routers de ISP y Gateway:

ISP
Router#configure terminal
Router(config)#hostname ISP
ISP(config)#enable password cisco
ISP(config)#enable secret class
ISP(config)#line console 0
ISP(config-line)#password cisco
ISP(config-line)#login
ISP(config-line)#exit
ISP(config)#line vty 0 4
ISP(config-line)#password cisco
ISP(config-line)#login
ISP(config-line)#exit
ISP(config)#interface loopback 0
ISP(config-if)#ip add 172.16.1.1 255.255.255.255
ISP(config-if)#no shutdown
ISP(config-if)#exit
ISP(config)#interface serial 0
ISP(config-if)#ip add 200.2.2.17 255.255.255.252
ISP(config-if)#clock rate 64000
ISP(config)#ip route 199.99.9.32 255.255.255.224 200.2.2.18
ISP(config)#end
ISP#copy running-config startup-config
Destination filename [startup-config]?[Intro]

Gateway

Router#configure terminal
Router(config)#hostname Gateway
Gateway(config)#enable password cisco
Gateway(config)#enable secret class
Gateway(config)#line console 0
Gateway(config-line)#password cisco
Gateway(config-line)#login
Gateway(config-line)#exit
Gateway(config)#line vty 0 4
Gateway(config-line)#password cisco
Gateway(config-line)#login
Gateway(config-line)#exit
Gateway(config)#fastethernet 0
Gateway(config-if)#ip add 10.10.10.1 255.255.255.0
Gateway(config-if)#no shutdown
Gateway(config-if)#exit
Gateway(config)#interface serial 0
Gateway(config-if)#ip add 200.2.2.18 255.255.255.252
Gateway(config-if)#no shutdown
Gateway(config)#ip route 0.0.0.0 0.0.0.0 200.2.2.17
Borrar y recargar el router.

Entra al modo EXEC privilegiado escribiendo enable.

Si se te pide una contraseña, introduce class (si no funciona, consulta al instructor).


Router>enable

En el modo EXEC privilegiado, introduce el comando erase startup-config.


Router#erase startup-config

Como respuesta, aparecerá la siguiente petición de entrada:


Erasing the nvram filesystem will remove all files! Continue? [confirm]

Presiona Intro para confirmar.

La respuesta deberá ser:


Erase of nvram: complete

En el modo EXEC privilegiado, introduce el comando reload.


Router(config)#reload

Como respuesta, aparecerá la siguiente petición de entrada:


System configuration has been modified. Save? [yes/no]:
Escribe n y luego presiona Intro.

Como respuesta, aparecerá la siguiente petición de entrada:


Proceed with reload? [confirm]
Presiona Intro para confirmar.

La primera línea de la respuesta será:


Reload requested by console.
La siguiente petición de entrada aparecerá después de que el router se recargue:
Would you like to enter the initial configuration dialog? [yes/no]:
Escribe n y luego presiona Intro.

Como respuesta, aparecerá la siguiente petición de entrada:


Press RETURN to get started!Presione Intro.
Ahora el router está listo para iniciar la práctica de laboratorio asignada.

También podría gustarte