Está en la página 1de 6

1.

Desarrollar un algoritmo para la empresa constructora “Tecnovivir”, que le permita


calcular e imprimir la planilla de una total de 50 obreros calificados a quienes debe
cancelar por hora trabajada, la hora trabajada se pautó en s/. 30.

A. ANALISIS DEL ALGORITMO:

B. DECLARACION DE VARIABLES:

C. DISEÑO DEL ALGORITMO:

a. PSEUDOCODIGO:
Algoritmo constructora
Escribir 'Ingresar el número de trabajadores'
Leer n
i <- 0
Mientras n>0 Hacer
n = n-1
i <- i+1
Escribir 'Ingresar el numero de horas de trabajador'
Escribir i
Leer ht
pt <- ht*30
Escribir pt
FinMientras
FinAlgoritmo

b. DIAGRAMA DE FLUJO:
c. PRUEBA DE ESCRITORIO:

2. Desarrolle un algoritmo que funcione como una caja registradora.

A. DISEÑO DEL ALGORITMO:


B. DECLARACION DE VARIABLES:
C. DISEÑO DEL ALGORITMO:
a. PSEUDOCODIGO:
Algoritmo Caja_registradora
Escribir 'Ingresar el Saldo de Apertura de Caja'
Leer saldo_caja
Escribir '¿Realizar nueva venta? si(s)/no(n)'
Leer resp_venta
Mientras resp_venta='s' Hacer
Escribir 'Ingresar monto de venta'
Leer monto_venta
Escribir 'Ingresar el efectivo del pago'
Leer monto_efectivo
vuelto <- monto_efectivo-monto_venta
saldo_caja <- monto_venta+saldo_caja
Escribir 'El vuelto es: '
Escribir vuelto
Escribir '¿Realizar nueva venta? si(s)/no(n)'
Leer resp_venta
FinMientras
Escribir 'El saldo de caja es: '
Escribir saldo_caja
FinAlgoritmo

b. DIAGRAMA DE FLUJO:
D. PRUEBA DE ESCRITORIO:

3. Desarrolle un algoritmo que permita determinar a partir del número de días ingresados
por pantalla, ¿Cuántos años, meses, semanas y días, constituyen el número de días
proporcionado? Utilizando la estructura “mientras” o while, o If.

A. ANALISIS DEL PROBLEMA:


B. DECLARACION DE VARIABLES:
C. DISEÑO DEL ALGORITMO:
a. PSEUDOCODIGO:
Algoritmo ejercicio_03
anios <- 0
meses <- 0
semanas <- 0
Escribir 'Ingresar numero de dias:'
Leer num_dias
c <- num_dias
Mientras c>=365 Hacer
anios <- anios+1
c <- c-365
FinMientras
Mientras c>=30 Hacer
meses <- meses+1
c <- c-30
FinMientras
Mientras c>=7 Hacer
semanas <- semanas+1
c <- c-7
FinMientras
dias <- c
Escribir 'El numero de anios es: '
Escribir anios
Escribir 'El numero de meses es: '
Escribir meses
Escribir 'El numero de semanas es: '
Escribir semanas
Escribir 'El numero de dias es: '
Escribir dias
FinAlgoritmo

b. DIAGRAMA DE FLUJO:
D. PRUEBA DE ESCRITORIO:
4. Determine el enunciado del siguiente diagrama de flujo:

- Se ingresa una cantidad de dinero en efectivo, contar la cantidad mínima de billetes


y monedas si se tiene las siguientes denominaciones

a) Billetes de cincuenta mil


b) Billetes de veinte mil
c) Billetes de diez mil
d) Billetes de cinco mil
e) Billetes de mil
f) Monedas de una unidad monetaria.