Está en la página 1de 5

Vamos a partir de un escenario bsico, el cual no tiene ninguna configuracin (tanto el router, switch y

PCs no tiene configurado nada).

Despus de tener creado el escenario vamos a escribir los siguientes comandos

router> enable
router# configure terminal
router(config)# hostname R1 (Colocamos un nombre al router)

R1(config)#banner motd #Bienvenido# (Colocamos un cartel de bienvenida)


R1(config)#enable secret cisco (Especifica una capa de seguridad adicional la cual colocamos "cisco")

CONFIGURANDO CONTRASEA DE CONSOLA


R1(config)#line console 0 (ingresamos a la consola)
R1(config-line)#password cisco-consola (establecemos una contrasea para ingresar a la consola)

CONFIGURANDO CONTRASEA VTY (TELNET)


R1(config)#line vty 0 4 (crea las 5 lneas VTY, pero podra ser una sola. Ej: line vty 0)
R1(config-line)#password cisco-vty (contrasea para las 5 lneas en este caso)
R1(config-line)#login (habilita la contrasea)
R1(config-line)#exit

R1(config)#Service password-encryption (encriptamos las contraseas establecidas anteriormente)


CONFIGURANDO LAS INTERFACES
Estos comandos se pueden aplicar a las diferentes interfaces que estn conectadas a nuestro
router.
para este ejemplo solo tenemos la interfaz F0/0, a la cual le vamos asignar una IP

R1(config)#interface f0/0
R1(config-if)#ip address 192.168.1.1 255.255.255.0
R1(config-if)#no shutdown (encendemos o levantamos la interfaz)

para finalizar y verificar las configuraciones podemos salirnos usando el comendo exit varias veces
y volver a ingresar al modo de configuracion, nos tendra que mostrar en cartel de bienvenida,
pedir la contrasea del enable secreet etc.
Tambin podemos usar el comando R1#show run para verificar las configuracion activas del router

Para finalizar vamos a usar el comando:


R1#copy running-config startup-config (Guarda la configuracin activa en la NVRAM)
Comandos Basicos de un Router Cisco

Cambiar el nombre del host:


(config)#hostname

Borrar la configuracin del router:

#erase nvram:

(debe confirmarse con enter una segunda vez)

Salvar la configuracin del router:

#copy running-config startup-config

Reiniciar el enrutador:

(Es normal que pida salvar los cambios de configuracin no guardados)

#reload

#Proceed with reload? [confirm]

Asignar ip a una interfaz

(config)#interface
(config-if)#ip address

Ejemplo:

(config)#interface serial 0/0


(config-if)#ip address 10.1.1.1 255.255.255.252

Asignar reloj a una interfaz:

(config-if)#clock rate

Ejemplo: (config-if)#clock rate 64000

Habilitar enrutamiento:
(config)#router [id de proceso]
(config-router)#network [wildcard]

Ejemplo 1:
(config)#router rip
(config-router)#network 172.16.0.0

(config-router)#version
2
Exclusivo para rip (habilitar enrutamiento que soporte subredes de mscara
variable)

Ejemplo 2:
(config)#router ospf 1
(config-router)#network 172.16.4.0 0.0.3.255 area 0

Visualizar la configuracin del router:

#show running-config

Visualizar la tabla de enrutamiento de un router:

#show ip route

Visualizar el estado de todas las interfaces:

#show interfaces

Visualizar el estado de una interfaz:

#show interface <#>

Ejemplo:

#show interface serial 0/0/0

Agregar una ruta esttica

(config)#ip route

Ejemplo:
ip route 192.168.2.0 255.255.255.0 serial2/0
Propagar rutas estticas por el protocolo de enrutamiento:

(config-router)#redistribute static

Establecer el password del modo enable:

(config)#enable password

Establecer el password encriptado:

(Es normal que arroje una alerta si se establece la misma clave para el enable password)

(config)#enable secret

Habilitar la encripcin de claves en el archivo de configuracin:

(config)#service password-encriyption

Habilitar las terminales virtuales:

(config)#line vty <#1> <#1>

(config-line)#password

(config-line)#login

Ejemplo:

(config)#line vty 0 4

(config-line)#password cisco

(config-line)#login
Anuncios