Está en la página 1de 34

CONFIGURACION CPES HUAWEI AR151

COLOMBIA

ANEXO TECNICO DE SERVICIOS DE


DATOS CLARO COLOMBIA
CONFIGURACIN DE CPEs HUAWEI AR151
V1.0

DIRECCIN DE INGENIERA

Este documento contiene secretos del negocio


e informacin de propiedad de CLARO
COLOMBIA. No est permitido ningn tipo
de utilizacin de la informacin contenida aqu
sin previo consentimiento escrito.

Bogot, Octubre de 2013


CONFIGURACION CPES HUAWEI AR151

CONTROL DE CAMBIOS

Fecha de Ver Cambiado Secciones Cambiadas Motivo del cambio


Cambio . por:
Oct-2013 1.0 Jorge Todas Primera versin del
Gutirrez. Documento
CONFIGURACION CPES HUAWEI AR151

TABLA DE CONTENIDO

CONTROL DE CAMBIOS ........................................................................................................ 2


1 DESCRIPCIN DEL EQUIPO........................................................................................... 2
1.1. Version de software (VRP) vigente. ................................................................................. 3
2 CONFIGURACIN DEL EQUIPO .................................................................................... 4
2.1. Acceso por consola ...................................................................................................... 4
2.2. Arranque de fbrica ...................................................................................................... 4
2.3. Administracion de archivos y archivo de arranque ............................................................. 6
2.4. Menu boot .................................................................................................................. 8
2.5. Mostrar la configuracin actual del equipo........................................................................ 9
2.6. Grabar la configuracin del equipo ................................................................................. 9
2.7. Modo usuario y modo sistema ........................................................................................ 9
2.8. Configuracin del mensaje de bienvenida ....................................................................... 10
2.9. Configuracin de usuario para ingreso al router tanto por consola como por Telnet .............. 10
2.10. Configuracin de la interfaz de consola y lneas VTY ....................................................... 10
2.11. Configuracin de la fecha y la hora................................................................................ 11
2.12. Configuracin de interfaces Ethernet............................................................................. 11
2.13. Configuracin de rutas estticas .................................................................................... 12
2.14. Configuracin de listas de acceso .................................................................................. 12
2.15. Configuracin de NAT ............................................................................................... 12
2.15.1. NAT Dinmico .................................................................................................. 12
2.15.2. NAT esttico...................................................................................................... 14
2.15.3. NAT ALG (Aplication layer gateway) ..................................................................... 15
2.16. Configuracin de protocolos de enrutamiento dinmicos .................................................. 15
2.16.1. OSPF ................................................................................................................ 15
2.16.2. BGP ................................................................................................................. 16
2.17. Configuracin de politicas en una interfaz ...................................................................... 17
2.18. Configuracin de calidad de servicio.............................................................................. 18
2.19. Configuracin de calidad de servicio para voz ................................................................. 19
2.19.1. Ultima milla Ethernet .......................................................................................... 19
3 HERRAMIENTAS DE DIAGNOSTICO - TROUBLESHOOTING ...................................... 20
3.1.1. Ping .................................................................................................................. 20
3.1.2. Tracert .............................................................................................................. 21
3.1.3. Debugging ......................................................................................................... 21
3.1.4. Solucion de problemas. Casos. .............................................................................. 24
4 ACTUALIZACION SOFTWARE DEL EQUIPO ................................................................ 25
5 OTROS PROTOCOLOS Y SERVICIOS............................................................................. 27
5.1. Configuracin de VRRP (Virtual RoutER Redundancy Protocol ) entre Huawei y Cisco ........ 27
5.1.1. Configuracin con 2 routers huawei ....................................................................... 27
5.1.2. Configuracin con 1 router Huawei y 1 router Cisco ................................................. 28
5.2. Configuracin de instancias VPN (VRF). ....................................................................... 28
5.3. Servicio dhcp............................................................................................................. 29
6 CONFIGURACIN DE SERVICIOS ESTANDAR PARA CLARO COLOMBIA ................... 30
6.1. Servicio Bandaancha ................................................................................................... 30

Confidencial Pag 1 2013-10-11


CONFIGURACION CPES HUAWEI AR151

1 DESCRIPCIN DEL EQUIPO

Los routers Huawei que adquiri CLARO para ser utilizados como CPEs en soluciones
corporativas son del modelo AR 151; las caractersticas de este equipo son las siguientes:

5 interfaces 10/100 Ethernet en el chasis.

1 puerto de consola.

Procesamiento de 300 Kpps.

Memoria RAM de 512 M.

Memoria flash de 512 M.

Principales protocolos y aplicaciones soportadas:

o Capa de enlace de datos: Ethernet, PPP, , PPPoE server/client, PPPoA


server/client, PPPoEoA server/client, IEEE 802.1P, IEEE 802.1Q, IEEE 802.3,
VLAN management, MAC address management, MSTP

o Capa de red DHCP server/client/relay, IP, IP Fast Switch,

o Protocolos de enrutamiento: Static Routing, OSPF, RIP, RIP2, BGP, Policy


Routing, and Multicast Routing(IGMP version1/2/3, PIM SM, PIM DM, MSDP)

o Capa de aplicacin: Upgrade management, device management, web-based


GUI, GTL, SNMP(v1/v2c/v3), RMON, NTP, CWMP, Auto-Config, site
deployment using USB disk, NetConf, CLI.

o Seguridad: ACL, firewall, 802.1x authentication, AAA authentication, RADIUS


authentication, HWTACACS authentication, broadcast storm suppression,
ARP security, ICMP attack defense, URPF, CPCAR, blacklist, IP source
tracing, PKI

o VPN: IPSec VPN, GRE VPN, DSVPN, SSL VPN, L2TP VPN.

o QoS: Diffserv mode, Priority mapping, traffic policing (CAR), traffic shaping,
congestion avoidance (based on IP precedence/DSCP WRED), congestion
management (LAN interface: SP/WRR/SP+WRR; WAN interface:

Confidencial Pag 2 2013-10-11


CONFIGURACION CPES HUAWEI AR151

PQ/CBWFQ), MQC (traffic classification, traffic behavior, and traffic policy), H-


QoS, Smart Application Control (SAC)

Vista frontal del AR 151:

1.1. VERSION DE SOFTWARE (VRP) VIGENTE.

A la fecha, octubre de 2013, la versin de software actualizada y homologada sobre el equipo


huawei AR151 es la versin 5.130, cuyo software (VRP) es el V200R005C00.cc

<CPEbandaancha>dis ver
Huawei Versatile Routing Platform Software
VRP (R) software, Version 5.130 (AR150 V200R005C00)
Copyright (C) 2011-2013 HUAWEI TECH CO., LTD
Huawei AR151 Router uptime is 0 week, 0 day, 3 hours, 23 minutes

MPU 0(Master) : uptime is 0 week, 0 day, 3 hours, 23 minutes


SDRAM Memory Size : 512 M bytes
Flash Memory Size : 512 M bytes
MPU version information :
1. PCB Version : AR01SRU0B VER.A
2. MAB Version : 0
3. Board Type : AR151
4. CPLD0 Version : 102
5. BootROM Version : 540

<CPEbandaancha>

La presente versin de software presenta mejoras respecto a la versin anterior (Version 5.110) en
temas de capacidad de manejo de nmero de prefijos que se aprenden por BGP. Con la versin
anterior solo se permitan 1000 prefijos. Con la presente versin liberada en agosto de 2013 se
permiten aprender hasta 10mil prefijos.

Confidencial Pag 3 2013-10-11


CONFIGURACION CPES HUAWEI AR151

2 CONFIGURACIN DEL EQUIPO

2.1. ACCESO POR CONSOLA

La conexin se realiza por el puerto serial del computador al puerto de consola del router
mediante el cable incluido con cada equipo o con un cable de consola estndar. Los parmetros
de configuracin del puerto se muestran a continuacin:

2.2. ARRANQUE DE FBRICA

El inicio del router, bien sea de primera vez o porque se ejecuta procedimiento para cargar
configuracin de fbrica coloca la siguiente salida:

(Se omite salida)

VRP_SockTm_Init create............OK
VRP initialize
Create tasks......................OK
Initialize tasks..................OK
Recovering configuration..........OK

Press any key to get started

Please configure the login password (<6-16>)


Enter password:Manager147** El equipo pide password para login inicial.
Confirm password:
<Huawei>

Confidencial Pag 4 2013-10-11


CONFIGURACION CPES HUAWEI AR151

La configuracin con que arranca el equipo es la siguiente:


<Huawei>dis current-configuration
[V200R005C00]
#
drop illegal-mac alarm
#
pki realm default
enrollment self-signed
#
aaa
authentication-scheme default
authorization-scheme default
accounting-scheme default
domain default
domain default_admin
local-user admin password cipher %@%@(KP]K+q}@"Ji~8If=zZ@lXUO%@%@
local-user admin service-type telnet http
#

firewall zone Local


priority 16
#
interface Vlanif1
ip address 192.168.1.1 255.255.255.0
#
interface Ethernet0/0/0
#
interface Ethernet0/0/1
#
interface Ethernet0/0/2
#
interface Ethernet0/0/3
#
interface Ethernet0/0/4
#
interface Cellular0/0/0
#
interface NULL0
#
snmp-agent local-engineid 800007DB03DCD2FC03A05F
snmp-agent
#
http server enable
#
user-interface con 0
authentication-mode password
set authentication password cipher %@%@[Q[8Gfr'M<1m3KPf&1C9,.z.QpQ}5;v@(EjD\@W_i;$,.z1,%@%@
user-interface vty 0
authentication-mode aaa
user privilege level 15
user-interface vty 1 4
#
wlan ac
#
return
<Huawei>

Confidencial Pag 5 2013-10-11


CONFIGURACION CPES HUAWEI AR151

En caso de que ya se tenga una configuracin previamente cargada y se desee recuperar esta
configuracin de fbrica, el comando a ejecutar es el siguiente:

<ROUTER>factory-configuration reset
Info: Successfully set factory config reset flag!
<ROUTER>

reinicia

(Se omite toda la salida que puede tomar unos 3 minutos)

VRP_SockTm_Init create............OK
VRP initialize
Create tasks......................OK
Initialize tasks..................OK
Recovering configuration..........OK

Press any key to get started


Please configure the login password (<6-16>)
Enter password:

2.3. ADMINISTRACION DE ARCHIVOS Y ARCHIVO DE ARRANQUE

El router almacena en su memoria flash tanto los archivos de configuracin como el sistema
oeprativo (VRP), y la forma de visulaizarlos es la siguiente:

<CPEbandaancha>dir
Directory of flash:/

Idx Attr Size(Byte) Date Time(LMT) FileName


0 -rw- 304,700 Oct 08 2013 20:55:34 sacrule.dat
1 -rw- 54,441,216 Sep 20 2012 11:35:32 AR200-V200R002C01SPC200.cc
2 -rw- 0 Mar 15 2013 19:37:42 brdxpon_snmp_cfg.efs
3 -rw- 4,020,821 Dec 14 2012 10:34:40 web.zip
4 -rw- 396 Dec 14 2012 10:34:42 rsa_host_key.efs
5 -rw- 222,931 Oct 08 2013 20:46:02 mon_file.txt
6 -rw- 540 Dec 14 2012 10:35:34 rsa_server_key.efs
7 -rw- 1,117 Sep 03 2013 05:01:40 vrpcfg.zip
8 drw- - Dec 14 2012 10:36:12 logfile
9 -rw- 263,936 Dec 14 2012 10:38:02 ar200_v200r002spc002.pat
11 -rw- 2,436 Sep 03 2013 06:24:58 lab-inge.cfg
14 -rw- 89,246,592 Sep 06 2013 18:41:44 ar150-v200r005c00.cc
15 -rw- 2,980 Oct 08 2013 18:21:46 iascfg_autobackup.zip
25 -rw- 3,160 Oct 08 2013 21:57:52 pruebasbandaancha.cfg
27 -rw- 3,148 Oct 08 2013 19:46:50 iascfg_autobackup.cfg
28 -rw- 3,072 Oct 11 2013 17:16:14 Boot_LogFile

Confidencial Pag 6 2013-10-11


CONFIGURACION CPES HUAWEI AR151

31 -rw- 1,000 Oct 11 2013 17:38:12 vrpcfg.cfg

468,560 KB total (322,320 KB free)


<CPEbandaancha>

Los archivos de configuracin son los que tienen la extensin *.cfg. Los archivos del sistema
operativo son los de extenxin *.cc. Teniendo entonces claro esto, se procede a definir el
archivo que se desee cargar en la memoria (NVRAM) para su ejecucin:

<Huawei>dis startup
MainBoard:
Startup system software: flash:/ar150-v200r005c00.cc
Next startup system software: flash:/ar150-v200r005c00.cc
Backup system software for next startup: null
Startup saved-configuration file: null
Next startup saved-configuration file: null
Startup license file: null
Next startup license file: null
Startup patch package: null
Next startup patch package: null
Startup voice-files: null
Next startup voice-files: null
<Huawei>

<Huawei>startup saved-configuration flash:/pruebasbandaancha.cfg Archivo de config.ejemplo


This operation will take several minutes, please wait...................
Info: Succeeded in setting the file for booting system
<Huawei>

<Huawei>dis startup
MainBoard:
Startup system software: flash:/ar150-v200r005c00.cc Sistema Operativo de arranque.
Next startup system software: flash:/ar150-v200r005c00.cc
Backup system software for next startup: null
Startup saved-configuration file: null
Next startup saved-configuration file: flash:/pruebasbandaancha.cfg Se verifica.
Startup license file: null
Next startup license file: null
Startup patch package: null
Next startup patch package: null
Startup voice-files: null
Next startup voice-files: null
<Huawei>

<Huawei>
Oct 11 2013 17:41:26+00:00 Huawei %%01DEV/4/ENTRESET(l)[0]:Board[0] is reset, The reason is: Reset by
user command.
Requesting system reboot
Restarting system.

Jul 4 2013, 13:41:03


Start Memory Test ? ('t' or 'T' is test):skip
Copying Data : Done
Uncompressing : Done
Initializing SMI Bus:OK

Confidencial Pag 7 2013-10-11


CONFIGURACION CPES HUAWEI AR151

Init flash, please wait......

2.4. MENU BOOT

El equipo permite detener su proceso de arranque normal e ingresar al men BOOT con el fin
de controlar el arranque del equipo, bien sea para cargar la configuracin por defecto, o una
configuracin especfica, o iniciar un nuevo sistema operativo (VRP).

Start Memory Test ? ('t' or 'T' is test):skip


Copying Data : Done
Uncompressing : Done
Initializing SMI Bus:OK

Init flash, please wait......OK


USB initializing ...
USB2 Host Stack Initialized.
USB Hub Driver Initialized
USBD Wind River Systems, Inc. 562 Initialized
EHCI Controller found.
Waiting to attach to USBD...Done.
USB initialization has been finished !
0xefffdf0 (tRootTask): usbBulkDevInit() returned OK
Press Ctrl+B to break auto startup .... Se presionan las teclas CTRL y B y el proceso de autoboot se detiene.

Enter Password: Huawei Este password se define cuando se arranca la configuracin de fbrica.

Main Menu

1. Default Startup
2. Serial Menu
3. Network Menu
4. Startup Select
5. File Manager
6. Reboot
7. Password Manager

Ya en este punto se puede seguir el men conforme a lo que se desee ejecutar. La opcin 1
continua el arranque normal del equipo, cargando la configuracin definida con el comando
start-up (seccin 2.1.2).

La opcin 4 me permite elegir el archivo de arranque del equipo, consultando previamente todos
los archivos cargados en la flash, mediante la opcin 5 (File Manager):

Startup Select

1. Display Startup
2. Set Boot File
3. Set Config File
4. Startupfile Check Manage
0. return

Confidencial Pag 8 2013-10-11


CONFIGURACION CPES HUAWEI AR151

Enter your choice(0-4):3


Select Config File

1. Flash
0. Return

Enter your choice(0-1):1


NOTE: Config file must be .zip or .ZIP

Current config file: flash:/pruebasbandaancha.cfg


Press ENTER directly for no change.
Or, please input the new file name:

Finalmente, regresando al menu principal est la opcin de reboot (6), con la cual se reinicia el
equipo.

2.5. MOSTRAR LA CONFIGURACIN ACTUAL DEL EQUIPO

Desde cualquier vista del equipo ejecutar el comando:

<AR151>dis current-configuration
[V200R005C00]
#
sysname CPEbandaancha
(Se omite la salida completa)

2.6. GRABAR LA CONFIGURACIN DEL EQUIPO

En modo usuario ejecutar el comando:

<AR151>save

The current configuration will be written to the device.


Are you sure to continue? (y/n)[n]:y
It will take several minutes to save configuration file, please wait........
Configuration file had been saved successfully
Note: The configuration file will take effect after being activated

2.7. MODO USUARIO Y MODO SISTEMA

Estando en modo usuario (<AR151>) ingresar al modo de sistema ([AR151]):

<AR151>system-view
Enter system view, return user view with Ctrl+Z.
[AR151]sysname ?
TEXT<"..."> Host name (no more than 246 characters)
[AR151]sysname PRUEBA Ejemplo de configuracin comando para nombrar el equipo.
[PRUEBA]

Confidencial Pag 9 2013-10-11


CONFIGURACION CPES HUAWEI AR151

2.8. CONFIGURACIN DEL MENSAJE DE BIENVENIDA

[AR151]header login information ?

TEXT<"..."> Set header text, take the first character as the specified start and end character, the string
between the start character and the end character is the header to be displayed,The banner text supports 480
characters max, including the start and the end character

[AR151]header login information "*************************************************************


* ATENCION: Este equipo es propiedad de CLARO COLOMBIA *
* El uso no autorizado esta estrictamente prohibido. *
* *
* Todos los usuarios son legalmente responsables de sus *
* acciones sobre el sistema y toda actividad sera registrada *
*************************************************************************"

2.9. CONFIGURACIN DE USUARIO PARA INGRESO AL ROUTER TANTO


POR CONSOLA COMO POR TELNET

El primer paso es crear el usuario con su respectivo password, se ingresa a proceso aaa:
[AR151]aaa
[AR151-aaa] local-user gestion password cipher Prueba123

Posteriormente se le asigna un nivel de comandos que puede realizar el usuario (de 0 a 15,
donde 3 es el mximo nivel permitido):

[AR151-aaa]local-user gestion privilege level 4


Error: Low-level users are not allowed to create, delete, or modify high-level users.
[AR151-aaa]local-user gestion privilege level 3
[AR151-aaa]

Luego se seleccionan los tipos de acceso que va a tener el usuario, en nuestro caso Telnet y
consola.

[AR151-aaa]local-user gestion service-type telnet

2.10. CONFIGURACIN DE LA INTERFAZ DE CONSOLA Y LNEAS VTY

[PRUEBA]user-interface console 0
[PRUEBA-ui-console0] authentication-mode aaa
[PRUEBA]user-interface vty 0 4
[PRUEBA-ui-vty0-4] authentication-mode aaa

Confidencial Pag 10 2013-10-11


CONFIGURACION CPES HUAWEI AR151

2.11. CONFIGURACIN DE LA FECHA Y LA HORA

<PRUEBA>clock datetime ?
HH:MM:SS Specify the time
<PRUEBA>clock datetime 16:34:00 ?
YYYY/MM/DD Specify the date from 2000 to 2099
<PRUEBA>clock datetime 16:34:00 2005/01/03

2.12. CONFIGURACIN DE INTERFACES ETHERNET

Ingresar al modo de configuracin de la interfaz:

[PRUEBA] interface Ethernet 0/0/8

Asociar una descripcin a la interfaz:

[PRUEBA-Ethernet0/0/8] description --- LAN PRUEBAS ---

Fijar la velocidad y el modo de operacin:

[PRUEBA-Ethernet0/0/8] speed ?
10 10M port speed mode
100 100M port speed mode

[PRUEBA-Ethernet0/0/8] duplex ?
full Full-Duplex mode
half Half-Duplex mode

Asignar una direccin IP a la interfaz:

[PRUEBA-Ethernet0/0/8]ip address 192.168.1.1 24


o
[PRUEBA-Ethernet0/0/8] ip address 192.168.1.1 255.255.255.0

Asignar una direccin secundaria a la interfaz:

[PRUEBA-Ethernet0/0/8] ip address 172.16.1.1 24 sub


o
[PRUEBA-Ethernet0/0/8] ip address 172.16.1.1 255.255.255.0 sub

Bajar administrativamente la interfaz:

[PRUEBA-Ethernet0/0/8]shutdown

Confidencial Pag 11 2013-10-11


CONFIGURACION CPES HUAWEI AR151

Subir administrativamente la interfaz

[PRUEBA-Ethernet0/0/8] undo shutdown

Subir lgicamente la interfaz sin necesidad de tener un equipo conectado

[PRUEBA-Ethernet0/0/8] loopback internal

Para volverla a la normalidad:

[PRUEBA-Ethernet0/0] undo loopback

Observar el estado actual de la interfaz y los contadores.

[PRUEBA] display interface Ethernet 0/0/8

2.13. CONFIGURACIN DE RUTAS ESTTICAS

[PRUEBA]ip route-static 0.0.0.0 0.0.0.0 10.160.1.1

2.14. CONFIGURACIN DE LISTAS DE ACCESO

[PRUEBA]acl number ?
INTEGER<2000-2999> Basic access-list(add to current using rules)
INTEGER<3000-3999> Advanced access-list(add to current using rules)
INTEGER<4000-4999> Specify a L2 acl group

Lista de acceso bsica:

[PRUEBA] acl 2000


[PRUEBA-acl-basic-2000]rule 1 permit source 192.168.1.0 0.0.0.255

Lista de acceso extendida:

PRUEBA] acl 3000


[PRUEBA-acl-adv-3000]rule 1 permit tcp source 192.168.1.0 0.0.0.255 destination
192.168.2.0 0.0.0.255 destination-port eq 80

2.15. CONFIGURACIN DE NAT

2.15.1. NAT DINMICO

El primer paso es definir un grupo de direcciones con el que se va a hacer el NAT:

[PRUEBA]nat address-group 1 ?

Confidencial Pag 12 2013-10-11


CONFIGURACION CPES HUAWEI AR151

IP_ADDR<X.X.X.X> Start address

[PRUEBA]nat address-group 1 200.74.100.1 ?


IP_ADDR<X.X.X.X> End address

[PRUEBA]nat address-group 1 200.74.100.1 200.74.100.1 ?


<cr> Please press ENTER to execute command

[PRUEBA]nat address-group 1 200.74.100.1 200.74.100.1

Luego en la interfaz WAN se asocia el NAT de salida con una lista de acceso extendida y con un
nat address-group; si no se asocia ste ltimo, el NAT se hace con la IP de la interfaz:

[PRUEBA]int Ethernet0/0/8
[PRUEBA-Ethernet0/0/8]nat outbound ?
INTEGER<2000-3999> Apply basic or advanced ACL

[PRUEBA-Ethernet0/0/8]nat outbound 3000 ?


address-group IP address-group of NAT
interface Specify the interface
<cr> Please press ENTER to execute command

[PRUEBA-Ethernet0/0/8]nat outbound 3000 address-group 1

<Huawei>display nat outbound


NAT Outbound Information:
--------------------------------------------------------------------------
Interface Acl Address-group/IP/Interface Type
--------------------------------------------------------------------------
Ethernet0/0/8 3000 1 pat
--------------------------------------------------------------------------
Total : 1

<Huawei>dis nat session all


NAT Session Table Information:

Protocol : ICMP(1)
SrcAddr Vpn : 192.168.20.4
DestAddr Vpn : 10.10.10.2
Type Code IcmpId : 0 8 54029
NAT-Info
New SrcAddr : 200.74.100.1
New DestAddr : ----
New IcmpId : 10257

Protocol : ICMP(1)
SrcAddr Vpn : 192.168.20.4
DestAddr Vpn : 10.10.10.2
Type Code IcmpId : 0 8 54031
NAT-Info
New SrcAddr : 200.74.100.1

Confidencial Pag 13 2013-10-11


CONFIGURACION CPES HUAWEI AR151

New DestAddr : ----


New IcmpId : 10258

Total : 2

2.15.2. NAT ESTTICO

Hay dos maneras de hacer un NAT esttico, la primera es definindolo en el modo de sistema:

[PRUEBA] interface Ethernet 0/0/8

[PRUEBA-Ethernet0/0/8]nat static ?
enable Enable function
global Specify global information of NAT
protocol Specify protocol

[PRUEBA-Ethernet0/0/8]nat static global ?


X.X.X.X Global IP address of NAT

[PRUEBA-Ethernet0/0/8] nat static global 200.74.1.25 inside ?


IP_ADDR<X.X.X.X> Inside IP address of NAT

[PRUEBA-Ethernet0/0/8] nat static global 200.74.1.25 inside 192.168.20.4

[PRUEBA] display nat static


Static Nat Information:
Interface : Ethernet0/0/8
Global IP/Port : 200.74.1.25/----
Inside IP/Port : 192.168.20.4/----
Protocol : ----
VPN instance-name : ----
Acl number : ----
Netmask : 255.255.255.255
Description : ----
Total : 1

La segunda es haciendo un NAT Server en la interfaz WAN del router, donde se definen los
parmetros para hacer NAT esttico slo de los puertos que uno defina y no de todas las clases de
trfico:

[PRUEBA-Ethernet0/0/8]nat server protocol tcp global ?


X.X.X.X Global IP address of NAT
current-interface Address of current interface
interface Specify the interface

[PRUEBA-Ethernet0/0/8]nat server protocol tcp global 200.74.1.25 www inside ?


IP_ADDR<X.X.X.X> Inside IP address of NAT

[PRUEBA-Ethernet0/0/8]nat server protocol tcp global 200.74.1.25 www inside 192.168.1.5 www

[PRUEBA] display nat server

Confidencial Pag 14 2013-10-11


CONFIGURACION CPES HUAWEI AR151

Nat Server Information:


Interface : Ethernet0/0/8
Global IP/Port : 200.74.1.25/80(www)
Inside IP/Port : 192.168.1.5/80(www)
Protocol : 6(tcp)
VPN instance-name : ----
Acl number : ----

2.15.3. NAT ALG (APLICATION LAYER GATEWAY)

Este NAT es til para permitir aplicaciones de telefona como SIP las cuales son sensibles al NAT
dinmico normal:

Para configurar el NAT ALG podemos hacer otro nat server

[PRUEBA-Ethernet0/0/0] nat server protocol tcp global 200.74.1.33 ftp inside 10.0.0.3 ftp

[PRUEBA] nat alg ftp enable


[PRUEBA] display nat server
Nat Server Information:
Interface : Ethernet2/0/0
Global IP/Port : 202.74.1.33/21(ftp)
Inside IP/Port : 10.0.0.3/21(ftp)
Protocol : 6(tcp)
VPN instance-name : ----
Acl number : ----

Total : 1

[PRUEBA] display nat alg


NAT Application Level Gateway Information:
----------------------------------
Application Status
----------------------------------
dns Disabled
ftp Enabled
rtsp Disabled
sip Disabled
----------------------------------

2.16. CONFIGURACIN DE PROTOCOLOS DE ENRUTAMIENTO DINMICOS

2.16.1. OSPF

Lo primero que se debe definir es el router ID, se utilizar la IP WAN del CPE como ID:

[PRUEBA]router id 10.160.1.1

Posteriormente se hace la configuracin del proceso de OSPF:

Confidencial Pag 15 2013-10-11


CONFIGURACION CPES HUAWEI AR151

[PRUEBA]ospf 1
[PRUEBA-ospf-1]area 0
[PRUEBA-ospf-1-area-0.0.0.0]network 10.160.1.1 0.0.0.3

Si se desea anunciar una ruta default:

[PRUEBA-ospf-1]default-route-advertise

Para anunciar redes de otros protocolos en OSPF:

[PRUEBA-ospf-1]import-route ?
bgp Border Gateway Protocol (BGP) routes
direct Connected routes
isis Intermediate System to Intermediate System (IS-IS) routes
limit Limit the number of routes imported into OSPF
ospf Open Shortest Path First (OSPF) routes
rip Routing Information Protocol (RIP) routes
static Static routes
unr User Network Routes

Para aplicar un filtro a las rutas que se desean anunciar o aprender por OSPF:

[PRUEBA-ospf-1]filter-policy ?
INTEGER<2000-2999> Apply basic ACL
acl-name Specify the ACL name for filtering IPv4 routes
ip-prefix IP address prefix-list
route-policy Route policy

[PRUEBA-ospf-1]filter-policy 2000 ?
export Filtering outgoing routing updates
import Filtering incoming routing updates

[PRUEBA-ospf-1]filter-policy 2000 export ?


bgp Border Gateway Protocol (BGP) routes
direct Connected routes
isis Intermediate System to Intermediate System (IS-IS) routes
ospf Open Shortest Path First (OSPF) routes
rip Routing Information Protocol (RIP) routes
static Static routes
unr User Network Routes
<cr> Please press ENTER to execute command

2.16.2. BGP

Configurar el proceso de BGP:

[PRUEBA]bgp 65000
[PRUEBA-bgp]undo synchronization

Confidencial Pag 16 2013-10-11


CONFIGURACION CPES HUAWEI AR151

[PRUEBA-bgp]group 1 external
[PRUEBA-bgp]peer 10.160.1.1 group 1
[PRUEBA-bgp]peer 10.160.1.1 as-number 14080
[PRUEBA-bgp]peer 10.160.1.1 timer keepalive 10 hold 30

Para anunciar redes, se deben adicionar como network en el proceso de BGP:

[PRUEBA-bgp]network 192.168.1.0 255.255.255.0

Para aplicar un filtro a las rutas que se desean anunciar o aprender por BGP:

[PRUEBA-bgp]filter-policy 2000 export ?


direct Connected routes
isis Intermediate System to Intermediate System (IS-IS) routes
ospf Open Shortest Path First (OSPF) routes
rip Routing Information Protocol (RIP) routes
static Static routes
unr User network routes
<cr> Please press ENTER to execute command

2.17. CONFIGURACIN DE POLITICAS EN UNA INTERFAZ

Para poder aplicar una poltica determinada en el equipo primero se debe definer una lista de
acceso que identifique el tipo de trfico (direcciones IP) al que se les desea aplicar la poltica.

[PRUEBA]acl number 3001


[PRUEBA-acl-adv-3001]rule 0 permit ip source 200.14.234.16 0.0.0.7 destination any

Luego se crea la poltica para aplicarle una caracterstica determinada al trfico por ejemplo para
fijar el next hop:

[PRUEBA]route-policy INTERNET permit node 1


Info: New Sequence of this List.

[PRUEBA-route-policy]if-match ?
acl Specify an ACL
as-path-filter BGP AS path list
community-filter Match BGP community filter
cost Match metric of route
extcommunity-filter Match BGP/VPN extended community filter
interface Specify the interface matching the first hop of routes
ip IP information
ip-prefix Specify an address prefix-list
ipv6 IPv6 Information
mpls-label Give the Label
rd-filter Route-distinguisher filter
route-type Match route-type of route
tag Match tag of route

[PRUEBA -route-policy]if-match acl 3001

Confidencial Pag 17 2013-10-11


CONFIGURACION CPES HUAWEI AR151

[PRUEBA-route-policy]apply ?
as-path BGP AS path list
backup-interface Backup outgoing interface
backup-nexthop Backup nexthop address
behavior Specify QoS policy as behavior
comm-filter Set BGP community filter (for deletion)
community BGP community attribute
cost Set metric of route
cost-type Type of metric for destination routing protocol
dampening Set BGP route flap dampening parameters
extcommunity Set BGP/VPN extended community filter
ip-address IP information
ip-precedence Specify QoS policy as IP precedence
ipv6 IPv6 Information
local-preference BGP local preference path attribute
mpls-label Give the Label
origin BGP origin code
ospf Where to import route
preference Give the Preference (Route Preference)
preferred-value BGP Preferred-value (weight) for routing table
qos-local-id Specify QoS policy as qos local id
tag Set tag of route
traffic-index Specify BGP Traffic Accounting Index
[PRUEBA -route-policy]apply ip-address next-hop 10.160.1.1

2.18. CONFIGURACIN DE CALIDAD DE SERVICIO

A continuacin se muestra un ejemplo para configurar calidad de servicio marcando los paquetes
que llegan por la LAN y dndoles prioridad por la interfaz WAN.

Primero se crea una poltica que marque los paquetes deseados (de acuedo a una lista de acceso)
con una precedencia determinada:

[PRUEBA]acl number 2001


[PRUEBA-acl-basic-2001]rule 1 permit source 192.168.50.0 0 0.0.255

[PRUEBA]route-policy Prioridad-2 permit node 1


[PRUEBA-route-policy]if-match acl 2001
[PRUEBA-route-policy]apply ip-precedence immediate

Se crea un clasificador de trfico que haga match con la precedencia de los datos deseada ya sea
por el ToS o el DSCP:

[PRUEBA]traffic classifier Precedencia-2


[PRUEBA-classifier-Precedencia-2]if-match ip-precedence 2
[PRUEBA-classifier-Precedencia-2]if-match dscp cs2

Confidencial Pag 18 2013-10-11


CONFIGURACION CPES HUAWEI AR151

Posteriormente se debe crear un behavior que especifica el trato que se le va a dar al tipo de
datos, es decir asegurarle un ancho de banda determinado:

[PRUEBA]traffic behavior Precedencia-2


[PRUEBA-behavior-Precedencia-2]queue af bandwidth 64

Finalmente se crea la poltica de calidad deservicio asociada al clasificador y al behavior del trfico:

[PRUEBA]traffic policy Prioridad-2


[PRUEBA-trafficpolicy-Prioridad-2]classifier Precedencia-2 behavior Precedencia-2

Por ltimo se aplica la poltica a la interfaz WAN por donde salen los datos:

[PRUEBA]interface Ethernet 0/0/8


[PRUEBA-Ethernet0/0/8]traffic-policy Prioridad-2 outbound

2.19. CONFIGURACIN DE CALIDAD DE SERVICIO PARA VOZ

2.19.1. ULTIMA MILLA ETHERNET

La configuracin de calidad de servicio (QoS) para voz se hace de la misma forma como se
explic en el punto anterior para los datos. La nica diferencia es que al asignar la cola de la
interfaz (queue) se utiliza la ef (expedited forwarding) y no la af (assured forwarding). A
continuacin se muestra un ejemplo de configuracin:

Primero se crea una poltica que marque los paquetes de voz con precedencia 5:

[PRUEBA]acl number 2000


[PRUEBA-acl-basic-2000]rule 1 permit source 10.8.0.0 0.0.0.7

[PRUEBA]route-policy Prioridad-5 permit node 1


[PRUEBA-route-policy]if-match acl 2000
[PRUEBA-route-policy]apply ip-precedence critical

Se crea un clasificador de trfico que haga match con la precedencia de la voz ya sea por el ToS o
el DSCP:

[PRUEBA]traffic classifier Precedencia-5 operator or


[PRUEBA-classifier-Precedencia-5]if-match ip-precedence 5
[PRUEBA-classifier-Precedencia-5]if-match dscp ef

Luego se crea un behavior para asegurarle un ancho de banda determinado:

[PRUEBA]traffic behavior Precedencia-5


[PRUEBA-classifier-Precedencia-5]queue ef bandwidth 64

Confidencial Pag 19 2013-10-11


CONFIGURACION CPES HUAWEI AR151

Finalmente se crea la poltica de calidad deservicio asociada al clasificador y al behavior del trfico:

[PRUEBA]qos policy Prioridad-5


[PRUEBA-trafficpolicy-Prioridad-5]classifier Precedencia-5 behavior Precedencia-5

Por ltimo se alpaca la poltica a la interfaz WAN por donde sale la voz:

[PRUEBA]interface Ethernet 0/0/8


[PRUEBA-Ethernet0/0/8]traffic-policy Prioridad-5 outbound

3 HERRAMIENTAS DE DIAGNOSTICO - TROUBLESHOOTING

3.1.1. PING

[PRUEBA]ping ?
STRING<1-255> IP address or hostname of a remote system
-a Select source IP address, the default is the IP address of the output interface
-c Specify the number of echo requests to be sent, the default is 5
-d Specify the SO_DEBUG option on the socket being used
-f Set Don't Fragment flag in packet (IPv4-only)
-h Specify TTL value for echo requests to be sent, the default is 255
-i Select the interface sending packets
-m Time in milliseconds to wait for sending next packet, the default is 500ms
-n Numeric output only. No attempt will be made to lookup host addresses for symbolic names
-name Display the host name of the destination address
-p No more than 8 (pad) hexadecimal characters to fill out the sent packet. For example -p f2 will fill the
sent packet with f and 2 repeatedly
-q Quiet output. Nothing is displayed except the summary lines at startup time and when finished
-r Record route. Includes the RECORD_ROUTE option in the ECHO_REQUEST packet and displays the
route
-s Specify the number of data bytes to be sent, the default is 56bytes
-si Set the specified interface as the source interface of ping packet
-system-time Display the sending time of echo request packets
-t Timeout in milliseconds to wait for each reply, the default is 2000ms
-tos Specify TOS value for echo requests to be sent, the default is 0
-v Verbose output. ICMP packets other than ECHO_RESPONSE those are received are listed
-vpn-instance Specify VPN-Instance of MPLS VPN
ignore-mtu Send packets without checking the interface MTU
ip IP Protocol
ipv6 IPv6 protocol
multicast Multicast ping
vc PWE3 Ping

Un ping de origen se genera con la letra a y tiene que contener una ip perten eciente al router.

[PRUEBA]ping -a 10.10.10.10 20.20.20.2


PING 20.20.20.2: 56 data bytes, press CTRL_C to break

Confidencial Pag 20 2013-10-11


CONFIGURACION CPES HUAWEI AR151

Reply from 20.20.20.2: bytes=56 Sequence=1 ttl=255 time=60 ms


Reply from 20.20.20.2: bytes=56 Sequence=2 ttl=255 time=10 ms
Reply from 20.20.20.2: bytes=56 Sequence=3 ttl=255 time=20 ms
Reply from 20.20.20.2: bytes=56 Sequence=4 ttl=255 time=20 ms
Reply from 20.20.20.2: bytes=56 Sequence=5 ttl=255 time=20 ms

--- 20.20.20.2 ping statistics ---


5 packet(s) transmitted
5 packet(s) received
0.00% packet loss
round-trip min/avg/max = 10/26/60 ms

3.1.2. TRACERT

[PRUEBA]tracert ?
STRING<1-255> IP address or hostname of a remote system
-a Set source IP address, the default is the IP address of the output interface
-f First time to live, the default is 1
-m Max time to live, the default is 30
-name Display the host name of the router on each hop
-p Destination UDP port number, the default is 33434
-q Number of probe packet, the default is 3
-s
-v Display the MPLS label information carried in the ICMP Time Exceed message. By default, it is only to
display the path information carried in the ICMP Time Exceed message and ICMP Port Unreachable message
without MPLS label information
-vpn-instance Specify VPN-Instance of MPLS VPN
-w Timeout in milliseconds to wait for each reply, the default is 5000ms
ipv6 IPv6 Protocol
vc PWE3 traceroute

3.1.3. DEBUGGING

Antes de habilitar el debug, se debe jecutar el siguiente comando en el modo de sistema:

[PRUEBA]info-center enable
Info: Information center is enabled.

En modo usuario ejecutar los commandos:

<PRUEBA>terminal monitor
Info: Current terminal monitor is on.
<PRUEBA>terminal debugging
Info: Current terminal debugging is on.

Habilitar el debug deseado en el equipo:

<PRUEBA>debugging ?
aaa AAA
acl4 ACL4 module

Confidencial Pag 21 2013-10-11


CONFIGURACION CPES HUAWEI AR151

aclada Aclada
adp-ipsec IP Security
all All debugging functions
am AM module
anti-attack Specify anti-attack configurations
application-apperceive Set application-apperceive information
arp ARP module
arp-ping ARP-ping
arp-proxy Arp proxy debugging functions
atm ATM module
bfd BFD module
bgp BGP protocol
bridge Bridge
bridge-adp Display bridge module debuging information
cm CM module
cwmp CPE WAN Management Protocol
dhcp Dynamic host configure protocol
dhcpv6 Dynamic host configure protocol for IPv6
dialer DCC module
dlsw Data Link Switching module
dns <Group> dns command group
dot1x EAPOL module
efm EFM module
error-down The interface was shut down because of an error event
ethernet Ethernet module
firewall Firewall debugging
forward Forward
fr <Group> fr command group
ftp-server FTP server debugging information
gresm GRESM module
gvrp Generic VLAN Registration Protocol
hdlc HDLC module
http Http server information
hwtacacs Set HWTACACS server
ifnet Ifnet module
igmp Specify parameters for IGMP
ike Specify IKE(Internet Key Exchange) configuration
information
ikev2 IKE V2 information
ip <Group> ip command group
ipsec Specify IPSec(IP Security) configuration information
ipv6 <Group> ipv6 command group
isdn ISDN module
isis Intermediate System to Intermediate System (ISIS)
routes
keychain Keychain module
l2if Layer two interface management
l2tp L2TP module
l2vovlan Voice VLAN
lapb LAPB module
llc2 LLC2 module
lldp Link Layer Discovery Protocol
lspagt LSPAGT module
mac-limit MAC limit
mfib MFIB module
mgr Ethernet OAM manager
mlppp MLPPP shell debugging

Confidencial Pag 22 2013-10-11


CONFIGURACION CPES HUAWEI AR151

mrm Multicast information


msdp MSDP module
mti Mti Module
mtrace Trace route to multicast source
nat Nat debugging functions
netconf Netconf infomation
netstream-index Netstream index
nhrp <Group> nhrp command group
nqa NQA module
ntp-service NTP module
ospf Open Shortest Path First (OSPF)
ospfv3 OSPF version 3 for IPv6
pad PAD module
pim PIM module
pki PKI debugging
portal <Group> portal command group
ppp <Group> ppp command group
pppoe-client PPPoE Client module
pppoe-server PPPoE server module
qinq <Group> qinq command group
radius RADIUS module
rawip RAWIP module
rawlink RAWLINK module
rip RIP module
ripng RIPng module
rm Routing Module
rmon Specify RMON configuration
sam Service agent module
sdlc SDLC module
sla SLA module
snmp-agent SNMP module
ssh SSH module
ssl SSL
sslvpn Sslvpn
stp Specify Spanning Tree Protocol (STP) configuration
information
tcm TCM module
tcp TCP module
timeout Set the time in minutes when the debug will be stopped
tm TM module
tnlm Tunnel configurations
trunk Trunk interface management
tunnel Tunnel module
tunnel-protocol Tunnel Protocol
udp UDP module
vfs Versatile file system
vrrp VRRP module
vrrp4 Specify configuration information about VRRP4
vrrp6 Specify configuration information about VRRP6
web Web module
wlan Wlan
x25 X.25 module

Confidencial Pag 23 2013-10-11


CONFIGURACION CPES HUAWEI AR151

3.1.4. SOLUCION DE PROBLEMAS. CASOS.

Dentro de los problemas tpicos que se pueden presentar est el no poder alcanzar el ancho de
banda configurado. En este caso se debe revisar la configuracin de la interfaz WAN y
negociacin que est aplicada. Se debe asegurar que la interfaz est en FULL DUPLEX. En caso
de que la autonegociacin no lo permta, se debe forzar manualmente.

interface Ethernet0/0/4
description WAN
undo negotiation auto

<CPEbandaancha>dis int eth0/0/4


Ethernet0/0/4 current state : UP
Line protocol current state : DOWN
Description:WAN
Route Port,The Maximum Transmit Unit is 1500
Internet protocol processing : disabled
IP Sending Frames' Format is PKTFMT_ETHNT_2, Hardware address is dcd2-fc03-a060
Last physical up time : 2013-10-11 17:44:44
Last physical down time : 2013-10-11 17:44:25
Current system time: 2013-10-11 21:16:44
Port Mode: COMMON COPPER
Speed : 100, Loopback: NONE
Duplex: FULL, Negotiation: DISABLE
Mdi : AUTO
Last 300 seconds input rate 840 bits/sec, 1 packets/sec
Last 300 seconds output rate 464 bits/sec, 0 packets/sec
Input peak rate 1684680 bits/sec,Record time: 2013-10-11 18:05:18
Output peak rate 227272 bits/sec,Record time: 2013-10-11 18:05:18

Input: 89303 packets, 98592855 bytes


Unicast: 75598, Multicast: 13362
Broadcast: 343, Jumbo: 0
Discard: 0, Total Error: 0

CRC: 2284, Giants: 0


Jabbers: 11, Throttles: 122
Runts: 0, Symbols: 0
Ignoreds: 0, Frames: 0

Output: 51267 packets, 5261349 bytes


Unicast: 51255, Multicast: 0
Broadcast: 12, Jumbo: 0
Discard: 0, Total Error: 0

Collisions: 0, ExcessiveCollisions: 0
Late Collisions: 0, Deferreds: 0

Input bandwidth utilization threshold : 100.00%


Output bandwidth utilization threshold: 100.00%
Input bandwidth utilization : 0.01%
Output bandwidth utilization : 0.01%

<CPEbandaancha>

Confidencial Pag 24 2013-10-11


CONFIGURACION CPES HUAWEI AR151

4 ACTUALIZACION SOFTWARE DEL EQUIPO

Para realizar el upgrade del equipo, se debe tener el software a actualizar y ya con este se procede
a copiar en el equipo se carga y se reinicia. El software de sistema operativo en equipos Huawei se
llama VRP.

Inicialmente convertimos el router en un servidor ftp para asi poder cargar el directorio de
nuestro porttil:

[PRUEBA]ftp server enable


Info: Succeeded in starting the FTP server
[PRUEBA]aaa
[PRUEBA-aaa]local-user huawei password cipher huawei123
[PRUEBA-aaa]local-user huawei service-type ftp
[PRUEBA-aaa]local-user huawei ftp-directory flash:

Posterior se ingresa al command line de Windows y previo a eso uno se posiciona donde este
guardado el archivo .cc del nuevo VRP y procede a abrir el ftp a la IP que tenga el router,
ingresamos con los datos creados previamente. Colocamos en binario para transferir con el
comando bin y despus con el comando put y el nombre del archivo lo copiamos dentro del
router put ar_150v200r002.cc.

Ya con el archivo dentro del router se procede a cargarlo para que en el prximo reinicio se
active.

[PRUEBA]startup system-software ar_150v200r002.cc verify

Confidencial Pag 25 2013-10-11


CONFIGURACION CPES HUAWEI AR151

<PRUEBA> display startup


MainBoard:
Startup system software: flash:/ar150.cc
Next startup system software: flash:/ar_150v200r002.cc
Backup system software for next startup: null
Startup saved-configuration file: null
Next startup saved-configuration file: flash:/vrpcfg.zip
Startup license file: null
Next startup license file: null
Startup patch package: null
Next startup patch package: null
Startup voice-files: null
Next startup voice-files: null

Se procede al reinicio para activar el nuevo VRP.

<PRUEBA>reboot
Info: The system is comparing the configuration, please wait.
Warning: All the configuration will be saved to the next startup configuration. Continue ? [y/n]:y
It will take several minutes to save configuration file, please wait...............
Configuration file had been saved successfully
Note: The configuration file will take effect after being activated
System will reboot! Continue ? [y/n]:y
Info: system is rebooting ,please wait...

Posterior a el reinicio esperamos a que el equipo suba nuevamente y ejecutamos el display version
para revisar que la nueva versin halla quedado.

<Huawei> display version


Huawei Versatile Routing Platform Software
VRP (R) software, Version 5.110 (AR150 V200R002C01)
Copyright (C) 2011-2011 HUAWEI TECH CO., LTD
Huawei AR151 Router uptime is 0 week, 1 day, 0 hour, 0 minute

MPU 0(Master) : uptime is 0 week, 1 day, 0 hour, 0 minute


SDRAM Memory Size : 512 M bytes
Flash Memory Size : 512 M bytes
MPU version information :
1. PCB Version : AR01SRU0A VER.A
2. MAB Version : 0
3. Board Type : AR201
4. CPLD1 Version : 0
5. BootROM Version : 106
SubBoard[1]:
1. PCB Version : AR00DLA1XA VER.A
2. Board Type : ADSL-A
3. BootROM Version : 2

Confidencial Pag 26 2013-10-11


CONFIGURACION CPES HUAWEI AR151

5 OTROS PROTOCOLOS Y SERVICIOS

5.1. CONFIGURACIN DE VRRP (VIRTUAL ROUTER REDUNDANCY


PROTOCOL ) ENTRE HUAWEI Y CISCO

VRRP es un protocolo empleado para proveer redundancia de equipos para un cliente creando
una direccin de LAN virtual en los routers. Este protocolo se puede configurar ya sea entre 2
equipos Huawei o un Huawei y un Cisco que soporte este protocolo.

5.1.1. CONFIGURACIN CON 2 ROUTERS HUAWEI

Router principal:

[PRUEBA-MASTER] interface Ethernet0/0/8


[PRUEBA-MASTER-Ethernet0/0/8]vrrp vrid 5 virtual-ip 192.168.1.1
[PRUEBA-MASTER-Ethernet0/0/8]vrrp vrid 5 priority 120
[PRUEBA-MASTER-Ethernet0/0/8]vrrp vrid 5 preempt-mode timer delay 20
[PRUEBA-MASTER-Ethernet0/0/8]vrrp vrid 5 track interface Ethernet 0/0/0 reduced 40

En este caso la IP fsica del equipo es la 192.168.1.2/24 y la virtual es la 192.168.1.1/24. Se define


una prioridad de 120 que debe ser la ms alta para que sea el principal y se hace track de la
interfaz WAN para que en caso de que se caiga se reduzca la prioridad en 40 y quede en 80 para
que el otro equipo entre a ser el principal.

Router backup:

[PRUEBA-BACKUP]int eth0/0/8
[PRUEBA-BACKUP-Ethernet0/0/8]vrrp vrid 5 virtual-ip 192.168.1.1
<PRUEBA-MASTER>dis vrrp
Ethernet0/0/8 | Virtual Router 5
State : Master
Virtual IP : 192.168.1.1
Master IP : 192.168.1.2
PriorityRun : 120
PriorityConfig : 120
MasterPriority : 120
Preempt : YES Delay Time : 20 s
TimerRun : 1 s
TimerConfig : 1 s
Auth type : NONE
Virtual MAC : 0000-5e00-0105
Check TTL : YES
Config type : normal-vrrp
Backup-forward : disabled
Create time : 2013-05-21 21:53:56 UTC-05:13
Last change time : 2013-05-21 21:53:59 UTC-05:13

[PRUEBA-BACKUP]dis vrrp

Confidencial Pag 27 2013-10-11


CONFIGURACION CPES HUAWEI AR151

Ethernet0/0/8 | Virtual Router 5


State : Backup
Virtual IP : 192.168.1.1
Master IP : 192.168.1.2
PriorityRun : 100
PriorityConfig : 100
MasterPriority : 120
Preempt : YES Delay Time : 0 s
TimerRun : 1 s
TimerConfig : 1 s
Auth type : NONE
Virtual MAC : 0000-5e00-0105
Check TTL : YES
Config type : normal-vrrp
Backup-forward : disabled
Create time : 2013-05-21 21:58:57 UTC-05:13
Last change time : 2013-05-21 21:58:58 UTC-05:13

5.1.2. CONFIGURACIN CON 1 ROUTER HUAWEI Y 1 ROUTER CISCO

La configuracin del router Huawei es exactamente igual a como se explic en el punto anterior.
La configuracin del router Cisco se muestra a continuacin:

Pruebas(config)#interface Ethernet0/0
Pruebas(config-if)#ip address 192.168.1.2 255.255.255.0
Pruebas(config-if)#vrrp 1 ip 192.168.1.1
Pruebas(config-if)#vrrp 1 preempt
Pruebas(config-if)#vrrp 1 priority 100

5.2. CONFIGURACIN DE INSTANCIAS VPN (VRF).

Los enrutadores HUAWEI tambin soportan mltiples instancias de VPN o mejor conocidas
como instancias de enrutamiento (VRF). Esta caracterstica permite manejar diferentes tablas de
enrutamiento dentro del mismo router con el fin de independizar servicios.

Los comandos de configuracin a aplicar son:

ip vpn-instance <servicio> --> "Creacin instancia VPN"


route-distinguisher <rd-asignado>

interface Ethernet0/0/8.2 --> "Configuracin del puerto asociando la instancia"


ip binding vpn-instance <servicio>
dot1q termination vid <vlan-servicio>
ip address <ip-wan-internet> 255.255.255.252
arp broadcast enable

Se comprueba si hay conexin, haciendo un ping dentro de la instancia a la IP complementaria.

Confidencial Pag 28 2013-10-11


CONFIGURACION CPES HUAWEI AR151

ping -vpn-instance <servicio> <ip-wan-gateway>

Si se requiere asociar el puerto LAN a la instancia VPN creada:


interface Ethernet0/0/8
ip binding vpn-instance <servicio>
ip address <ip-lan-servicio> 255.255.255.252

Conectando un PC a la LAN Eth0/0/8 se comprueba que hay conexin el PC y el enrutador.

--> Definicin de enrutamiento.


ip route-static vpn-instance Internet 0.0.0.0 0 <ip-lan-gateway>

5.3. SERVICIO DHCP

Aca se describe como se configura un servidor DHCP basado en un rango de direcciones donde
los clientes DHCP y el servidor estn en el mismo segmento de red.

[PRUEBA]dhcp enable
Info: The operation may take a few seconds. Please wait for a moment.done.
[PRUEBA]ip pool pool1
Info: It's successful to create an IP address pool.
[PRUEBA-ip-pool-pool1]network 10.10.10.0 mask 24
[PRUEBA-ip-pool-pool1]gateway-list 10.10.10.1
[PRUEBA-ip-pool-pool1]excluded-ip-address ?
IP_ADDR<X.X.X.X> The start IP address of the excluded IP network section
[PRUEBA-ip-pool-pool1]excluded-ip-address 10.10.10.2 ?
IP_ADDR<X.X.X.X> The end IP address of the excluded IP network section
<cr> Please press ENTER to execute command
[PRUEBA-ip-pool-pool1]excluded-ip-address 10.10.10.2 10.10.10.24

Despues de crear el rango de direcciones y excluir las direcciones IP se asigna a la interfz la cual
esta conectada a la LAN.

[PRUEBA]int eth0/0/8
[PRUEBA-Ethernet0/0/8]dhcp select global

[PRUEBA]dis ip pool
-----------------------------------------------------------------------
Pool-name : pool1
Pool-No :0
Position : Local Status : Unlocked
Gateway-0 : 10.10.10.1
Mask : 255.255.255.0
VPN instance : --

IP address Statistic
Total :253
Used :0 Idle :230
Expired :0 Conflict :0 Disable :23

Confidencial Pag 29 2013-10-11


CONFIGURACION CPES HUAWEI AR151

6 CONFIGURACIN DE SERVICIOS ESTANDAR PARA CLARO COLOMBIA

A continuacin se presentan las configuraciones que se deben aplicar para la


implementacin de los servicios estndar que ofrece CLARO Colombia:

6.1. SERVICIO BANDAANCHA

El servicio de internet BANDA-ANCHA que se presenta a continuacin posee las siguientes


caractersticas las cuales se ajustan a las caractersticas ofrecidas a nivel de producto:

1. Configuracin de DHCP (Server) para entregar direccionamiento privado a la LAN del


cliente.
2. Configuracin de NAT dinmico que permite entregar el servicio de internet con una
sola direccin IP /32. El servicio BANDA-ANCHA por estndar no entrega
direccionamiento IP pblico (LAN) a los hosts del cliente.
3. En caso de que el cliente pague por tener direccionamiento IP pblico (Por producto
se permite tener hasta 5 direcciones IP asignadas a hosts del cliente, /29), tambin
se presenta la configuracin para asignar IP pblica en interfaz LAN directamente.
4. Enrutamiento esttico.
5. Control de ancho de banda sobre la interfaz WAN del router. El router Huawei AR151
se utilizar para soluciones bandaancha de ms de 12 Mbps. Estas capacidades no
pueden ser ofrecidas por el equipo estndar de Bandaancha.

A continuacin se anexa la palntilla de configuracin:

<CPEbandaancha>dis current-configuration
[V200R005C00]
#
sysname CPEbandaancha
header login information "%
*************************************************************
* ATENCION: Este equipo es propiedad de CLARO COLOMBIA *
* El uso no autorizado esta estrictamente prohibido. *
* *
* Todos los usuarios son legalmente responsables de sus *
* acciones sobre el sistema y toda actividad sera registrada*
*************************************************************
#
drop illegal-mac alarm
#
vlan batch 2 to 3 Indica las VLAN creadas.
#
wlan ac-global carrier id other ac id 0
#

Confidencial Pag 30 2013-10-11


CONFIGURACION CPES HUAWEI AR151

dhcp enable Servicio DHCP.


#
vlan 2
name LANPrivada
vlan 3
name IPPublica
#
pki realm default
enrollment self-signed
#
acl number 2000 Para aplicar en el control de acceso al equipo.
rule 1 permit source 10.0.0.0 0.255.255.255
#
acl number 3000 Para aplicar en el NAT hacia Internet.
rule 1 permit ip source 192.168.1.0 0.0.0.255
#
ip pool dhcp-lanprivada Definir parmetros del servicio DHCP(Server)
gateway-list 192.168.1.1
network 192.168.1.0 mask 255.255.255.0
excluded-ip-address 192.168.1.2 192.168.1.9 Opcional. Se muestra como modo ejemplo.
dns-list 200.14.207.210 200.14.205.2 Definicin de los servidores DNS a asignar.
#
aaa Activacin proceso de autenticacin.
authentication-scheme default
authorization-scheme default
accounting-scheme default
domain default
domain default_admin
local-user gestion password cipher %@%@:i6m&mr*HYd37:XF`Wf5]r7+%@%@
local-user gestion privilege level 3
local-user gestion service-type telnet terminal ssh
#
firewall zone Local Comando por defecto. No aplica.
priority 16
#
nat address-group 1 190.145.127.36 190.145.127.36 Nat dinmico hacia una(1) IP /32.
#
interface Vlanif2
description LAN
ip address 192.168.1.1 255.255.255.0
ip address 190.145.127.37 255.255.255.252 sub Opcional en caso de que el cliente pida IP Pblica. Se
permite usar el mismo segmento 30 que se aplica al NAT dinmico.
dhcp select global Aplicacin del servicio DHCP para la LAN.
#
interface Ethernet0/0/0
description LAN
port link-type access
port default vlan 2 Aplicacin VLAN asociada al direccionamiento privado del cliente.

#
interface Ethernet0/0/1
description LAN
port link-type access
port default vlan 2
#
interface Ethernet0/0/2
description LAN

Confidencial Pag 31 2013-10-11


CONFIGURACION CPES HUAWEI AR151

port link-type access


port default vlan 2
#
interface Ethernet0/0/3
description LAN
port link-type access
port default vlan 2
#
interface Ethernet0/0/4 Interfaz WAN designada por el equipo.
description WAN
#
(En la subinterfaz WAN se aplica la config.de control de BW)
interface Ethernet0/0/4.306 Subinterfaz creada y asociada a la VLAN de WAN.
description WAN DEDICADA MPLS pymes-internet
dot1q termination vid 306
ip address 10.10.80.14 255.255.255.252 Usar rango /21 en caso de ir por acceso compartido.
qos car inbound cir 30000000 Ejemplo para plan 30Mbps downstream hacia el CPE.
qos car outbound cir 15000000 Los valores de cbs y pbs aparecern por defecto al aplicar la config.
nat outbound 3000 address-group 1 Aplicacin del NAT dinmico.
#
interface Cellular0/0/0
#
interface NULL0
#
snmp-agent local-engineid 800007DB03DCD2FC03A05F
snmp-agent
#
ip route-static 0.0.0.0 0.0.0.0 10.10.80.13 Salida estndar IP WAN de internet.
#
user-interface con 0
authentication-mode aaa
user-interface vty 0
acl 2000 inbound Aplicacin ACL 2000 para control de acceso al equipo.
authentication-mode aaa
user privilege level 15
user-interface vty 1 4
acl 2000 inbound Aplicacin ACL 2000 para control de acceso al equipo.
authentication-mode aaa
#
wlan ac Comando por defecto. No aplica.
#
return
<CPEbandaancha>

Confidencial Pag 32 2013-10-11