Está en la página 1de 7

SOLUCIN

EJERCICIO # 3

Ricardo Bolaos
SOLUCIN DE EJERCICIO # 3
Este archivo es una plantilla en la que usted deber desarrollar, para el ejercicio
seleccionado lo siguiente:
Anlisis
Algoritmo principal y subalgoritmos (aplique procedimientos y/o
funciones)
Prueba de escritorio: Deber grabar un video donde se vea claramente la hoja
donde aparezcan el algoritmo y subalgoritmos y otra hoja con la tabla de
variables de la prueba. Tenga en cuenta: escriba con un color distinto las
variables locales de los procedimientos y funciones en la hoja con la tabla de
variables. Muestre muy bien lo que va ocurriendo instruccin por instruccin.
Asigne el siguiente nombre al video: <Prueba Ejercicio#>. Luego sbalo a su
unidad de Google Drive. A este archivo deber crearle el enlace para compartirlo
con permisos para Ver, pues luego tendr que incluirlo en la seccin Prueba
de Escritorio de esta plantilla (seccin 1.4)
Pseudocdigo en PSeInt: cree el archivo con el pseudocdigo en PSeInt y
asigne el nombre <PSeInt_Ejercicio#>. Luego sbalo a su unidad de Google
Drive. A este archivo deber crearle el enlace para compartirlo con permisos
para Ver, ya que luego tendr que incluirlo en la seccin Pseudocdigo en
PSeInt de esta plantilla (seccin 1.5)
A partir de la pgina 3 usted deber ir desarrollando lo que se solicita. Siga las
instrucciones indicadas en cada apartado.

2
Ejercicio # 3
1.1 Enunciado:
Ejercicio 3. Halle el valor de la siguiente serie para n trminos:

1 2 3 4 5 6
= + + + + +
1! 3! 5! 7! 9! 11!

1.2 Anlisis:
Describa ac el anlisis problema.
Para resolver el problema de la serie, busqu inicialmente la forma general de cmo
poder escribir la serie y encontr que:

1 2 3 4 5 6
= + + + + + =
1! 3! 5! 7! 9! 11! (2 1)!
=1

Luego para poder determinar el algoritmo que me resolviera la serie, separ esta en
dos partes, para inicialmente determinar el factorial de la expresin (que
corresponde al denominador de la serie) y as posteriormente calcular el valor de la
serie S.
El factorial a hallar es: (2*a-1)!, de acuerdo al valor que se le asigne a la variable n,
para hallar este lo asigne como una funcin aparte en el desarrollo del algoritmo.
Una vez hallado el factorial procedo a hallar el valor de la serie S, como se puede
ver en el algoritmo abajo.

3
1.3 Algoritmo:
Realice ac el algoritmo y subalgoritmos que dan solucin al problema.
Proceso serie
Definir x,n,a,b,factb como entero;
Definir s como real;
Escribir "Digite el valor de x";
Leer x;
Escribir "Digite el valor de n";
Leer n;
//Sea la expresin de la serie a resolver S=sumatoria(x^n/(2*n-1)!)
//entonces procedo a resolver
s<-0;
para a<-1 hasta n hacer
b<-(2*a-1);
factb<-factorial(b);
s<-s+(x^a/factb);
finpara
Escribir "El valor de la serie es S= ",s;
FinProceso

Funcion fact<-factorial(b)
Definir fact, c como entero;
fact<-1;
Para c<-1 hasta b Hacer
fact<-fact*c;
FinPara
FinFuncion

4
1.4 Prueba de escritorio:
Copie y pegue ac el enlace o URL del video que usted grab de la prueba de
escritorio, que subi a su unidad en Google Drive y que comparti segn las
indicaciones.

https://drive.google.com/open?id=0B2J4l9QhEOPdLTNnZGhESW10V0U

1.5 Pseudocdigo en PSeInt:


Copie y pegue ac el enlace o URL del archivo correspondiente al algoritmo y
subalgoritmos del problema realizados en PSeInt, que subi a su unidad en Google
Drive y que comparti segn las indicaciones.

https://drive.google.com/open?id=0B2J4l9QhEOPdX3hhbndZV3VyLVU

5
6
7