Está en la página 1de 10

DEBER

POR: Jos Lalangui

Ejercicio 1. Realice un algoritmo para indicar las actividades que efecta el da martes.
1. INICIO
2. Me levanto a las 6:00 am
3. Me bano
4. Me cambio
5. Desayuno a las 6:15 am
6. Lavo el plato
7. Me cepillo los dientes
8. Bajo las gradas del departamento
9. Salgo del departamento
10. Camino a la parada del bus
11. Espero la lnea 7 de bus
12. Me subo al bus
13. Me bajo del bus en la parada
14. Me dirijo a la universidad
15. Llego a la universidad a la 6:58 am
16. Entro a clases a las 7:00 am
17. Salgo de clases a las 12:00 pm
18. Me dirijo al departamento
19. Llego al departamento a las 12:30 pm
20. Almuerzo
21. Lavo la vajilla
22. Realizo tareas a las 3:00 pm
23. Meriendo a las 7:00 pm
24. Me voy a dormir a las 10pm
25. FIN

Ejercicio 2. Escriba vlido o invlido en cada identificador para el pseudocdigo y responda por qu?

Identificador Vlido o invlido Por qu?

Area Valido Est de acuerdo con las reglas del pseudocdigo

rea Invalido No puede llevar tildes

dato 1 Invalido No pueden llevar espacios

dato_1 Valido Est de acuerdo con las reglas del pseudocdigo

1radio Invalido No puede empezar con nmeros

radio1 Valido Est de acuerdo con las reglas del pseudocdigo

Ejercicio 3. Escriba vlido o invlido a cada declaracin de variable en pseudocdigo.

Declaracin de variable Vlido o invlido

entero a Invalido

entero _a Valido

real x Invalido

real x1 Invalido

real 1x Invalido

caracter %s Valido
Ejercicio 4. Escriba vlido o invlido a cada declaracin de constante en pseudocdigo. Si la constante es vlida,
especifique el tipo respectivo.

Declaracin de constante Vlido o invlido Tipo de constante

const entero MAX 20 Valido Entero

const cadena X 7.8E10.3 Invalido

const caracter C x Valido Caracter

const real 3.1415 Valido Real

const entero N Marco Invalido

const CAR c Invalido

const real G 9.8 Valido Real

const cadena NOM Lucy Invalido

const entero X 9.3e-2 Invalido

const cadena W abc Valido Cadena

Ejercicio 5. Calcule las siguientes expresiones en pseudocdigo y escriba el resultado respectivo.


1. 9+3*16/ 2**3-5/2 = 25/2 = 12.5
2. 15/3+4*3^2-5*6 = 11
3. (6*3+8-9/3+2 4)/2 = 39/2 = 19.5

Ejercicio 6. Complete la columna de resultado y de valor binario segn la expresin.

Expresiones lgicas Resultado Valor binario

(2 > 3) Falso (0010>0011)

(8 < 5) Falso (1000<0101)

(7 > 5) y (4 < 9) Verdad (0111>0101) y


(0100<1001)

(12 > 6) y (13 < 9) Falso (1100>0110) y


(1101<1001)

(12 > 6) o (13 < 9) Verdad (1100>0110) y


(1101<1001)

no (2 > 4) Verdad no (0010>0100)

no (5 < 8) Verdad no (0101>1000)

Ejercicio 7. Tache los identificadores que no son vlidos.

_numero home 2variables fin Nmero

dinero$ el punto ao base_1

Ejercicio 8. Escriba las siguientes expresiones matemticas como expresiones algortmicas.


+ ((x+y)/(x-3))+2x
+ 2
3
+ ((x+y)/((x/5)-(3/y)))+2x
3/ + 2
5
2 + 5 ((2+5y)/(x-3))+4x-(7-y)^(1/3)
+ 4 37
3
2 5 4 ((2xy-5y)/(x-3))-((4x-xy)/(7-y/(4+x))^(1/3)
3
3 7 /(4 + )

Ejercicios de la estructura de control secuencial

Ejercicio 1. Complete el siguiente algoritmo que calcula el rea del trapecio e identifique las variables de entrada y salida.

Algoritmo AreaTrapecio
var real _________________ , basemenor, altura, area inicio
escribir Digite la longitud de la Base mayor en cm:
_________________ basemayor
escribir Digite la longitud de la Base menor en cm:
leer _________________
_________________ Digite la altura
leer altura
_________________ (basemayor + basemenor) * altura / 2
escribir El rea del trapecio es: , area, cm. fin

Identifique las variables de:


Entrada ______________________________________
Salida _______________________________________

Ejercicio 2. Complete el siguiente algoritmo que calcula el rea y el permetro de un tringulo issceles e identifique las
variables de entrada y salida.

Algoritmo Area_Perimetro_Isoseles var


_________________ base, altura, lado, area, perimetro inicio
escribir Cuanto mide la base del tringulo isosceles
leer _________________
escribir Cuanto mide la altura del tringulo leer
altura
area _________________
_________________ sqrt ((base/2)*(base/2)+altura*altura)
perimetro _________________
_________________ El rea del tringulo es: , area
escribir y el permetro es: , _________________ fin

Identifique las variables de:


Entrada _____________________________________
Salida _______________________________________

Ejercicio 3. Qu realiza el siguiente pseudocdigo?

Algoritmo principal
var real x, y, z
inicio escribir Escriba dos nmeros
leer x, y
z x * x + 2 * x * y + y * y
escribir El Resultado es , z
fin
Explicacin: _______________________________________

Identifique las variables de:


Entrada _____________________________________
Salida _______________________________________
Ejercicio 4. Qu realiza el siguiente pseudocdigo?

Algoritmo principal
var real x, y, z, r
inicio escribir Escriba tres nmeros
leer x, y, z r ( x + y + z ) / 3
escribir El resultado es , r
fin
Explicacin: _______________________________________

Identifique las variables de:


Entrada _____________________________________
Salida _______________________________________

Ejercicio 5. Utilizando los algoritmos 3 y 4 realice las siguientes pruebas de escritorio. Qu valor final almacena la
variable z y la variable r?

Para el ejercicio 3 Para el ejercicio 4


x = 5, y = 3, z = _______ x = 8, y = 12, z = 7, r = ________

Ejercicio 6. Complete el siguiente pseudocdigo y diagrama de flujo para convertir centmetros a metros.

Algoritmo Centimetros_A_Metros
var real cm, m inicio escribir Digite los centmetros
________________________________ m cm/100
imprimir La conversin en metros es: , ______ fin

Ejercicio 7. Complete el siguiente pseudocdigo y diagrama de flujo para convertir pesos a


dlares y euros, utilizando dos constantes, euro = 18.6 y dlares = 12.9.

Algoritmo ConversionMoneda const


CE 18.6
CD 12.9 var
real pesos, total_eur, total_dol
inicio escribiir Cuantos pesos quiere cambiar leer pesos
______________________________
______________________________
escribir El total de euros es:, total_eur
escribir El total de dolares es:, total_dol
fin
Ejercicio 8. Complete el siguiente pseudocdigo y diagrama de flujo para encontrar el rea y
permetro de un tringulo equiltero.

Algoritmo Area_Perimetro_Tri_Equilatero var real base, alt, area, peri


inicio escribir Digite la base y la altura del tringulo:
_____________________________
area base * alt / 2
_____________________________
escribir El rea del tringulo es: , ________
escribir El permetro del tringulo es: , ________
fin

Ejercicios de la estructura de control selectiva simple, doble y anidada

Ejercicio 1. Identifique qu realiza el siguiente pseudocdigo y explquelo a continuacin. Adems complete el diagrama
de flujo respectivo.

Algoritmo AreaTrapecio
var entero a, b, c
inicio escribir Digite 3 nmeros leer a, b, c si (a > b y a
> c) entonces
escribir a, es el mayor fin_si si (b > a y b >
c) entonces
escribir b, es el mayor fin_si si (c > a y c >
b) entonces
escribir c, es el mayor
fin_si
fin

Respuesta:_______________________
Ejercicio 2. Complete los espacios vacos para el siguiente problema. Segn la edad de una persona imprimir si es nio (0-
12), adolescente (13-17) o adulto (mayor o igual a 18).

Algoritmo Edades var


entero e
inicio escribir Digita tu edad leer ___________ si
(______________) entonces escribir eres un
nio si_no
si (______________) entonces
escribir eres un adolescente si_no
escribir eres un adulto fin_si
fin_si
fin

Ejercicio 3. Complete los espacios vacos para el siguiente problema. Segn los tres lados de un tringulo, escribir si es
equiltero (tres lados iguales), issceles (dos lados iguales) o escaleno (lados diferentes).

Algoritmo TipoDeTriangulo
var real
l1,l2, l3
inicio
escribir Cunto miden los tres lados?: leer l1,
l2, l3
si (______________ y ______________) entonces escribir
El tringulo es Equiltero, lados iguales. si_no
si (______________ o ______________ o ______________) entonces
escribir El tringulo es Issceles, 2 lados iguales. si_no
escribir El tringulo es Escaleno, ningn lado igual.
fin_si
fin_si
fin

Ejercicio 4. Complete el siguiente pseudocdigo que utiliza la estructura selectiva doble anidada, para imprimir si la
persona es nio, adolescente, adulto o anciano, segn el rango de edades siguiente: a) 0 a 12 es nio.
b) 13 a 17 es adolescente.
c) 18 a 80 es adulto.
d) Mayor que 80 es anciano.

Algoritmo Edades var


entero edad
inicio escribir Cul es la edad? leer
__________________ si (edad <=
____________ ) entonces escribir
Es nio si_no
_________ (edad <= 17) entonces
escribir es adolescente
si no
si
________________________________
escribir es adulto si_no

__________________________________
fin_si fin_si fin_si
fin

Ejercicios de la estructura de control repetitiva Mientras


Ejercicio 1. Realice la prueba de escritorio del siguiente algoritmo y conteste las preguntas que se encuentran despus del
Pseudocdigo.

Algoritmo Ejercicio1
Var entero cont inicio
cont 5 mientras ( cont < 20
) hacer escribir
prueba cont cont +
2
fin_mientras
fin

a) Cuntas veces se imprime la palabra prueba?


b) Si la variable cont se incrementa en tres, es decir contcont+3, cuntas veces se imprime la palabra prueba?

Ejercicio 2. Realice la prueba de escritorio del siguiente algoritmo y escriba los valores con los que quedan las variables a,
b, c al finalizar el algoritmo.

Algoritmo Ejercicio2
Var entero a, b, c
inicio
a3b
8c
4
mientras (a < 65) hacer a
a*cbb+ac
c+1
fin_mientras escribir
a,b,c
fin

Ejercicio 3.

Algoritmo Ejercicio3
Var a) Qu realiza el pseudcdigo?
entero m _________________________________________
inicio
m3 b) Con qu valor se queda la variable m? Por qu?
mientras m < 21 hacer _________________________________________
escribir m _________________________________________
mm+3
fin_mientras
fin

Ejercicio 4.

Algoritmo Ejercicio4
Var a) Qu realiza el pseudcdigo?
ent _________________________________________
ero i inicio i
1
b) Con qu valor se queda la variable i? Por qu?
mientras i < 12 hacer
_________________________________________
escribir i i i + 1
_________________________________________
fin_mientras
fin

Ejercicio 5. Complete el pseudocdigo y elabore el diagrama de flujo para mostrar en pantalla todos los mltiplos de 6,
entre el 20 y el 200 (incluidos).

Algoritmo Ejercicio5
Var
__________ x
inicio
x _______ mientras
________ hacer escribir
_________
x __________ fin_mientras
fin

Ejercicio 6. Complete el pseudocdigo y elabore el diagrama de flujo para sumar los 50 primeros nmeros enteros
positivos (1-50). Muestre en pantalla el resultado.

Algoritmo Ejercicio6
Var
entero __________
inicio
suma 0 i
1
mientras ________ hacer suma
____________________
ii+1
fin_mientras
escribir _________ fin

Ejercicio 7. Complete el pseudocdigo y elabore el diagrama de flujo para calcular el producto (multiplicacin) de los
mltiplos de 5, entre 0 y 100 (incluidos). Muestre los mltiplos de 5 y el resultado del producto.
Algoritmo Ejercicio7 Var
entero i 5, prod 1
inicio
mientras i < ________ hacer escribir i
prod_________________
i i + ______
fin_mientras
escribir ________
fin