Está en la página 1de 16

ACTIVIDAD PARA

Nombre: STEPHANIE VILAR

1. HORAS
Algoritmo radio
Escribir "Dijite el nmero de iteracciones del programa";
Leer n;
Para i<-1 Hasta n Con Paso 1 Hacer
Escribir "Radio del Circulo";
Leer r;
A <-(3.14*r^2);
P<-(2*3.14*r)
Escribir "Radio del circulo:", r;
Escribir "Area del circulo:", A;
Escribir "Perimetro del circulo:", P;

Fin Para
FinAlgoritmo

2. NOTAS
Algoritmo Notas
Escribir "Dijite el nmero de iteracciones del programa";
Leer n;
Para i<-1 Hasta n Con Paso 1 Hacer
Escribir "Nota #1";
Leer N1;
Escribir "Nota #2";
Leer N2;
Escribir "Nota #3";
Leer N3;
Escribir "Nota #4";
Leer N4;
s<-(N1+N2+N3+N4);
p<-(s/4)
Escribir "Primera nota:", N1;
Escribir "Segunda nota:", N2;
Escribir "Tercera nota:", N3;
Escribir "Cuarta nota:", N4;
Escribir "Promedio de las 4 notas:",p;

Fin Para
FinAlgoritmo

3. PULGADAS
Algoritmo centimetrospulgadas
Escribir "Dijite el nmero de iteracciones del programa";
Leer n;
Para i<-1 Hasta n Con Paso 1 Hacer
Escribir "Centimetros a convertir";
Leer c;
p<-((1/2.54)*c);
Escribir "Centrimetros a convertir:", c;
Escribir "Conversin a pulgadas:", p;

Fin Para
FinAlgoritmo

4. HORAS
Algoritmo horas
Escribir "Dijite el nmero de iteracciones del programa";
Leer n;
Para i<-1 Hasta n Con Paso 1 Hacer
Escribir "Hora actual";
Leer t;
Escribir "Cantidad de horas a esperar";
Leer h;
R<-(t+h);
Escribir "Hora actual:", t;
Escribir "Cantidad de horas que desea esperar:", h;
Escribir "En el tiempo deseado a esperar el reloj marcar las:", R;

Fin Para
FinAlgoritmo

5. NMERO REAL

Algoritmo numeroreal

Escribir "Dijite el nmero de iteracciones del programa";

Leer n;

Para i<-1 Hasta n Con Paso 1 Hacer

Escribir "Numero real";

Leer r;

D<-(r-TRUNC(r));

Escribir "Numero real:", r;


Escribir "Parte decimal de su nmero real es:", D;

Fin Para

FinAlgoritmo

6. CERTAMEN

Algoritmo certamen

Escribir "Dijite el nmero de iteracciones del programa";

Leer n;

Para i<-1 Hasta n Con Paso 1 Hacer

Escribir "Nota del Certamen #1";

Leer C1;

Escribir "Nota del Certamen #2";

Leer C2;

Escribir "Nota del laboratorio";

Leer NL;

NF<-(60);

NC<-((NF-0.3*NL)/0.7);

C3<-((NC*3)-C1-C2);

Escribir "Nota final:", NF;

Escribir "Nota de Laboratorio:", NL;

Escribir "Nota que necesita el alumno para aprobar el ramo con nota final 60:", C3;

Fin Para

FinAlgoritmo

7. PRIMITIVA CONDICIONAL

Algoritmo primitivacondicional
Escribir "Dijite el nmero de iteracciones del programa";

Leer n;

Para i<-1 Hasta n Con Paso 1 Hacer

Escribir "Primer coeficiente de la funcin";

Leer a;

Escribir "Segundo coeficiente de la funcin";

Leer b;

Escribir "Tercer coeficiente de la funcin";

Leer c;

D<-((b^2)-(4*a*c));

Si (D>=0) Entonces

x1<-(-b+RC(D))/2*a;

x2<-(-b-RC(D))/2*a;

Escribir "x1=", x1;

Escribir "x2=",x2;

SiNo

Escribir "Raices imaginarias";

Fin Si

Fin Para

FinAlgoritmo

8. NMERO MAYOR QUE

Algoritmo mayorque

Escribir "Dijite el nmero de iteracciones del programa";

Leer n;

Para i<-1 Hasta n Con Paso 1 Hacer

Escribir "Primer nmero";


Leer A;

Escribir "Segundo nmero";

Leer B;

Si A>B Entonces

Escribir A;

SiNo

Escribir B;

Fin Si

Fin Para

FinAlgoritmo

9. MAYOR QUE #2

Algoritmo mayorque2

Escribir "Dijite el nmero de iteracciones del programa";

Leer n;

Para i<-1 Hasta n Con Paso 1 Hacer

Escribir "Primer Numero";

Leer A;

Escribir "Segundo Numero";

Leer B;

Escribir "Tercer Numero";

Leer C;

Si (A>B)&&(B>C) Entonces

Escribir A;

SiNo

si (B>C)&&(C>A)

Escribir B;

SiNo
si (C>B)&&(B>A)

Escribir C;

SiNo

si (A>C)&&(C>B)

Escribir A;

SiNo

si(C>A)&&(A>B)

Escribir C;

SiNo

Si (B>A)&&(A>C) Entonces

Escribir B;

SiNo

Si (A=B)&&(B=C)&&(C=A) Entonces

Escribir "Los numeros son


iguales";

SiNo

Si (A=B)&&(B>C) Entonces

Escribir A;

SiNo

Si
(A=B)&&(C>B)Entonces

Escribir C;

SiNo

Si
(B=C)&&(C>A) Entonces

Escribir C;

SiNo

Si
(B=C)&&(A>C) Entonces
Escribir A;

SiNo

Si (A=C)&&(C>B) Entonces

Escribir C;

SiNo

Si (A=C)&&(B>C) Entonces

Escribir B;

Fin Si

Fin Si

Fin
Si

Fin Si

Fin Si

Fin Si

Fin Si

Fin Si

FinSi

FinSi

FinSi

FinSi

Fin Si

Fin Para
FinAlgoritmo

10. TRIANGULOS

Algoritmo TRIANGULOS

Escribir "Dijite el nmero de iteracciones del programa";

Leer n;

Para i<-1 Hasta n Con Paso 1 Hacer

Escribir "Primer lado";

Leer A;

Escribir "Segundo lado";

Leer B;

Escribir "Tercer lado";

Leer C;

Si (A=B)&&(B=c) Entonces

Escribir "Es un triangulo equilatero";

SiNo

Si (A=B)&&(B<>C) Entonces

Escribir "Es un triangulo isoseles";

SiNo

Si (B=C)&&(C<>A) Entonces

Escribir "Es un triangulo isoseles";

SiNo

Si (A=C)&&(C<>B) Entonces

Escribir "Es un triangulo isoseles";

SiNo

Si (A<>B)&&(B<>C)&&(C<>A) Entonces

Escribir "Es un triangulo escaleno";

Fin Si

Fin Si
Fin Si

Fin Si

Fin Si

Fin Para

FinAlgoritmo

11. REA TRIANGULOS

Algoritmo areatriangulo

Escribir "Dijite el nmero de iteracciones del programa";

Leer n;

Para i<-1 Hasta n Con Paso 1 Hacer

Escribir "Primer lado";

Leer A;

Escribir "Segundo lado";

Leer B;

Escribir "Tercer lado";

Leer C;

S<-(A+B+C);

R<-RC(S*(S-A)*(S-B)*(S-C));

Escribir "El primer valor es:",A;

Escribir "El segundo valor es:",B;

Escribir "El tercer valor es:",C;

Si A<0 Entonces

Escribir "Hay un error en el ingreso de el lado A"

Escribir "No se puede calcular el area ni el perimetro"

SiNo

si B<0 Entonces

Escribir "Hay un error en el ingreso del lado B"


Escribir "No se puede calcular el area ni el perimetro"

SiNo

Si C<0 Entonces

Escribir "Hay un error en el ingreso del lado C"

Escribir "No se puede calcular el area ni el perimetro"

FinSi

FinSi

Fin Si

Fin Para

FinAlgoritmo

12. CEDULA

Algoritmo cedula

Escribir "Dijite el nmero de iteracciones del programa";

Leer n;

Para i<-1 Hasta n Con Paso 1 Hacer

Escribir "Ao de nacimiento";

Leer FN;

Escribir "Ao presente";

Leer AP;

E<-(AP-FN);

Escribir "La edad es:",E;

Si (E>=18) Entonces

Escribir "Debe tramitar cedula"

SiNo

Si (E<18) Entonces

Escribir "No debe tramitar su cedula"

Fin Si
Fin Si

Fin Para

FinAlgoritmo

13. INCENTIVOS

Algoritmo incentivos

Escribir "Dijite el nmero de iteracciones del programa";

Leer n;

Para i<-1 Hasta n Con Paso 1 Hacer

Escribir "con este programa sabremos si un operario recibir bonificacin o no


siendo la produccin mnima de 100 unidades"

Escribir "digite las unidades producida por el operario"

Leer a

Si a>100

Escribir "el operario recibira bonificacion"

Sino

Escribir "el operario no recibira bonos "

FinSi

Fin Para

FinAlgoritmo

14. BONIFICACIN

Algoritmo bonificacin

Escribir "Dijite el nmero de iteracciones del programa";

Leer n;

Para i<-1 Hasta n Con Paso 1 Hacer

Escribir "digite la cantidad producida por el operario"


Leer a

si a<1000

Escribir "el vendedor no recibe bonificacion"

SiNo

si a>=1000 && a<5000

Escribir "recibira un bono de 3% "

B<-(a*0.03)

Escribir "recibira un bono de:" B;

Sino

si a>=5000 && a<20000

Escribir "recibira un bono de 5% "

B<-(a*0.05)

Escribir "recibira un bono de:" B;

Sino

si a>=20000

escribir "recibira un bono de 8% "

B<-(a*0.08)

Escribir "recibira un bono de:" B;

FinSi

FinSi

FinSi

FinSi

FinAlgoritmo

Fin Para

FinAlgoritmo

15. SEGN 1

Algoritmo segun1
Escribir "Dijite el nmero de iteracciones del programa";
Leer n;
Para i<-1 Hasta n Con Paso 1 Hacer
Escribir "opcin";
Leer OP;
Escribir "Primer valor";
Leer V1;
Escribir "Segundo valor";
Leer V2;
Si OP es 4 y V2=0 Entonces
Escribir "No es posible realizar la opcin 4, ya que V2=0";
SiNo

Segun OP Hacer
1:
R<-(V1+V2);
Escribir "Suma de los valores:", R;
2:
R<-(V1-V2);
Escribir "Resta de los valores:", R;
3:
R<-(V1*V2);
Escribir "Producto de los valores:", R;
4:
R<-(V1/V2);
Escribir "Divisin de los valores:", R;
De Otro Modo:
Escribir "Opcin fuera de rango";
Fin Segun
FinSi

Fin Para
FinAlgoritmo

16. DA DE LA SEMANA

Algoritmo semana

Escribir "Dijite el nmero de iteracciones del programa";

Leer n;

Para i<-1 Hasta n Con Paso 1 Hacer

Escribir "Escoja un nmero del 1 al 7";

Leer OP;
Segun OP Hacer

1:

Escribir "LUNES";

2:

Escribir "MARTES";

3:

Escribir "MIERCOLES";

4:

Escribir "JUEVES";

5:

Escribir "VIERNES";

6:

Escribir "SABADO";

7:

Escribir "DOMINGO";

De Otro Modo:

Escribir "Nmero fuera de rango"

Fin Segun

Fin Para

FinAlgoritmo

17. MESES DEL AO

Algoritmo Meses

Escribir "Dijite el nmero de iteracciones del programa";

Leer n;

Para i<-1 Hasta n Con Paso 1 Hacer


Escribir "Escoja un nmero del 1 al 12";

Leer OP;

Segun OP Hacer

1:

Escribir "ENERO";

2:

Escribir "FEBRERO";

3:

Escribir "MARZO";

4:

Escribir "ABRIL";

5:

Escribir "MAYO";

6:

Escribir "JUNIO";

7:

Escribir "JULIO";

8:

Escribir "AGOSTO";

9:

Escribir "SEPTIEMBRE";

10:

Escribir "OCTUBRE";

11:

Escribir "NOVIEMBRE";

12:

Escribir "DICIEMBRE";

De Otro Modo:
Escribir "Nmero fuera de rango"

Fin Segun

Fin Para

FinAlgoritmo