Está en la página 1de 18

ALGORITMOS 301303_275

Formato Etapa 2 - Taller fundamentos de programacin -


Algoritmos
Nombre estudiante: Helmer Stiven Barrios Castillo
Ejercicio#1

Desarrolle un Algoritmo que de las instrucciones para preparar un


plato tpico de su regin que sea suficiente para 4 invitados (debe
anexar una foto del plato en el foro) lo desarrollan todos

Ejercicio#2

Desarrolle un Diagrama o Algoritmo que permita leer dos valores y


escribir la suma, resta, multiplicacin y divisin de estos nmeros.

//Nombre del autor: Helmer Stiven Barrios Castillo


// Fecha: Sbado 16 de septiembre de 2017
// Doy fe que este ejercicio es de mi autora, en caso de encontrar plagio la nota de
todo
//mi trabajo debe ser de CERO adems de las respectivas sanciones a que haya
lugar.

Algoritmo Operar_dos_Valores

Repetir

Mostrar "OPERACIONES DE DOS NUMEROS"

Mostrar "Seleccione la operacin que desea realizar"


Escribir " 1- Sumar"
Escribir " 2- Restar"
Escribir " 3- Multiplicar"
Escribir " 4- Dividr"
Escribir " 5- Salir"
Leer Opci

Si Opci=1 Entonces
Escribir "Ingrese el primer valor a operar"
Leer V1
Escribir "Ingrese el segundo valor a operar"
Valor1<-V1
Leer V2
Valor2<-V2
Mostrar "La suma de " V1 " ms " V2 " es:"

VSuma<-Valor1+Valor2

Escribir VSuma

FinSi

Si Opci=2 Entonces
Escribir "Ingrese el primer valor a operar"
Leer V1
Escribir "Ingrese el segundo valor a operar"
Valor1<-V1
Leer V2
Valor2<-V2
Mostrar "La Resta de " Valor1 " menos " Valor2 " es:"

VResta<-Valor1 - Valor2

Escribir VResta

FinSi

Si Opci=3 Entonces
Escribir "Ingrese el primer valor a operar"
Leer V1
Escribir "Ingrese el segundo valor a operar"
Valor1<-V1
Leer V2
Valor2<-V2
Mostrar "La multiplicacin de " V1 " por " V2 " es:"

VMultiplicacion<-Valor1*Valor2
Escribir VMultiplicacion

FinSi

Si Opci=4 Entonces
Escribir "Ingrese el primer valor a operar"
Leer V1
Escribir "Ingrese el segundo valor a operar"
Valor1<-V1
Leer V2
Valor2<-V2
Mostrar "La divisin de " V1 " entre " V2 " es:"

VDivision<-Valor1/Valor2
Escribir VDivision

FinSi

Hasta Que Opci=5

FinAlgoritmo
Ejercicio#3

Desarrolle un Algoritmo que permita leer un valor entero, calcular


su cuadrado y mostrar su resultado.

//Nombre del autor: Helmer Stiven Barrios Castillo


// Fecha: Sbado 16 de septiembre de 2017
// Doy fe que este ejercicio es de mi autora, en caso de encontrar plagio la nota de
todo
//mi trabajo debe ser de CERO adems de las respectivas sanciones a que haya
lugar.

Algoritmo Calculo_cuadrado_de_un_numero

Repetir

Mostrar "CUADRADO DE UN NMERO ENTERO"

Mostrar "Escriba el nmero entero del cual desea conocer el valor de su


cudrado o presione 0 para salir"
Leer Nument

RNument <-Nument*Nument
Escribir "El cuadrado del nmero " Nument " es: "
Mostrar RNument

Hasta Que Nument=0

FinAlgoritmo
Ejercicio#5

Desarrollar un Algoritmo que permita determinar la hipotenusa de


un tringulo rectngulo conocido los valores de las longitudes de
los catetos.

//Nombre del autor: Helmer Stiven Barrios Castillo


// Fecha: Sbado 16 de septiembre de 2017
// Doy fe que este ejercicio es de mi autora, en caso de encontrar plagio la nota de
todo
//mi trabajo debe ser de CERO adems de las respectivas sanciones a que haya
lugar.

Algoritmo Hipotenusa_Triangulo
Operando <- 1^2

Respuesta <- "ok" // Confirmacin de mas tiangulos a operar


Escribir "Calculo de la Hipotenusa de un tringulo rectngulo, conociendo la
longitud de sus catetos"

Escribir "Ingrese los catetos o lados del tringulo:"


Leer L1,L2
// Proceso de los catetos del tringulo
C1 <- L1 ^2
C2 <- L2 ^2
// Catetos resultantes sacamos la raiz cuadrada
CT <- C1 + C2
H <- CT ^ (1/2)

Escribir "Hipotenusa del tringulo es: ", H

FinAlgoritmo

Ejercicio#6

Desarrollar un diagrama o algoritmo que leer la temperatura en


grados centgrados y muestre su resultado en Fahrenheit y kelvin.

//Nombre: del autor: Helmer Stiven Barrios Castillo


// Fecha: Sbado 16 de septiembre de 2017
// Doy fe que este ejercicio es de mi autora, en caso de encontrar plagio la nota de
todo
//mi trabajo debe ser de CERO adems de las respectivas sanciones a que haya
lugar.

Algoritmo Conversion_Temperaturas
Mostrar "CONVERTIDOR DE TEMPERATURAS EN GRADOS CELSIUS"
Repetir

Mostrar "Seleccione el nmero de la unidad de medida en la que desea


convertir la temperatura o 0 para finalizar"
Escribir " 1- Grados Fahrenheit"
Escribir " 2- Grados Kelvin"
Escribir " 0- Salir"
Leer Opc

Si Opc=1
Escribir "Ingrese el valor de grados centigrados a convertir en
Fahrenheit, nicamente el nmero sin la unidad de medida"
Leer CentFa

Far<- CentFa*9/5+32
Mostrar CentFa " grados Centigrados equivalen a " Far " grados
Fahrenheit "

FinSi

Si Opc=2
Escribir "Ingrese el valor de grados centigrados a convertir en Kelvin,
nicamente el nmero sin la unidad de medida"
Leer CentKel

Kel<- CentFa+273.15
Mostrar CentFa " grados Centigrados equivalen a " Kel "grados
Kelvin "

FinSi

Hasta Que Opc=0

FinAlgoritmo
Ejercicio#8

Desarrollar un Algoritmo que permita convertir un valor en galones


a Litros, barriles y litros.

//Nombre: del autor: Helmer Stiven Barrios Castillo


// Fecha: Sbado 16 de septiembre de 2017
// Doy fe que este ejercicio es de mi autora, en caso de encontrar plagio la nota de
todo
//mi trabajo debe ser de CERO adems de las respectivas sanciones a que haya
lugar.

Algoritmo Conversion_Galones
Mostrar "CONVERTIDOR DE GALONES"
Repetir

Mostrar "Seleccione el nmero de la unidad de medida en la que desea


convertir una cantidad determinada de galones o 0 para finalizar"
Escribir " 1- Galones a Litros"
Escribir " 2- Galones a Barriles"
Escribir " 0- Salir"
Leer Opc

Si Opc=1
Escribir "Ingrese el valor de Galones a convertir en Litros,
nicamente el nmero sin la unidad de medida"
Leer GaLitro

Litros<- GaLitro*3.7854118
Mostrar GaLitro " Galones equivalen a " Litros " Litros "

FinSi

Si Opc=2
Escribir "Ingrese el valor de Galones a convertir en Barriles,
nicamente el nmero sin la unidad de medida"
Leer BarLitro

Barriles<- BarLitro*0.023809523049954
Mostrar BarLitro " Galones equivalen a " Barriles "Barriles "

FinSi

Hasta Que Opc=0


FinAlgoritmo

Ejercicio#9

Desarrollar un diagrama o Algoritmo que permita convertir


ingresar un valor en libras y lo convierta en quintales, miligramo y
toneladas.

//Nombre del autor: Helmer Stiven Barrios Castillo


// Fecha: Lunes 18 de septiembre de 2017
// Doy fe que este ejercicio es de mi autora, en caso de encontrar plagio la nota de
todo
//mi trabajo debe ser de CERO adems de las respectivas sanciones a que haya
lugar.
Algoritmo Conversion_Libras

Mostrar "CONVERTIDOR DE LIBRAS"


Repetir

Mostrar "Seleccione el nmero de la unidad de medida en la que desea


convertir una cantidad determinada de Libras o 0 para finalizar"
Escribir " 1- Libras a Quintales"
Escribir " 2- Libras a Miligramos"
Escribir " 3- Libras a Toneladas"
Escribir " 0- Salir"
Leer Opc

Si Opc=1
Escribir "Ingrese el valor de Libras a convertir en Quintales,
nicamente el nmero sin la unidad de medida"
Leer QuintLib

Quintal<-QuintLib*0.00453592
Mostrar QuintLib " Libras equivalen a " Quintal " Quintales "

FinSi

Si Opc=2
Escribir "Ingrese el valor de Libras a convertir en Miligramos,
nicamente el nmero sin la unidad de medida"
Leer MiLib

Miligram<- MiLib*453592
Mostrar MiLib " Libras equivalen a " Miligram " Miligramos "

FinSi

Si Opc=3
Escribir "Ingrese el valor de Libras a convertir en Toneladas,
nicamente el nmero sin la unidad de medida"
Leer Tonel

Tonelada<- Tonel*0.000453592
Mostrar Tonel " Libras equivalen a " Tonelada " Toneladas "

FinSi

Hasta Que Opc=0

FinAlgoritmo

Ejercicio#13

Desarrollar un diagrama o algoritmo que permita determinar sin un


valor cualquiera es par o impar.

//Nombre del autor: Helmer Stiven Barrios Castillo


// Fecha: Lunes 18 de septiembre de 2017
// Doy fe que este ejercicio es de mi autora, en caso de encontrar plagio la nota de
todo
//mi trabajo debe ser de CERO adems de las respectivas sanciones a que haya
lugar.

Algoritmo Par_Impar
Escribir "Determine si un valor es par o impar"
Escribir "Digite el nmero que desea saber si es par o impar"

Leer Num

Si Num MOD 2=0 Entonces


Escribir "El nmero ingresado es par"
SiNo
Escribir "El nmero es impar"

FinSi

FinAlgoritmo

Ejercicio#14

Desarrolle un diagrama o algoritmo que permita determinar si un


valor N es mltiplo de un Valor Z.

//Nombre del autor: Helmer Stiven Barrios Castillo


// Fecha: Lunes 18 de septiembre de 2017
// Doy fe que este ejercicio es de mi autora, en caso de encontrar plagio la nota de
todo
//mi trabajo debe ser de CERO adems de las respectivas sanciones a que haya
lugar
Algoritmo Multiplos
Mostrar "DETERMINE SI UN NMERO ES MULTIPLO DE OTRO"

Escribir 'Ingrese el primer nmero'


Leer n1;
Escribir 'Ingrese el segundo nmero'
Leer n2;
Si n1>n2 Entonces
Si n1 MOD n2=0 Entonces
Escribir 'El numero ',n1,' es multiplo de ',n2;
Sino
Escribir 'El numero ',n1,' No es multiplo de ',n2;
FinSi
Sino
Si n2 MOD n1=0 Entonces
Escribir 'El numero ',n2,' es multiplo de ',n1;
Sino
Escribir 'El numero ',n2,' No es multiplo de ',n1;
FinSi
FinSi
FinAlgoritmo

Ejercicio#21

Desarrollar un Diagrama o Algoritmo que permita leer 3 valores


diferentes e indique cual es el mayor de ellos, el menor o si son
iguales.

//Nombre del autor: Helmer Stiven Barrios Castillo


// Fecha: Domingo 24 de septiembre de 2017
// Doy fe que este ejercicio es de mi autora, en caso de encontrarplagio la nota de
todo
//mi trabajo debe ser de CERO adems de las respectivas sanciones a que haya
lugar.
Algoritmo Definir_Mayor_3_Valores
DEFINIR numero1 COMO ENTERO;
DEFINIR numero2 COMO ENTERO;
DEFINIR numero3 COMO ENTERO;
Mostrar "COMPRUEBE CUAL NMERO ES MAYOR O MENOR DE LOS
NMEROS QUE INGRESE"
ESCRIBIR ("Escriba el primer nmero");
LEER numero1;
ESCRIBIR ("Escriba el segundo nmero");
LEER numero2;
ESCRIBIR ("Escriba el tercer nmero");
LEER numero3;
SI (numero1 > numero2) y (numero1 > numero3) ENTONCES
ESCRIBIR ("El primer nmero es el mayor");
SINO
SI (numero2 > numero3) ENTONCES
ESCRIBIR ("El segundo nmero es el mayor");
SINO
ESCRIBIR ("El tercer nmero es el mayor");
FINSI
FINSI

FinAlgoritmo

Ejercicio#23

Desarrolle un Diagrama o Algoritmo que permita determinar la


nota mnima que usted debe sacar en el examen final del curso
Algoritmos de acuerdo a las condiciones actuales 75% y
25%(final), esta nota debe estar representada tanto en puntos y
en nota (0..5.0). Lo desarrollan todos
Ejercicio#26

Se pide desarrollar el algoritmo del juego Adivina un Nmero,


con las siguientes caractersticas:

a) El nmero debe estar en el rango de 1 a 1000 (generado


aleatoriamente)

b) Debe tener dos niveles nivel bsico y nivel experto, el nivel


bsico no tendr restricciones en nmero de oportunidades,
adems se le dar indicaciones como Caliente, Frio.. El Nivel
experto solo tendr 5 oportunidades con mensajes de ayuda
lejos, cerca

c) Al finalizar debe informar el nmero de intentos realizados


antes de encontrar la respuesta correcta. lo desarrollan todos

Ejercicio#27

Es necesario realizar un algoritmo que funcione como una


calculadora con las 4 funciones bsicas (opcional puede incluir otra
funcin). El algoritmo termina y entrega el resultado al presionar
la tecla = lo desarrollan todos

//Nombre del autor: Helmer Stiven Barrios Castillo


// Fecha: Lunes 18 de septiembre de 2017
// Doy fe que este ejercicio es de mi autora, en caso de encontrar plagio la nota de
todo
//mi trabajo debe ser de CERO adems de las respectivas sanciones a que haya
lugar.
Proceso Calculadora

Repetir
Escribir "============CALCULADORA==========="

Escribir "Qu operacin desea hacer?"


Escribir "1: Sumar"
Escribir "2: Restar"
Escribir "3: Multiplicar"
Escribir "4: Dividir"
Escribir "5: funcin Seno"
Escribir "6: funcin Coseno"
Escribir "7: Funcin Tangente"
Escribir "8: Raiz Cuadrada"
Escribir "9: Salir"

Leer opcion

//Si el usuario ingresa un nmero diferente


//a las alternativas entonces mostrar un error

Segun opcion hacer

1:
//Sumar
Total <- "="
suma<-0;
Respuesta_ <- "si"
si (opcion=1) Entonces
Escribir "===============SUMAR===============";
Escribir "Ingrese primer nmero a sumar";
Leer numero_a
Escribir "Ingrese segundo nmero a sumar";
Leer numero_b
Escribir "Desea sumar otro nmero? ingrese si o no"
Leer Respuesta_
si Respuesta_= "si" Entonces
Escribir "Ingrese el siguiente nmero"
Leer numero_c
Escribir "Seleccione = para presentar el resultado"
Sino
Escribir "Seleccione = para presentar el resultado"
FinSi
Leer Total
Si Total= "=" Entonces
Escribir "El resultado es: " numero_a+numero_b+numero_c;
Sino
Escribir "Seleccione = para presentar el resultado"
Fin Si
Fin si

2:
//Restar
Total <- "="
Respuesta_ <- "si"
Definir resta como real;
si(opcion=2)Entonces
Definir num1, num2 Como Real;

Escribir "==============RESTAR===============";
Escribir "Ingrese primer nmero a restar";
Leer numero1
Escribir "Ingrese segundo nmero a restar";
Leer numero2
Escribir "Desea sumar otro nmero? ingrese si o no"
Leer Respuesta_
si Respuesta_= "si" Entonces
Escribir "Ingrese el siguiente nmero"
Leer numero3
Escribir "Seleccione = para presentar el resultado"
Sino
Escribir "Seleccione = para presentar el resultado"
FinSi
Leer Total
Si Total= "=" Entonces
Escribir "El resultado es: " numero1-numero2-numero3;
Sino
Escribir "Seleccione = para presentar el resultado"
Fin Si

FinSi

3:
//Multiplicar

Total <- "="


multipliacion <- (numero1mult)*(numero2mult)
Respuesta_ <- "si"
si (opcion = 3) Entonces

Escribir "==========MULTIPLICAR===========";
Escribir "Ingrese primer nmero multiplicando";
Leer numero1mult
Escribir "Ingrese segundo nmero multiplicador";
Leer numero2mult
Escribir "Para continuar la operacin ingrese si"
Leer Respuesta_
si Respuesta_= "si" Entonces
Escribir "Ingrese el siguiente nmero"
Leer numero3mult
Escribir "Seleccione = para presentar el resultado"
Sino
Escribir "Seleccione = para presentar el resultado"
FinSi
Leer Total
Si Total= "=" Entonces
Escribir "El resultado es: " numero1mult*numero2mult
Sino
Escribir "Seleccione = para presentar el resultado"
Fin Si

FinSi

4:

//Dividir
Total <- "="
Respuesta_ <- "si"

si (opcion=4) Entonces

Escribir "==============DIVIDIR==============";
Escribir "Ingrese numerador: ";
Leer nume;
Escribir "Ingrese denominador: ";
Leer deno;
Si deno=0 Entonces
Escribir "ERROR! el denominador no puede ser cero (0)";
Sino
Escribir "Seleccione = para presentar el resultado"
Leer Total
Si Total= "=" Entonces
Escribir "El resutlado es: " nume/deno;
Sino
Escribir "Seleccione = para presentar el resultado"
Fin Si
Fin si

Fin si
5:
//Seno
Total <- "="
si (opcion=5) Entonces
Escribir "===============FUNCIN SENO===============";
Escribir "ingrese un nmero al que desea hallar su funcin Seno"
leer num_Seno
Escribir "Seleccione = para presentar el resultado"
Leer Total
Si Total = "=" Entonces
Escribir "El resutlado es: " Sen(num_Seno)
Sino
Escribir "Seleccione = para presentar el resultado"
Fin Si
Fin si

6:
//Coseno

Total <- "="


si (opcion=6) Entonces

Escribir "===============FUNCIN COSENO===============";


Escribir "ingrese un nmero al que desea hallar su funcin Seno"
leer num_Cos
Escribir "Seleccione = para presentar el resultado"
Leer Total
Si Total = "=" Entonces
Escribir "El resutlado es: " Cos(num_Cos)
Sino
Escribir "Seleccione = para presentar el resultado"
Leer Total
si Total = "=" Entonces
Escribir "El resutlado es: " Cos(num_Cos)
FinSi
Fin Si
Fin si

7:
//Tangente

Total <- "="


si (opcion=6) Entonces
Escribir "===============FUNCIN TANGENTE===============";
Escribir "ingrese un nmero al que desea hallar su funcin Seno"
leer num_Tan
Escribir "Seleccione = para presentar el resultado"
Leer Total
Si Total = "=" Entonces
Escribir "El resutlado es: " Tan(num_Tan)
Sino
Escribir "Seleccione = para presentar el resultado"
Leer Total
si Total = "=" Entonces
Escribir "El resutlado es: " Tan(num_Tan)
FinSi
Fin Si
Fin si

8:
//Raz Cuadrada
Resul_raiz <- rc(num_Raiz)
Total <- "="
si (opcion=8) Entonces
Escribir "===============RAZ CUADRADA===============";
Escribir "ingrese un nmero al que desea hallarle su raz"
leer num_Raiz
Escribir "Seleccione = para presentar el resultado"
Leer Total
Si Total = "=" Entonces
Escribir "El resutlado es: " rc(num_Raiz)
Sino
Escribir "Seleccione = para presentar el resultado"
Fin Si

Fin si

9: si (opcion=9) Entonces
Escribir "Gracias por usar la calculadora, vuelva pronto"
fin si
De otro modo:
Escribir "Opcin no vlida"
FinSegun
Escribir "Presione enter para continuar"
Esperar Tecla
Hasta Que Opcion=9
FinProceso
Ejercicio#32

Encontrar el mayor y el promedio de una serie de nmeros, donde


solo se permiten ingreso de nmeros positivos, (en caso de
negativos indicar con un mensaje que es negativo), el programa
entrega el resultado cuando el valor ingresado sea 0. (Lo
desarrollan todos)

Ejercicio#33

Realizar un programa que le presente un men al usuario con las


siguientes opciones: lo desarrollan todos.

1. Leer dos nmeros enteros positivos nicamente, 2. Sumar los


dos nmeros ledos, 3. Restarle al primer nmero el segundo
(siempre y cuando el primero sea mayor que l segundo, en caso
contrario indicar con un mensaje que la operacin no es posible
realizarla y volver al men principal, 4. Multiplicar los dos
nmeros (siempre y cuando ninguno de los nmeros sea igual a
cero, , en caso contrario indicar con un mensaje que la operacin
no es posible realizarla y volver al men principal,), 5. Dividir el
primer nmero dado por el segundo, 6 Salir. nota: Se debe
garantizar que el usuario haya ingresado los dos nmeros antes de
poder realizar cualquier operacin y que no se puede escribir un
resultado sin la realizacin de un operacin.