Está en la página 1de 4

Respuestas algoritmos

1-Inicio
Leer
....N1
Leer
....N2
..Si N1< N2 entonces
..........Imprimir N1
..........Imprimir N2
..... Si no
...........Imprimir N2
......... Imprimir N1
...Fin si
fin

2-Inicio
Imprime
..."digite los minutos en que duro haciendo la actividad"
Leer
...Tiem
Imprime
..."para que el programa funciones digite entre comillas una de las dos actividades dormir o
sentarse"
Leer
.....Actividad
Si actividad = "dormir" entonces
.......Caloras= 1,08*tiem
.....Si no
........Actividad= sentarse
........Caloras= 1,66*tiem
....Fin si
Imprimir
..."las calorias que consumo en cierta actividad fueron de"
Imprimir
....Caloras
Fin

3-Inicio

leer: a,b
si a =b entonces
igual a*b
Sino si a>b
mayor =a-b
sino menor =a+b
fin si
fin si
imprimir
fin
4-Anlisis

Entrada: a, b, c.

Salida: nmero mayor

1.- inicio

2.- conocer el valor de a, b, c.

3.-preguntar si

A >b

b>C

c>a

4.-imprimir el nmero mayor

5.- fin

5-Anlisis

Entrada: horas total trabajadas (h t)

Salida: sueldo total (s t)

1.-inicio

2.- conocer las he

3.- preguntar si trabajo 40 hrs.

= sueldo normal

Si trabajo< horas. Extras E*s-n*2

Si trabajo> horas. E*s-n*3

4.- mostrar respuesta

5.- fin
6Inicio

Leer nomb, cve, prec_orig


Si cve = 01 entonces
prec_desc = prec_orig - prec_orig * 0.10

si no
prec_desc = prec_orig - prec_orig * 0.20
fin-si
Imprimir nomb, cve, prec_orig, prec_desc
fin

7-Inicio

Leer num_camisas, prec


tot_comp = num_camisas * prec
Si num_camisas > = 3 entonces
tot_pag = tot_comp - tot_comp * 0.20
si no
tot_pag = tot_comp - tot_comp * 0.10
fin-si
Imprimir tot_pag
fin
4 PROPUESTOS

Anlisis
Entrada: M f
Salida: C p
1.- inicio
2.- conocer el M f
3.-si el Mf< 50,000= aplicar
Cuota del 3% Mf*.03= c p
4.-si el Mf<50,00= aplicar
Cuota del 2% m f *.02=c p.
5.- mostrar resultado.
6.-fin

3-Proceso Ejercicio
Escribir 'Ingrese su edad: ';
Leer edad;
Escribir 'Ingrese su sexo masculino-femenino (M o F): ';
Leer sexo;
Si ((sexo='M') | (sexo='m')) Entonces
pulsaciones<-(210-edad)/10;
Sino
pulsaciones<-(220-edad)/10;
FinSi
Escribir 'Pulsaciones: ',pulsaciones;
FinProceso

8-

9-