Está en la página 1de 10

RIP

El protoclo de informacin de enrutamiento (RIP, Routing Information Protocol) es un protocolo


de enrutamiento de puerta de enlace interior (IGP) utilizado por los routers para intercambiar
informacin de enrutamiento. RIP utiliza el recuento de saltos como mtrica de enrutamiento. RIP
impide que los bucles de enrutamiento mediante la implementacin de un lmite en el nmero de
saltos permitidos en una ruta de acceso desde el origen a un destino. El nmero mximo de saltos
permitidos para RIP es 15. Este lmite de saltos, sin embargo, tambin limita el tamao de las
redes que RIP puede soportar. La versin 2 (RIPv2) fue desarrollada debido a las deficiencias del
RIP original.

Diferencia entre RIPv1 y RIPv2:

RIPv2 es realmente una mejora de las caractersticas y extensiones de RIPv1 ms que un protocolo
totalmente nuevo.

1) RIPv1 es el protocolo de enrutamiento Classful y el protocolo de enrutamiento RIPv2 Classless.

2) En RIPv1, las mscaras de subred no se incluyen en la actualizacin de enrutamiento y En RIPv2


Las mscaras de subred se incluyen en la actualizacin de enrutamiento.

3) RIPv2 multicasts toda la tabla de enrutamiento a todos los routers adyacentes en la direccin
224.0.0.9, en contraposicin a RIPv1 que utiliza broadcast (255.255.255.255). El direccionamiento
unidifusin an se permite para aplicaciones especiales.

Configuracion basica:

Cisco IOS, utiliza el comando "router rip" para habilitar el protocolo de enrutamiento RIP. El
comando version se utiliza para especificar qu versin de RIP utilizar (1 o 2). Si se omite el
comando de versin, el enrutador adopta por defecto el envo de RIPv1, pero puede recibir tanto
RIPv1 como RIPv2.

El comando "red" se utiliza para especificar las subredes conectadas directamente en el enrutador
que se va a configurar y que estn destinadas a ser incluidas en las actualizaciones de
enrutamiento.

De acuerdo con la red clasificada, especificada, las subredes de esa red se identifican
automticamente y participan en la actualizacin de enrutamiento. De forma predeterminada, las
actualizaciones de enrutamiento se resumen en los lmites de la red.

En RIPv2, este comportamiento de resumen automtico se puede desactivar mediante el comando


"sin resumen automtico" . Adems, el resumen manual se puede configurar en un nivel por
interfaz.
Ejemplo de configuracin:

R1 # conf

R1 (config) #router rip

R1 (config-router) #version 2

R1 (config-router) #network 192.168.12.0

R1 (config-router) #exit

Verificacin:

R1 # show ip protocol

Protocolo de enrutamiento es "RIP"

Envo de actualizaciones cada 30 segundos, el siguiente vence en 27 segundos

Invlido despus de 180 segundos, mantenga pulsado 180, enjuagado despus de 240

La lista de filtros de actualizacin saliente para todas las interfaces no est configurada

No se establece la lista de filtros de actualizacin entrantes para todas las interfaces

Redistribucin: rip

Control de versin predeterminado: enve la versin 2, reciba la versin 2

Interfaz Enviar Recv Activado RIP Llavero

FastEthernet0 2 2

FastEthernet1 2 2

Loopback0 2 2

Vlan1 2 2
El resumen automtico de la red est en efecto

Ruta mxima: 4

Enrutamiento para redes:

1.0.0.0

192.168.10.0

192.168.11.0

192.168.12.0

Fuentes de informacin de enrutamiento:

Gateway Distancia ltima actualizacin

192.168.11.2 120 00:00:09

Distancia: (el valor predeterminado es 120)

El protocolo de informacin de enrutamiento (RIP) descrito aqu es libremente basado en el


programa "enrutado", distribuido con el 4.3 Berkeley Distribucin de software. Sin embargo,
existen otras implementaciones de lo que se supone que es el mismo protocolo.
Desafortunadamente, estas diversas implementaciones no estn de acuerdo en detalles. Las
especificaciones aqu representan una combinacin de caractersticas tomado de varias
implementaciones. Creemos que un programa diseado de acuerdo con este documento
interoperar con enrutado, y con todas las otras implementaciones de RIP de las que somos
conscientes.

RIP es una clase de algoritmos conocidos como "vector de distancia algoritmos ".La primera
descripcin de esta clase de algoritmos conocido por el autor est en Ford y Fulkerson [ 6 ]. Debido
a esto, a veces se les conoce como algoritmos Ford-Fulkerson. El termino Bellman-Ford tambin se
utiliza. Proviene del hecho de que la formulacin se basa en la ecuacin de Bellman, la base de la
programacin "(para una introduccin estndar a esta rea, vase [ 1 ]). La presentacin en este
documento est estrechamente basada en [ 2 ]. Este texto contiene una introduccin a la
matemtica de los algoritmos de enrutamiento. Describe y justifica varias variantes del algoritmo
presentado aqu, as como una serie de otros algoritmos relacionados. Los algoritmos bsicos
descritos en este protocolo se utilizaron en la computadora encaminamiento tan pronto como
1969 en el ARPANET. Sin embargo, la ascendencia de este protocolo est dentro de los protocolos
de red de Xerox.
Los protocolos PUP (ver [ 4 ]) utilizaron el Gateway Information Protocol para intercambio de
informacin de enrutamiento. Una versin algo actualizada de este se adopt un protocolo para
los Sistemas de Red Xerox (XNS)arquitectura, con el nombre Protocolo de informacin de
enrutamiento.

Enrutamiento de Berkeley es en gran medida el mismo que el Routing Information Protocolo, con
direcciones XNS reemplazadas por una direccin ms general formato capaz de manejar IP y otros
tipos de direcciones, y con las actualizaciones de enrutamiento se limitan a una cada 30 segundos.
Debido a esto similitud, el trmino Protocolo de informacin de enrutamiento (o simplemente
RIP) es utilizado tanto para referirse al protocolo XNS como al protocolo utilizado por encaminado

RIP est diseado para su uso en Internet basado en IP. La Internet se organiza en una serie de
redes conectadas por pasarelas. las redes pueden ser enlaces punto a punto o redes ms
complejas como Ethernet o ARPANET. Hosts y puertas de enlace se presentan con datagramas IP
dirigidos a algn host. El enrutamiento es el mtodo de que el host o gateway decide dnde
enviar el datagrama. Puede ser capaz de enviar el datagrama directamente al destino, si destino se
encuentra en una de las redes que estn directamente el host o la puerta de enlace. Sin embargo,
el caso interesante es cuando el destino no es directamente accesible. En este caso, el anfitrin o
gateway intenta enviar el datagrama a una pasarela que est ms cerca de la destino. El objetivo
de un protocolo de enrutamiento es muy simple: proporcionar la informacin que se necesita para
hacer el enrutamiento.
OSPF
Introduccin

El protocolo Open Shortest Path First (OSPF), definido en RFC 2328 , es un


Internal Gateway Protocol (IGP) que se usa para distribuir la informacin de
ruteo dentro de un solo sistema autnomo.

Antecedentes

El protocolo OSPF se desarroll debido a la necesidad dentro de la


comunidad de Internet de introducir un Internal Gateway Protocol (IGP) no
patentado de gran funcionalidad para la familia de protocolos TCP/IP. La
discusin sobre la creacin de un IGP interoperable comn para Internet
comenz en 1988 y no se formaliz hasta 1991. En aquel momento el Grupo
de trabajo de OSPF pidi que el OSPF se considerara un avance de un
borrador de estandarizacin de Internet.

El protocolo OSPF est basado en tecnologa de estado de link, la cual es una


desviacin del algoritmo basado en el vector Bellman-Ford usado en los
protocolos de ruteo de Internet tradicionales, como el RIP. OSPF ha
introducido conceptos nuevos, como la autenticacin de actualizaciones de
ruteo, Mscaras de subred de longitud variable (VLSM), resumen de ruta, etc.

Estos captulos discuten la terminologa OSPF, el algoritmo y los pros y los


contras del protocolo a la hora de disear y construir las redes grandes y
complicadas de hoy en da.
OSPF versus RIP

El rpido crecimiento y expansin de las redes de hoy en da ha hecho llegar


a RIP hasta sus lmites. RIP tiene ciertas limitaciones que pueden causar
problemas en las redes grandes:

RIP tiene un lmite de 15 saltos. Se considera inalcanzable a una red RIP


que se extiende por ms de 15 saltos (15 routers).

El protocolo RIP no puede gestionar mscaras de subred de longitud


variable (VLSM). Dada la escasez de direcciones IP y la flexibilidad que
proporciona VLSM en la asignacin eficiente de direcciones IP, esto se
considera un inconveniente importante.

Las difusiones peridicas de la tabla de ruteo completa consumen una


gran cantidad de ancho de banda. ste es un problema importante con
las redes de gran tamao, especialmente en links lentos y nubes WAN.

RIP converge de manera ms lenta que OSPF. En las grandes redes la


convergencia se realiza en unos minutos. Los routers RIP atraviesan un
periodo de retencin y recoleccin de residuos y, lentamente, agotan
el tiempo de espera de la informacin que no se ha recibido
recientemente. No es apropiado que suceda en entornos amplios, ya
que puede causar inconsistencias en el ruteo.

RIP no incluye ningn concepto de retrasos de red ni de costos de link.


Las decisiones de ruteo se basan en los conteos de saltos. Siempre se
prefiere la trayectoria con el menor conteo de saltos al destino, aun si
la trayectoria ms larga cuenta con un mejor ancho de banda total de
links y menos retrasos.

Las redes RIP son redes planas. No existe ningn concepto de reas o
lmites. Con la introduccin del ruteo sin clases y el uso inteligente de
la agregacin y el resumen, las redes RIP parecen haber quedado atrs.

Se han introducido algunas mejoras en una nueva versin de RIP,


denominada RIP2. RIP2 analiza las cuestiones de VLSM, de autenticacin y de
actualizaciones de ruteo de multidifusin. El RIP2 no es una gran mejora del
RIP (ahora llamado RIP 1) porque an tiene limitaciones en aspectos
esenciales en las grandes redes de la actualidad, como el conteo de saltos y la
convergencia lenta.

Por otra parte, el OSPF soluciona la mayora de los problemas que se


presentaron anteriormente:

Con OSPF, no hay limitacin para el conteo de saltos.

La utilizacin inteligente de VLSM es muy til para la asignacin de una


direccin de IP.

OSPF utiliza IP Multicast para enviar actualizaciones de estado de link.


Esto garantiza menos procesamiento en los routers que no estn
escuchando los paquetes OSPF. Adems, las actualizaciones slo se
envan en caso de cambios de ruteo en lugar de peridicamente. Esto
asegura un mejor uso del ancho de banda.

OSPF tiene mejor convergencia que RIP. Esto se debe a que los
cambios en el ruteo se propagan en forma instantnea y no peridica.

OSPF permite un mejor balanceo de carga.

OSPF permite una definicin lgica de redes en la que los routers se


pueden dividir en reas. Esto limita la explosin de las actualizaciones
de estado de link sobre toda la red. Esto tambin brinda un mecanismo
para agregar rutas y reducir la propagacin innecesaria de informacin
de subred.

OSPF permite la autenticacin de ruteo a travs de distintos mtodos


de autenticacin de contraseas.

OSPF permite la transferencia y etiquetado de rutas externas


introducidas en un sistema autnomo. As se realiza un registro de las
rutas externas introducidas por protocolos exteriores como el BGP.
Esto por supuesto conlleva ms complejidad en la configuracin y troubles
hooting de las redes OSPF. Los administradores que estn acostumbrados a
la simplicidad de RIP se encuentran con gran cantidad de informacin nueva
que deben aprender para mantenerse al da con las redes OSPF. Adems,
esto genera ms sobrecarga en la asignacin de memoria y la utilizacin del
CPU. Podra ser necesario actualizar algunos de los routers que ejecutan RIP
para administrar la tara causada por el OSPF.

Costo de OSPF

El costo (tambin llamado mtrica) de una interfaz en OSPF es una indicacin


de la sobrecarga requerida para enviar paquetes a travs de una interfaz
especfica. El costo de una interfaz es inversamente proporcional al ancho de
banda de dicha interfaz. Un mayor ancho de banda indica un menor costo. El
cruce de una lnea serial de 56k implica mayores gastos generales (costo
mayor) y ms retrasos de tiempo que el cruce de una lnea Ethernet de 10M.
La frmula que se usa para calcular el costo es:

costo = 10000 0000/ancho de banda en bps

Por ejemplo, cruzar una lnea Ethernet de 10M costar 10 EXP8/10 EXP7 = 10
y cruzar una lnea T1 costar 10 EXP8/1544000 = 64.

De forma predeterminada, el costo de una interfaz se calcula sobre la base


del ancho de banda; puede forzar el costo de una interfaz con el comando de
modo de subconfiguracin de interfaz ip ospf cost <valor>.

Activacin de OSPF en el router


La activacin de OSPF en el router comprende los dos pasos siguientes en el
modo de configuracin:
1. Activacin de un proceso OSPF utilizando el comando router ospf <process-id>.
2. Asignacin de reas a las interfaces mediante el comando network <network or IP address>
<mask> <area-id>.
El ID del proceso OSPF es un valor numrico local en el router. No tiene que
coincidir con las id del proceso en otros routers. Es posible ejecutar varios
procesos OSPF en el mismo router, pero no se recomienda dado que crea
mltiples instancias de base de datos que agregan una sobrecarga adicional al
router.
El comando network es un modo de asignar una interfaz a determinada rea. La
mscara se utiliza como acceso directo y ayuda a colocar una lista de interfaces
en la misma rea con una lnea de configuracin. La mscara contiene bits
comodines donde el 0 es una coincidencia y el 1 es un bit de no preocuparse;
por ejemplo, 0.0.255.255 indica una coincidencia en los dos primeros bytes del
nmero de la red.
El ID de rea es el nmero de rea en el que queremos que est la interfaz. El id
de rea puede ser un nmero entero entre 0 y 4294967295 o puede tomar una
forma similar a una direccin de IP A.B.C.D.
Aqu tiene un ejemplo:

RTA#
interface Ethernet0
ip address 192.213.11.1 255.255.255.0

interface Ethernet1
ip address 192.213.12.2 255.255.255.0

interface Ethernet2
ip address 128.213.1.1 255.255.255.0

router ospf 100


network 192.213.0.0 0.0.255.255 area 0.0.0.0
network 128.213.1.1 0.0.0.0 area 23

La primera sentencia de red coloca a E0 y E1 en la misma rea 0.0.0.0, y la


segunda sentencia de red coloca a E2 en el rea 23. Observe la mscara 0.0.0.0,
que indica una concordancia total en la direccin IP. sta es una forma sencilla de
colocar una interfaz en una rea determinada si tiene problemas para entender
una mscara.
Autenticacin OSPF
Es posible autenticar los paquetes OSPF para que los routers puedan participar en
los dominios de ruteo en funcin de contraseas predefinidas. De forma
predeterminada, un router utiliza un valor Null de autenticacin, lo que significa
que los intercambios de ruteo en una red no estn autenticados. Existen otros dos
mtodos de autenticacin: Autenticacin de contrasea simple y autenticacin del
resumen del mensaje (MD-5).